15:59:14 <inc0> #startmeeting kolla
15:59:15 <openstack> Meeting started Wed Apr 19 15:59:14 2017 UTC and is due to finish in 60 minutes.  The chair is inc0. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:18 <openstack> The meeting name has been set to 'kolla'
15:59:19 <jascott1> o/
15:59:21 <srwilkers> o/
15:59:23 <rwellum> o/
15:59:24 <zhubingbing> meeting
15:59:24 <zhubingbing> o/
15:59:24 <zhubingbing> o/
15:59:24 <zhubingbing> o/
15:59:26 <inc0> #topic rollcall
15:59:32 <berendt> o/ woot
15:59:34 <inc0> howdy folks
15:59:38 <sdake> o/
15:59:44 <inc0> how y'all doin' today
15:59:45 <spsurya_> o/
15:59:53 <akwasnie> o/
16:00:00 <Jeffrey4l> o/
16:00:01 <srwilkers> doing swell
16:00:05 <duonghq> o/
16:00:11 <duonghq> wo0t
16:00:16 <pbourke> woot
16:00:17 <sbezverk> o/
16:00:21 <mnaser> o/
16:00:35 <hrw> o/
16:00:44 <egonzalez> woot o/
16:00:47 <kfox1111> o/
16:01:39 <inc0> #topic announcements
16:02:18 <inc0> Another plea for help from PTL - we'll host hands on workshops in Boston for kolla-ansible
16:02:25 <inc0> and we'll need mentors in room
16:02:31 <zhubingbing> ;)
16:02:32 <sdake> inc0 who else you got lined up
16:02:38 <sdake> and what time and day is the sesion
16:02:40 * berendt will not be in Boston :(
16:03:02 <duonghq> o/ if you want, I can give you a hand
16:03:15 <sdake> duonghq visa approved then?
16:03:21 <inc0> https://www.openstack.org/summit/boston-2017/summit-schedule/events/18177/easier-openstack-deployment-novice-installation-using-kolla?BackURL=https%3A%2F%2Fwww.openstack.org%2Fsummit%2Fboston-2017%2Fsummit-schedule%2Fglobal-search%3Ft%3Djastrzebski%23eventid%3D18177
16:03:29 <duonghq> sdake, yes, it should be delivered to me tomorrow or Friday
16:03:33 <inc0> duonghq: would appreciate it greatly
16:03:34 <sdake> duonghq nice!
16:03:45 <inc0> Tue 4:40-6:10
16:04:03 <zhubingbing> ;)
16:04:20 <sdake> inc0 if I dont have a conflict, I'll participate - I'll let you know if I have a conflict prior to summit
16:04:36 <inc0> yeah, just throwing it out there
16:04:56 <berendt> who will prepare the session?
16:04:59 <inc0> room is big, it's going to be recorded and we can show once for all that you can deploy fully fledged openstack within an hour
16:05:03 <inc0> that's on me berendt
16:05:30 <berendt> inc0: any help needed for the preparation?
16:05:51 <inc0> I might, I'll get back to you, thank you!
16:05:57 <mnaser> sounds like a nice way to end tuesday, ill be there granted there's no meeting that show up
16:06:24 <inc0> would be great:)
16:06:30 <inc0> ok, let's move on
16:06:38 <sdake> moment
16:06:38 <inc0> any announcements from community?
16:06:41 <sdake> yes :)
16:06:45 <inc0> go ahead
16:07:11 <sdake> Jeffrey4l tagged kolla-kubernetes 0.6.0 - released blueprints are here: https://launchpad.net/kolla-kubernetes/+milestone/0.6.0
16:07:24 <sdake> thanks for making 0.6.0 a success :)
16:07:25 <portdirect> w00t :)
16:08:14 <inc0> ok, well, moving to actual agenda;)
16:08:16 <mnaser> <insert clap emoji>
16:08:28 <inc0> #topic Core mentorship (inc0)
16:08:42 <inc0> ok, I want to kick off mentorship program
16:09:11 <inc0> it's a first for me so bear with me and let's work together to get this show on the road:)
16:09:35 <sdake> inc0 what did you hvae in mind ?
16:10:07 <inc0> #link https://etherpad.openstack.org/p/kolla-mentorship-signup
16:10:27 <inc0> I'd like to start pairing people together - core and person who want's to become core:)
16:10:35 <srwilkers> i really like this idea
16:10:40 <krtaylor> +1
16:11:01 <inc0> idea is, core mentor will review reviews of his mantee
16:11:05 <sdake> spsurya_ you at all interested?  if so - etherpad ftw :)
16:11:15 <sdake> manatee? :)
16:11:21 <inc0> manatee
16:11:23 <inc0> ;)
16:11:25 <inc0> well
16:11:29 <sdake> the correct word is mentee :)
16:11:32 <krtaylor> mentee?
16:11:36 <inc0> my god
16:11:39 <jascott1> ive studied for years and am still not a manatee
16:11:42 <inc0> student
16:12:00 <sdake> jascott1 i feel the same way :)
16:12:09 <jascott1> :)
16:12:23 <srwilkers> padawan
16:12:25 <inc0> so mentor will make sure to provide feedback to student if feedback is needed
16:12:28 <inc0> padawan, yes
16:12:35 <inc0> apprentice
16:12:38 <jascott1> there are always two, one master and one apprentice
16:12:40 <sbezverk> srwilkers: :)
16:12:48 <rwellum> I'm first on that list - enthusiasm not desperation..
16:12:55 <inc0> lol
16:13:05 <sdake> i think what would work best i a mentor pool
16:13:14 <spsurya_> +1
16:13:15 <inc0> also student will have trusted person to ask all the question student might want to ask;)
16:13:21 <sdake> we all have different strengths to bring to mentoring
16:13:39 <inc0> well at the end of the day
16:13:41 <hrw> I like the idea
16:13:48 <inc0> everyone is part of same community
16:13:55 <inc0> it's more of a kickoff
16:14:18 <inc0> also, mentor will either talk to me or propose core voting himself once student is ready:)
16:14:23 <sbezverk> inc0: agreed 1:1 is more managable for both participants
16:14:28 <srwilkers> sbezverk, +1
16:14:29 <inc0> core voting is end of mentorship
16:14:41 <Jeffrey4l> kolla-k8s is hot ;)
16:14:42 <rwellum> Good part is if the student emerges as a Core candidate - he or she will have a mentor who can speak for them.
16:14:46 <inc0> and also will make my job easier to determine who should be core candidate;)
16:15:09 <sdake> Jeffrey4l that is why the PTL bag is red ;)
16:15:11 <pbourke> inc0: suggest matching timezones if possible
16:15:20 <inc0> ofc pbourke
16:15:38 <inc0> so let's do first match of metnors-students right now:)
16:15:50 <inc0> since we have both lists filled
16:16:02 <pbourke> hmm k8s is popular
16:16:03 <inc0> jascott1: I chose you:P
16:16:20 <inc0> for reasons obvious;)
16:16:21 <jascott1> awww
16:16:25 <jascott1> thanks!
16:17:18 <inc0> so please, let's pair up all the mentees with mentor right now
16:17:21 <rwellum> Wow this is middle school picking teams all over again... :(
16:17:46 <sdake> kfox1111 your utc -7 :)
16:17:50 <sdake> rather utc -8
16:18:04 <sdake> rwellum ya - i am not big on the pick one idea
16:18:13 <inc0> pbourke can you take blallau under your wing?
16:18:24 <pbourke> inc0: sure thing
16:18:35 <blallau> thank you :)
16:18:36 <inc0> sdake: mind caring for rwellum ?:)
16:18:42 <hrw> rwellum: please use UTC instead of European Summer Timezone
16:18:55 <rwellum> ha - yeah hrw
16:18:59 <sdake> inc0 yes, although I am also mentoring spsurya_ atm - so need two spots :)
16:19:00 <rwellum> :)
16:19:39 <inc0> kfox1111 then?:)
16:20:05 <sdake> perhaps kfox1111 can assist mentoring rwellum and spsurya_ with me :)
16:20:26 <inc0> well, figure it out guys yourself:) I don't want to interfee
16:20:29 <pbourke> guys I assume this list is also always open, suggest linking it from the kolla wiki and sending to the ML
16:20:39 <pbourke> ?
16:20:41 <inc0> pbourke: good point! I'll handle that
16:20:46 <pbourke> thanks inc0
16:20:47 <inc0> ofc it's always open
16:20:54 <krtaylor> +1, I'd like to maybe next round
16:21:01 <sdake> krtaylor there is no next round
16:21:06 <sdake> krtaylor if your interested, sign up
16:21:08 <inc0> krtaylor: it's one constant round:)
16:21:18 <inc0> there are still mentors available, myself included:)
16:21:31 <rwellum> Many of these mentors have been super helpful in the past so I'm happy with whoever.
16:21:54 <inc0> so general interaction doesn't change, we still are same community
16:22:09 <inc0> one thing that changes is part of mentors job is to initiate core voting
16:22:19 <inc0> or ask me to do so
16:22:23 <pbourke> what does that mean
16:22:37 <inc0> if your student is ready in your eyes
16:22:41 <pbourke> ah
16:22:43 <pbourke> got it
16:22:50 <inc0> send proposal email or ask me to do it, I don't mind either way
16:23:23 <kfox1111> sdake: yeah
16:23:41 <sdake> kfox1111 - you interested in taking point on one of spsurya_ or rwellum and i'll play backup :)
16:23:48 <inc0> I'm also going to talk about it during summit project update session
16:23:54 <inc0> so it will be all official:)
16:24:15 <inc0> we need some cores for k8s in Asia timezones
16:24:15 * berendt has to leave earlier, will read backlogs later
16:24:28 <inc0> and Euro
16:24:29 <kfox1111> sdake: works for me.
16:24:39 <inc0> ok let's move on, we'll get back to this topic in few weeks
16:24:47 <sdake> kfox1111 k - put your name first and second on which one you want to take main contact with :)
16:24:50 <inc0> #topic Demystifying the gate (sdake) http://doodle.com/poll/bee7umevf43nwi6y
16:24:55 <inc0> sdake you have the floor
16:25:00 <sdake> thanks inc0
16:25:05 <sdake> in support of the mentorship program
16:25:09 <kfox1111> sdake: I don't want to play favorites. flip a coin?
16:25:13 <sdake> I am holding a two week 6 session 45 minute workshop
16:25:18 <sdake> kfox1111 flip a coin ftw :)
16:25:27 <sdake> kfox1111 that is actually how our mascot was decided :)
16:25:54 <sdake> these workshops will be recorded and published
16:25:59 <sdake> (on youtube)
16:26:06 <srwilkers> sdake, thats awesome
16:26:16 <sdake> I would encourage anyone that is interested in learning how the gate works in kolla-kubernetes to join in
16:26:22 <sdake> the first step is voting for timing
16:26:34 <sdake> I recognize the timing isnt' ideal for apac
16:26:42 <sdake> although I need to sleep sometime ;)
16:26:48 <sdake> thanks srwilkers
16:27:23 <sdake> one thing I've learned in my ramp up on kolla-kubernetes is understanding the gate is cruicial to being an effective developer
16:27:34 <sdake> jascott1 - we sort of had one of thes ethis week ad-hoc - what were your thoughts?
16:27:40 <kfox1111> wow... google has "virtual coin flip" built in now...
16:27:42 <kfox1111> scary.
16:27:43 <jascott1> it was good
16:28:00 <sdake> spsurya_ ?
16:28:00 <sbezverk> sdake: who is going to share "kube gate" working knowledge? I hope you sign up kfox1111 for it ;)
16:28:16 <inc0> sdake: can we move on?:)
16:28:16 <spsurya_> sdake: here
16:28:20 <sdake> sbezverk i have a basic enough understanding of the gate to get people to a competent stage
16:28:37 <sdake> if your interested, please vote on the doodle poll
16:28:45 <sdake> http://doodle.com/poll/bee7umevf43nwi6y
16:28:51 <inc0> I second sdake on that
16:28:54 <sdake> i am sending out the announcement to the ml friday
16:29:02 <sdake> (on times selected)
16:29:02 <inc0> gates are hard to understand and intimidating, but really important
16:29:13 <inc0> thank you Steve for taking this on
16:29:14 <kfox1111> sbezverk: I think we both shoudl work on spreading that knowlege.
16:29:23 <sdake> inc0 np :)
16:29:31 <kfox1111> the more folks that knows the gate the better we all will be.
16:29:51 <sdake> sbezverk kfox1111 your welcome to attend the sessions if you like - could use the help :)
16:30:07 <sbezverk> kfox1111: would love to, it is just bad timing for me until the second week of June
16:30:44 <inc0> sdake: anything else?
16:30:50 <sdake> inc0 should do it thanks
16:30:58 <inc0> thanks:)
16:31:10 <inc0> #topic Mixing binary and source image (daidv)
16:31:22 <inc0> hmm, daidv is not around it seems
16:31:43 <inc0> ok, let's move on then
16:31:56 <inc0> #topic Kolla-Kubernetes development (srwilkers)
16:32:02 <inc0> Steve, shoot
16:32:45 <srwilkers> so i threw this on the agenda because i saw some conversation in passing, and im really supportive of finding a dev path that works for kolla-kubernetes
16:33:09 <duonghq> inc0, I'll take over daidv's topic after this topic
16:33:12 <srwilkers> this was something i worked on for awhile but got sidetracked after some priorities took over
16:33:19 <inc0> ok duonghq
16:33:25 <kfox1111> what do you mean by 'dev path'?
16:33:34 <srwilkers> path, environment, whatever
16:33:46 <portdirect> 'world?'
16:33:53 <kfox1111> like, a set of instructions for setting up a dev system?
16:33:55 <duonghq> srwilkers, you mean learning curve?
16:34:04 <portdirect> no more that kfox1111 is getting at
16:34:35 <portdirect> there have been a couple options mooted recently - and they all sound pretty good
16:34:41 <sdake> i think has we demystify the gate, a development environment will shake out of that work
16:34:49 <portdirect> but would be great to pick one that we can run with and support longterm
16:35:02 <kfox1111> sdake: yeah.
16:35:17 <duonghq> ya, after demystify the gate, dev should straight out
16:35:25 <sdake> duonghq ++
16:35:30 <portdirect> ah ok - so this is not being looked at? https://blueprints.launchpad.net/kolla-kubernetes/+spec/devenv-taketwo
16:35:30 <kfox1111> portdirect: mostly agree. but I'm afraid devs are cats. they often do whatever they want. :)
16:35:44 <kfox1111> so we can provide a reference, but its likely a lot of folks wont follow.
16:35:57 <inc0> #link https://review.openstack.org/#/c/457317/ one way to do it
16:36:03 <srwilkers> kfox1111, then that's their problem when they say "it worked locally but wont pass the gate"
16:36:08 <kfox1111> I've never seen two dev envs that were the same. :/
16:36:17 <kfox1111> srwilkers: right.
16:36:24 <srwilkers> kfox1111, as a dev, i agree entirely with you
16:36:46 <srwilkers> kfox1111, so thats why id like to see a reference. and sdakes right: the gate sessions will shake out that reference
16:36:51 <portdirect> inc0: that certainly is one way to skin this cat - looks nice
16:37:04 <jascott1> it depends what we are going for but minikube has those limitations that worry me
16:37:10 <sbezverk> srwilkers: if it is not passig the gate there is a good reason and in 99% it is not the gate as people like to think
16:37:36 <srwilkers> sbezverk, yep.
16:37:37 <sdake> sbezverk i tend to agree, the gate is typically correct unless it thorws a flase negative
16:37:40 <portdirect> jascott1: yeah - minikube is great for webapps but is a bit limiting for what we need
16:37:42 <inc0> sbezverk: but gates != dev
16:37:51 <sdake> inc0 for sbezverk the gates are dev
16:38:03 <sbezverk> sdake: for every failure people need to identify root cause and then address it accordingly
16:38:07 <inc0> well, not for me;)
16:38:11 <portdirect> sbezverk: +2
16:38:13 <sdake> inc0 i understand sbezverk 'z workflow in detail as I have had to emulate it to get any real work done
16:38:14 <jascott1> also as newer peeps study the gate it would be great to annotate it
16:38:34 <inc0> gate has a lot of noise that is required by infra
16:38:41 <inc0> lots of hacks to get it up and running
16:38:49 <portdirect> but the core should be the same i think
16:38:49 <inc0> that's why I dislike reading gate code
16:38:51 <kfox1111> jascott1: big plus 1. :)
16:38:59 <portdirect> regardless of the mothod chosen to implement it
16:39:02 <inc0> agree portdirect - and core is kubernetes
16:39:18 <kfox1111> yeah. I think we can segregate the parts of the gate that really are gate specific and those that are generic too.
16:39:19 <inc0> k8s gives us nice lowest common denominator
16:39:26 <sdake> kfox1111 ftw :)
16:39:26 <kfox1111> make it easier to reuse those parts for dev env.
16:39:34 <portdirect> inc0: its why we are all here :D
16:39:35 <inc0> kfox1111: that alone would go a long way
16:39:38 <srwilkers> kfox1111, yep. agree
16:39:53 <kfox1111> I took an initial stab at that, but haven't had the time to complete it.
16:39:55 <portdirect> it would go 99% of the way
16:40:03 <sbezverk> kfox1111: I am ok for dev env to reuse, but not ok when gate is getting changed to accomodate dev env..
16:40:11 <kfox1111> thats why stuff like setup_kubernetes.sh is a seperate script. shouldn't be too gate specific anymore.
16:40:13 <srwilkers> this is something i'd like to help with.  ive got some bandwidth, and tackling some gate work would be a good way for me to dip my toes back in
16:40:21 <srwilkers> and something ive been wanting to understand more anyway
16:40:22 <kfox1111> we just need to figure out how to completely pull it out and make it rerunable.
16:40:22 <portdirect> same here
16:40:23 <clarkb> inc0: patches welcome to make it more readable. We definitely try to strike a balance of collecting necessary info and being too verbose
16:40:26 <inc0> we can create ansible playbook to deploy it too, it's easy win and single command to run this would be cool
16:40:32 <inc0> kinda like stack.sh for devstack
16:40:46 <sdake> clarkb its not your code - its kolla's code :)
16:40:53 <inc0> clarkb: with zuulv3 it will be much easier to handle
16:41:06 <inc0> since we can ditch shell in favor of ansible
16:41:15 * kfox1111 is really looking forward to zuulv3
16:41:16 <inc0> (if I understand zuulv3 correctly)
16:41:23 <clarkb> sdake: inc0 said the gate is unreadablr due to infra hacks
16:41:43 <sdake> clarkb i see - well i can't defend that - i dont know what hacks are being spoken of
16:41:49 <inc0> clarkb: mostly because of various regions
16:41:58 <inc0> not infra itself
16:42:00 <srwilkers> but at any rate inc0, thats pretty much it. happy to see sdake's gate sessions, since that took a lot of my talking points away. also gives me something to listen in on next week
16:42:10 <inc0> don't get me wrong, I'm not attacking infra :(
16:42:20 <clarkb> I'd happily revuew changes to make things more readable if there are issues
16:42:41 <kfox1111> yeah. there is some weird stuff around infra's firewalls/dns caching/rax.
16:42:43 <sbezverk> inc0: most of hack we have in the gate is because of multiple versions we currently support
16:42:57 <kfox1111> its stuff that really is specific to our use case though. most other openstack projects don't deploy sdn in vm's.
16:42:58 <sbezverk> as soon as it is sorted out, the gate code will be much much cleaner
16:42:59 <inc0> yeah that's what I'm saying
16:43:10 <inc0> we want to make it run on all infra nodepools
16:43:24 <inc0> that produces code that's not useful for anyone outside gates
16:43:34 <kfox1111> I think we should be able to safely tuck that away into their own scripts though.
16:43:40 <inc0> if we can separate that kind of stuff from actual devenv deployment, that'd be great
16:43:46 <kfox1111> "don't look at this file unless you are debugging the gate env itself."
16:43:53 <inc0> exactly
16:44:08 <inc0> personal request of PTL, can we do this asap and make it a priority?
16:44:37 <inc0> well, I'll work on it myself;)
16:44:41 <kfox1111> a priority above getting v4 support?
16:44:43 <inc0> but will need your help
16:45:01 <kfox1111> I can help explain things at least.
16:45:06 <sbezverk> kfox1111: the only place comes to mind is iptables script, the rest is kolla gate specific, no?
16:45:14 <inc0> k, let's do that then, I'll focus on this part
16:45:41 <kfox1111> sbezverk: there's some iptables rewriting stuff that is very gate specific. there's stuff to change unbind to be accessable from k8s as well as the host (for dns)
16:45:58 <kfox1111> I think there are a couple of other minor things but can't remember off hand.
16:46:20 <inc0> also I'd remove all the multi-branch things really
16:46:25 <sbezverk> kfox1111: right two then ;) iptables and dns, does not sound like a disaster to me
16:46:38 <kfox1111> inc0: multi-branch things?
16:46:51 <kfox1111> support for 2/3/4/t?
16:47:06 <inc0> yeah
16:47:17 <kfox1111> -2.
16:47:18 <sbezverk> that WILL simplify the gate for sure
16:47:23 <kfox1111> some day, yes.
16:47:28 <inc0> kfox1111: nto from gates
16:47:29 <kfox1111> not at least until 1.0.
16:47:39 <inc0> hold on, I'm not removing this from gate logic
16:47:47 <kfox1111> oh. you mean, move the multibranch stuff into the gate specific code?
16:47:52 <inc0> yes
16:47:57 <kfox1111> ah. ok.
16:48:04 <kfox1111> well.... 90% agree.
16:48:16 <kfox1111> I think a suer might want to checkout and test a build on 2 or 3.
16:48:20 <inc0> once you know your ropes, feel free to shuffle it around
16:48:30 <kfox1111> so, some script that versions the checkout for the version they want to test.
16:48:34 <inc0> it's about getting it up and running
16:48:47 <kfox1111> but, yeah, generally agree. its mostly gate specific today.
16:49:34 <inc0> #action inc0: segregate gate specific code from general kolla-k8s
16:49:57 <inc0> portdirect srwilkers it's your topic;) anything else you wanted to mention?
16:50:23 <rwellum> A Dev Env is a chicken-egg situation I've discovered. On one hand I want a quick environment to get me up and running and contributing to the project, on the other hand if it's too automated then the I have no idea of the underlying technologies involved, and I don't think I can reach Core that way. The former is great for demo's though. On the other hand,
16:50:23 <rwellum> if/when the former fails, it's hard to get anyone interested in helping because it's all a black-box, and the Cores who could help won't use the dev environment necessarily. This has been my experience so far.
16:50:38 <sdake> rwellum right- which is why we need to learn together
16:50:48 <sdake> rwellum that is why the deployment guide was written
16:50:56 <sdake> rwellum thank to atleasat 10+ people in the community
16:50:58 <rwellum> Agreed sdake
16:51:08 <sdake> if we learn together - we experience it
16:51:10 <kfox1111> rwellum: yeah. agreed. tahts why I think adapting and breaking up the gate stuff to support a dev env would help.
16:51:14 <sdake> that is why we are demystifyign the gate
16:51:16 <kfox1111> make it moduler with shell like,,
16:51:27 <rwellum> +1 definitely.
16:51:35 <kfox1111> setup_kubernetes. setup_helm. setup_sdn, setup_compute_kit.
16:51:41 <kfox1111> its easy to get off the ground.
16:51:41 <sdake> if we have one magic script that runs, that isn't learning together ;)
16:51:49 <kfox1111> when someone wants to know something more about how ti works,
16:51:56 <kfox1111> then can look at the one script that they are most interested in.
16:52:13 <kfox1111> and will learn how both the gate and the dev env work at the same time.
16:53:01 <sdake> i agreee one set of scripts
16:53:09 <sdake> coming out of the demystifying the gate
16:53:12 <sdake> is winning
16:53:12 <spsurya_> +1 sdake
16:53:16 <spsurya_> +1 rwellum
16:53:57 <sdake> then everyone leans how the gate works, everyone learns how the dev env works, everyone learns
16:53:59 <kfox1111> one thing I think would help is genericizing the "wait_for" scripts. make one that takes in a few arguments. might make it a lot less code for people to look through to understand.
16:54:02 <inc0> cool, I think we have a plan
16:55:18 <sdake> i guess we are out of time
16:55:21 <sdake> opens?
16:55:25 <sdake> or what
16:55:30 <duonghq> ya, 5mins left
16:56:07 <inc0> opens.
16:56:11 <inc0> #topic open discussion
16:56:30 <clarkb> I will throw https://docs.openstack.org/infra/manual/testing.html out there as docs on how our test envs are set up and what you can rely on (if you think you've run into a cloud or region specific issue that may be helpful)
16:56:56 <sdake> clarkb - thanks dude - didn't know that doc existed and been working on openstack for 5+ years :)
16:57:08 <kfox1111> clarkb: thanks. I do need to spend some more time with the gate and rax. currently the multinode is still failing always on it.
16:57:09 <sdake> i think all the cores could spend the time to read it
16:57:12 <clarkb> sdake: its relatively new, came out of barcelona as something we should have so put it together
16:57:23 <kfox1111> it started failing when we want to k8s 1.6.
16:57:27 <sdake> clarkb ++ :)
16:57:29 <inc0> great
16:57:57 <inc0> any more opens?
16:58:01 <sdake> kfox1111 - lets figure out with infra how to actually root cause the rax problems
16:58:14 <sdake> kfox1111 rather then rechecking a million times and blaming infra for what ostensibly is our gating code :)
16:58:53 <clarkb> also happy to look at logs again if you were able to gather more info off the subnode(s)
16:59:46 <sdake> clarkb I think a thread on the ml about this topic would be helpful - so we can figure out what logs to gather
16:59:49 <inc0> ok we're out of time
16:59:51 <sdake> atm we don't know what to record
16:59:51 <inc0> thank you all!
16:59:56 <inc0> #endmeeting kolla