15:59:21 <inc0> #startmeeting kolla
15:59:23 <openstack> Meeting started Wed Aug  2 15:59:21 2017 UTC and is due to finish in 60 minutes.  The chair is inc0. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:27 <openstack> The meeting name has been set to 'kolla'
15:59:29 <inc0> #topic w00t for Kolla
15:59:34 <duonghq> wo0t
15:59:34 <kfox1111_> o/
15:59:35 <inc0> w00t
15:59:39 <duonghq> o/ \o \o/
15:59:51 <inc0> -o-
16:00:06 <inc0> morning excersise is important
16:00:16 <vhosakot> O/
16:00:43 <duonghq> seem that we do not have many people here
16:00:49 <krtaylor> o/
16:00:51 <vhosakot> o/
16:00:53 <duonghq> hi vhosakot
16:01:00 <vhosakot> hi duonghq :)
16:01:05 <rwellum> o/
16:01:06 <egonzalez> woot o/
16:01:17 <coolsvap> O/
16:01:41 <krtaylor> oops, oh yeah, w00t!
16:02:32 <mgoddard> o/
16:03:13 <vhosakot> wooot! :)
16:03:57 <inc0> ok, announcements
16:04:01 <inc0> #topic Announcements
16:04:25 <inc0> so, I'll run for PTL one more time guys and gals:) I'll submit my candidacy later today
16:04:43 <vhosakot> nice inc0 :)
16:04:46 <rwellum> +1
16:04:56 <inc0> but frankly I think this will be my last one.
16:05:16 <vhosakot> will there be a poem in your PTL candidacy inc0? :)
16:06:17 <inc0> so I'd like to plant idea in your collective heads and encourage thinking of becoming next PTL;) if you decide to try, let me know so I can prep you for what's to come:)
16:06:51 <inc0> sdake did that and it made transition lot easier for me, it's only fair if I do the same:)
16:07:00 <inc0> also vhosakot there will be now. A haiku.
16:07:13 <vhosakot> lol :)
16:07:55 <inc0> also, if anyone wants to run for Queens, I also encourage that
16:08:14 <inc0> ok that's it from me
16:08:24 <inc0> anyone wants to announce anything?
16:08:40 <vhosakot> we need folks to vote for the kolla Sydney talks please :)
16:09:00 <inc0> right, we have quite a list of talks submitted:)
16:09:19 <inc0> type in kolla in search box, I was amazed;)
16:09:31 <vhosakot> right, would be great if the community votes for the talks
16:09:42 <vhosakot> yeah there are a bunch about kolla and k8s too
16:10:04 <inc0> ok, let's get to agenda
16:10:19 <inc0> #topic Feature freeze and Feature freeze exception.
16:10:32 <inc0> not sure who added this
16:10:46 <duonghq> it's mine, but it should be your topic, inc0
16:10:54 <inc0> haha
16:10:59 <duonghq> I see that we have some bp which as essential
16:11:11 <duonghq> so which one need to go to FFE?
16:11:16 <inc0> so we were ususally pretty lax with feature freeze
16:11:44 <duonghq> iirc, we will freeze in next week?
16:11:55 <inc0> also we still are within 2 weeks from P-3 so our release trailing, the way I interpret it (which mgiht be wrong) also moves real ff
16:12:00 <inc0> right
16:12:42 <duonghq> so, do you have any bp or anything that you want to add to ffe?
16:13:20 <inc0> let's see what will be merged before ff
16:13:37 <inc0> and then whoever wants to apply for ffe, lets do this next week
16:14:26 <inc0> I don't want to apply for any ff because it's not me ultimately who will have to follow through:)
16:14:43 <duonghq> we do not have many bp which in Good progress or Needs Code Review yet
16:16:03 <inc0> I think we need to clean up our bps in general
16:16:05 <inc0> I'll do it
16:16:10 <duonghq> nice
16:16:15 <inc0> and let's discuss next week about ffe
16:16:30 <inc0> also, anyone who works on feature, make sure you have bp submitted and targeted to pike
16:17:02 <rwellum> I think we need a bp for centralized logging, at least for kolla-k8s.
16:17:21 <duonghq> https://blueprints.launchpad.net/kolla-ansible/+spec/ansible-specific-task-become -> this is my fault if it cannot be merged in P
16:17:26 <inc0> well kolla-k8s doesn't follow stable release policy yet
16:17:32 <inc0> so feature freeze doesn't apply there
16:17:49 <inc0> let's not use word fault please
16:18:18 <inc0> if only part of it merges, that's ok too
16:18:35 <duonghq> I should put more attention on it from the beginning
16:19:01 <inc0> on the other hand, we need to make sure both kolla and kolla-ansible are functional
16:19:14 <inc0> not merged features aren't horrible, they'll land in queens
16:19:19 <inc0> broken upgrades are
16:19:44 <duonghq> agreed
16:20:13 <inc0> #action: inc0 to clean up blueprints
16:20:33 <inc0> anything else on that topic?
16:20:44 <duonghq> no
16:20:55 <inc0> #topic Ansible strategy solutions
16:21:08 <duonghq> ya, quite short agenda today?
16:21:20 <inc0> yeah
16:21:33 <duonghq> For implement keystone zero-downtime mechanism in Kolla,
16:21:34 <duonghq> Ansible strategy is the only way atm, but Ansible is licensed as GPLv3.
16:21:34 <duonghq> According to following link:
16:21:38 <duonghq> #link http://lists.openstack.org/pipermail/legal-discuss/2017-August/000480.html
16:21:45 <duonghq> we have 2 options, and I think the option a) is the easist one.
16:22:00 <duonghq> a) Can kolla-ansible work without it? Or is it essential? If it can work
16:22:00 <duonghq> without the strategy plugin and the strategy plugin just makes some
16:22:00 <duonghq> things nicer, then you can put it in a different repo
16:22:00 <duonghq> (kolla-ansible-nice-strategy-plugin or whatever), have that repo not be
16:22:00 <duonghq> part of kolla's official deliverables, and write a document for kolla
16:22:01 <duonghq> users as to how they can optionally install and configure the plugin.
16:22:25 <duonghq> so, basically, we can create external repositogy outside the OpenStack official repository
16:22:42 <duonghq> and pull needed plugin when user want to zero-downtime upgrade ks
16:22:49 <inc0> yeah
16:22:59 <duonghq> how do you think about this approach?
16:23:10 <inc0> that being said, having to build whole opensource infra from scratch is pain:/
16:23:28 <inc0> how about try to submit this ot ansible?
16:23:50 <inc0> I mean it is generic problem to solve
16:24:17 <rwellum> duonghq: have you spoken to RH? Especially as they are interacting with Kolla more these days? I saw sdake saying on the email thread that it just comes down to company attorneys.
16:24:24 <duonghq> It's better solution but I don't think we can get it done in short time, and nobody know if we will get other issue again in the feature
16:25:01 <duonghq> rwellum, no, I only grab mordred idea and put it here
16:25:39 <inc0> we can do both
16:25:39 <duonghq> I think his suggestion is ok
16:25:49 <inc0> submit it somewhere on github and start using it
16:25:58 <inc0> and try to push it to ansible proper
16:26:25 <duonghq> sure, it's best way, but I think we need a simple mechanism for load custom plugin
16:26:29 <duonghq> from github
16:26:36 <duonghq> how about git submodule?
16:26:36 <inc0> true
16:26:42 <inc0> uhh
16:26:45 <inc0> not sure
16:26:56 <inc0> if we can pip install plugin that'd solve it
16:27:02 <inc0> not sure if possible in ansible
16:27:35 <rwellum> Pretty sure that's not supported by RH
16:27:44 <duonghq> is it possible for kolla? or pip in general?
16:27:56 <inc0> in ansible
16:28:12 <duonghq> rwellum, hmm, so I think make it is a option feature is ok
16:29:11 <duonghq> inc0, given Monty's email in legal ml, do you think we can get keystone zero-downtime upgrade and neutron rolling upgrade bp merge in P?
16:29:26 <kfox1111_> rwellum: ping me after the meeting to discuss centeralized loging. we have two different aproaches we need to pick from. I've prototyped both.
16:29:36 <inc0> duonghq: doubt that:/
16:29:41 <inc0> I mean
16:29:46 <inc0> no, we can actually
16:29:57 <krtaylor> TLDR; is the issue big-tent doesn't allow gpl? else what about a new openstack project outside kolla but still in openstack?
16:30:26 <inc0> krtaylor: I think big tent won't allow gpl
16:30:32 <krtaylor> I guess that is what Monty was referring to then, ok
16:30:34 <inc0> however openstack-hosted might work
16:30:43 <duonghq> inc0,  so I will implement it tomorrow (in my tz), hope that I can get it reviewed soon
16:31:17 <duonghq> I'll create plugin in my personal repo first, then mechanism for custom module load in kolla-ansible
16:31:17 <inc0> duonghq: you can always do ansible-playbook --forks 1 :)
16:31:23 <kfox1111_> probably deserves another email to the legal list.
16:31:31 <kfox1111_> though I think they have blocked gpl several times now.
16:31:41 <duonghq> inc0,  what does --forks do?
16:31:56 <kfox1111_> mostly I think from kolla's request for ansible stuff.
16:32:05 <egonzalez90> Actually can use serial as a environment variable
16:32:27 <inc0> duonghq: it will run only one server at the time over whole playbook
16:32:32 <inc0> or env
16:32:41 <inc0> it will make upgrade long, but it'll work
16:33:07 <duonghq> so, currenty implementation is ok with --forks 1?
16:33:10 <egonzalez90> https://github.com/openstack/kolla-ansible/blob/master/tools/kolla-ansible#L118
16:33:32 <duonghq> the only major issue is we cannot restart all container at a time
16:33:39 <duonghq> egonzalez90, is it right?
16:34:42 <egonzalez90> Yep, using that serial won't restart all at the same time, but may cause issues in other services
16:35:32 <egonzalez90> cannot remember the details about which services had those issues
16:35:37 <inc0> nova
16:35:38 <inc0> ;)
16:36:23 <duonghq> so, we cannot get it done without some special treament (include ansible strategy)?
16:36:42 <inc0> well, yes
16:37:01 <inc0> but our upgrade is ususally fast enough (for control nodes) that it doesn't matter that much anyway
16:37:12 <duonghq> ya, painful situation (again)
16:37:38 <inc0> one thing to make it a bit smoother would be to manage haproxy and drain api connections for service upgrade time
16:37:59 <egonzalez90> Implemet serial per task in ansible codebase, something they rejected other times
16:38:48 <inc0> well strategy plugin might go in
16:38:59 <inc0> as it's a plugin
16:39:10 <duonghq> so, get thing in ansible upstream is not so easy
16:39:30 <inc0> yeah I know:/
16:40:28 <duonghq> I think the easiest solution is making our plugin and install through pip?
16:40:59 <duonghq> and by someway we detect if we have the module and enable it?
16:41:00 <inc0> if ansible works with that, yes
16:41:48 <duonghq> if the plugin doesn't exist in the system, we fallback the normal upgrade (with a small downtime)
16:42:01 <duonghq> if it's exist, we can use the plugin
16:42:04 <duonghq> I think os
16:42:37 <duonghq> so the issue is if we can make Ansible plugin install by pip
16:42:44 <inc0> right
16:42:52 <inc0> then we create pip package and put it in requirements
16:43:27 <duonghq> I think make it is kolla's plugin is easier
16:43:31 <duonghq> j/k
16:44:01 <inc0> it is easier, but we'd need to get out of openstack and that's harder;)
16:44:28 <duonghq> I mean we just make it outside openstack
16:44:42 <egonzalez90> Btw, OSA have a repo in OpenStack for ansible plugins
16:44:46 <egonzalez90> https://github.com/openstack/openstack-ansible-plugins/tree/master/strategy
16:45:36 <inc0> licensed as apache
16:45:49 <duonghq> didn't realize it, but ASLv2 is good
16:45:53 <inc0> might be an issue
16:45:56 <inc0> well
16:46:05 <duonghq> but I'm not sure they do right way
16:46:09 <inc0> question is if they just miss gplv3
16:46:59 <inc0> https://github.com/ansible/ansible/blob/devel/lib/ansible/plugins/strategy/linear.py
16:47:02 <inc0> it's GPL
16:47:13 <duonghq> yup
16:48:02 <inc0> I'll talk to them and give them heads up
16:48:51 <duonghq> okay
16:51:19 <inc0> anything else on this topic?
16:51:27 <duonghq> no
16:51:44 <duonghq> that's all
16:51:44 <inc0> ok, I'll talk with OSA team maybe together we'll figure sth out too
16:51:46 <duonghq> thank you
16:51:52 <inc0> #topic open discussion
16:51:55 <inc0> anyone?
16:52:00 <jamesbenson> any updates on external ceph vs keeping it in docker?
16:52:13 <jamesbenson> for pike/queens?
16:52:15 <inc0> jamesbenson: we will discuss it on ptg
16:52:15 <jamesbenson> on
16:52:17 <jamesbenson> k
16:52:50 <jamesbenson> that's all for me
16:53:37 <inc0> ok, I guess we're done:)
16:53:39 <inc0> thank you all!
16:53:44 <inc0> #endmeeting kolla