16:00:13 <Jeffrey4l> #startmeeting kolla
16:00:14 <openstack> Meeting started Wed Jun 13 16:00:13 2018 UTC and is due to finish in 60 minutes.  The chair is Jeffrey4l. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:17 <openstack> The meeting name has been set to 'kolla'
16:00:21 <Jeffrey4l> #topic rollcall
16:00:40 <mandre> o/
16:01:02 <chason> o/
16:01:33 <pbourke_> o/
16:01:47 <bmace> o/
16:03:19 <Jeffrey4l> #topic Announcements
16:03:30 <Jeffrey4l> anything update from community?
16:03:54 <Jeffrey4l> guess no, move on.
16:03:56 <Jeffrey4l> #topic Ceph Bluestore gates
16:04:05 <Jeffrey4l> i think you added this pbourke_, right?
16:04:12 <pbourke_> Yes
16:04:17 <Jeffrey4l> #link https://review.openstack.org/566801
16:04:27 <pbourke_> I was hoping tone may be able to join, unsure if he’s around
16:04:38 <Jeffrey4l> this pb is almost done.
16:04:49 <Jeffrey4l> guess he is not here
16:04:51 <pbourke_> He was having some issues / uncertainty about how to partition loop back devices
16:05:22 <pbourke_> I’m on my phone right now commuting so unfortunately I’m unable to really provide details ://
16:05:24 <Jeffrey4l> i pinged him, seems he is off.
16:05:41 <pbourke_> I’ll check in with him tomorrow and follow up on it
16:06:08 <pbourke_> We’re very close, so any help getting gates working is greatly appreciated
16:06:13 <Jeffrey4l> yeah, i will try to check with him.
16:06:16 <Jeffrey4l> too.
16:06:22 <pbourke_> Thanks a mill
16:06:50 <Jeffrey4l> my pleasure :D
16:06:55 <Jeffrey4l> ok. move on
16:07:00 <Jeffrey4l> #topic Kolla storyboard
16:07:08 <Jeffrey4l> still yours? pbourke_
16:07:16 <pbourke_> Sure
16:07:26 <pbourke_> So my only question is, should we move to this?
16:07:27 <Jeffrey4l> #link https://storyboard.openstack.org/#!/project_group/list
16:07:51 <pbourke_> Are there pros/cons, will all projects move eventually regardless?
16:08:06 <mandre> we'll eventually have to move, the question is when?
16:08:18 <pbourke_> I think we could do it for the S cycle
16:08:26 <Jeffrey4l> from the project list, there is no *important*(may be not proper fo this word) moved to storyboard.
16:09:02 <pbourke_> I can try dig into what’s involved and update the community in a week or so
16:09:14 <mandre> has anyone looked at storyboard yet?
16:09:25 <Jeffrey4l> the critical thing i think storyboard should support is, stable branch management.
16:09:51 <mandre> I don't think we're using launchpad in a special way, so transitioning to storyboard should be smooth
16:09:54 <Jeffrey4l> for example, i can not found the bug in ironi stable/queens branch in storyboard
16:10:55 <Jeffrey4l> mandre, i checked storyboard. seems this feature is not implmeneted in web. but already implement in api.
16:11:10 <mandre> ok, would be good to clarify
16:11:11 <pbourke_> Perhaps it’s missing some crucial stuff that’s stopping the majority moving over just yet
16:11:20 <pbourke_> I really don’t know
16:11:55 <Jeffrey4l> another one is search enging friendly.. i got nothing with "Migrate to in-tree zuul jobs site:storyboard.openstack.org"
16:12:22 <ktibi_> we use it for kayobe and it's very good :)
16:12:48 <Jeffrey4l> any solution for stable branch management? ktibi_
16:13:17 <mandre> Jeffrey4l: https://storyboard.openstack.org/#!/story/2002542 was just created, I don't think the crawlers had time to reach it yet :)
16:14:18 <Jeffrey4l> mandre, yeah, you are correct. tried a old bug, which works. thanks.
16:14:29 <ktibi_> Jeffrey4l, hum need to ask to mgoddard
16:15:19 <ktibi_> Jeffrey4l, you can use tag maybe
16:15:56 <Jeffrey4l> so we still need time to check the gap between LP and storyboard.
16:16:05 <Jeffrey4l> ktibi_, yeah, maybe..
16:17:04 <Jeffrey4l> iirc, there is already some discuss in the ML, we could check it.
16:17:10 <ktibi_> Jeffrey4l, you can keep LP for bug reporting and storyboard for new feature or thing like that
16:17:40 <Jeffrey4l> but the issue is why we need both rather than one?
16:18:08 <Jeffrey4l> i thought storyboard is a replacement of LP.
16:18:11 <pbourke_> I wouldn’t be in favor of moving till it supports everything we need
16:18:17 <mandre> ktibi_: ugh, if we're going to migrate we need to switch over to storyboard entirely
16:19:17 <ktibi_> Jeffrey4l, mandre yes of course, it's just if you don't want to migrate all the same day ^^
16:20:15 <Jeffrey4l> pbourke_, agree. but for me, branch bug management is a critical issue need be solved. no matter using whatever solution. tags? multi bugs?
16:20:35 <pbourke_> I agree, all that would need to be figured out
16:20:46 <pbourke_> Moving is not a critical issue
16:20:51 <pbourke_> Righty now anyway
16:20:56 <pbourke_> *right
16:21:39 <pbourke_> I’m
16:21:51 <mandre> if the bug management per branch is critical for us, we should probably tell the storyboard team
16:21:51 <pbourke_> Good to move on :)
16:21:52 <Jeffrey4l> yeah. then next step for this , i think, is check with storyboard team to solve the issue we concern :)
16:22:17 <Jeffrey4l> mandre, yes. will do
16:22:30 <Jeffrey4l> ok, let us move
16:22:43 <Jeffrey4l> #topic Building python3 only containers (fedora28 base)
16:22:47 <Jeffrey4l> mandre, yours
16:22:53 <mandre> yes, thanks Jeffrey4l
16:22:53 <Jeffrey4l> #link https://etherpad.openstack.org/p/python3-poc-status
16:23:23 <mandre> as you probaly know, there is a lot of work going on to migrate everything to python3
16:23:42 <mandre> just as a reminder, python 2.7 will be EOL in a little more than 1.5 year
16:24:36 <mandre> so the RDO folks want to start building containers with *python3 only*
16:25:02 <mandre> and build a PoC where we keystone works
16:26:05 <Jeffrey4l> only for keystone?
16:26:16 <mandre> so the idea is to use a fedora 28 base image that ships with python3 only and use a special repo RDO provides for the base image, where everything should be python3 compatible
16:26:25 <mandre> keystone and glance at first
16:26:36 <mandre> with keystone being the priority target
16:26:50 <pbourke_> And it needs to be fedora right?
16:26:53 <Jeffrey4l> for a little long term, will this work support all openstack services?
16:27:37 <mandre> pbourke_: well, fedora really is the pragmatic choice, since centos7 will never support python3
16:27:55 <mandre> fedora 28 is what is closest to the upcoming version
16:27:56 <Jeffrey4l> btw, is there any plan for centos8?
16:27:58 <pbourke_> Never?
16:28:12 <pbourke_> Ah, 8 will
16:28:15 <mandre> yeah
16:28:47 <mandre> Jeffrey4l: yeah, eventually all of the openstack packages will need to work with python3
16:29:05 <mandre> rdo already builds openstack packages for fedora
16:29:31 <mandre> so there is a couple of ways we could proceed toward that goal
16:29:45 <mandre> we could add a new fedora base image
16:30:26 <mandre> that would mean updating most of the dockerfiles to add the 'fedora' base in all of the conditionals
16:30:32 <Jeffrey4l> then this works will be temperory solution, after centos8 is out, this works will rebased on centos8, and fedora will be dropped, right?
16:30:55 <mandre> and this would also imply that we start supporting fedora, which is not really the idea
16:31:08 <mandre> Jeffrey4l: exactly!
16:32:01 <pbourke_> Sounds ok mandre
16:32:22 <mandre> another solution, would be to somehow trick the build tools to use fedora base image, while making it think it builds for centos
16:32:32 <mandre> but that would be very dirty I think :)
16:32:39 <Jeffrey4l> one question, when and how kolla move to python3 for all distro?
16:32:57 <mandre> I just wanted to check with you if you're open to the idea before I start investing too much time in this effort
16:32:59 <pbourke_> When the packages are ready I guess
16:33:11 <Jeffrey4l> mandre, that will be affect kolla's release ( rocky?)
16:33:46 <Jeffrey4l> i do not think kolla will build image based python3 with a fake centos image ( fedora) in this cycle.
16:34:19 <Jeffrey4l> pbourke_, one distro by one distro or wait until all distro are ready ;)
16:34:19 <mandre> Jeffrey4l: I don't think we need to make it a release goal for us, it's just providing a way for RDO to build using fedora base and their repos
16:34:38 <Jeffrey4l> then how about a feature branch for doing this?
16:34:59 <Jeffrey4l> then after centos8 is out, we could merge that branch back to master
16:36:10 <mandre> Jeffrey4l: can we merge things in a feature branch, or should it live as a patch series?
16:36:46 <mandre> other option would be to hack on a kolla fork on github or elsewhere and point the rdo tools to this fork
16:36:48 <Jeffrey4l> start such kind of testing on master, and it will cross much cycle, is a wried things
16:37:20 <mandre> and this would be the groundwork for us for supporting centos8 when it's out
16:37:24 <Jeffrey4l> mandre, we haven't a feature branch before, but i think we can do whatever we want in feature branch.
16:37:47 <Jeffrey4l> we need to check with tc for this ^^
16:38:29 <Jeffrey4l> if this is possible, we clould star the work in a python3 feature branch.
16:38:45 <mandre> yeah I like that idea
16:38:46 <Jeffrey4l> not just for centos. we could try to make distro works with py3
16:39:26 <Jeffrey4l> make all distro*
16:39:47 <mandre> that's all for me
16:40:23 <Jeffrey4l> pbourke_, what do  you think about having a py3 feature in kolla for testing?
16:40:58 <Jeffrey4l> #action Jeffrey4l check with tc about creating feature branch in kolla
16:41:22 <Jeffrey4l> thanks mandre
16:42:09 <Jeffrey4l> then let us move to open discussion
16:42:16 <Jeffrey4l> #topic open discussion
16:42:22 <Jeffrey4l> any open topics?
16:42:57 <bmace> once https://review.openstack.org/#/c/573788/ lands the kolla-ansible dev environment should be all set to run with the cli, including support for multi-node deploys
16:43:28 <bmace> thanks much to mark for testing that all and getting it working.  at this point the cli is in the same state that we have it internally, and if people want new features, etc, feel free to get involved :)
16:43:44 <bmace> that is it for me.
16:43:59 <Jeffrey4l> cool. thanks bmace
16:45:46 <Jeffrey4l> ok. seems we are done today
16:45:55 <Jeffrey4l> thanks everyone for coming
16:46:00 <Jeffrey4l> have a nice day ;)
16:46:03 <mandre> thanks Jeffrey4l
16:46:03 <Jeffrey4l> #endmeeting