15:00:11 <egonzalez> #startmeeting kolla
15:00:11 <openstack> Meeting started Wed Jan  9 15:00:11 2019 UTC and is due to finish in 60 minutes.  The chair is egonzalez. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <openstack> The meeting name has been set to 'kolla'
15:00:24 <egonzalez> #topic rollcall
15:00:27 <spsurya> 0/
15:00:48 <egonzalez> o/
15:01:34 <pbourke> o/
15:03:05 <egonzalez> #topic agenda
15:03:15 <egonzalez> * Roll-call
15:03:15 <egonzalez> * Announcements
15:03:15 <egonzalez> * Releases
15:03:15 <egonzalez> * CI state https://etherpad.openstack.org/p/kolla-ci-status
15:03:15 <egonzalez> * kolla-cli discussion
15:03:15 <egonzalez> * open discussion
15:03:36 <egonzalez> #topic Announcements
15:03:57 <egonzalez> Welcome back from holidays :)
15:04:08 <egonzalez> just one announcement
15:04:38 <egonzalez> Call for presentations for denver summit/ptg is open until 23rd of january
15:05:05 <egonzalez> ensure to propose the talks before that date
15:05:13 <egonzalez> thats all from me
15:05:22 <egonzalez> any update or announcement?
15:05:22 <spsurya> Noted
15:05:43 <spsurya> Yes
15:06:23 <spsurya> Review priority is added for Kolla core review
15:06:38 <spsurya> Feel free to try
15:07:14 <egonzalez> spsurya cool thanks  for adding it, for sure will be helpful to track priority changes
15:07:14 <spsurya> Also feel free to go on ML discussion on this
15:08:01 <egonzalez> spsurya anything else?
15:08:46 <spsurya> Kolla CLI functional test is failing
15:09:04 <egonzalez> spsurya there is a topic for kolla-cli later
15:09:10 <spsurya> Blocked merging of some of the patch
15:09:28 <spsurya> egonzalez sorry 😐
15:09:43 <spsurya> Yeah nothing for now
15:09:49 <egonzalez> we can talk that later in the ci state topic
15:10:01 <egonzalez> #topic Releases
15:10:23 <egonzalez> this week a new release for every stable branch has been made
15:10:40 <egonzalez> many bugs has been fixed
15:11:07 <egonzalez> most of them because 3rd pary changes as repositories or packages
15:11:14 <egonzalez> *party
15:11:46 <egonzalez> also, this week milestone release is done too
15:12:02 <egonzalez> *milestone 2 (m2) as b1 tag
15:13:52 <egonzalez> any question about the releases?
15:15:04 <egonzalez> #topic CI state https://etherpad.openstack.org/p/kolla-ci-status
15:15:31 <egonzalez> a repo change in grafana broke kolla builds, fix in master is merged
15:15:46 <egonzalez> backports are passing CI job
15:16:09 <egonzalez> please check those changes if have some time
15:17:00 <egonzalez> spsurya your turn with kolla-cli jobs
15:17:28 <spsurya> Yeah egonzalez
15:17:39 <spsurya> I was digging into this today
15:17:59 <spsurya> Will continue tomorrow on this
15:18:05 <egonzalez> #link https://bugs.launchpad.net/kolla-cli/+bug/1810387
15:18:05 <openstack> Launchpad bug 1810387 in kolla-cli "Stop is broken due a kolla-ansible change" [Undecided,New]
15:18:35 <egonzalez> spsurya my change to modify kolla-ansible stop changed the behavior
15:19:12 <egonzalez> now need to use site.yml with kolla_action=stop instead of running stop.yml playbook
15:19:40 <spsurya> egonzalez thanks for bug link and info
15:20:07 <egonzalez> is mostly copy/paste the deploy action changing kolla_action variable
15:21:05 <spsurya> Ok
15:21:42 <egonzalez> any update on the CI state? changes, new tests, or anything?
15:22:18 <spsurya> nothing from my side
15:23:08 <egonzalez> #topic kolla-cli discussion
15:23:30 <egonzalez> a few weeks ago i've been asked about kolla-cli release model
15:23:50 <egonzalez> this raised the question in a previous meeting about how was the state of the cli itself
15:24:29 <egonzalez> CI has been broken for a few weeks, and the core team wasnt reviewing or adding changes
15:25:50 <pbourke> whats yours feeling on it egonzalez
15:25:55 <pbourke> *your
15:26:21 <egonzalez> i think kolla-cli has potential to be a good thing to users
15:26:33 <egonzalez> however not much interest from devs nor operators to use it
15:27:17 <pbourke> I think it possible that if the docs had being updated to make it a more integral part of kolla, people would then have used it
15:27:29 <pbourke> as it stands it never really got off the ground
15:27:58 <egonzalez> yep, thats sure
15:28:16 <pbourke> its still possible for this to happen but you need people to do the work
15:29:39 <pbourke> you could send out a post to the ML to see if people could be rallied behind it
15:30:07 <pbourke> if not its probably best to look at phasing it out, as if left unmaintained it will confuse users
15:30:23 <pbourke> just my 2c
15:30:36 <chason_> kolla-cli documentation need some restructure work before publishing it.
15:30:50 <egonzalez> yes, i'd like to make cli success, as first item we could add it to the docs and fix the funtional tests
15:31:17 <egonzalez> then ask for users if they have interest on it and if there are devs wiling to do the work
15:31:48 <egonzalez> lets say, a couple of months to see if something changes?
15:31:54 <pbourke> sounds reasonable
15:32:16 <egonzalez> then if nothing changes and it left unmaintained, make a vote for the removal
15:32:26 <egonzalez> sounds good to you?
15:32:32 <pbourke> yup :)
15:33:19 <spsurya> +1
15:33:25 <chason_> +1
15:33:26 <egonzalez> nice
15:33:41 <egonzalez> #action add kolla-cli to kolla-ansible deploy docs
15:34:11 <egonzalez> #action send an email to reach interest from operators and developers
15:34:24 <egonzalez> anything else ?
15:36:29 <pbourke> nothing from me
15:37:01 <egonzalez> ok, lets move to open discussion
15:37:09 <egonzalez> pbourke thanks
15:37:15 <egonzalez> #topic open discussion
15:37:38 <egonzalez> anything else missing to discuss today?
15:37:57 <chason_> egonzalez If you have time, please check my reply to your comment on this patch: https://review.openstack.org/#/c/627954/
15:38:04 <chason_> Thanks! :D
15:38:29 <egonzalez> chason_ sure
15:39:23 <egonzalez> chason_ many packages changed to py3 in ubuntu, check the depends-on change on kolla image patch to see which has shifted
15:42:09 <egonzalez> any other topic?
15:44:05 <chason_> OK, will follow it and update my patch.
15:45:47 <hrw> sorry for missing whole meeting
15:46:06 <egonzalez> guess nothing else, lets wrap the meeting
15:46:37 <egonzalez> thank you all for coming :) have a nice day
15:46:42 <egonzalez> #endmeeting