15:00:54 <egonzalez> #startmeeting kolla
15:00:55 <openstack> Meeting started Wed Mar 20 15:00:54 2019 UTC and is due to finish in 60 minutes.  The chair is egonzalez. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:59 <openstack> The meeting name has been set to 'kolla'
15:01:02 <egonzalez> #topic rollcall
15:01:51 <mnasiadka> o/
15:02:32 <chason> o/
15:03:13 <hrw> o/
15:05:10 <egonzalez> hope mark to be here today :(
15:05:16 <egonzalez> #topic Announcements
15:05:39 <egonzalez> Kolla will have feature freeze for Stein from March 18th - 21st
15:06:11 <egonzalez> this mean after this week no feature can be merged until we tag rc1 (creates stable/stein branch)
15:06:41 <egonzalez> be sure only merge bugs or things missing which breaks the release
15:06:50 <hrw> so py3 -> train
15:07:09 <egonzalez> yes
15:08:05 <hrw> added review priority -1 (branch freeze) to https://review.openstack.org/#/c/642375
15:08:11 <egonzalez> work started late and we dont have enough time to test all properly
15:08:38 <hrw> and got heavily hit by issues from many sides
15:08:39 <egonzalez> can make stein in a dangerous state, so I prefer to leave for train release
15:08:45 <hrw> +2
15:09:13 <egonzalez> py3 for T is a big goal, since rhel8 may come, and other distros shift most to py3 too
15:09:43 <hrw> Train is 'py3 must be present', Ucycle is 'py2 may go'
15:09:52 <egonzalez> next announcement
15:09:56 <egonzalez> New PTL
15:10:18 <egonzalez> Mark (mgoddard) is our new PTL for Train cycle
15:10:36 <hrw> yay Mark!
15:10:42 <egonzalez> give him all the support and be as nice with him as you're been with me
15:10:48 <hrw> egonzalez: thanks for being PTL
15:11:01 <egonzalez> is been a please to serve for this awesome project, thank you all for the support
15:11:10 <egonzalez> *pleasure
15:11:57 <egonzalez> thats all announcements from my side, any other new?
15:12:05 <hrw> not me
15:13:03 <egonzalez> #topic Kolla whiteboard https://etherpad.openstack.org/p/KollaWhiteBoard
15:13:55 <egonzalez> please keep an eye on this etherpad, here are gate status, feature tracking and release states
15:14:11 <hrw> ok
15:14:23 <egonzalez> not sure what else need to be discussed today about the etherpad
15:14:45 <hrw> I will reformat it a big - add lists etc
15:15:02 <hrw> s/big/bit
15:15:16 <egonzalez> hrw thanks
15:15:27 <egonzalez> added a gate failure: kolla-ansible rpm distros failing due duplicated placement wsgi process name
15:15:53 <hrw> noted
15:16:29 <hrw> mnasiadka: something for you?
15:16:39 <hrw> ;d
15:17:06 <mnasiadka> No no, I’m good, quiet is my nature :)
15:17:55 <egonzalez> #topic Tech preview concept in kolla-ansible
15:18:13 <egonzalez> this is a concept i've been thinking for a while
15:18:17 <hrw> egonzalez: some spec/bp for it?
15:18:25 <hrw> doc/notes?
15:18:42 <egonzalez> should we tag some services as not tested aka tech preview?
15:18:46 <egonzalez> hrw regarding?
15:19:06 <egonzalez> this came out around cyborg patch sets
15:19:09 <hrw> ignore
15:19:30 <egonzalez> the developer have said the service is not tested really because doesnt have the required hardware
15:20:07 <egonzalez> if we merge it, we're officially releasing a service which likely is not working or will break someday
15:20:52 <egonzalez> so the tech preview tag, will advise users that the service is not fully functional or may not work as is not production read
15:20:54 <egonzalez> ready
15:21:02 <mnasiadka> Uh, so then one thing is mark it as tech preview, or delay to Train and find test env
15:21:33 <hrw> egonzalez: 'tech preview'? why not 'untested'
15:21:57 <hrw> 'tech preview' has no real meaning
15:22:00 <egonzalez> same apply to other service which has been implemented few releases ago and no patches updated them
15:22:56 <egonzalez> probably many of our supported services really dont work on all distros/install types
15:23:02 <hrw> I like idea
15:23:04 <mnasiadka> Well, we have more services that we are not testing...
15:23:34 <JamesBenson> I like the tagging idea as well
15:24:19 <egonzalez> yeah, so tech preview or whatever term we want to use
15:24:39 <egonzalez> we can discuss this on a mailing list or a spec review
15:24:53 <mnasiadka> Makes sense
15:25:03 <hrw> +2
15:25:28 <egonzalez> anything to add this topic?
15:25:44 <hrw> fine with moving it to ML
15:25:47 <egonzalez> #action Work on the "tech preview" concept
15:25:51 <JamesBenson> which release would that be put on?
15:26:04 <egonzalez> not sure if that #action thing do anything at all
15:26:09 <JamesBenson> or immediately?
15:26:19 <hrw> JamesBenson: Train material
15:26:24 <JamesBenson> thx
15:26:26 <egonzalez> it will take some time to discuss, so probably train
15:26:30 <mgoddard> hi all
15:26:34 <hrw> mgoddard: hello
15:26:40 <hrw> JamesBenson: Stein is done.
15:26:49 <mgoddard> very sorry to miss the start of my first meeting /facepalm
15:26:50 <egonzalez> mgoddard Hi, congrats on your new role :)
15:27:09 <mgoddard> I'm at a customer site with no internet, and got caught up
15:27:15 <mgoddard> thanks egonzalez
15:27:20 <hrw> mgoddard: happens. I have two meetings now
15:27:55 <mgoddard> just catching up
15:28:14 <egonzalez> can we move to other topics? we have a couple more left
15:28:23 <hrw> go
15:28:36 <egonzalez> #topic Make TripleO centos job voting? https://review.openstack.org/#/c/636141
15:28:48 <mgoddard> I added this one
15:28:50 <egonzalez> i thing hrw this is yours or from someone from RH
15:29:06 <egonzalez> ah, my mistake then
15:29:20 <mgoddard> there was a request to make the tripleo centos job voting. What do we think?
15:29:38 <mgoddard> It would be good to have coverage of their workflow, to ensure we don't break them
15:29:52 <mgoddard> OTOH, we can't fix issues in their CI
15:30:24 <egonzalez> jobs has been red the last times i looked at
15:30:27 <hrw> tripleo-build-containers-centos-7 - that job it is?
15:30:39 <mgoddard> yes
15:31:04 <egonzalez> dont know the future of them using kolla images as they are moving to podman stuff for next release/s
15:31:39 <mgoddard> podman is docker compatible, I'm not aware of plans to change
15:31:42 <egonzalez> but their looking to rhel8 in kolla,so maybe is not anytime soon the time they shift
15:31:57 <egonzalez> right
15:31:59 <hrw> egonzalez: "alias docker=podman" and you may not notice they say...
15:32:31 <mnasiadka> You will notice, but it’s another discussion
15:33:08 <mgoddard> quick vote - +1/-1?
15:33:09 <mnasiadka> I would enable it, it has been green for some time
15:33:28 <mnasiadka> +1
15:33:49 <mgoddard> http://zuul.openstack.org/builds?job_name=tripleo-build-containers-centos-7&project=openstack%2Fkolla
15:33:49 <hrw> +1 - always can disable
15:33:52 <mgoddard> that's a good record
15:33:55 <mgoddard> +1
15:34:13 <egonzalez> +1
15:34:41 <mgoddard> ok. Let's vote accordingly on the patch
15:35:18 <mgoddard> move on?
15:35:22 <egonzalez> yep
15:35:24 <hrw> yep
15:35:36 <hrw> https://etherpad.openstack.org/p/KollaWhiteBoard reformatted btw
15:35:41 <egonzalez> #topic Meeting time change?
15:35:51 <egonzalez> mgoddard also yours i think
15:36:09 <egonzalez> without previous info, my +1 to this
15:36:11 <mgoddard> yeah. This is something I added to my manifesto
15:36:35 <mgoddard> I'd like to see if there is a meeting time that is more suitable for our contributors in APAC
15:37:04 * hrw on UTC+1
15:37:07 <mgoddard> the current time is more US-friendly, but we don't seem to have too many US-based contributors these days
15:37:15 <mgoddard> I'm UTC
15:37:24 <mgoddard> any objections?
15:37:29 <hrw> free to move
15:37:30 <egonzalez> +1
15:37:51 <hrw> easier at APAC time (my morning) than LATAM morning
15:37:59 <egonzalez> even many of them cannot connect to IRC due firewall restrictions, but may caught more interest
15:38:13 <mgoddard> I'll send something on the ML. If we get no interest we can keep it the same
15:38:19 <hrw> +1
15:38:25 <egonzalez> +1
15:38:37 <mgoddard> #action mgoddard to send to ML about meeting time change
15:38:50 <mgoddard> Not sure if I can do that without starting the meeting myself
15:38:59 <mgoddard> Let's move on
15:39:11 <egonzalez> not sure if that even works hehe
15:39:18 <egonzalez> #topic Virtual PTG?
15:39:25 <mgoddard> me again :)
15:39:48 <mgoddard> we've talked about holding a virtual PTG, it's time to find a time that fits
15:40:03 <hrw> when is PTG/Summit?
15:40:16 <mgoddard> how many hours/days to people think is appropriate
15:40:18 <mgoddard> ?
15:40:25 <egonzalez> maybe first find how many topics are to be discussed to plan times?
15:41:00 <mgoddard> summit/PTG is April 29 - May 4th
15:41:29 <mgoddard> good idea egonzalez
15:41:46 <mgoddard> might be a bit of chicken and egg - some people might not attend if its too long :)
15:42:15 <mgoddard> I think 1 day/8 hours would be plenty. Does anyone differ?
15:42:23 <egonzalez> yeah, i'd need plan for vacation days for those days
15:42:31 <egonzalez> yeah, probably is enough
15:42:53 <hrw> 1st and 3rd are national holidays here so I may go somewhere with my daughter
15:42:56 <mnasiadka> I’m on vacation from 30th April to 14th May ;)
15:43:10 <mgoddard> I'd prefer to do it at a different time to summit/PTG
15:43:29 <mgoddard> I will be in ironic discussions too
15:43:35 <egonzalez> me too, more people could attend and will be EU/APAC time friendly
15:43:40 <mgoddard> +1
15:43:49 <mnasiadka> +1
15:43:50 <mgoddard> it didn't work very well last time
15:44:08 <mgoddard> if we have dedicated time we can concentrate
15:44:21 <mgoddard> and if everyone is dialling in it will be a more level playing field
15:44:26 <hrw> yep
15:45:30 <mgoddard> ok. I'll send a second ML post about virtual PTG - requests for topics and availability
15:45:51 <mgoddard> #action mgoddard to ask ML about virtual PTG availability and topics
15:46:37 <mgoddard> any more on this?
15:46:50 <egonzalez> not from me
15:47:04 <mgoddard> ok, let's move on
15:47:09 <egonzalez> #topic open discussion
15:47:29 <mgoddard> Perhaps we could go back to the white board, since I missed it
15:47:41 <mgoddard> thanks for fixing it up hrw
15:47:52 <egonzalez> #topic Kolla whiteboard https://etherpad.openstack.org/p/KollaWhiteBoard v2
15:47:53 <mgoddard> this is something we use in ironic, and I think it works well
15:48:00 <mgoddard> this is something we use in ironic, and I think it works well
15:48:21 <mgoddard> it's a good way to keep track of CI status, features in progress etc
15:48:29 <mgoddard> also, how to prioritise reviews each week
15:48:31 <hrw> what about merging https://etherpad.openstack.org/p/kolla-ci-status into it?
15:48:38 <mgoddard> hrw: +1
15:48:54 <hrw> mgoddard: for priorities I prefer 'review priority' flag in gerrit
15:48:56 <egonzalez> +1
15:49:23 <egonzalez> we could use priorities for topics rather than per patch in etherpad
15:49:54 <hrw> yes
15:49:59 <mgoddard> I've not found the review priority flag too helpful so far, but I haven't tried too hard to use it either
15:50:16 <mgoddard> having the review priority +1 not being sticky is a bit annoying
15:50:18 <hrw> mgoddard: it is visible every time you are on gerrit
15:50:59 <mgoddard> hrw: maybe I just need to pay more attention to it
15:51:13 <mgoddard> ok, let's ignore review priority section for now
15:51:16 <hrw> I have gerrit nearly always open somewhere
15:51:50 <mgoddard> hrw: same, but you have to look at the priority column to see it
15:51:52 <mgoddard> anyway...
15:52:20 <hrw> mgoddard: https://review.openstack.org/#/q/project:openstack/kolla+status:open shows it
15:52:24 <mgoddard> I'd like us to try keeping a list of in progress features on the whiteboard
15:52:35 <hrw> mgoddard: good idea
15:52:41 <mgoddard> hrw: yeah, I know it's there
15:53:15 <mgoddard> I don't think we've historically been great at keeping track of ongoing work in kolla. It's always hard in open source, but we can try
15:53:56 <mgoddard> it's not so important for small things, but features spanning multiple patches we can track them there
15:54:23 <mnasiadka> mgoddard: we could also rework the gerrit dashboard, so some things are more visible. I like the Ironic one for example.
15:54:36 <mgoddard> so if we allow a couple of minutes each meeting to update the whiteboard, hopefully it will start to reflect reality
15:54:48 <mgoddard> mnasiadka: that's a good idea
15:54:56 <egonzalez> mnasiadka can we make that per project? i have my own dashboards
15:55:18 <mgoddard> https://github.com/openstack/gerrit-dash-creator
15:55:18 <egonzalez> like:
15:55:21 <egonzalez> #link https://review.openstack.org/#/dashboard/?title=Kolla+Review+Dashboard&foreach=is%3Aopen&Starred+by+PTL+or+me=project%3A^.*kolla.*+%28starredby%3Aegonzalez90+OR+is%3Astarred%29+AND+status%3Aopen&&High+Priority+Changes=project%3A^.*kolla.*+label%3AReview-Priority%3D2&Priority+Changes=project%3A^.*kolla.*+label%3AReview-Priority%3D1&&Stable+Branch=project%3A^.*kolla.*+branch%3A^stable%2F.*+limit%3A10&&Waiting+For+Second+Review=
15:55:21 <egonzalez> project%3A^.*kolla.*+NOT+label%3AWorkflow%3C%3D-1+NOT+label%3ACode-Review%3C%3D-2+label%3ACode-Review%3E%3D2+limit%3A20&&Waiting+For+Reviews=project%3A^.*kolla.*+limit%3A20&&Patches+that+mention+Kolla=NOT+project%3A^.*kolla.*+message%3Akolla+limit%3A20+limit%3A20
15:55:32 <mgoddard> there's an official kolla one in the dash creator, I think I use that
15:55:52 <mnasiadka> egonzalez: yup, there is a gerrit dashboard creator repo with python scripts attached, we should have it there
15:56:30 <egonzalez> hrm, been working with the url until figured out how to make it godo
15:56:31 <hrw> egonzalez: nice one
15:56:32 <egonzalez> good
15:56:45 <egonzalez> sounds good then
15:57:34 <mgoddard> before we finish, I saw earlier py3 will be dropped until Stein?
15:57:47 <mgoddard> s/Stein/Train/
15:58:26 <hrw> mgoddard: yep. Stein froze
15:58:43 <mgoddard> I'm a bit concerned that we have half py3 in ubuntu
15:58:46 <egonzalez> not every distro is ready yet and many services doesnt work neiher with it
15:59:00 <mgoddard> are we sure it's currently using py2?
15:59:08 <hrw> mgoddard: it uses both
15:59:21 <mgoddard> so we have some images using py3?
15:59:25 <hrw> yes
15:59:32 <hrw> UCA Stein is mix
15:59:33 <egonzalez> both yes, non API might be py3 but we're not aware
15:59:50 <egonzalez> we noticed APIs because builds failed due deps
16:00:03 <mgoddard> will this affect the image size having both installed?
16:00:32 <hrw> mgoddard: nothing we can do - openstack-base grabs both versions
16:00:41 <egonzalez> maybe we better install in base image, to not install each time a depent package needs
16:00:58 <hrw> from what I rmember
16:01:09 <mgoddard> I suppose what I'm saying is, can we even decide to drop py3 support for ubuntu binary? We just use whatever we're given - py2 or py3
16:01:20 <mgoddard> for source images we can stick to py2
16:01:30 <mgoddard> I think we are over time
16:01:35 <egonzalez> we cant
16:01:42 <egonzalez> some packages removed support to py2
16:01:56 <egonzalez> yep, lets end the meeting
16:01:57 <mgoddard> so at this point we can't just drop py3 support
16:02:07 <mgoddard> ok thanks everyone
16:02:13 <mgoddard> and thanks for chairing egonzalez
16:02:19 <egonzalez> #endmeeting