15:01:38 <mgoddard> #startmeeting kolla
15:01:40 <openstack> Meeting started Wed Mar 27 15:01:38 2019 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:43 <openstack> The meeting name has been set to 'kolla'
15:02:06 <mgoddard> #topic rollcall
15:02:18 <mnasiadka> o/
15:02:20 <mgoddard> Please raise your virtual hands
15:02:22 <mgoddard> \o
15:02:22 <chason> o/
15:02:36 <spsurya> o/
15:03:56 <mgoddard> #topic agenda
15:04:03 <mgoddard> * Roll-call
15:04:06 <mgoddard> * Announcements
15:04:08 <mgoddard> ** Kolla is currently in feature freeze
15:04:10 <mgoddard> ** RC1 target is April 1 - April 5, at which point we will cut stable/stein and unfreeze master
15:04:12 <mgoddard> * Review action items from last meeting
15:04:14 <mgoddard> * Kolla whiteboard https://etherpad.openstack.org/p/KollaWhiteBoard
15:04:16 <mgoddard> * Stein release status
15:04:17 <mgoddard> * Meeting time change
15:04:19 <mgoddard> * Virtual PTG
15:04:21 <mgoddard> * Launchpad vs Storyboard (clean up LP or migrate to Storyboard)
15:04:24 <mgoddard> #topic announcements
15:04:53 <mgoddard> #info Kolla is currently in feature freeze
15:05:10 <egonzalez> o/ sorry im late
15:05:20 <mgoddard> Please be vigilant about not merging features - bug fixes only until we cut the branch
15:05:23 <mgoddard> no problem egonzalez
15:05:40 <mgoddard> #info RC1 target is April 1 - April 5, at which point we will cut stable/stein and unfreeze master
15:06:18 <mgoddard> continuing with the two week delay from stein release schedule, that puts our RC1 at April 1 - 5
15:06:33 <mgoddard> which is next week
15:06:56 <mgoddard> we can discuss how realistic that is later
15:07:04 <mgoddard> #topic review action items
15:07:29 <mgoddard> Last week there were 3 action items
15:07:34 <mgoddard> 1. Work on the "tech preview" concept
15:07:41 <mgoddard> did anyone look at this?
15:08:03 <egonzalez> havent look into it
15:08:28 <hrw> o/
15:08:29 <mgoddard> ok. I guess we should decide before the release if we're going to go with it as a concept
15:08:32 <mgoddard> hi hrw
15:08:42 <spsurya> mgoddard: wasn't in last meeting, so not aware about this
15:09:19 <mgoddard> spsurya: I think it's a way to say that a feature is not fully tested, but is available for use
15:09:28 <hrw> mgoddard: can we set -1 priority on features patches? it is described as 'branch freeze' in gerrit
15:09:53 <mgoddard> hrw: does that prevent the patch from being merged?
15:10:11 <mgoddard> and if you push a new patchset does it remove the -1?
15:10:22 <hrw> mgoddard: have to check
15:10:32 <mgoddard> hrw: ok. Sometimes -2 is used
15:10:52 <mgoddard> Other action items were for me:mgoddard to send to ML about meeting time change
15:10:55 <mgoddard> mgoddard to ask ML about virtual PTG availability and topics
15:10:57 <hrw> mgoddard: pushing new patch keeps review priority
15:11:04 <mgoddard> mgoddard to send to ML about meeting time change
15:11:32 <mgoddard> hrw: ok, thanks for checking. We'll also need to make sure it blocks the merge
15:12:24 <mgoddard> I sent out those two ML posts. Thanks to those who replied. If you haven't responded yet about the meeting time in particular, please do
15:12:44 <mgoddard> virtual PTG too, we have 4 attendees listed currently
15:12:47 <hrw> handy doodle was created by mandre - link in a thread
15:13:22 <mgoddard> #link https://doodle.com/poll/y4934shapcc32usx
15:13:46 <mgoddard> seems like we already have the best time, looking at the doodle :)
15:14:12 <mgoddard> will leave it open for a while
15:14:28 <mgoddard> let's move on
15:14:34 <mgoddard> #topic kolla whiteboard
15:14:42 <mgoddard> #link https://etherpad.openstack.org/p/KollaWhiteBoard
15:14:45 * jroll pops his head in late
15:14:51 <mgoddard> hi jroll
15:15:27 <hrw> I like that white board
15:15:29 <mgoddard> whiteboard claims CI is green, I think this is correct?
15:16:04 <hrw> mgoddard: heat gave issue due to us using releases not present on server
15:16:11 <mgoddard> hrw: that issue with cronitor, is it affecting current stable branches or just the version bump patches?
15:16:34 <hrw> mgoddard: sorry, not looked. was deep in other tasks
15:16:35 <mgoddard> hrw: yeah, but that doesn't affect the current branches, right?
15:16:40 <mgoddard> hrw: np
15:17:17 <mgoddard> we could add links to the zuul builds page on the whiteboard to make it easy to check at a glance
15:17:28 <mgoddard> not perfect but gives an indication
15:17:43 <hrw> current branches should be fine with heat stuff
15:17:50 <hrw> update patches fail
15:17:57 <mgoddard> e.g. http://zuul.openstack.org/builds?project=openstack%2Fkolla&uuid=master
15:18:24 <mgoddard> I mean http://zuul.openstack.org/builds?project=openstack%2Fkolla&branch=master
15:19:37 <mgoddard> could everyone update the status of features they're working on in the whiteboard?
15:21:24 <hrw> sure
15:23:01 <mgoddard> Thanks for looking at the chain of upgrade fixes. Mostly there now, just need https://review.openstack.org/644974 and https://review.openstack.org/616640
15:23:11 <mgoddard> Who is brave enough to look at the upgrade CI job?
15:23:47 <mgoddard> ...
15:23:50 <mgoddard> :)
15:24:06 <mnasiadka> We need to be brave enough to merge and monitor bugs/issues :)
15:24:12 <mgoddard> everyone ready to move on?
15:24:18 <hrw> mnasiadka: so +2 it!
15:24:19 <mgoddard> mnasiadka: pffft
15:24:30 <mnasiadka> hrw: will do
15:24:59 <mgoddard> mnasiadka: you are correct. I've been slowly trying to work through some
15:25:21 <mgoddard> I think we need to have a bug review meeting at some point
15:26:02 <mgoddard> I asked cores to look through any bugs opened by them or assigned to them, hoping it would clear some out
15:26:12 <mgoddard> please do so if you haven't already
15:26:17 <mnasiadka> I’ll try to do some reporting on bugs and find the really old ones that should be marked invalid.
15:26:41 <mgoddard> thanks mnasiadka
15:26:45 <hrw> no bugs on me
15:26:53 <mgoddard> this gives me an idea for the open discussion
15:27:02 <mgoddard> let's move on
15:27:08 <mgoddard> #topic Stein release status
15:27:41 <mgoddard> We're currently in feature freeze, next week is notionally RC1 week if we stick to a 2 week lag
15:27:49 <mgoddard> How realistic is that?
15:28:30 <mgoddard> I guess at a minimum, we need the patch that switches to Stein versions in kolla
15:28:40 <spsurya> shouldn't be any issue i think
15:28:47 <egonzalez> is ok, but we have to wait until rdo creates stein repos outside dlrn
15:28:49 <mgoddard> which means we need those dependencies to be release
15:28:59 <egonzalez> pacakges are tested, but repos changes
15:29:00 <hrw> mgoddard: most of them are now
15:29:13 <hrw> but only most.
15:29:14 <mgoddard> hrw: last I checked they were mostly rc1
15:29:30 <mnasiadka> And resolve all package name changes (such as the heat one), I’m sure more will come.
15:29:35 <hrw> right, final release...
15:30:00 <mgoddard> Looking at https://releases.openstack.org/stein/schedule.html, the stein release is 8th - 12th April
15:30:22 <hrw> so kolla 22th?
15:30:29 <mgoddard> Should we even RC1/branch before then, given that we won't have all the deps in place?
15:30:52 <mgoddard> Just trying to get my head around the scheduling dependencies here
15:31:22 <mgoddard> I want to write all this stuff up. Kolla is sufficiently different from other projects that we need our own PTL & release guide
15:31:36 <egonzalez> in previous release we've tagged rc1 with at least tarballs changed and revert the changes later
15:31:43 <hrw> mgoddard: I think that we can rc1 on 1st April with whatever got released by other projects and then for rc2 have requirement that all projects need to be released before our rc2
15:31:58 <egonzalez> last release, rdo was a bit late creating repos so we pushed directly to stable/branch
15:32:22 <egonzalez> the final release was like 3 week after openstack final release
15:32:41 <hrw> I am off next week - Linaro Connect
15:32:56 <mgoddard> #info hrw away next week
15:33:09 <mnasiadka> Final RCs for normal project are next week, so we might aim for rc1 one/two weeks later if things are stable
15:34:17 <mgoddard> I suppose that we could release an RC that depends on other projects RCs, rather than waiting for final releases
15:34:55 <hrw> +1
15:35:12 <mnasiadka> +1
15:35:23 <mgoddard> ok, let's at least see how it looks next week. If there are still lots missing we can delay, but otherwise aim to RC1 & branch with what's availabel
15:35:48 <egonzalez> many services runs independent and doesnt follow release calendar
15:35:54 <mgoddard> #info Kolla to RC1 & branch next week, assuming most dependencies are in place
15:35:55 <egonzalez> like kuryr
15:36:08 <hrw> egonzalez: still need to stick to something
15:36:09 <mgoddard> egonzalez: what do we normally do with those? Pick the latest release?
15:36:41 <egonzalez> hrm, let me check, i think last time we used latest version
15:36:49 <mgoddard> I guess if we pick the latest at the time, then only minor bump on the branch
15:38:04 <egonzalez> some have branch tarball
15:38:22 <mgoddard> ok, since this is my first release rodeo, let's try to build up my TODO list
15:38:32 <mgoddard> I have this so far:
15:38:43 <mgoddard> * cycle highlights (done)
15:38:51 <hrw> mgoddard: store it in kolla/doc/releasenotes.md ;D
15:39:07 <mgoddard> * tidy up release notes prior to branch cut
15:39:27 <mgoddard> * Update OpenStack service versions (patch in progress)
15:39:59 <mgoddard> * Modify RDO repo to use stable (thanks for the reminder egonzalez)
15:40:16 <mgoddard> * Propose RC1 tag & branch to releases repo
15:40:42 <mgoddard> * Unfreeze master, revert stein versions & RDO
15:41:03 <mgoddard> * Propose RC$N and final release tags to releases
15:42:00 <mgoddard> * After release, every $N days, bump openstack service versions on all branches & minor release
15:42:06 <mgoddard> So what did I miss? :)
15:42:47 <egonzalez> RDO repos will be likely after rc1, just asked at #rdo channel
15:43:02 <mgoddard> Jeffrey4l: you around?
15:43:39 <mgoddard> egonzalez: are there other repos that need updating?
15:43:57 <egonzalez> globals.yml point to stein
15:43:59 <mgoddard> UCA just stays on stein right?
15:44:14 <egonzalez> oraclelinux rdo url, is different place
15:44:20 <mgoddard> ok
15:44:45 <mgoddard> by globals.yml, you mean openstack_release?
15:44:57 <mgoddard> in group_vars/all.yml?
15:44:58 <egonzalez> yes
15:44:59 <hrw> mgoddard: UCA has repo per openstack release
15:45:25 <hrw> mgoddard: so once train starts we move to train in train
15:45:50 <mgoddard> looks like we need to set kolla_source_version in group_vars/all.yml
15:46:02 <egonzalez> #link https://review.openstack.org/#/c/600328/
15:46:25 <egonzalez> ^^ thats the rpm repos change
15:46:50 <mgoddard> nice, I even reviewed it :)
15:47:20 <mgoddard> ok. If anyone thinks of anything I haven't included, let me know
15:47:24 <egonzalez> we dont miss anything i think
15:47:33 <mgoddard> great
15:47:50 <mgoddard> #topic Meeting time change
15:48:26 <mgoddard> had quite a few replies to the doodle. Current favourite is... 1500UTC!
15:49:02 <hrw> looks like not so many interested people in apac
15:49:03 <mgoddard> I'll wait for anyone else to reply
15:49:13 <egonzalez> 1500 is 1 our early right? im not really good with timezones
15:50:08 <mgoddard> I guess another question to ask is, is there anyone who would like to attend at 1500 but can't make it on wednesdays
15:50:09 <hrw> śro, 27 mar 2019, 15:50:08 UTC
15:50:24 <hrw> 15:00 UTC is current meeting time
15:50:42 <mgoddard> I'll put that question on the ML, just in case
15:51:12 <mgoddard> #action mgoddard to ask ML whether wednesday 1500UTC suits everyone who wants to attend
15:51:20 <mgoddard> #topic virtual PTG
15:51:22 <egonzalez> probably need to reach spsurya chason and others from asia directly, none of them replied yet
15:51:57 <mgoddard> both are in this meeting, the link was pasted earlier
15:52:01 <chason> current meeting time is OK for me. :D
15:52:10 <mgoddard> great
15:52:14 <mgoddard> #link https://etherpad.openstack.org/p/kolla-train-ptg
15:52:20 <spsurya> egonzalez: mgoddard fine for me too
15:52:52 <mgoddard> we have 4 attendees for the virtual PTG so far. Any other takers? Please add your name on the pad
15:53:11 <mgoddard> And feel free to propose topics while you're there
15:54:00 <mgoddard> #topic Launchpad vs Storyboard
15:54:15 <mgoddard> mnasiadka raised this. Should we switch?
15:54:58 <hrw> what is storyboard?
15:55:08 <mgoddard> #link http://storyboard.openstack.org
15:55:13 <egonzalez> last time we discussed there was missing features in storyboard like release management
15:55:25 <mnasiadka> Still it’s not there
15:55:29 <mgoddard> I believe that is still the case
15:55:39 <mnasiadka> We would need to stay on lp for release mgmt
15:56:20 <mgoddard> What do we want from release management here? Being able to list which release a bug/feature was fixed/added in?
15:57:01 <hrw> I would prefer to stay on LP. know it already so do not have to learn storyboard just for one project
15:57:48 <mgoddard> Having used storyboard for various other projects, I can't say I am desperate to move to it
15:58:24 <hrw> but I do not use LP much with kolla so +0 to either change
15:58:38 <mgoddard> It is quite a lot simpler, which is nice, but probably missing things vs LP
15:58:59 <mgoddard> Not hearing anyone shouting for it, let's punt to the U cycle
15:59:10 <mnasiadka> Let’s clean up bugs, releases, etc in lp
15:59:23 <mgoddard> mnasiadka: +1 I think our time would be better spent on that
15:59:31 <mgoddard> #topic open discussion
15:59:42 <mgoddard> 1 minute left, a nice segue to...
15:59:47 <mgoddard> bug czar!
16:00:10 <mgoddard> I was looking at the PTL page, there are apparently various things I can delegate
16:00:28 <mgoddard> anyone want to volunteer to be bug czar?
16:00:53 <mgoddard> if so, please respond in #openstack-kolla
16:01:03 <mgoddard> Thanks for attending everyone
16:01:13 <mgoddard> #endmeeting