15:00:24 <mgoddard> #startmeeting kolla
15:00:24 <openstack> Meeting started Wed Apr 24 15:00:24 2019 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:29 <openstack> The meeting name has been set to 'kolla'
15:00:29 <hrw> o/
15:00:32 <jroll> \o
15:00:35 <mgoddard> #topic rollcall
15:00:53 <mgoddard> \/o
15:01:37 <chason> o/
15:02:52 <mgoddard> #topic agenda
15:02:56 <mgoddard> * Roll-call
15:02:59 <mgoddard> * Announcements
15:03:01 <mgoddard> ** Meeting cancelled on 2019-5-1 due to summit/PTG
15:03:03 <mgoddard> ** mgoddard at summit/PTG from 2019-04-26, returning 2019-05-07
15:03:05 <mgoddard> * Review action items from last meeting
15:03:07 <mgoddard> * Kolla whiteboard https://etherpad.openstack.org/p/KollaWhiteBoard
15:03:09 <mgoddard> * Stein release status
15:03:11 <mgoddard> * Virtual PTG
15:03:13 <mgoddard> #topic announcements
15:03:17 <mgoddard> #info Meeting cancelled on 2019-5-1 due to summit/PTG
15:03:25 <mgoddard> #info mgoddard at summit/PTG from 2019-04-26, returning 2019-05-07
15:03:45 <mgoddard> Any other announcements?
15:04:26 <hrw> nope
15:05:20 <mgoddard> #topic review action items
15:05:23 <mgoddard> mgoddard to nudge release team about stable releases
15:05:25 <mgoddard> mgoddard to propose stein RDO switch patch
15:05:27 <mgoddard> mnasiadka to write up a short bug triage & grooming process in docs
15:05:29 <mgoddard> mgoddard to stop ocata publish job
15:05:31 <mgoddard> mgoddard to send a doodley poll to ML about PTG
15:05:35 <mgoddard> Stable releases went out \o/
15:05:59 <hrw> so now our turn to use them and do release?
15:06:05 <mgoddard> I proposed the RDO switch patch, but there is no RDO repo yet.
15:06:35 <mgoddard> hrw: sorry, I meant that our patches to the releases repo were merged
15:06:43 <mgoddard> #link https://review.opendev.org/651601
15:07:15 <hrw> ok
15:08:57 <mgoddard> A patch was merged that attempted to stop the ocata jobs, but they appear to still be running :/
15:09:10 <mgoddard> Looking at it again, it was only done for centos.
15:09:42 <mgoddard> although those jobs also seem to be running :(
15:10:01 <mgoddard> #action mgoddard to try again to disable ocata publishing jobs
15:10:30 <mgoddard> I sent out a poll about the PTG. Last I looked it was very conflicty
15:10:43 <mgoddard> mnasiadka: did you manage to write up about bug triage?
15:11:55 <mgoddard> I think he's not here
15:12:07 <mgoddard> #topic Kolla whiteboard https://etherpad.openstack.org/p/KollaWhiteBoard
15:12:39 <mgoddard> Please take a few minutes to ensure any features you are working on are on the whiteboard, and that it is up to date
15:13:57 <hrw> I have to check failure of my py3 patch and then probably seek someone who understand failure
15:14:36 <mgoddard> CI looks largely ok. A few issues during the opendev switch
15:14:44 <igordc> hello - I don't see OVN support on the list.. still, is there anyone potentially going to work on that this cycle?
15:14:57 <mgoddard> igordc: you? :)
15:15:05 <igordc> mgoddard, who knows :)
15:15:06 <mnasiadka> mgoddard: nope, were sick, will try after vacation :)
15:15:19 <hrw> igordc: you want it working, you make it working?
15:15:35 <mgoddard> I'm not aware of anyone planning to work on it currently
15:15:58 <mgoddard> there's a kolla blueprint here: https://blueprints.launchpad.net/kolla/+spec/neutron-ovn
15:16:08 <igordc> hrw, well yeah, unless someone else is already trying to make it work
15:16:22 <mgoddard> and a kolla-ansible one here: https://blueprints.launchpad.net/kolla-ansible/+spec/ovn-controller-neutron-ansible
15:16:31 <mgoddard> WIP patch here: https://review.openstack.org/580894
15:16:32 <igordc> mgoddard, thanks I'll lijnk to it if I work on this
15:17:30 <igordc> right, have to test jeffrey's patch and see what it does today
15:17:38 <mgoddard> igordc: try reaching out to the authors of those blueprints and patched
15:17:38 <mgoddard> Any other comments on the whiteboard?
15:17:47 <mgoddard> I guess we can try to use it more in the Train cycle
15:18:15 <mgoddard> Onwards
15:18:18 <mgoddard> #topic Stein release status
15:18:41 <mnasiadka> igordc: it would make sense to check ovn db ha, it was active passive in the past
15:19:05 <mgoddard> I don't have too much to say on this. I think we're mainly waiting on the CentOS RDO patch
15:19:52 <mgoddard> There have been some bugs raised by people testing the release. Please do try to keep more of an eye on launchpad at this time
15:20:45 <mgoddard> I guess we could do with a way of tracking this
15:21:08 <igordc> mgoddard, I've to retry deploying, hopefully I'll get internet connectivity this time
15:21:38 <igordc> mgoddard, wasn't able to spend much time to debug the missing internet connectivity
15:23:50 <mgoddard> this is an area we're lacking testing for - we ought to check that the VMs booted in CI can be accessed via SSH, and can reach the internet
15:24:54 <mnasiadka> if we would have a list of CI improvements - I guess anybody can pick this up
15:31:47 <mgoddard> anyone hear me now?
15:32:08 <hrw> yes
15:32:18 <mgoddard> sorry, I think I lost connectivity
15:32:22 <hrw> sorry, stuck in three discussions
15:32:54 <mgoddard> on the CI topic, yes we ought to generate a list of necessary improvements during the PTG
15:33:12 <mgoddard> speaking of which
15:33:15 <mgoddard> #topic Virtual PTG
15:33:36 <mgoddard> #link https://doodle.com/poll/adk2smds76d8db4u?utm_campaign=poll_added_participant_admin&utm_medium=email&utm_source=poll_transactional&utm_content=gotopoll-cta#table
15:33:57 <mgoddard> we have dates with 4 people, but never all 5
15:34:46 <mnasiadka> so hrw is the one that can't do 15th of May and beyond, and I can't do earlier dates :)
15:34:50 <hrw> let me check 15th
15:35:03 <mgoddard> mnasiadka and hrw are mutually exclusive :)
15:35:17 <mgoddard> perhaps they are the same person :/
15:35:46 <hrw> added 15th as 'maybe'
15:36:02 <mgoddard> other option is the next week
15:36:23 <hrw> mnasiadka: going to opensource day on 14th?
15:36:27 <mgoddard> hrw: what's the maybe for?
15:36:38 <mnasiadka> hrw: nope, coming back from vacation on 14th :)
15:36:47 <hrw> mgoddard: may attend if needed
15:37:37 <mgoddard> ok. currently that's the favourite then. Would you prefer we try adding the following week to see if that helps?
15:38:24 <hrw> whole next one is fine for me
15:38:48 <mgoddard> mnasiadka?
15:38:59 <mgoddard> it's not great for me really tbh :)
15:39:05 <hrw> 6-10 is fine, 13-16 is full of events, 20-24 and 27-31 are fine
15:39:20 <mnasiadka> mgoddard: anything from 15th May beyond :)
15:39:51 <mgoddard> ok. I'll add dates further out and send out again
15:40:00 <mnasiadka> So second half of May - I can attend any day.
15:40:07 <mgoddard> #action mgoddard to add dates to the PTG poll further out
15:41:10 <mgoddard> #topic open discussion
15:41:18 <mgoddard> Anyone have anything to discuss today?
15:41:39 <hrw> https://review.opendev.org/#/c/557659 (arm64 ci) - will rebase and send new revision
15:41:51 <hrw> new machine is in infra so should work
15:42:08 <mgoddard> nice
15:42:42 <mgoddard> will be a good addition
15:42:46 <hrw> yep
15:43:01 <mgoddard> please ping when its ready
15:43:05 <hrw> yep
15:43:54 <igordc> what's the platform for the virtual ptg?
15:44:13 <mgoddard> we'll use some form of video conferencing TBC
15:44:27 <hrw> whichever it will be first 5-10 minutes will be checking do everyone hear everyone
15:44:41 <mgoddard> I normally use Google hangouts, others may have other ideas
15:45:03 <igordc> hrw, yeah lol
15:45:10 <mnasiadka> whatever that works :)
15:45:25 <hrw> hangouts are easiest cause everyone can have it for free
15:45:32 <hrw> mnasiadka: there is no such thing ;(
15:45:53 <mnasiadka> hrw: last time we used webex, on the weird form of physical+virtual ptg ;)
15:46:02 <mnasiadka> hrw: it was the only thing that worked
15:46:07 <hrw> ;D
15:46:48 <mnasiadka> hrw: hangouts work probably for most of us, but I think hangouts will be shut down somewhere end of this year (not that it matters)
15:47:32 <mgoddard> any other topics?
15:47:48 <mgoddard> if not I'll get back to writing slides
15:48:06 <mgoddard> thanks everyone
15:48:11 <hrw> thx mgoddard
15:48:12 <mgoddard> #endmeeting