15:00:45 <mgoddard> #startmeeting kolla
15:00:47 <openstack> Meeting started Wed Sep 25 15:00:45 2019 UTC and is due to finish in 60 minutes. The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:50 <openstack> The meeting name has been set to 'kolla'
15:00:51 <mgoddard> #topic rollcall
15:01:02 <mgoddard> put your hands in the air like you just don't care
15:01:05 <mgoddard> \o/
15:01:07 <yoctozepto> o/
15:01:15 <generalfuzz> o/
15:01:15 * yoctozepto still caring a bit
15:01:16 <egonzalez> o/
15:01:36 <scottsol> o/ (kinda - at a conference)
15:03:39 <mgoddard> #topic agenda
15:04:19 <mgoddard> * Roll-call
15:04:22 <mgoddard> * Announcements
15:04:22 <jovial[m]> \o
15:04:24 <mgoddard> ** Kolla feature freeze next week
15:04:27 <mgoddard> * Review action items from last meeting
15:04:30 <mgoddard> * CI status
15:04:30 <mgoddard> * Train release planning
15:04:32 <mgoddard> * Review priorities
15:04:34 <mgoddard> * Kayobe Train planning meeting recap
15:04:36 <mgoddard> * Short-term and long-term proposal for managing non-OpenStack projects Docker images (e.g. sensu case)
15:04:38 <mgoddard> * Need for review of pre-train TODOs/FIXMEs, e.g. placement separation case https://review.opendev.org/683680
15:04:40 <mgoddard> #topic announcements
15:04:58 <mgoddard> #info Kolla feature freeze next week
15:05:20 <mgoddard> This means we will stop accepting patches for features
15:06:13 <mgoddard> Exceptions can be made following core team agreement
15:06:18 <mgoddard> Any others?
15:06:32 <yoctozepto> none here
15:06:45 <generalfuzz> will it be open for enabling wsgi in services?
15:06:46 <mgoddard> #info CentOS 8 released yesterday
15:07:05 <mgoddard> Container images expected early next week
15:07:15 <yoctozepto> generalfuzz: let's discuss exceptions after planned meeting parts
15:07:20 <mgoddard> +1
15:07:26 <mgoddard> #topic Review action items from last meeting
15:07:42 <mgoddard> mgoddard to email Jeffrey4l & co about kolla-cli
15:08:02 <mgoddard> I didn't, but Jeffrey4l saw the ping and caoyuan emailed me
15:08:21 <mgoddard> It is not ready for release yet, but should be in ~1 month
15:08:31 <mgoddard> they will keep us updated
15:08:42 <yoctozepto> ok
15:08:53 <mgoddard> #topic CI status
15:09:02 <mgoddard> kolla is RED
15:09:38 <mgoddard> need some reviews on https://review.opendev.org/#/c/684687/
15:10:01 <mgoddard> kayobe is RED
15:10:08 <yoctozepto> will be fixed today, I think I know what could have gone wrong there, just need more time, let's not disable it just now unless you have a different urgent patch
15:10:39 <yoctozepto> that was re kolla
15:10:42 <mgoddard> ok
15:10:45 <yoctozepto> not promising to fix kayobe ;-)
15:10:49 <mgoddard> why not?
15:10:55 <mgoddard> :p
15:11:01 <yoctozepto> I dunno, maybe because I would only break it
15:11:12 <yoctozepto> who knows
15:11:21 <yoctozepto> k-a pretty green, pretty nice
15:11:30 <yoctozepto> egonzalez onto the tacker issue in nfv
15:11:44 <egonzalez> the current patch in k-ansible fixes it
15:11:45 <mgoddard> I saw the k-a patch passes CI now
15:11:48 <yoctozepto> he actually patched it but awaits glance details
15:11:53 <mgoddard> is the kolla patch necessary?
15:12:06 <egonzalez> no, will abandon it
15:12:07 <yoctozepto> no, I think you should abandon it, egonzalez
15:12:09 <mgoddard> k
15:12:11 <yoctozepto> :D
15:12:37 <yoctozepto> ^ example of a little discussion of 3 agreeing people
15:13:24 <mgoddard> here's the k-a patch for tacker: https://review.opendev.org/684275
15:13:39 <mgoddard> marked RP+1
15:14:05 <mgoddard> and kayobe
15:14:16 <mgoddard> we were broken by python-ironicclient 3.0.0
15:14:29 <yoctozepto> mgoddard: it needs glance confirmation
15:14:38 <yoctozepto> tacker patch I mean
15:14:50 <mgoddard> 3.1.0 is working its way to pypi now, also needs a requirements bump
15:15:41 <mgoddard> yoctozepto: what do you mean by glance confirmation?
15:16:40 <egonzalez> tacker uses glance_store and requires some config, not sure about how many of the backends are suported or tested
15:16:42 <yoctozepto> # NOTE(egonzalez): No idea why this is used instead of glance servers, investigating...
15:16:53 <yoctozepto> it looks weird to have this in tacker
15:16:59 <yoctozepto> [glance_store]
15:16:59 <yoctozepto> default_backend = file
15:16:59 <yoctozepto> filesystem_store_datadir = /var/lib/tacker/csar_files/
15:17:09 <yoctozepto> (weird=wrong)
15:17:13 <mgoddard> is it a way to bypass the glance API?
15:17:35 <mgoddard> i.e. it would be configured the same way as in glance
15:17:36 <egonzalez> i think tacker is storing packages wihtout using glance locally
15:18:04 <egonzalez> locally or remotelly depending the backend
15:18:13 <yoctozepto> maybe fix for now with a big FIXME instead of just a note?
15:18:19 <yoctozepto> if they don't respond timely
15:18:25 <egonzalez> ok
15:18:33 <mgoddard> do we have contacts in the tacker team to get this resolved?
15:18:44 <egonzalez> file type should be fine for now
15:19:11 <egonzalez> nope, only IRC, people I had contact are not active anymore
15:20:08 <yoctozepto> launchpad and irc already tried
15:20:27 <mgoddard> ok
15:20:30 <yoctozepto> ml is the next step
15:20:41 <mgoddard> +1
15:20:48 <yoctozepto> egonzalez: could you attack them?
15:20:54 <egonzalez> sure
15:20:59 <yoctozepto> only friendly fire :D
15:21:13 <yoctozepto> thx
15:21:13 <mgoddard> #action egonzalez to ask about glance-store config for tacker on openstack-discuss
15:21:26 <mgoddard> or whatever channel works
15:21:44 <mgoddard> #topic Train release planning
15:22:05 <mgoddard> We're getting close
15:23:02 <mgoddard> hopefully we can start on centos 8 / py3 work soon
15:23:10 <mgoddard> is anyone planning to pick that up?
15:23:21 <yoctozepto> mgoddard: is there docker there?
15:23:25 <yoctozepto> or just podman
15:23:32 <mgoddard> yoctozepto: pass
15:23:45 <mgoddard> we use upstream docker
15:24:05 <mgoddard> hopefully it will support centos 8
15:24:30 <mgoddard> https://download.docker.com/linux/centos/8 doesn't exist yet
15:24:42 <yoctozepto> checked the same
15:24:44 <yoctozepto> yup
15:24:49 <yoctozepto> no el8 packages
15:25:02 <yoctozepto> google returns only
15:25:05 <mgoddard> it's still early
15:25:09 <yoctozepto> "podman replaces docker" stuff
15:25:15 <mgoddard> anyway, we're talking about images first
15:25:29 <yoctozepto> yup, image side
15:25:31 <yoctozepto> not host
15:25:35 <yoctozepto> might be easier
15:25:42 <yoctozepto> will see
15:25:58 <yoctozepto> I saw some infographic showing rhel8 containers on rhel7 hosts
15:26:05 <yoctozepto> so they presumably support that well
15:26:12 <mgoddard> I'm working hard on nova cells
15:26:15 <mgoddard> oh that's good
15:26:50 <yoctozepto> https://developers.redhat.com/blog/2019/08/23/run-red-hat-enterprise-linux-8-in-a-container-on-rhel-7/
15:27:11 <mgoddard> generalfuzz: now would be a good time to discuss internal TLS
15:27:12 <yoctozepto> #link https://developers.redhat.com/blog/2019/08/23/run-red-hat-enterprise-linux-8-in-a-container-on-rhel-7/
15:27:22 <mgoddard> (backends)
15:27:55 <generalfuzz> so, after this next patch (https://review.opendev.org/#/c/664517)
15:28:29 <generalfuzz> we should be ready to start working on enabling wsgi in services
15:28:44 <generalfuzz> I figure one or two at a time
15:28:56 <generalfuzz> can this work begin in train?
15:29:35 <mgoddard> it can begin in train, whether it will end in train is another matter :)
15:29:57 <mgoddard> it's a priority feature, so I think we could cut it some slack
15:30:31 <generalfuzz> doubtful we will do all services in train timeline, but can def do some
15:30:33 <mgoddard> but the main priority must be centos 8 & python 3 after feature freeze, and once that's done we should call time
15:31:14 <mgoddard> it's hard to say yes or no - there are lots of variables
15:31:30 <mgoddard> we don't know how long it will take, or how long we have
15:31:37 <yoctozepto> we could have started rhel8 with ubi it seems: https://developers.redhat.com/blog/2019/07/29/red-hat-universal-base-image-how-it-works-in-3-minutes-or-less/
15:33:12 <generalfuzz> well, if we agree that an approach like https://review.opendev.org/#/c/664516/ is correct, I will start after https://review.opendev.org/#/c/664517 goes in, and it will land where it lands
15:33:19 <mgoddard> generalfuzz: I'd suggest to start working on it and we can see how we go
15:34:05 <mgoddard> generalfuzz: there were quite a few comments on the backend patch
15:35:23 <mgoddard> I'd quite like to see an approach where we have a role that generates the necessary config that we can reuse
15:35:50 <mgoddard> anyway, probbably not the time for design discussions
15:36:14 <mgoddard> I think we're in agreement
15:36:20 <generalfuzz> yes
15:36:24 <mgoddard> yoctozepto: do you think ipv6 will land?
15:36:26 <generalfuzz> and open to suggestions
15:37:08 <yoctozepto> mgoddard: will try my best
15:37:25 <mgoddard> yoctozepto: ok
15:37:41 <mgoddard> better to wait & get it right than rush though IMO
15:37:49 <yoctozepto> indeed
15:38:51 <mgoddard> I should have new patches for nova cells up soon. I know it's a big one, but I'd appreciate some reviews
15:39:23 <mgoddard> I'm focussing on the nova part, and pushing the mariadb/rabbitmq bits out
15:39:45 <mgoddard> hoping that means we'll get it in sooner rather than later
15:40:16 <mgoddard> We have some train feature priorities for kayobe now, but I'll discuss later
15:40:38 <mgoddard> #topic Review priorities
15:40:48 <mgoddard> Any patches we need to focus on this week?
15:40:58 <mgoddard> jovial[m]: kayobe included
15:41:06 * yoctozepto focuses on ipv6 (proponent side)
15:41:33 <generalfuzz> I would like to get this in: https://review.opendev.org/#/c/664517
15:42:13 <yoctozepto> whoa, wait for my reviews :D
15:42:44 <mgoddard> added RP+1
15:43:03 <yoctozepto> for some reason it does not conflict with ipv6
15:43:08 <yoctozepto> +0.5 for that
15:43:20 <generalfuzz> nice
15:43:41 <jovial[m]> kayobe: I will look at https://review.opendev.org/#/c/682701/ now - seems quite important
15:44:13 <mgoddard> jovial[m]: thanks
15:44:28 <mgoddard> jovial[m]: bear in mind kayobe CI is busted, so leave off +A for now
15:44:58 <mgoddard> we should probably add RP+1 to bug fixes as we get nearer the end of the release
15:44:58 <jovial[m]> We are just waiting for the new ironic-inspector package?
15:45:15 <mgoddard> jovial[m]: ironicclient
15:46:56 <mgoddard> #topic Kayobe Train planning meeting recap
15:47:05 <mgoddard> Yesterday we had a planning meeting for kayobe
15:47:12 <mgoddard> #link https://etherpad.openstack.org/p/kayobe-train-planning
15:47:12 * yoctozepto eager to learn details
15:47:50 <mgoddard> discussed a number of potential features
15:48:08 <mgoddard> centos8 was interesting
15:48:30 <yoctozepto> s/feature/failure/g
15:48:33 <mgoddard> decided we'd support centos 7 and 8 for at least one release, to allow a smooth upgrade of hosts
15:48:57 <mgoddard> centos7 will be py2, centos8 py3
15:49:16 <mgoddard> expecting to need to reinstall hosts to get from 7 to 8
15:49:34 <mgoddard> so we need to think about how we do that smoothly
15:49:37 <yoctozepto> drop centos7 in v?
15:49:47 <mgoddard> maybe
15:49:57 <mgoddard> or u
15:50:19 <yoctozepto> I think ussuri should have it unless we hit something big
15:50:27 <yoctozepto> like python2 more dead than now
15:50:34 <mgoddard> questions about running centos 8 containers on centos 8 hosts
15:50:46 <mgoddard> and implications for live migration with different versions of qemu
15:51:49 <mgoddard> then some discussions of python 3, and where we use it
15:51:59 <mgoddard> "Difficult to estimate - medium size ball of string"
15:52:27 <mgoddard> We talked about cleaning up our integration points with kolla-ansible
15:52:49 <mgoddard> a few ideas proposed, but none without their corner cases
15:53:10 <mgoddard> finally, we voted on priorities for the train cycle
15:53:23 <mgoddard> results were:
15:53:26 <mgoddard> centos8
15:53:29 <mgoddard> python3
15:53:36 <mgoddard> Support multiple environments from a single kayobe configuration
15:53:40 <mgoddard> Improved support for integrating with Ceph-Ansible
15:53:44 <mgoddard> Next generation discovery & network configuration
15:53:49 <mgoddard> Easier customization of Kayobe commands
15:53:55 <mgoddard> Nova cells support
15:54:08 <mgoddard> As usual, TBC depending on having someone to do the work
15:54:18 <mgoddard> I added those to the kolla whiteboard
15:54:23 <mgoddard> Any Qs?
15:55:07 <mgoddard> #topic Need for review of pre-train TODOs/FIXMEs, e.g. placement separation case https://review.opendev.org/683680
15:55:23 <mgoddard> I did fix a bunch of things up after we branched stein
15:55:33 <mgoddard> #link https://review.opendev.org/683680
15:56:07 <mgoddard> I guess I missed that one, probably because it has no TODO
15:56:28 <mgoddard> do we have any others?
15:56:37 <mgoddard> yoctozepto: I guess this was your topic?
15:57:37 <yoctozepto> o/
15:57:54 <yoctozepto> yes, mine
15:58:00 <yoctozepto> see if we can get more
15:58:09 <yoctozepto> team call to look out for these :-)
15:59:36 <mgoddard> do we need to do a periodic grep FIXME|TODO ?
16:00:02 <yoctozepto> yeah, let's set CI to fail for old TODO/FIXME still around
16:00:10 <openstackgerrit> Viktor Michalek proposed openstack/kolla master: Debian/binary CI: added kolla-build-debian-binary https://review.opendev.org/683675
16:00:16 <yoctozepto> the only sure way to get the job done 8-)
16:00:52 <mgoddard> hmm, that seems a little heavy handed
16:01:18 <yoctozepto> (yup, it was a joke but nobody noticed, nobody laughed)
16:01:51 <mgoddard> ah, I have it documented already: https://docs.openstack.org/kolla/latest/contributor/release-management.html#after-rc1
16:02:14 <yoctozepto> indeed you have
16:02:28 <mgoddard> we're over time
16:02:33 <mgoddard> no open discussion today :(
16:02:42 <mgoddard> Thanks all
16:02:43 <openstackgerrit> Scott Solkhon proposed openstack/kolla master: Add Prometheus RabbitMQ exporter https://review.opendev.org/684799
16:02:47 <yoctozepto> and no-pre-ptg talk
16:02:54 <yoctozepto> :-(
16:02:59 <yoctozepto> thanks mgoddard
16:03:02 <mgoddard> #endmeeting