15:08:19 <yoctozepto> #startmeeting kolla
15:08:20 <openstack> Meeting started Wed Oct 30 15:08:19 2019 UTC and is due to finish in 60 minutes.  The chair is yoctozepto. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:23 <openstack> The meeting name has been set to 'kolla'
15:08:27 <yoctozepto> #topic rollcall
15:08:33 <yoctozepto> \o
15:08:34 <hrw> o\
15:08:37 <mnasiadka> \o/
15:08:57 <chason> o/
15:09:03 <yoctozepto> hi chason
15:09:08 <yoctozepto> long time no see
15:09:19 <chason> Hi yoctozepto o/
15:09:33 <yoctozepto> all right, let's move on
15:09:34 <generalfuzz> o/
15:09:40 <yoctozepto> #topic agenda
15:09:49 <yoctozepto> * Roll-call
15:09:49 <yoctozepto> * Announcements
15:09:49 <yoctozepto> ** Ussuri will be python 3 only. https://etherpad.openstack.org/p/drop-python2-support
15:09:49 <yoctozepto> * Review action items from last meeting
15:09:49 <yoctozepto> * CI status
15:09:50 <yoctozepto> * Train release planning
15:09:52 <yoctozepto> * Review priorities
15:09:54 <yoctozepto> * Which images should we mark as maintained in the support matrix?
15:09:56 <yoctozepto> * Reducing load of build & publishing jobs on CI & Dockerhub (continued) https://etherpad.openstack.org/p/kolla-train-image-evaluation
15:10:15 <yoctozepto> #topic announcements
15:10:29 <yoctozepto> #note Ussuri will be python 3 only. https://etherpad.openstack.org/p/drop-python2-support
15:10:49 <yoctozepto> already dropping support for py2
15:10:54 <yoctozepto> coordinated by hrw atm
15:11:05 <yoctozepto> he is so eager to kill py2
15:11:28 <yoctozepto> we have not branched off yet so it stays in freeze
15:11:42 <yoctozepto> #topic Review action items from last meeting
15:12:10 <yoctozepto> and there were none
15:12:26 <yoctozepto> #topic  CI status
15:12:41 <yoctozepto> so we are having trouble with cbs dropping odl repo
15:12:46 <yoctozepto> patches are ready
15:12:55 <yoctozepto> rocky is blocked the most because it is missing all the patches
15:13:08 <yoctozepto> qdrouterd, odl and the 3rd I forgot but hrw knows
15:13:39 <yoctozepto> queens is broken but it's em so we already planned to stop realeasing
15:13:47 <yoctozepto> breakage helped us doing so
15:13:48 <hrw> I usually check in gerrit but my main machine is now out-of-use
15:14:00 <hrw> I also thought that meeting will be an hour later
15:14:17 <yoctozepto> hrw: welcome in the club, sir
15:14:30 <yoctozepto> the 3rd breakage is searchlight
15:14:38 <yoctozepto> patching is being coordinated so we are good
15:15:08 <yoctozepto> k-a looks good
15:15:21 <yoctozepto> more than average breakage in rocky but does not look permanent
15:15:52 <yoctozepto> all right let's move on
15:15:55 <mnasiadka> yoctozepto: what about the keystone 504 thing? I haven't seen it in a while...
15:15:57 <hrw> searchlight got patch
15:16:19 <yoctozepto> mnasiadka: we are being lucky I guess
15:16:27 <hrw> I think that we patched all the issues - just have to get those in some order
15:16:56 <yoctozepto> #topic Review priorities
15:17:40 <yoctozepto> #link https://launchpad.net/kolla-ansible/+milestone/9.0.0
15:17:47 <yoctozepto> #link https://launchpad.net/kolla/+milestone/9.0.0
15:18:05 <hrw> brb
15:18:23 <mnasiadka> kolla looks fine, k-a needs some love
15:18:33 <mnasiadka> or defining which bugs do not need to be closed before we cut rc
15:18:45 <yoctozepto> mnasiadka: indeed
15:19:10 <yoctozepto> I will go over the list after the meeting
15:19:22 <yoctozepto> I see lots of my nice-to-have-it-fixed
15:20:00 <yoctozepto> 3 highs though
15:20:03 <yoctozepto> #link https://bugs.launchpad.net/kolla-ansible/+bug/1846820
15:20:03 <openstack> Launchpad bug 1846820 in kolla-ansible "nova-conductor may crash during deploy due to haproxy-keystone 504" [High,Triaged]
15:20:11 <yoctozepto> #link https://bugs.launchpad.net/kolla-ansible/+bug/1845244
15:20:11 <openstack> Launchpad bug 1845244 in kolla-ansible train "Nova scheduler is stopped after each reboot" [High,In progress] - Assigned to Radosław Piliszek (yoctozepto)
15:20:15 <hrw> remember that we may do rc1 and then cooperate on fixing rest
15:20:18 <yoctozepto> #link https://bugs.launchpad.net/kolla/+bug/1843043
15:20:18 <openstack> Launchpad bug 1843043 in kolla-ansible train "kolla-ansible mariadb_backup fails due to xtrabackup being incompatible with mariadb 10.3" [High,In progress] - Assigned to Mark Goddard (mgoddard)
15:20:24 <mnasiadka> yoctozepto: the nova scheduler one is not merged yet?
15:20:34 <yoctozepto> mnasiadka: asked myself the same question
15:21:06 <mnasiadka> https://review.opendev.org/#/c/690982/
15:21:11 <yoctozepto> #link https://review.opendev.org/690982
15:21:24 <yoctozepto> guess what? looks waiting for mnasiadka
15:21:25 <yoctozepto> :-)
15:21:26 <mnasiadka> seems it's ready to merge, but there's a mention it has been fixed somewhere else?
15:21:44 <yoctozepto> no, the SIGHUP issue with oslo/nova has been fixed
15:21:51 <yoctozepto> so we can again use SIGHUP in some other places
15:21:57 <yoctozepto> irrelevant
15:22:14 <mnasiadka> ok, sent to the gates
15:22:37 <yoctozepto> so 504 is random
15:22:49 <yoctozepto> I will remove it from the milestone because it's hard to depend on it
15:23:05 <yoctozepto> I mean, we deploy successfully like >95%
15:23:25 <mnasiadka> yoctozepto: let's just lower the priority for now
15:23:27 <yoctozepto> also, never had it in local testing
15:23:38 <yoctozepto> mnasiadka: ok, done
15:23:50 <mnasiadka> and agree that we close Highs before rc, and then deal with the rest
15:24:17 <yoctozepto> mnasiadka: agreed
15:24:20 <yoctozepto> hrw: objections?
15:24:26 <yoctozepto> that leaves us mariadb
15:24:27 <hrw> go for it
15:24:49 <yoctozepto> mariabackup to be exact
15:24:58 <yoctozepto> Mark has fixed/implemented it
15:25:06 <yoctozepto> mgoddard
15:25:12 <hrw> we moved to mariabackup some time ago
15:25:23 <mnasiadka> let's check with him tomorrow and then we can start cutting stable/train
15:25:28 <hrw> there was a patch to add CI tests for mariadb
15:25:44 <yoctozepto> hrw: yup
15:25:50 <yoctozepto> or a few patches in fact
15:26:10 <yoctozepto> #link https://review.opendev.org/690598
15:26:11 <yoctozepto> wip
15:26:32 <yoctozepto> #link https://review.opendev.org/655663
15:26:34 <yoctozepto> also wip
15:26:36 <yoctozepto> all right
15:26:39 <yoctozepto> needs mgoddard
15:26:44 <yoctozepto> no point in waiting
15:26:55 <yoctozepto> other in progress are marked by RP+1
15:28:29 <yoctozepto> chason: https://review.opendev.org/691481
15:29:04 <yoctozepto> we have to require this now, better nice message than later failure from ansible
15:29:45 <yoctozepto> #link https://review.opendev.org/686024
15:29:50 <yoctozepto> this is in a sad state
15:30:00 <yoctozepto> but guess we have to leave it be
15:30:21 <yoctozepto> all right
15:30:37 <yoctozepto> #topic Which images should we mark as maintained in the support matrix?
15:30:45 <yoctozepto> it's a boomerang
15:30:53 <yoctozepto> mnasiadka, hrw: ^
15:31:04 <yoctozepto> have not we reached a consensus?
15:31:37 <chason> removed my -1. :)
15:31:54 <hrw> we have maintained, tested, community and 'do not care', right/
15:32:01 <yoctozepto> #link https://etherpad.openstack.org/p/kolla-train-image-evaluation
15:32:07 <yoctozepto> yeah, we did not mark any M so far
15:32:11 <yoctozepto> afair
15:32:22 <hrw> let keep it that way in Train
15:32:41 <hrw> we added support matrix, marked what is and what is not tested
15:32:46 <yoctozepto> though it looks weird, we might "fix" it later anyway
15:32:59 <hrw> can come to it during ussuri to not waste dev time
15:33:00 <yoctozepto> that is not much of an issue
15:33:03 <yoctozepto> mnasiadka: agreed?
15:33:19 <mnasiadka> yup
15:33:21 <hrw> next week at vptg we take a list and start marking one by one
15:33:48 <yoctozepto> all right
15:34:05 <hrw> #action announce kolla virtual ptg on mailing list
15:34:07 <yoctozepto> #topic Reducing load of build & publishing jobs on CI & Dockerhub (continued)
15:34:36 <yoctozepto> I'm copypasting the stuff from the agenda
15:34:48 <yoctozepto> but I am pretty sure there is not much to discuss in terms of reducing load
15:34:56 <yoctozepto> but more like increasing the stability
15:34:56 <hrw> I think that we are fine with train state of build/publishing. Would be nice to get binary/source stuff sorted out during ussuri
15:35:04 * yoctozepto looking at odl
15:35:10 * yoctozepto looking at searchlight
15:35:22 <mnasiadka> well, we need to look at images one by one I guess
15:35:23 <yoctozepto> hrw: add to ussuri agenda
15:35:42 <mnasiadka> to remove creepy-ness like monasca-grafana
15:35:55 <yoctozepto> #link https://etherpad.openstack.org/p/kolla-ussuri-ptg
15:35:59 <hrw> #action Split images into UNBUILDABLE/CI_TESTED/rest so we can have odl as buildable but not do it on CI
15:36:17 <yoctozepto> please add the ideas to the ussuri ptg
15:36:26 <yoctozepto> #topic Open discussion
15:36:28 <hrw> ok
15:36:48 <yoctozepto> so we are having the ptg next week
15:36:51 <yoctozepto> partially virtual
15:36:54 <yoctozepto> partially physical
15:36:56 <yoctozepto> hrw comes
15:37:01 <yoctozepto> hope mnasiadka does too
15:37:24 <yoctozepto> the crew is small so we are not throwing a party in Bialystok but still hope to spend a quality time
15:37:46 <hrw> it will be in Białystok, Poland. Nearest airport is in Warsaw. If someone arrives on Wed then I give a ride by car to Białystok
15:37:57 <hrw> yoctozepto: WHAT? no party???
15:38:06 <hrw> do some beers or sth?
15:38:31 <yoctozepto> hrw: ah, I'm a water-drinker but yeah I will take you to places
15:38:38 <yoctozepto> I mean there is nothing offical at the Uni
15:38:42 <yoctozepto> too late to organize
15:38:49 <hrw> ;d
15:38:51 <yoctozepto> and too small scale
15:39:22 <yoctozepto> kolla fans are invited as well, reach me out for details
15:39:33 <yoctozepto> I think the ML message is on me too
15:39:53 <hrw> ok
15:40:19 <yoctozepto> ping mnasiadka
15:40:23 <mnasiadka> I'll try to come, need to sort out one thing first
15:40:42 <yoctozepto> life first
15:40:46 <yoctozepto> then kolla
15:41:12 <yoctozepto> let's say we accept that
15:41:19 <hrw> :D
15:41:36 <yoctozepto> anything else to discuss?
15:41:46 <yoctozepto> I guess PTG will allow us to be more focused
15:41:55 <hrw> moar cores, moar!
15:42:07 <yoctozepto> yeah, we need cores
15:42:49 <yoctozepto> anyone anything?
15:43:12 <hrw> done
15:43:26 <yoctozepto> ping generalfuzz because he was around
15:43:54 <generalfuzz> I'll be there virtually :)
15:44:28 <yoctozepto> all right
15:44:30 <hrw> yoctozepto: some camera and screen to show/see remotees would be great to have
15:45:08 <yoctozepto> hrw: my notebook handles it all well, we are 2-3 vs the rest :-)
15:45:14 <hrw> ok
15:45:36 <yoctozepto> not buying cisco videoconferencing stuff just for the ptg ;p
15:45:57 <hrw> ;D
15:46:08 <yoctozepto> thank you all for attending our quick and a bit late meeting
15:46:18 <yoctozepto> #endmeeting