15:00:10 <mgoddard> #startmeeting kolla
15:00:11 <openstack> Meeting started Wed Jan 15 15:00:10 2020 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <mgoddard> #topic rollcall
15:00:15 <openstack> The meeting name has been set to 'kolla'
15:00:19 <mgoddard> \o
15:00:21 <yoctozepto> o/
15:00:24 <mnasiadka> o/
15:00:26 <osmanlicilegi> o/
15:01:00 <yoctozepto> and adding osmanlicilegi to https://wiki.openstack.org/wiki/Meetings/Kolla would make sense
15:01:32 <mnasiadka> yoctozepto: he can add himself ;)
15:01:44 <cosmicsound> \o
15:01:50 <yoctozepto> mnasiadka: that was implied :-)
15:02:12 <yoctozepto> (and calling that <1min warning)
15:02:21 <mgoddard> #topic agenda
15:02:23 <mgoddard> * Roll-call
15:02:25 <mgoddard> * Announcements
15:02:27 <mgoddard> * Review action items from last meeting
15:02:29 <mgoddard> * CI status
15:02:31 <mgoddard> * Train release planning
15:02:33 <mgoddard> * Ussuri release planning
15:02:35 <mgoddard> * CI scenarios: https://etherpad.openstack.org/p/KollaAnsibleScenarios
15:02:37 <mgoddard> * unpublishing images: https://blueprints.launchpad.net/kolla/+spec/dockerhub-image-tag-unpublishing
15:02:39 <mgoddard> #topic announcements
15:02:50 <mgoddard> Is CentOS 8.1 available?
15:02:57 <yoctozepto> hrw said so
15:03:18 <mnasiadka> 8.1.1911 it is
15:03:42 <cosmicsound> mgoddard , not yet fully out 8.1 https://wiki.centos.org/About/Building_8.x#Current_Timeline_8.1
15:03:52 <mgoddard> thanks cosq
15:03:53 <hrw> meeting...
15:03:54 <mgoddard> thanks cosmicsound
15:04:07 <mgoddard> Any other announcements?
15:04:25 <hrw> Debian:10 got ceph 14. but you know that already
15:04:50 <openstackgerrit> Merged openstack/kolla stable/train: Stop gzipping logs in post  https://review.opendev.org/701912
15:04:52 <openstackgerrit> Merged openstack/kolla-ansible stable/train: Fix Zun Docker runtime selection  https://review.opendev.org/702225
15:04:53 <openstackgerrit> Merged openstack/kolla-ansible master: Ansible lint: task names - horizon  https://review.opendev.org/702413
15:05:09 <mgoddard> #info Debian buster has a ceph nautilus backport
15:05:18 <yoctozepto> very good
15:05:21 <mgoddard> #topic Review action items from last meeting
15:07:17 <mgoddard> mnasiadka to continue removing priority from inactive blueprints
15:07:18 <mgoddard> CI guy to start an etherpad with a list of services for CI testing
15:07:20 <mgoddard> yoctozepto to create bp for unpublishing
15:07:24 <mgoddard> mnasiadka: ?
15:07:31 <mgoddard> yoctozepto: ??
15:07:32 <mnasiadka> nearly finished, so consider it done
15:07:57 * yoctozepto done
15:08:00 <mgoddard> cool
15:08:01 <yoctozepto> bp create
15:08:07 <yoctozepto> etherpad too
15:08:14 <mgoddard> where is said etherpad?
15:08:25 <yoctozepto> both are in agenda
15:08:30 <yoctozepto> for discussion
15:08:44 <yoctozepto> 16:02:35 <mgoddard> * CI scenarios: https://etherpad.openstack.org/p/KollaAnsibleScenarios
15:08:44 <yoctozepto> 16:02:37 <mgoddard> * unpublishing images: https://blueprints.launchpad.net/kolla/+spec/dockerhub-image-tag-unpublishing
15:09:22 <mgoddard> #link https://etherpad.openstack.org/p/KollaAnsibleScenarios
15:09:28 <mgoddard> #link https://blueprints.launchpad.net/kolla/+spec/dockerhub-image-tag-unpublishing
15:09:32 <yoctozepto> first round is roles/services with some grouping
15:11:08 <mgoddard> primary/secondary/ternary is subjective :)
15:11:21 <mgoddard> barbican probably secondary
15:11:37 <mgoddard> anyways
15:11:46 <mgoddard> thanks for that.
15:11:52 <mgoddard> #topic CI status
15:12:12 <mgoddard> Were the fernet issues fixed by new images?
15:12:33 <mnasiadka> Yes, at least in master from what I see
15:12:46 <mgoddard> looks like it
15:12:49 <mgoddard> cool
15:13:10 <yoctozepto> 16:11:08 <mgoddard> primary/secondary/ternary is subjective :)
15:13:12 <yoctozepto> indeed
15:13:23 <mgoddard> debian/source issue fixed by https://review.opendev.org/#/c/702442/
15:13:23 <mnasiadka> one of the backports in train failed on broken dockerproject repo
15:13:23 <patchbot> patch 702442 - kolla - Debian/source: do not force tag in build jobs (MERGED) - 1 patch set
15:13:43 <mgoddard> mnasiadka: in train? we shouldn't be using dockerproject there?
15:13:48 <yoctozepto> blazar can be secondary too, I know it works
15:13:53 <mnasiadka> mgoddard: argh, sorry - in rocky
15:14:09 <yoctozepto> mgoddard: fix proposed?
15:14:16 <mnasiadka> yeah, fix proposed to rocky
15:14:40 <mgoddard> yes - https://review.opendev.org/#/c/702664/1
15:14:40 <patchbot> patch 702664 - kolla-ansible (stable/rocky) - Use Docker CE repositories by default - 1 patch set
15:15:07 <mnasiadka> seems it got through zuul - let me push it further
15:15:09 <mgoddard> I think that's all for CI
15:15:30 <mgoddard> #topic Train release planning
15:15:52 <mgoddard> I think we can drop this topic now - kolla and kayobe now all released for train
15:16:14 <yoctozepto> yeah
15:16:19 <mgoddard> #topic Ussuri release planning
15:16:31 <yoctozepto> mgoddard: might be worth it to get back on docs page
15:16:44 <yoctozepto> with train
15:17:02 <mgoddard> yoctozepto: +1
15:17:06 <mgoddard> anyone want to pick that up?
15:17:20 <mnasiadka> yoctozepto: might be worth to add that to the contributor/PTL guide - to check that next time and fix if necessary
15:17:42 <yoctozepto> mnasiadka: yeah, expressed this idea in ml mail
15:18:06 <yoctozepto> I can be assigned
15:18:11 <yoctozepto> should do sooner or later
15:18:21 <yoctozepto> (to both tasks)
15:18:32 <mgoddard> #action yoctozepto add kolla train deploy guide
15:18:35 <born2bake> https://www.linbit.com/en/why-linstor-openstack-use/
15:18:54 <born2bake> https://blueprints.launchpad.net/kolla-ansible/+spec/linstor-storage
15:18:56 <mgoddard> #action yoctozepto add project-deploy-guide to contributor release guide
15:19:04 <mgoddard> born2bake: we're just in a meeting currently
15:19:54 <yoctozepto> born2bake: get someone from linstor to do it :-)
15:19:59 <mgoddard> so, ussuri
15:20:10 <mgoddard> I spent some time with CentOS 8 recently
15:20:35 <mgoddard> It's now at a point where ansible aio jobs pass
15:21:02 <mgoddard> Most patches are mergeable, but there are still some hacks to avoid ceph and a few missing packages
15:21:34 <mgoddard> mnasiadka has offered to look at using the master branch of ceph, as used in the ceph-container project, as a way to get ceph libraries
15:21:48 <mnasiadka> yep, will look into this
15:22:07 <mgoddard> #action mnasiadka to look at using the master branch of ceph, as used in the ceph-container project, as a way to get ceph libraries for CentOS 8
15:22:26 <mgoddard> I think I marked ready patches with RP+1
15:22:49 <openstackgerrit> Scott Solkhon proposed openstack/kolla-ansible master: Support Neutron policy file in both .json and .yaml format  https://review.opendev.org/702682
15:22:59 <mgoddard> tripleo seem to want c8 on train, so we should aim to get that patch chain in place
15:23:06 <mgoddard> (for testing)
15:23:55 <mgoddard> Thoughts?
15:24:01 <mgoddard> Any other ussuri things we should discuss?
15:24:10 <yoctozepto> not really
15:24:16 <hrw> they need a way for c7->c8 upgrades too - probably that's why train
15:24:38 <mgoddard> yes - they have the same plan as us. I just meant that they are trying to test that
15:25:06 <mgoddard> Kayobe train was released recently
15:25:20 <yoctozepto> yeah, very nice to see it progressing
15:25:21 <mgoddard> Not sure if that made last week's meeting
15:25:31 <mgoddard> #info Kayobe train release now available
15:25:45 <yoctozepto> I think it did this way or another
15:25:49 <yoctozepto> but still
15:25:55 <yoctozepto> congrats kayobe
15:26:07 <mgoddard> We need to work out what to do for Ussuri, but no surprises it will be python3 & CentOS 8
15:26:38 <mgoddard> #topic CI scenarios: https://etherpad.openstack.org/p/KollaAnsibleScenarios
15:26:50 <mgoddard> yoctozepto: go for it
15:27:33 <yoctozepto> not much to add, first step is complete, roughly lists how well we support these things
15:27:39 <yoctozepto> be it in CI or if someone uses it
15:27:56 <yoctozepto> (mostly based on me, please promote to 2nd tier if you know something works)
15:28:15 <yoctozepto> let's work out what the next step would be
15:28:31 <yoctozepto> we need to somehow mix and match these services into scenarios
15:28:37 <yoctozepto> and then deploy/undeploy?
15:31:25 <yoctozepto> any thoughts, great ideas?
15:31:38 <yoctozepto> words of wisdom?
15:32:00 <mgoddard> we could next list the scenarios we have that we want to keep, and note which services they test
15:32:32 <mgoddard> that will show which services are untested/need a scenario
15:33:29 <mgoddard> I promoted a few things we use
15:33:58 <yoctozepto> mgoddard: thanks
15:34:03 <yoctozepto> makes sense
15:35:13 <mgoddard> adding some stuff about scenarios at the top
15:35:16 <cosmicsound> so ceph-ansible will be kept?
15:35:36 <yoctozepto> cosmicsound: mgoddard being hopeful
15:36:02 <cosmicsound> I see
15:36:12 <cosmicsound> +1 mgoddard
15:37:09 <cosmicsound> Is kolla-cli part of any main services or one needs to deploy it separately
15:37:49 <yoctozepto> cosmicsound: it's an extra project to control your kolla-ansible config
15:38:06 <yoctozepto> you don't "deploy" it
15:38:25 <cosmicsound> yes its like pip installed
15:38:36 <cosmicsound> was thinking if is not part of kolla toolbox
15:38:55 <cosmicsound> yet thats anyhow a bit out of meeting topic here now
15:40:18 <yoctozepto> cosmicsound: kolla-toolbox is a container we deploy indeed
15:40:28 <yoctozepto> it is a helper container
15:40:32 <yoctozepto> for kolla-ansible
15:41:05 <cosmicsound> got it
15:41:16 <yoctozepto> mnasiadka, hrw, osmanlicilegi, cosmicsound: promote 3rd order to 2nd order if you use the services, thanks
15:41:29 <hrw> kevinz: ^^
15:41:51 <mgoddard> yoctozepto: could we combine zun and cinder-lvm tests?
15:42:02 <yoctozepto> mgoddard: we could
15:42:14 <yoctozepto> they make sense together
15:42:28 <cosmicsound> Vitrage would also need some care, it has some issues together with zun or horizon, maybe with both or none
15:43:01 <yoctozepto> cosmicsound: I doubt vitrage sees much love upstream nowadays though
15:43:20 <mnasiadka> and vitrage's HA is broken from the beginning
15:43:34 <yoctozepto> https://opendev.org/openstack/vitrage/commits/branch/master
15:43:43 <cosmicsound> noticed that already
15:43:43 <yoctozepto> well, they are working on some fixes
15:43:53 <cosmicsound> https://bugs.launchpad.net/kolla-ansible/+bug/1857562
15:43:53 <openstack> Launchpad bug 1857562 in kolla-ansible "[Zun][Vitrage][Horizon] Containers view broken when enabled Vitrage" [Undecided,New]
15:44:02 <yoctozepto> ah, horizon
15:44:05 <cosmicsound> I had this one opened, maybe was not right place for it, yet I did it
15:44:06 <yoctozepto> that's another story
15:44:16 <cosmicsound> I seen mostly horizon affected by it
15:44:23 <cosmicsound> It breaks all ZUN related views
15:44:42 <cosmicsound> And several others did not mapped all of them yet
15:45:22 <born2bake> zun with ceph! :)
15:45:26 <mgoddard> back to CI
15:45:38 <mgoddard> what do we need to do next?
15:45:41 <yoctozepto> cosmicsound: moved
15:45:52 <yoctozepto> does not look like something we can do
15:45:59 <yoctozepto> back to CI
15:46:12 <mgoddard> is someone going to mark which services are covered by approved scenarios?
15:46:17 <yoctozepto> map roles
15:46:27 <cosmicsound> was thinking about cloudkitty to be secondary?
15:46:27 <mgoddard> cosmicsound: +1
15:46:33 <yoctozepto> cosmicsound: go for it, yeah
15:47:16 <yoctozepto> I can do the mapping
15:48:04 <mgoddard> #action yoctozepto to map which services are covered by approved CI scenarios
15:48:15 <mgoddard> and on
15:48:17 <mgoddard> #topic unpublishing images: https://blueprints.launchpad.net/kolla/+spec/dockerhub-image-tag-unpublishing
15:48:53 <mgoddard> yoctozepto: is this you?
15:49:05 <yoctozepto> still me, mgoddard
15:49:37 <yoctozepto> we kind of did not have enough time to discuss it through last time
15:49:53 <yoctozepto> now bp says everything so far
15:50:13 <mgoddard> so this would be a CI job. When would it run?
15:51:06 <yoctozepto> only periodic can access the key
15:51:08 <yoctozepto> so daily
15:51:18 <mgoddard> and what would it do?
15:51:22 <yoctozepto> remove :D
15:51:27 <mgoddard> predefined list of tags, or more dyanmic?
15:51:39 <yoctozepto> I would go for something dynamic
15:51:46 <yoctozepto> to fire and forget
15:51:58 <yoctozepto> but whatever works, really
15:52:03 <mgoddard> list images, check master tag, delete if older than $time?
15:52:31 <yoctozepto> mgoddard: mhm
15:52:39 <mgoddard> has this caused anyone a problem?
15:52:45 <yoctozepto> could also remove very old tags like pike
15:52:56 <mgoddard> it only affects master, which people shouldn't be using generally
15:52:57 <hrw> anything not maintained
15:53:02 <osmanlicilegi> +1 for dropping eol images
15:53:04 <yoctozepto> mgoddard: yeah, me, confusion with qdrouterd availability
15:53:16 <cosmicsound> true that +1 yoctozepto
15:53:35 <mgoddard> what was confusing?
15:53:38 <cosmicsound> any image not available and in globals.yml cause or can cause confusion
15:54:16 <mgoddard> we have the support matrix now, which should help
15:54:30 <mgoddard> (reminds me, we'll need to update it for c8)
15:54:35 <yoctozepto> mgoddard: that I managed to get ubuntu qdrouterd
15:54:42 <hrw> so: 1. EOL branches  2. master images older than $time  3. entries from list of 'images are there but needs to be removed'
15:55:09 <yoctozepto> mhm
15:56:21 <mgoddard> what is this list?
15:56:35 * yoctozepto must go, bbl, please continue though
15:56:47 <hrw> mgoddard: so far no idea but I will not be surprised if we find something
15:58:23 <mgoddard> ok
15:58:34 <mgoddard> #topic open discussion
15:58:42 <mgoddard> Anyone have anything before we finish?
15:58:58 * hrw nope
15:58:58 <mnasiadka> yeah, I found out the magic collection of repos to install ceph on CentOS 8
15:59:17 <mnasiadka> would be happy to get this merged before: https://review.opendev.org/#/c/699413/10
15:59:18 <patchbot> patch 699413 - kolla - CentOS 8: base and openstack-base images - 10 patch sets
15:59:38 <mgoddard> mnasiadka: this is ceph master branch?
15:59:42 <mnasiadka> mgoddard: yes
16:00:31 <mgoddard> let's wrap up
16:00:36 <mgoddard> Thanks y'all
16:00:38 <mgoddard> #endmeeting