15:00:30 <mgoddard> #startmeeting kolla
15:00:31 <openstack> Meeting started Wed Feb  5 15:00:30 2020 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:34 <openstack> The meeting name has been set to 'kolla'
15:00:42 <mgoddard> #topic rollcall
15:00:51 <mgoddard> \o
15:00:53 <scottsol> o/
15:00:56 <osmanlicilegi> o/
15:01:55 <yoctozepto> o/
15:02:48 <mgoddard> #topic agenda
15:02:55 <mgoddard> * Roll-call
15:02:57 <mgoddard> * Announcements
15:02:59 <mgoddard> ** https://groups.google.com/forum/#!topic/ansible-outreach/sLte90d5hdc
15:03:01 <mgoddard> * Review action items from last meeting
15:03:03 <mgoddard> * CI status
15:03:05 <mgoddard> * Ussuri release planning
15:03:07 <mgoddard> * lack of features: https://www.openstack.org/software/releases/train/components/kolla-ansible
15:03:09 <mgoddard> * CI scenarios: https://etherpad.openstack.org/p/KollaAnsibleScenarios
15:03:11 <mgoddard> #topic announcements
15:03:40 <mgoddard> #info Ansible contributor conference on 30-31 March
15:03:49 <mgoddard> #link https://groups.google.com/forum/#!topic/ansible-outreach/sLte90d5hdc
15:04:05 <mgoddard> Any others?
15:04:11 <yoctozepto> not here
15:04:30 <osmanlicilegi> there will be an open infra days on 17th march and the local community is interested having sessions with kolla and openstack-ansible
15:04:40 <osmanlicilegi> https://openinfradayturkey.com/
15:04:49 <osmanlicilegi> mgoddard: would you like to visit istanbul? :)
15:05:28 <mgoddard> wow that's a big venue
15:05:41 <yoctozepto> "OpenStack Foundation officially supports and sponsors this event. "
15:05:55 <yoctozepto> well, nice
15:06:41 <mgoddard> it would be good to have someone talking about kolla there
15:06:47 <osmanlicilegi> we haven't had any openstack days since 2017
15:07:08 <mgoddard> I'm not sure if I'd be able to do it
15:07:17 <mgoddard> anyone else available for it?
15:07:54 <mnasiadka> I could - I think
15:08:18 <mnasiadka> If nobody else is interested ;)
15:08:26 <mgoddard> using up a lot of my 'wife single parenting' credits with trips to london
15:08:43 <osmanlicilegi> if nobody can join us, I will talk with the organizers for a turkish kolla session
15:09:01 <mgoddard> that would be good if you can make it mnasiadka
15:11:02 <mgoddard> if not, osmanlicilegi can fly the flag for kolla in Turkish
15:11:20 <mgoddard> #topic Review action items from last meeting
15:11:22 <mgoddard> mnasiadka to herd cats for contributor guide goal
15:11:29 <mgoddard> any cats herded?
15:11:59 <mgoddard> there was a mail on openstack-discuss about it
15:12:00 <mgoddard> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-February/012364.html
15:12:00 <mnasiadka> osmanlicilegi herded
15:12:16 <osmanlicilegi> I think he's still waiting for me. I couldn't have chance to read all the docs this week.
15:12:18 <mnasiadka> I saw it, will look into templates
15:13:17 <osmanlicilegi> I need some more time cause I'm overloaded with the datacenter migration project
15:13:29 <mgoddard> we have some time
15:13:45 <mgoddard> it's not affected by feature freeze as it's docs, so no huge rush
15:14:03 <mgoddard> #topic CI status
15:14:12 <mgoddard> All looking good?
15:14:24 <mgoddard> I noticed rocky ubuntu publish jobs are failing
15:14:51 <mgoddard> yet another ruby issue
15:15:11 <mgoddard> fluentd image
15:15:28 <osmanlicilegi> fluent-plugin-elasticsearch requires Ruby version >= 2.3.
15:15:33 <osmanlicilegi> need to pin this too
15:15:39 <osmanlicilegi> I'll do it
15:15:58 <mgoddard> thanks osmanlicilegi
15:16:08 <mgoddard> #action osmanlicilegi to fix rocky ubuntu build jobs
15:16:13 <osmanlicilegi> what do you think about pinning fluentd to prevent further errors?
15:16:49 <osmanlicilegi> like rabbit or elk stack, we can upgrade it under control
15:17:08 <mgoddard> I think it's a plugin rather than fluentd itself
15:17:08 <mgoddard> but yes we need to pin something I expect
15:18:35 <mgoddard> Otherwise CI looks fine
15:18:35 <osmanlicilegi> ok, I'll look for it and will send a patch for your reviews
15:18:45 <mgoddard> thanks
15:18:57 <mgoddard> #topic Ussuri release planning
15:19:03 <mgoddard> I'll start with C8
15:19:11 <mgoddard> we've merged a lot of patches now
15:19:53 <mgoddard> https://review.opendev.org/#/q/topic:bp/centos-rhel-8+(status:open+OR+status:merged)
15:20:30 <mgoddard> 3 more patches and we will have most deploy jobs in kolla and kolla-ansible
15:20:43 <mgoddard> status here: https://etherpad.openstack.org/p/kolla-centos8
15:21:06 <mnasiadka> I'll push a review for c8 ceph-ansible jobs
15:21:17 <mgoddard> excellent
15:21:34 <mgoddard> we have hrw's patch for hacluster
15:21:50 <mgoddard> although it lacks crmsh so won't get masakari passing
15:21:53 <osmanlicilegi> and I'll start for rmq and elk soon
15:22:28 <mgoddard> yep, those are big ones
15:23:33 <mgoddard> do we need a TODO list on that status page?
15:24:07 <mgoddard> at some point we need to merge all this stuff back to train
15:24:21 <mnasiadka> I think a TODO list would be nice
15:24:40 <osmanlicilegi> +1
15:25:01 <mnasiadka> we all know c8 is the biggest priority, so if we more or less know the bits and pieces to do - it helps with clarity of picking up items
15:25:27 <mgoddard> ok
15:25:37 <mgoddard> #action mgoddard to add a TODO list to centos8 status page
15:25:59 <mgoddard> What else is going on for Ussuri currently?
15:26:56 <mgoddard> Ceph removal
15:27:09 <mgoddard> Do we have our ducks lined up for that?
15:27:21 <mgoddard> ceph-ansible upgrade merged
15:27:23 <mgoddard> mnasiadka
15:27:36 <mgoddard> anything else we need to do?
15:27:43 <mnasiadka> yeah, I'll update the change for removal and once it passes - we should be fine
15:28:22 <mgoddard> images too?
15:28:33 <mnasiadka> the external ceph doc is now very straightforward - but if anybody sees any items we could be better at when it comes to external ceph - I'm open for proposals
15:28:40 <mnasiadka> well, k-a part first - then removal of images
15:28:46 <mgoddard> +1
15:29:20 <mgoddard> we need to remove ceph jobs from kolla first
15:29:31 <mgoddard> and replace with ceph-ansible
15:29:54 <mnasiadka> yeah, makes sense
15:29:58 <mnasiadka> will note that
15:30:41 <mgoddard> ok
15:30:49 <mgoddard> Other features people want to discuss?
15:31:10 <osmanlicilegi> nope
15:31:12 <yoctozepto> none here so far
15:31:40 <mgoddard> #topic lack of features: https://www.openstack.org/software/releases/train/components/kolla-ansible
15:31:46 <mgoddard> what's all this then?
15:32:11 <yoctozepto> mgoddard: we might like to brag like the others do :-)
15:32:16 <mgoddard> example?
15:32:25 <yoctozepto> https://www.openstack.org/software/releases/train/components/openstack-ansible
15:32:34 <yoctozepto> https://www.openstack.org/software/releases/train/components/tripleo
15:32:48 <mgoddard> I see
15:33:09 <yoctozepto> https://opendev.org/osf/openstack-map/src/branch/master/deployment_tools.yaml
15:33:14 <yoctozepto> https://opendev.org/osf/openstack-map/src/branch/master/deployment_tools_capabilities.yaml
15:33:30 <mnasiadka> So - should I rebase the docker healthchecks patch?
15:33:33 <mnasiadka> If we're in features?
15:33:36 <mnasiadka> And somebody will review it?
15:33:45 <mnasiadka> :)
15:34:09 <mgoddard> https://www.openstack.org/software/releases/train/components/kayobe
15:34:10 <yoctozepto> mnasiadka: you late, we already moved on
15:34:26 <mnasiadka> well, I'll ask in a month :D
15:34:29 <yoctozepto> mgoddard: yeah and kayobe :-)
15:34:31 <mgoddard> wrong mascot for kayobe!
15:34:36 <openstackgerrit> Michal Nasiadka proposed openstack/kolla master: CI: Replace ceph jobs with ceph-ansible  https://review.opendev.org/705986
15:34:56 <yoctozepto> oh fsck
15:35:28 <yoctozepto> https://www.openstack.org/software/releases/train/components/bifrost
15:35:32 <yoctozepto> looks like placeholder mascot
15:35:57 <mgoddard> :(
15:36:20 <mgoddard> https://opendev.org/osf/openstack-map/src/branch/master/deployment_tools_capabilities.yaml#L168
15:36:58 <yoctozepto> getting it from barbican lol
15:37:03 <yoctozepto> a bug to report
15:37:13 <mgoddard> I think we can claim all features except supports-heterogeneous-versions
15:37:33 <mgoddard> which might or might not work
15:37:41 <mgoddard> but we make no guarantee
15:38:07 <mgoddard> so who would like to do the bragging?
15:38:56 <mgoddard> I'll take it
15:39:07 <yoctozepto> yeah, ptl is recommended
15:39:25 <mgoddard> #action mgoddard to add features for kolla and kayobe to openstack-map
15:39:44 <mgoddard> #topic CI scenarios: https://etherpad.openstack.org/p/KollaAnsibleScenarios
15:40:08 <mgoddard> #link https://etherpad.openstack.org/p/KollaAnsibleScenarios
15:40:35 <yoctozepto> what about that magnum with designate
15:40:47 <mgoddard> match made in heaven
15:40:49 <mgoddard> maybe
15:41:27 <mgoddard> one easy win we could get is to drop cinder-lvm
15:41:35 <mgoddard> save some cycles
15:41:50 <mgoddard> make sure the zun job is triggered on all necessary changes
15:41:57 <mgoddard> anyone want to pick that up?
15:43:04 * yoctozepto is up
15:43:24 <yoctozepto> up to the task
15:43:34 <yoctozepto> and seriously
15:43:56 <yoctozepto> who commented on that magnum+designate :-)
15:44:00 <yoctozepto> maybe it's right
15:44:01 <yoctozepto> I don
15:44:04 <yoctozepto> t know
15:44:20 <mgoddard> #action yoctozepto to drop cinder-lvm CI and job and trigger zun job on cinder-lvm role changes
15:45:14 <mgoddard> what do people think about the 'alternative compute' job?
15:45:18 <mgoddard> bit of a catch all
15:45:25 <mgoddard> qinling?
15:45:26 <mgoddard> senlin
15:45:28 <mgoddard> masakari
15:45:30 <mgoddard> neutron+ovn
15:45:32 <mgoddard> swift?
15:45:33 <hrw> it's wednesday already? ouch
15:45:34 <mgoddard> ironic?
15:45:36 <mgoddard> nova cells?
15:45:38 <mgoddard> ovn?
15:46:04 <mgoddard> lol
15:46:14 <mgoddard> meeting time hrw
15:46:30 <mgoddard> we assigned all actions to you
15:46:37 <yoctozepto> mgoddard: if we have no better scenarios
15:46:52 <mgoddard> well we're literally making this stuff up
15:47:11 <mgoddard> if there's a better scenario then we can use it
15:49:42 <openstackgerrit> Mark Goddard proposed openstack/kolla-ansible master: CentOS 8: Add deploy jobs in CI  https://review.opendev.org/693544
15:49:54 <mgoddard> any other thoughts on CI scenarios?
15:50:07 <yoctozepto> hrw, mnasiadka, osmanlicilegi ?
15:50:44 <mnasiadka> I was thinking about scale out
15:50:54 <osmanlicilegi> seems quite well for me, at least for start
15:50:57 <mnasiadka> (Controller wise)
15:52:35 <mgoddard> we do get caught out on scale out sometimes. Seems like a lot to add an extra job though
15:53:20 <mgoddard> would need a few changes to the zuul playbooks
15:53:46 <mnasiadka> yeah, most probably - but we would benefit in future :)
15:54:18 <mgoddard> compute scale out is probably a more common operational task
15:54:37 <yoctozepto> but much simpler :-)
15:54:44 <mgoddard> although generally less troublesome due to lack of clustered services
15:54:52 <mgoddard> add it to the list as a suggestion
15:55:04 <mgoddard> let's get some open time in
15:55:08 <mgoddard> #topic open discussion
15:55:27 <mgoddard> Any topics for today?
15:57:01 <osmanlicilegi> I'm done. I feel like my brain stopped :|
15:57:34 <scottsol> if anyone has a spare mo I have a patch waiting thats been hanging around for a couple of week with no reviews https://review.opendev.org/#/c/702682/
15:57:34 <patchbot> patch 702682 - kolla-ansible - Support Neutron policy file in both .json and .yam... - 2 patch sets
15:57:47 <scottsol> low priority just a gentle poke
15:57:57 <mgoddard> thanks scottsol
15:58:20 <mgoddard> I'll put it on my list
15:58:27 <hrw> scottsol: expand both commit message and relnote please
15:59:37 <mgoddard> I think we're done here
15:59:42 <mgoddard> Thanks everyone
15:59:45 <mgoddard> #endmeeting