15:00:18 <mgoddard> #startmeeting kolla
15:00:19 <openstack> Meeting started Wed Apr 22 15:00:18 2020 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:23 <openstack> The meeting name has been set to 'kolla'
15:01:13 <mgoddard> #topic rollcall
15:01:16 <mgoddard> \o
15:01:17 <yoctozepto> o/
15:01:34 <Fl1nt> noob question, what's rollcall ?
15:01:48 <hrw> ~o~
15:01:54 <hrw> Fl1nt: 'who is here'
15:02:03 <priteau> https://en.wikipedia.org/wiki/Roll_call
15:02:05 <Fl1nt> oh ok
15:02:09 <Fl1nt> o/
15:02:11 <priteau> "A taking of attendance as part of a meeting agenda"
15:02:12 <Fl1nt> so ^^
15:02:14 <priteau> o/
15:03:04 <mgoddard> #topic announcements
15:03:17 <mgoddard> #undo
15:03:18 <headphoneJames> o/
15:03:18 <openstack> Removing item from minutes: #topic announcements
15:03:21 <mgoddard> #topic agenda
15:03:33 <mgoddard> * Roll-call
15:03:35 <mgoddard> * Announcements
15:03:37 <mgoddard> ** Proposed cross-project goal for Victoria: https://review.opendev.org/720107
15:03:37 <patchbot> patch 720107 - governance - goals: add container-images - 3 patch sets
15:03:39 <mgoddard> ** Kolla builder next generation proposal: http://lists.openstack.org/pipermail/openstack-discuss/2020-April/014255.html
15:03:41 <mgoddard> * Review action items from last meeting
15:03:43 <mgoddard> * CI status
15:03:45 <mgoddard> * Kolla Klub https://etherpad.openstack.org/p/kolla-sig
15:03:47 <mgoddard> ** Survey tools comparison https://ethercalc.openstack.org/46c7q4lnww6j
15:03:49 <mgoddard> * Ussuri release planning (kayobe)
15:03:51 <mgoddard> * Ussuri release planning (kolla & kolla ansible)
15:03:53 <mgoddard> * Virtual PTG
15:03:55 <mgoddard> * Train release planning (centos 8)
15:03:57 <mgoddard> * Announcements
15:03:59 <mgoddard> #topic announcements
15:04:09 <mgoddard> #info Proposed cross-project goal for Victoria on container images
15:04:16 <mgoddard> #link https://review.opendev.org/720107
15:04:16 <patchbot> patch 720107 - governance - goals: add container-images - 3 patch sets
15:05:10 <mgoddard> Seems there could be some interesting outcomes from this
15:05:24 <mgoddard> And some opening up to the potential of using kolla
15:05:25 <yoctozepto> so this is mnaser's proposal that we could participate in as we have some relevant experience
15:05:52 <yoctozepto> bindep is interesting to finally get nice
15:06:15 <hrw> I decided to limit myself to read comments
15:06:21 <mgoddard> right, although it's a long way from magically installing all your deps IMO
15:06:26 <yoctozepto> actually sean-k-mooney has just written up something relevant to bindep on the ml, regarding the next announcement
15:06:35 <yoctozepto> (as well)
15:06:48 <mgoddard> #info Kolla builder next generation proposal
15:06:54 <mgoddard> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-April/014255.html
15:07:12 <mgoddard> Thanks yoctozepto for starting this conversation. I encourage people to get involved
15:08:27 <yoctozepto> mgoddard: sure, I think we should do these kinds of things on ml from time to time, if not just to raise community awareness
15:08:40 <mgoddard> #info OpenStack projects proposing RC1 releases this week
15:08:53 <yoctozepto> (not kolla!)
15:09:02 <cosmicsound> o/
15:09:05 <mgoddard> #info Kolla feature freeze next week
15:09:17 <yoctozepto> :O
15:09:19 <mgoddard> yup
15:09:21 <yoctozepto> :D
15:09:26 <hrw> let me check what I have open...
15:09:31 <mgoddard> ok, that's enough #info
15:09:49 <mgoddard> Review action items from last meeting
15:09:53 * Fl1nt reading
15:09:53 <mgoddard> #topic Review action items from last meeting
15:10:10 <mgoddard> mgoddard to prepare project update for kolla klub
15:10:13 <mgoddard> osmanlicilegi to adapt popularity-contest for kolla needs
15:10:15 <mgoddard> osmanlicilegi to look into kolla klub survey/poll
15:10:17 <mgoddard> mgoddard to read PTG emails and request slots
15:10:19 <mgoddard> hrw to switch kolla centos 8 train from delorean to centos-release-openstack-train
15:10:22 <mgoddard> we will find out if I have done mine tomorrow
15:10:46 <mgoddard> I haven't requested PTG slots yet, but did put a proposal on the mailing list
15:10:59 <hrw> https://review.opendev.org/721329 does my part. We are waiting for centos-release-* packages (on a way).
15:10:59 <patchbot> patch 721329 - kolla (stable/train) - [WIP] switch to official CentOS 8 repositories - 3 patch sets
15:11:11 <mgoddard> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-April/014174.html
15:11:12 <hrw> all images build fine.
15:11:25 <mgoddard> thanks
15:11:42 <mgoddard> osmanlicilegi did his, but can't attend the meeting
15:11:50 <yoctozepto> yeah, thanks osmanlicilegi!
15:11:54 <mgoddard> #action mgoddard to sign up for PTG slots
15:11:56 <yoctozepto> nice summary there
15:12:10 <hrw> 16:02 < osmanlicilegi> mgoddard: I have to skip today's meeting cause there will a lockdown here for the next 4 days. I need to visit pharmacy and market. You can find my survey tools comparison at https://ethercalc.openstack.org/46c7q4lnww6j. If there's anything missing for this task, just ping me.
15:12:16 <yoctozepto> #link https://ethercalc.openstack.org/46c7q4lnww6j
15:12:38 <mgoddard> #topic CI status
15:13:02 <hrw> c8/aarch64 is RED due to lack of erlang
15:13:11 <openstackgerrit> James Kirsch proposed openstack/kolla master: Add stunnel container for Glance service  https://review.opendev.org/720850
15:13:16 <hrw> both train and ussuri. we have to wait for CentOS 8.2 ;(
15:14:00 <yoctozepto> otherwise pretty green
15:14:05 <mgoddard> hrw: can you mark the rabbitmq image as unbuildable until then so we're green?
15:14:19 <mgoddard> then at least we can catch regressions
15:14:22 <hrw> mgoddard: kolla-toolbox is red too :(
15:14:24 <hrw> mgoddard: ok
15:15:02 <mgoddard> #action hrw mark rabbitmq and kolla-toolbox unbuildable for c8/aarch64
15:15:20 <mgoddard> #topic Kolla Klub https://etherpad.openstack.org/p/kolla-sig
15:15:39 <mgoddard> Meeting tomorrow, 1500 UTC
15:16:13 <mgoddard> I'll give a project update, and we can feed back about surveys
15:16:25 <mgoddard> #topic Survey tools comparison https://ethercalc.openstack.org/46c7q4lnww6j
15:16:29 <Fl1nt> We should also
15:16:37 <yoctozepto> it's interesting to learn details on kolla usage too
15:17:05 <mgoddard> indeed. I think some case studies would be nice
15:17:06 <Fl1nt> have a little agenda for what we as a community expect from this klub
15:17:13 <mgoddard> ideally I won't be presenting every session :)
15:17:27 <yoctozepto> mgoddard: that would be regression!
15:18:06 <yoctozepto> Fl1nt: yup, that discussion should be part of agenda
15:18:14 <yoctozepto> the homework was to think about it
15:18:17 <mgoddard> Fl1nt: I did try to ask last time, but didn't get too much response
15:18:41 <openstackgerrit> Marcin Juszkiewicz proposed openstack/kolla master: No kolla-toolbox & rabbitmq for aarch64/centos8  https://review.opendev.org/721999
15:18:42 <openstackgerrit> Marcin Juszkiewicz proposed openstack/kolla master: Revert "No kolla-toolbox & rabbitmq for aarch64/centos8"  https://review.opendev.org/722000
15:18:45 <mgoddard> feedback seemed to be 'not too much naval gazing - just get on with it'
15:19:05 <Fl1nt> yep, unfortunately, I think, on my own part, that many operators wait for a more vivid community in terms of support channels.
15:19:48 <mgoddard> Agenda is here, feel free to add something: https://docs.google.com/document/d/1EwQs2GXF-EvJZamEx9vQAOSDB5tCjsDCJyHQN5_4_Sw/edit#heading=h.u784zrqsv2k1
15:20:08 <Fl1nt> ok, I'll think about it.
15:20:25 <mgoddard> if it's something you want to drive, that might encourage others to get involved
15:20:44 <mgoddard> ok, let's look at osmanlicilegi's results, since he put time into it
15:20:57 <mgoddard> https://ethercalc.openstack.org/46c7q4lnww6j
15:21:42 <yoctozepto> at the end of the day, google forms look the best
15:21:49 <mgoddard> kolla klub agena item 1:
15:21:52 <mgoddard> Survey tools survey results
15:21:55 <yoctozepto> but I guess China cannot access them
15:23:04 <mgoddard> yeah that's a shame
15:23:39 <Fl1nt> yeah, such constraints definitely slowdown collaboration.
15:23:56 <mgoddard> typeform seems nice, apart from the 10 question limit
15:24:22 <Fl1nt> Can we achieve the survey in 10 questions?
15:24:58 <mgoddard> It seems a bit low
15:25:26 <yoctozepto> but maybe it fits
15:25:37 <Fl1nt> Maybe the trick is to create multiple survey and explain that multiple strategy has we want to include and ease the discussion with everyone? So no one will complain about having multiple poll.
15:25:38 <yoctozepto> we also need to consider multianswer and freeform parts
15:25:49 <mgoddard> +1
15:25:59 <mgoddard> osmanlicilegi has some multi answer
15:26:06 <yoctozepto> let's extend the calc for that
15:26:10 <mgoddard> I don't see freeform though
15:26:17 <mgoddard> IMO that would be one of the most valuable parts
15:26:19 <hrw> Fl1nt: the problem is analizing results
15:27:14 <Fl1nt> hum... 45€ for the professional plan, can't we pay for it ?
15:27:28 <mgoddard> One thing I worry about with these surveys is how discoverable the data will be
15:27:49 <Fl1nt> that's the killer feature of Google
15:27:56 <mgoddard> I think at a minimum we need data export
15:28:04 <mgoddard> but also we need to be able to host that somewhere
15:28:33 <yoctozepto> it would be nice to learn about osf's solution
15:28:42 <Fl1nt> +1
15:29:16 <mgoddard> I see a few uses for the results
15:29:30 <mgoddard> 1. give the team a better picture of what people do and don't use
15:29:30 <Fl1nt> you can connect typeform anserws to google sheets
15:29:54 <mgoddard> 2. allow to connect up questions to sources of knowledge
15:30:14 <mgoddard> a survey is probably quite good at 1., I don't know how well it serves 2
15:30:31 <yoctozepto> mgoddard: could you elaborate on 2.?
15:31:21 <mgoddard> i.e. user comes in asking about storlets + kolla, who do we connect them to?
15:31:54 <mgoddard> maybe I'm just thinking too siloed, and we should send them to #openstack-storlets
15:32:14 <mgoddard> almost what I want is a social network :)
15:32:19 <mgoddard> linkedin for openstack
15:32:30 <yoctozepto> mgoddard: I was about to say "linkedin for kolla"
15:32:32 <yoctozepto> but yeah
15:32:43 <mgoddard> maybe it's a pipe dream
15:33:04 <yoctozepto> you already know I'm a dreamer too, so you have my full support
15:33:29 <mgoddard> I'd just like to avoid the problem that questions often go unanswered because not all experts read IRC, and when we send people to $project-channel it's often to /dev/null
15:33:49 <yoctozepto> yeah, especially those least used ones
15:33:59 <Fl1nt> yeah, exactly my point of why I suggested having discord, let's face it, nobody except old school devs/operators like us will use IRC, new comers to Openstack tends to be rather younger and have different tools/usage to communicate.
15:34:08 * osmanlicilegi is back after a quick shopping
15:34:18 <yoctozepto> osmanlicilegi: quick, huh? ;D
15:34:26 <yoctozepto> probably after cilegi ;-)
15:34:43 <mgoddard> Fl1nt: it's not just about the medium though, most people just don't want to consume the firehose
15:34:54 <Fl1nt> honestly, kolla channel is for sure the most active one.
15:35:15 <osmanlicilegi> yoctozepto: ;]
15:35:18 <Fl1nt> sure, it was an exemple to support the fact that this community can't be based on either IRC or List.
15:35:19 <mgoddard> maybe the answer is we should direct people to the mailing list more often
15:35:35 <mgoddard> at least there people filter out threads
15:35:36 <yoctozepto> just let's not talk ask.oo, it s... is not decent enough :-)
15:35:51 <mgoddard> indeed
15:36:06 <mgoddard> anyways, in terms of surveys
15:36:16 <mgoddard> google forms is best, but limited
15:36:17 <Fl1nt> if you ask you'll get 10000 answers of the form to use, if you build it and propose it, you'll get adoption if it fit.
15:36:36 <mgoddard> is there a runner up to forms?
15:37:01 <mgoddard> typeform? apart from 10 question limit
15:37:10 <Fl1nt> yep typeform
15:37:19 <mgoddard> osmanlicilegi: did any surveys offer freeform text?
15:37:27 <yoctozepto> it feels tedious to fill in
15:37:36 <yoctozepto> and has 100 answers limit monthly
15:37:47 <Fl1nt> typeform and surveymonkey.com are the both big names in that industry
15:37:55 <Fl1nt> outside of google form I mean
15:38:00 <osmanlicilegi> mgoddard: iirc all has freeform text support
15:38:03 <mgoddard> I think 100 answers per month would be plenty yoctozepto!
15:38:23 <yoctozepto> mgoddard: be a dreamer! ;p
15:38:28 <osmanlicilegi> btw, typeform seems best after google forms if 10 questions is ok
15:39:05 <Fl1nt> if 10 questions is your blocker, I'll subvention the typeform if necessary.
15:39:06 <yoctozepto> seems so
15:39:13 <yoctozepto> I don't like one q per page though
15:39:31 <mgoddard> I think we should move on :)
15:39:35 <yoctozepto> ++
15:39:49 <mgoddard> #topic Ussuri release planning (kayobe)
15:39:50 <Fl1nt> yep
15:39:56 <mgoddard> priteau, dougsz, jovial[m]
15:39:58 <osmanlicilegi> yoctozepto: typeform is customizable. one question per page can be my fault
15:40:11 <yoctozepto> osmanlicilegi: would you drop a question to ml and osf about their framework for surveys?
15:40:15 <mgoddard> If you didn't catch it earlier, feature freeze next week
15:40:17 <yoctozepto> maybe someone responds
15:40:19 <yoctozepto> osmanlicilegi: ack
15:40:25 <yoctozepto> (now onto kayobe)
15:40:25 <osmanlicilegi> yoctozepto: I will, today.
15:40:40 <mgoddard> https://review.opendev.org/#/q/project:openstack/kayobe+branch:master+status:open
15:40:47 <priteau> mgoddard: thanks for the reminder
15:40:57 <priteau> Lots of open patches :o
15:41:08 <mgoddard> yep
15:41:19 <mgoddard> quite a few +2'd or approved though
15:41:52 <priteau> mnasiadka: are you planning to update https://review.opendev.org/#/c/709689/ to answer Mark's comments?
15:41:52 <patchbot> patch 709689 - kayobe - Add framework to deploy user-defined containers on... - 11 patch sets
15:42:13 <mgoddard> if anyone has time then adding a second +2 would help clear some
15:42:54 <mgoddard> would be nice to get https://review.opendev.org/#/c/658815/ in but I don't know if I have time to test the migration
15:42:54 <patchbot> patch 658815 - kayobe - WIP: Switch default docker storage driver to overlay2 - 2 patch sets
15:43:10 <dking> For Kayboe, should cloud_vip_address be set for localhost? I'm receiving the error that kolla_internal_vip_address is not set for localhost. And if so, where's the right place to set that?
15:43:14 <mgoddard> if someone else has time feel free to pick it up
15:43:25 <mgoddard> dking: we're just in a meeting at the moment
15:43:37 <mgoddard> dking: but you can set it in networks.yml
15:43:51 <dking> Okay. Thank you. I'll probably try back in an hour or so, then.
15:43:51 <mgoddard> dking: which is global for all hosts
15:44:26 <mgoddard> any more for kayobe
15:44:29 <mgoddard> ?
15:44:34 <openstackgerrit> Merged openstack/kolla-ansible master: Fix that cyborg agent failed to start privsep daemon.  https://review.opendev.org/721139
15:44:48 <mgoddard> #topic Ussuri release planning (kolla & kolla ansible)
15:45:21 <yoctozepto> all good
15:45:48 <hrw> Debian packages partially available
15:46:00 <mgoddard> added RP+1 to https://review.opendev.org/#/c/721632/1
15:46:01 <patchbot> patch 721632 - kolla-ansible - Add docs and release note for CentOS 8 - 1 patch set
15:46:15 <hrw> for CentOS I wait for centos-release-* packages and will add some of them to cover RDO needs
15:46:51 <hrw> rabbitmq/erlang are now in queue: https://review.opendev.org/721800 then advanced-virtualization and ceph-nautilus will follow
15:46:51 <patchbot> patch 721800 - kolla - CentOS: use RabbitMQ and Erlang from official repos - 1 patch set
15:46:52 <mgoddard> hrw: is that for train?
15:47:00 <hrw> mgoddard: both train and ussuri
15:47:03 <mgoddard> ok
15:47:28 <hrw> mgoddard: only centos-release-openstack-{train,ussuri} will differ
15:48:28 <mgoddard> we have a few tls backend patches in flight. Hopefully we can get them in
15:49:06 <mgoddard> would be nice to do it for all services already using httpd, but getting late
15:49:08 <hrw> I will add relnote to kolla/rmq patch for aarch64 to make it visible that c8/aarch64 is not part of initial release
15:49:44 <mgoddard> ok, thanks
15:49:49 <yoctozepto> https://review.opendev.org/707800
15:49:49 <patchbot> patch 707800 - kolla - [community goal]: Add contributor and PTL guide - 2 patch sets
15:49:54 <yoctozepto> this needs some love
15:50:14 <mgoddard> +1
15:50:29 <mgoddard> although not affected by freeze
15:50:56 <mnasiadka> priteau: yes, tomorrow
15:51:50 <mgoddard> #topic Virtual PTG
15:52:03 <mgoddard> Do we have much to say on it?
15:52:27 <mgoddard> We can gather topics in a few weeks I think
15:52:53 <mgoddard> #topic Train release planning (centos 8)
15:52:57 <hrw> as usual: this cycle summary, c8 summary, next cycle goals
15:53:11 <hrw> train for C8 is splendid
15:53:27 <hrw> we have all images buildable
15:53:28 <mgoddard> I think this was just a request to make a release when train/c8 is ready?
15:53:33 <hrw> yes
15:54:17 <mgoddard> ok. If I backport the k-a docs/reno patch to train then I think we're ready for a release
15:54:49 <openstackgerrit> Marcin Juszkiewicz proposed openstack/kolla master: No kolla-toolbox & rabbitmq for aarch64/centos8  https://review.opendev.org/721999
15:54:52 <openstackgerrit> Merged openstack/kolla-ansible stable/train: Fix that cyborg conductor failed to communicate with placement  https://review.opendev.org/721770
15:55:01 <hrw> added relnote
15:55:02 <mgoddard> it should at least work for greenfield deploys. I'll do 7-8 migration docs separately to not block a releaase
15:55:09 <hrw> ok
15:55:11 <hrw> thanks
15:55:17 <mgoddard> #topic Open discussion
15:55:29 <Fl1nt> Documentation question
15:55:43 <Fl1nt> is rocky release considered as EOL ?
15:56:10 <yoctozepto> Fl1nt: extended maintenance
15:56:22 <yoctozepto> Fl1nt: we accept patches as lons as CI works (it works afaik)
15:56:33 <yoctozepto> but do not really propose ourselves etc.
15:56:40 <Fl1nt> because the k-a with external ceph needs some fixes, I'll be happy to write them, but it also need some fixes on the nova role as it doesn't work at this moment.
15:56:49 <yoctozepto> and I'd like to discuss https://bugs.launchpad.net/kolla-ansible/+bug/1874218 a bit
15:56:49 <openstack> Launchpad bug 1874218 in kolla-ansible "swift sanity checks (smoke tests) broken" [Low,Triaged]
15:56:56 <yoctozepto> are we into sanity checks / smoke tests?
15:57:06 <yoctozepto> they look pooey now
15:57:18 <openstackgerrit> James Kirsch proposed openstack/kolla master: Modify Heat and Nova containers to execute httpd setup  https://review.opendev.org/722028
15:57:23 <yoctozepto> Fl1nt: only rocky?
15:57:42 <priteau> Fl1nt: I am curious, what doesn't work with nova and external ceph?
15:57:46 <Fl1nt> maybe stein, but I didn't have HW/CI to test that release for now
15:57:55 <Fl1nt> @priteau, the keyring
15:57:58 <Fl1nt> because
15:58:06 <Fl1nt> with external ceph
15:58:19 <Fl1nt> you don't handle which ceph client/release you're using
15:58:21 <Fl1nt> and so
15:58:53 <Fl1nt> when using ceph.client.nova.keyring filename with rbd_user = cinder and inner key = ceph.client.cinder.keyring content
15:58:59 <Fl1nt> ceph client saw the trick
15:59:16 <Fl1nt> and complain about it and raise an error
16:00:22 <yoctozepto> mgoddard: no thoughts on smoke tests / sanity checks?
16:00:40 <Fl1nt> the only way to overcome that, is to upload the ceph.client.cinder.keyring on nova_compute and nova_libvirt container instead of ceph.client.nova.keyring.
16:00:48 <Fl1nt> or
16:01:05 <Fl1nt> to add a client directive within your ceph.conf like
16:01:13 <Fl1nt> [client.nova]
16:01:23 <Fl1nt> keyring = <path_to_cinder_keyring>
16:01:35 <Fl1nt> which is... ugly for the least ^^
16:01:48 <Fl1nt> exemple: https://opendev.org/openstack/kolla-ansible/src/tag/7.2.1/ansible/roles/nova/tasks/external_ceph.yml
16:02:14 <Fl1nt> but on train: https://opendev.org/openstack/kolla-ansible/commit/a9fecc41a31749c97e89ba6b66c9c46714fa6da8
16:02:25 <mgoddard> Fl1nt: I would suggest talking to mnasiadka. He made quite a few changes to external ceph config in master
16:02:38 <Fl1nt> cool
16:02:55 <mgoddard> we're out of time I'm afraid
16:02:59 <mgoddard> Thanks all
16:03:02 <mgoddard> #endmeeting