15:00:27 <mgoddard> #startmeeting kolla
15:00:28 <openstack> Meeting started Wed May 13 15:00:27 2020 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <openstack> The meeting name has been set to 'kolla'
15:00:32 <mgoddard> #topic rollcall
15:00:35 <mgoddard> \o
15:01:56 <yoctozepto> o/
15:02:10 <hrw> ~o
15:02:19 <mgoddard> mgoddard mnasiadka hrw egonzalez yoctozepto rafaelweingartne cosmicsound osmanlicilegi
15:03:28 <headphoneJames> o/
15:03:48 <mgoddard> #topic agenda
15:03:56 <mgoddard> * Roll-call
15:03:57 <mgoddard> * Announcements
15:03:59 <mgoddard> ** OpenStack Ussuri released! https://www.openstack.org/software/ussuri
15:04:01 <mgoddard> * Review action items from last meeting
15:04:03 <mgoddard> * CI status
15:04:05 <mgoddard> * Ussuri release planning (kayobe)
15:04:07 <mgoddard> * Ussuri release planning (kolla & kolla ansible)
15:04:09 <mgoddard> * Kolla Klub https://etherpad.openstack.org/p/kolla-sig
15:04:11 <mgoddard> #topic announcements
15:04:22 <mgoddard> #info OpenStack Ussuri released! (but not kolla yet...)
15:04:51 <mgoddard> Kolla is a cycle-trailing project, so we now enter the time of confusion where Ussuri is released but Kolla is not
15:05:02 <mgoddard> #link https://www.openstack.org/software/ussuri
15:05:14 <mgoddard> congrats headphoneJames on making the front page ^
15:05:22 <mgoddard> (via backend TLS)
15:05:46 <headphoneJames> team effort ;)
15:05:54 <mnasiadka> o/
15:06:19 <mgoddard> #topic Review action items from last meeting
15:06:46 <hrw> I hope that this time we will release sooner than later ;D
15:06:51 <mgoddard> None
15:07:15 <mgoddard> #topic CI status
15:07:35 <openstackgerrit> Merged openstack/kolla-ansible master: Fix hacking min version to 3.0.1  https://review.opendev.org/727502
15:07:38 <mgoddard> Ah yeah
15:07:58 <mgoddard> #info Ansible 2.9.8 breaks kolla-ansible master branch
15:08:23 <mgoddard> #info Ansible 2.9.9 released!
15:08:25 <mgoddard> #link https://pypi.org/project/ansible/2.9.9/
15:08:40 <hrw> nice
15:08:45 <hrw> with fix?
15:08:50 <mgoddard> yes
15:09:02 <mgoddard> My second ansible bug & fix to trigger a day 2 release :)
15:09:28 <mgoddard> seems kolla-ansible is a better test of ansible than ansible's CI
15:09:55 <mgoddard> ok CI
15:10:15 <yoctozepto> mgoddard: nice :-)
15:10:20 <mgoddard> kolla & kolla-ansible lookin' green
15:10:40 <openstackgerrit> Merged openstack/kolla master: Fix hacking min version to 3.0.1  https://review.opendev.org/727501
15:10:48 <wuchunyang> kolla-ansible is a test project for ansible. :-)
15:11:15 <yoctozepto> we are doing more ansible than ansible does ansible :-)
15:11:42 <openstackgerrit> Merged openstack/kolla-cli master: Fix hacking min version to 3.0.1  https://review.opendev.org/727503
15:11:50 <mgoddard> kayobe CI got hit by a zuul role name rename
15:12:01 <mgoddard> backports in progress
15:12:48 <mgoddard> #topic Ussuri release planning (kayobe)
15:13:00 <mgoddard> priteau
15:14:18 <mgoddard> https://tiny.cc/kayobe-review-dashboard2
15:14:47 <priteau> o/
15:15:02 <jovial[m1> hi all
15:15:20 <mgoddard> hi
15:15:26 <mgoddard> quite a few backports open
15:16:03 <jovial[m1> Any chance of getting mnasiadka's custom seed containers into ussuri?
15:16:03 <mgoddard> Looks like I need to refresh the c8 docs patch
15:16:12 <mgoddard> That depends on mnasiadka :)
15:16:27 <priteau> I went over open patches recently and reviewed almost all of the ready ones
15:16:29 <jovial[m1> I've started using it in places you see :D
15:16:48 <mnasiadka> jovial[m1: I'll work on it today - specially for you ;)
15:17:01 <priteau> I would like to see the seed container support too :)
15:17:29 <mgoddard> high demand feature
15:17:35 <jovial[m1> thanks mnasiadka - It seemed to work well in my testing - very useful feature
15:17:41 <priteau> Quick question: should we keep the six removal patch for just before branching, like the rest of py2 removal?
15:17:43 <mgoddard> jovial[m1: I can't see LUKS. Did it land?
15:17:51 <mgoddard> priteau: +1
15:17:56 <jovial[m1> my fix didn't work :(
15:18:08 <priteau> LUKS doesn't pass CI
15:18:16 <mgoddard> hmm
15:18:17 <priteau> https://review.opendev.org/#/c/720040/
15:18:18 <patchbot> patch 720040 - kayobe - Add support for encrypted block devices - 11 patch sets
15:18:22 <jovial[m1> I have to investigate what we are missing in the generic cloud image
15:18:37 <jovial[m1> works as expected in vagrant
15:18:37 <mgoddard> misses criteria to make the dashboard
15:19:15 <priteau> "Could not find the requested service systemd-cryptsetup@loopback-crypt.service: host"
15:19:49 <mgoddard> jovial[m1: I'd suggest pointing requirements.yml to a branch of the role and iterating rather than releasing and hoping for the best :)
15:20:19 <mgoddard> or (better) test locally. sausage has cloud images
15:20:21 <jovial[m1> good call - I was just so sure I squelched it :)
15:21:23 <priteau> mgoddard: The reason I haven't approved "Constraint python-openstackclient install with requirements.txt" backport is because we discussed fixing it differently in master, by using a different venv
15:21:45 <mgoddard> ok
15:22:44 <mgoddard> jovial[m1: what about https://review.opendev.org/#/c/724818/ ?
15:22:45 <patchbot> patch 724818 - kayobe - Add ability to run playbooks before and after a ka... - 7 patch sets
15:22:46 <mgoddard> will it land?
15:23:21 <jovial[m1> I noticed the six patch conflicts with the centos 8 support one - which one should we merge first?
15:23:54 <jovial[m1> mgoddard: I put a note about it being experimental and subject to change in the README
15:24:13 <jovial[m1> does that give use clearance to merge and improve on it later?
15:24:56 <mgoddard> ok. looks like it needs another review
15:25:04 <mgoddard> on my list
15:25:38 <priteau> I haven't looked at hooks patch yet, I was excluding patches that didn't pass CI
15:25:50 <mgoddard> only docs fail
15:25:55 <priteau> I've just seen that it's only docs failure
15:26:23 <priteau> I can review it probably only on Friday
15:26:34 <mgoddard> ok
15:27:14 <mgoddard> I'll mark some patches with RP+1
15:27:25 <mgoddard> I think we need another push
15:27:33 <mgoddard> Anything else for Kayobe?
15:28:06 <priteau> Not from me
15:28:40 <priteau> Except this patches that presumably fix CI on stable branches: https://review.opendev.org/#/c/727684/
15:28:40 <patchbot> patch 727684 - kayobe (stable/train) - Use ensure-docker role instead of install-docker - 1 patch set
15:28:48 <priteau> s/this/these/
15:29:07 <mgoddard> yes, approvals for those please
15:29:17 <priteau> We haven't run any CI job on stable branches recently but I expect it is broken
15:29:34 <mgoddard> #topic Ussuri release planning (kolla & kolla ansible)
15:29:58 <mgoddard> I suppose we ought to start working through the release process
15:31:12 <mgoddard> #link https://docs.openstack.org/kolla/latest/contributor/release-management.html
15:31:43 <mgoddard> e.g. switch to released tarballs
15:32:27 <mgoddard> Does anyone want to pick that up?
15:32:28 <hrw> mgoddard: before or after branching?
15:32:33 <mgoddard> hrw: before
15:32:42 <hrw> will prepare patch
15:32:45 <mgoddard> all in the doc above :)
15:33:55 <mgoddard> #action hrw to switch source tarballs to ussuri final releases
15:34:29 <mgoddard> What do we have as FFEs?
15:34:33 <mgoddard> Backend TLS?
15:34:46 <headphoneJames> hopefully :)
15:35:24 <hrw> we may consider drop of gnocchi btw
15:35:29 <mgoddard> may we?
15:35:45 <mgoddard> I think our ceilometer users may be a bit annoyed
15:35:49 <hrw> last release July 2019
15:35:59 <priteau> AFAIK it still works fine
15:36:04 <Fl1nt> \o hi
15:36:10 <hrw> and nearly no trace of activity
15:36:13 <Fl1nt> sorry was in a job meeting
15:36:27 <mgoddard> hi Fl1nt
15:36:45 <mgoddard> I think we can keep gnocchi and reconsider if it starts breaking on us
15:36:54 <Fl1nt> ceilometer may benefit from it but it can use another backend
15:37:32 <mgoddard> not in an existing cloud
15:37:35 <hrw> will write comments to tarballs patch
15:38:00 <mgoddard> ok
15:38:10 <priteau> It's possible to use Monasca as Ceilometer backend now, but that's still fairly new. I don't see why Gnocchi should be dropped as long as it is the recommended backend for Ceilometer.
15:39:06 <Fl1nt> yep definitely, that's not because there are no activity that it means it doesn't work anymore
15:39:07 <priteau> At the very least, deprecate it in one release and drop it only in the next one
15:39:53 <mgoddard> let's see how it evolves. There still seem to be people interested in using it. Maybe they will also maintain it
15:41:05 <Fl1nt> interesting (old but relevant) article from Julien that would explain a lot: https://julien.danjou.info/lessons-from-openstack-telemetry-deflation/ seems like people are transitioning from ceilo to prometheus etc
15:41:43 <yoctozepto> Fl1nt: no wonder as all telemetry components seem to be low-activity
15:41:52 <yoctozepto> a bit sad though
15:42:06 <mgoddard> At this point in the release people should be switching to testing the new release and fixing bugs
15:42:08 <Fl1nt> yep, Julien explain it pretty well on its article and especially why
15:42:12 <yoctozepto> still, maybe this aspect is better handled at more general level
15:42:34 <yoctozepto> fixing bugs is indeed what is on my radar :-)
15:43:01 <Fl1nt> I'm on sync with you @priteau and @mgoddard we should keep it for compatibility until it really break something.
15:43:41 <mgoddard> Do we have anything else to discuss for Ussuri?
15:44:09 <yoctozepto> Fl1nt: ++
15:44:19 <yoctozepto> mgoddard: rather not, maybe only tls
15:44:25 <yoctozepto> are we getting tls for neutron? :D
15:44:35 <yoctozepto> it seems it's the major lacking component
15:44:51 <mgoddard> it doesn't have apache
15:45:11 <yoctozepto> mgoddard: ah, so it counts as pitb
15:45:14 <headphoneJames> I can take a look shortly
15:45:16 <mgoddard> yes
15:45:29 <mgoddard> headphoneJames: I would prefer to focus on finishing what we have
15:45:34 <yoctozepto> headphoneJames: thanks, don't sweat it though
15:45:39 <yoctozepto> indeed ^^
15:45:40 <mgoddard> i.e. https://etherpad.opendev.org/p/tls_tasks
15:45:57 <hrw> ~curse rally
15:46:53 <Fl1nt> @hrw, why? It work pretty well.
15:46:57 <mgoddard> would the world end if we used native neutron-server & TLS?
15:47:02 <mgoddard> https://docs.openstack.org/neutron/latest/configuration/neutron.html
15:47:09 <mgoddard> certfile/keyfile
15:47:26 <mgoddard> could always switch to apache later, but would be a simple change to complete the core set
15:47:28 <Fl1nt> what do you mean by native neutron server?
15:48:22 <mgoddard> at the moment we use the python web server
15:48:25 <mgoddard> no httpd
15:48:25 <openstackgerrit> Marcin Juszkiewicz proposed openstack/kolla master: Switch to Ussuri release tarballs  https://review.opendev.org/727810
15:48:41 <mgoddard> not sure which library it uses under the hood
15:48:44 <Fl1nt> oh ok
15:48:53 <mgoddard> anyways, it's not top of the list
15:49:16 <headphoneJames> I added it to the bottom
15:49:17 <Fl1nt> As for the docker philosophy, I would use neutron-server native as it's already a wsgi app
15:49:18 <hrw> Fl1nt: rally or rally-openstack? ;D
15:49:33 <Fl1nt> rally and rally-openstack
15:50:06 <Fl1nt> adding another process within the container would make it a good candidate for PODs rather than docker actually
15:50:23 <mgoddard> Fl1nt: we use httpd for many of our APIs
15:50:34 <Fl1nt> even if I know that there are many containers already usign httpd ^^
15:50:54 <mgoddard> better performance & reliability
15:51:18 <hrw> Fl1nt: rally does not use openstack/releases at all
15:51:21 <mgoddard> #topic Kolla Klub https://etherpad.openstack.org/p/kolla-sig
15:51:26 <Fl1nt> @mgoddard, yeah, and that's actually the best way to decide, does it add value by improving performance and stability? Then it's OK ^^
15:51:43 <mgoddard> #link https://docs.google.com/document/d/1EwQs2GXF-EvJZamEx9vQAOSDB5tCjsDCJyHQN5_4_Sw/edit#
15:51:51 <mgoddard> We have no topic for the next meeting
15:52:04 <mgoddard> (21st May)
15:52:09 <mgoddard> What should we discuss?
15:52:25 <Fl1nt> I've had a quick side chat
15:52:31 <openstackgerrit> Marcin Juszkiewicz proposed openstack/kolla master: Switch to Ussuri release tarballs  https://review.opendev.org/727810
15:52:33 <Fl1nt> with an attendee of the last meeting
15:53:31 <Fl1nt> and it seems folks are interested by how is kolla/kolla-ansible/kayobe team can actually simplify code contribution as it's an easier step to climb.
15:53:42 <Fl1nt> like
15:54:14 <Fl1nt> they asked a lot about something like a clean and easily discoverable onboarding page.
15:54:24 <Fl1nt> and of course, communication channels
15:54:44 <mgoddard> we have a community goal this cycle to improve the contributor page
15:55:06 <mgoddard> https://review.opendev.org/707800
15:55:06 <patchbot> patch 707800 - kolla - [community goal]: Add contributor and PTL guide - 2 patch sets
15:55:14 <mgoddard> Reviews appreciated
15:55:38 <mgoddard> Also, the first topic proposed for kolla klub is 'project onboarding'
15:56:03 <Fl1nt> yep, I think that the process is pretty straight forward if you carefully read all openstack related documentation, but it yet lack a lot of discoverability
15:56:28 <Fl1nt> and the fact that the way to contribute to openstack projects differs a lot from any other GIT hosted projects is kind of a pain point for them.
15:56:39 <Fl1nt> "a lot"
15:56:46 <mgoddard> we can't change that
15:56:53 <Fl1nt> yep I know ^^
15:57:06 <mgoddard> we can improve our docs and discoverability though
15:57:18 <Fl1nt> it's not that difficult honestly and maybe that entry level kind of filter a lot of bad things too.
15:57:22 <mgoddard> if you have ideas, please propose or draft up
15:57:30 <Fl1nt> yep
15:57:55 <mgoddard> (after reviewing the proposed patch, since that is what the future looks like)
15:58:30 <mnasiadka> mgoddard: I would be glad if somebody could take the burden of improving contributor and PTL guide :)
15:58:38 <mnasiadka> (from my hands)
15:58:42 <Fl1nt> I'll have a look at that doc topic as I'll have to write a bunch of.
15:58:48 <mgoddard> I think often though the problem is 'I simply don't know where to start or what to search for'
15:59:09 <Fl1nt> yep, that what I call discoverability
15:59:33 <mgoddard> Yes, what I am saying is that if you don't know what to ask for, I don't know how to help :)
15:59:43 <hrw> I think that starting with 'I have a problem with service XY' is good way
16:00:07 <Fl1nt> but that point is coming from two factors too, 1 is the openstack doc site being a pain of UI/UX and Search engine such as google still referencing really old docs as first answers.
16:00:33 <mgoddard> yes, SEO is a problem. It was discussed on ML recently
16:00:45 <yoctozepto> it is discussed again and again
16:00:54 <hrw> and will be
16:00:54 <mgoddard> we're out of time
16:01:07 <mgoddard> Shall I propose an onboarding session for the klub next week?
16:01:18 <Fl1nt> yep, that would be cool actually
16:01:39 <mgoddard> ok
16:01:58 <mgoddard> I have slides. Anyone want to help present?
16:02:16 <yoctozepto> I can
16:02:20 <mgoddard> thanks
16:02:23 <yoctozepto> I did onboard
16:02:36 <mgoddard> #action mgoddard and yoctozepto to sync up on onboarding for kolla klub
16:02:45 <mgoddard> I'll send an email with the topic
16:02:51 <yoctozepto> ok
16:02:51 <mgoddard> That's all folks
16:02:59 <mgoddard> #endmeeting