15:01:49 <mgoddard> #startmeeting kolla
15:01:50 <openstack> Meeting started Wed May 20 15:01:49 2020 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:54 <openstack> The meeting name has been set to 'kolla'
15:01:55 <mgoddard> #topic rollcall
15:01:58 <mgoddard> \p
15:02:00 <yoctozepto> mgoddard mnasiadka hrw egonzalez yoctozepto rafaelweingartne cosmicsound osmanlicilegi
15:02:07 <yoctozepto> o/
15:02:11 <osmanlicilegi> o/
15:02:20 <headphoneJames> o/
15:03:19 <yoctozepto> mgoddard: let's move on; rollcall can happen any time
15:03:29 <yoctozepto> I mean rolling in :-)
15:03:43 <yoctozepto> as the call already happened
15:03:43 <hrw> o\
15:03:52 <yoctozepto> mnasiadka: meeting NOW
15:04:34 <mgoddard> #topic agenda
15:04:36 <mnasiadka> yoctozepto: hate meetings! o/
15:04:38 <mgoddard> * Roll-call
15:04:40 <mgoddard> * Announcements
15:04:42 <mgoddard> * Review action items from last meeting
15:04:44 <mgoddard> * CI status
15:04:46 <mgoddard> * Ussuri release planning (kayobe)
15:04:48 <mgoddard> * Ussuri release planning (kolla & kolla ansible)
15:04:50 <mgoddard> * PTG planning
15:04:52 <mgoddard> * Kolla Klub https://etherpad.openstack.org/p/kolla-sig
15:05:00 <mgoddard> #topic announcements
15:05:18 <mgoddard> None from me. Anyone else?
15:05:30 <yoctozepto> no announcement-level infos
15:05:31 <mgoddard> #info Kolla klub meeting tomorrow
15:05:43 <yoctozepto> ah, that counts :D
15:06:04 <mgoddard> oh actually
15:06:21 <mgoddard> #info Kolla 9.1.0 released, including initial support for CentOS 8
15:06:32 <mgoddard> #undo
15:06:33 <openstack> Removing item from minutes: #info Kolla 9.1.0 released, including initial support for CentOS 8
15:06:38 <yoctozepto> it was years ago, come on
15:06:42 <mgoddard> #info Kolla 9.1.0 released for Train, including initial support for CentOS 8
15:06:48 <hrw> uf. I thought that two meetings at same time. missed one hour ago ;D
15:06:58 <yoctozepto> hrw: never happier, eh?
15:07:07 <yoctozepto> missing w/ no consequences
15:07:13 <mgoddard> it was released 3 hours ago
15:07:13 <hrw> yoctozepto: 3h ago I had three...
15:07:22 <hrw> mgoddard: yay!
15:07:23 <yoctozepto> hrw: :-(((
15:07:41 <mgoddard> #topic Review action items from last meeting
15:07:48 <mgoddard> hrw to switch source tarballs to ussuri final releases
15:07:50 <mgoddard> mgoddard and yoctozepto to sync up on onboarding for kolla klub
15:07:52 <mgoddard> hrw: did his
15:08:02 <yoctozepto> mgoddard & yoctozepto planned theirs ;d
15:08:02 * mgoddard and yoctozepto syncing up after this
15:08:15 <mgoddard> #topic CI status
15:08:26 <yoctozepto> times out a lot recently :<
15:08:35 <yoctozepto> but I believe is mostly green
15:09:17 <mgoddard> yeah, I expect one of the clouds is slower
15:09:54 <priteau> There were some mirror problems late last week, seems to be better now?
15:10:15 <yoctozepto> seems better
15:10:33 <yoctozepto> priteau: your sentence is true most of the time actually :D
15:11:03 * hrw do not comment CI this week
15:11:21 <mgoddard> #topic Ussuri release planning (kayobe)
15:11:31 <mgoddard> ok priteau, jovial[m]
15:11:58 <mgoddard> jovial[m]: your patches looking good?
15:12:27 <priteau> luks3 just started passing checks
15:12:57 <mgoddard> that's good
15:13:05 <mgoddard> luks good to me
15:14:02 <jovial[m]> yep - luks is good now I think :)
15:14:20 <mgoddard> cool
15:14:23 <jovial[m]> just working on a small refactoring to the hooks one to support cusotm targets
15:14:27 <priteau> Hopefully extension points can make it?
15:14:42 <mgoddard> custom targets?
15:14:54 <mgoddard> could it be done as a follow up?
15:14:54 <jovial[m]> `network-online`
15:15:28 <mgoddard> otherwise it will never land
15:15:31 <jovial[m]> Well, I switched to using a decorator instead of the cliff hooks
15:15:45 <jovial[m]> but to the user, there is no change
15:16:43 <mgoddard> the current patch just has a few comments on the docs
15:16:49 <mgoddard> let's fix those and merge
15:16:57 <jovial[m]> OK, sounds like a plan
15:17:37 <mgoddard> and mnasiadka, how are your custom seed containers
15:17:58 <mnasiadka> I think they are good, need reviews
15:18:19 <mnasiadka> Applied all previous comments
15:19:00 <mgoddard> ok, I'll look tomorrow
15:19:33 <mgoddard> py2 removal patch passed, let's land it
15:20:04 <mgoddard> I went through release notes, couldn't see any that needed tidying
15:20:50 <priteau> If luks3 looks good (reviewing now), let's merge it first to avoid conflicts when cherry-picking
15:21:17 <jovial[m]> +1
15:21:24 <mgoddard> aka make /me fix conflicts :)
15:22:13 <jovial[m]> I can fix the conflcits if you like :)
15:22:15 <priteau> I'll fix it if you want :P
15:22:34 <mgoddard> so at this point we should be focusing on bug fixing, and working out which bugs we need to fix for ussuri
15:22:53 <mgoddard> CentOS 8 is likely to trip us up still
15:23:00 <jovial[m]> any major bugs we know of?
15:23:57 <mgoddard> brtknr and dougsz hit a weird networking issue in their workshop yesterday
15:24:15 <mgoddard> probably specific to the infrastructure, but still worth looking at
15:24:27 <mgoddard> jovial[m] if you have time maybe that's something you could look at?
15:25:14 <jovial[m]> sure
15:25:22 <mgoddard> brtknr: could you raise a bug in storyboard for it?
15:25:23 <jovial[m]> Do we have a bug report for that?
15:26:26 <mgoddard> anything else for kayobe?
15:27:19 <priteau> Not from me
15:27:29 <priteau> Actually
15:27:34 <priteau> Please review https://review.opendev.org/#/c/729448/
15:27:34 <patchbot> patch 729448 - kayobe - Fix pygments style - 2 patch sets
15:27:45 <priteau> The docs in prod are hard to read, that's the fix
15:28:00 <mgoddard> #topic Ussuri release planning (kolla ansible)
15:29:03 <mgoddard> hrw and I started cranking the release handle this week
15:29:41 <hrw> o, I did?
15:29:43 <mgoddard> looks like the patches all merged
15:29:50 <mgoddard> hrw: yeah, source tarballs
15:29:53 <hrw> ah.
15:30:06 <hrw> sorry, requirements CI killed me
15:30:30 <mgoddard> #link https://docs.openstack.org/kolla/latest/contributor/release-management.html
15:31:09 <yoctozepto> yeah, I have been reviewing that stuff and approving
15:31:21 <mgoddard> I think we're actually ready to create an RC1 and branch
15:31:25 <yoctozepto> fixing conflicts, usual stuff
15:31:30 <mgoddard> thanks
15:31:36 <mgoddard> any blockers to RC1?
15:31:45 <yoctozepto> yeah, I think it will not hurt to do RC1
15:31:53 <yoctozepto> one look more, sec
15:32:33 <yoctozepto> not all versions look to have been fixed at releases
15:32:44 <mgoddard> ?
15:32:48 <mgoddard> ah
15:33:02 <yoctozepto> yeah - ah
15:33:17 <mgoddard> what are we missing?
15:33:19 <yoctozepto> and we have not approved the community goal before release
15:33:20 <mgoddard> networking-mlnx?
15:33:33 <mgoddard> we can backport docs
15:33:46 <hrw> https://review.opendev.org/#/c/707800/ one?
15:33:46 <patchbot> patch 707800 - kolla - [Community goal] Update the contributor guide - 3 patch sets
15:33:51 <mgoddard> RC1 blocks RDO release, so I'm keen to get it out
15:34:10 <yoctozepto> l2gw
15:34:17 <yoctozepto> mksproxy
15:34:25 <yoctozepto> vmtp
15:34:31 <yoctozepto> these are at master
15:34:47 <yoctozepto> networking-ansible is at openstack_branch (ussuri)
15:34:56 <yoctozepto> similarly networking-mlnx
15:35:00 <hrw> mksproxy and vmtp we should once and for all set at one ver and then drop
15:35:04 <yoctozepto> so 5 to fix
15:35:09 <yoctozepto> hrw: very likely
15:35:20 <yoctozepto> let's check the situation now
15:35:24 <yoctozepto> that's what we have time for :-)
15:35:34 <hrw> yep
15:35:42 <mgoddard> not all had releases available yesterday
15:36:01 <yoctozepto> mksproxy is dead for 3 years
15:36:07 <yoctozepto> why are we keeping this
15:36:10 <mgoddard> looks like l2gw has a release now
15:36:27 <yoctozepto> networking-mlnx pending release
15:36:39 <yoctozepto> similarly ansible
15:36:44 <yoctozepto> so l2gw to fix
15:37:01 <hrw> +1 on guide
15:37:16 <yoctozepto> vmtp dead for one year
15:37:49 <hrw> l2gw released 16.0.0 today
15:38:08 <yoctozepto> so 1 to fix before RC1 (as is possible)
15:38:12 <yoctozepto> 2 to fix later
15:38:23 <yoctozepto> 1 to remove definitely (mksproxy, what the ...)
15:38:32 <yoctozepto> 1 to likely drop - vmtp
15:39:50 <yoctozepto> is anyone proposing to fix l2gw to release?
15:40:01 <yoctozepto> and the other two on master
15:40:01 <mgoddard> I'll do it
15:40:09 <yoctozepto> mgoddard: let's attack all 3
15:40:12 <yoctozepto> and be done
15:40:12 <hrw> I just did l2gw
15:40:14 <openstackgerrit> Marcin Juszkiewicz proposed openstack/kolla master: ussuri binary tarballs: l2gw  https://review.opendev.org/729638
15:40:22 <yoctozepto> hrw: then two others too :D
15:40:55 <yoctozepto> vmtp and mksproxy look seriously python2
15:40:59 <yoctozepto> they likely not work
15:41:01 <yoctozepto> xD
15:41:32 <mgoddard> ok, looks like we have a quick path to RC1
15:41:42 <openstackgerrit> Marcin Juszkiewicz proposed openstack/kolla master: ussuri binary tarballs: l2gw, mksproxy, vmtp  https://review.opendev.org/729638
15:42:03 <mgoddard> What else for ussuri?
15:42:41 <yoctozepto> so there is the community goal docs
15:42:41 <openstackgerrit> Merged openstack/kayobe master: Fix pygments style  https://review.opendev.org/729448
15:42:46 <yoctozepto> I'm working on k-a part too
15:42:55 <yoctozepto> but too many distractions :D
15:43:47 <hrw> we need patches which deprecate nova-mksproxy and vmtp
15:43:52 <hrw> before ussuri release
15:44:06 <hrw> so we can kill them in victory
15:44:33 <mgoddard> #link https://launchpad.net/kolla/+milestone/10.0.0
15:44:37 <mgoddard> #link https://launchpad.net/kolla-ansible/+milestone/10.0.0
15:46:44 <headphoneJames> nova backend tls is ready to go if thats of interest
15:46:47 <headphoneJames> https://review.opendev.org/724794
15:46:47 <patchbot> patch 724794 - kolla-ansible - Add support for encrypting Nova API - 10 patch sets
15:47:12 <mgoddard> headphoneJames: did you find out why the jobs sometimes failed?
15:47:33 <headphoneJames> no
15:48:07 <mgoddard> probably not ready to go then :)
15:48:13 <headphoneJames> fair enough
15:48:15 <mgoddard> they were very much TLS related failures
15:48:19 <mgoddard> from what I could tell
15:49:01 <headphoneJames> though its green now
15:49:03 <mgoddard> there are quite a few things on the tls tasks list, would be good to work through those
15:49:16 <headphoneJames> I'm working on the root CA impl
15:49:18 <yoctozepto> the critical on cyborg in ussuri is interesting
15:49:26 <yoctozepto> would make sense to fix before rc1 ;p
15:49:28 <mgoddard> I'd like to see quite a few passes, given I saw the same failure in two jobs previously
15:49:58 <mgoddard> critical seems quite high for cyborg
15:49:59 <openstackgerrit> Will Szumski proposed openstack/kayobe master: Add support for encrypted block devices  https://review.opendev.org/720040
15:50:17 * osmanlicilegi bbl
15:50:25 <yoctozepto> mgoddard: well, it means we should mark the whole row of cyborg as unsupported ;p
15:50:25 <mgoddard> it can be fixed easily enough, if we don't need opae-sdk
15:50:33 <yoctozepto> yeah, we probably don't
15:50:44 <yoctozepto> since I didn't receive any other response
15:50:50 <mgoddard> anyone want to fix that?
15:50:58 <yoctozepto> I think let's do removal of this part and releasenote
15:51:04 <hrw> anyone uses it?
15:51:11 <mgoddard> 99cloud seem to
15:51:29 <yoctozepto> yeah and it seems we don't build in train centos8 too
15:51:34 <mgoddard> Jeffrey4l: around?
15:51:34 <yoctozepto> eh :D
15:52:00 <hrw> create a deprecation/remove patch and add them to reviewers? ;D
15:52:14 <hrw> sorry, bad humour day
15:52:19 <mgoddard> I'll send an email to Jeffrey4l
15:52:37 <mgoddard> #action mgoddard to send an email to Jeffrey4l about cyborg
15:52:40 <yoctozepto> I'll create a patch nonetheless
15:52:44 <yoctozepto> it will be ready then
15:53:08 <mgoddard> guess I won't email then :)
15:53:10 <mgoddard> #undo
15:53:11 <openstack> Removing item from minutes: #action mgoddard to send an email to Jeffrey4l about cyborg
15:53:17 <mgoddard> just add him as a reviewer
15:53:31 <yoctozepto> mgoddard: yeah, makes sense ;p
15:54:43 <yoctozepto> mgoddard: /me needs 9.1.1 milestone in launchpad :-)
15:54:54 <yoctozepto> (always forgets where to add one lol)
15:55:23 <mgoddard> yoctozepto: done
15:55:42 <openstackgerrit> jacky06 proposed openstack/kolla-ansible master: Switch to newer openstackdocstheme and reno versions  https://review.opendev.org/729641
15:56:34 <mgoddard> #topic PTG planning
15:56:41 <openstackgerrit> Radosław Piliszek proposed openstack/kolla-ansible master: [Community goal] Update the contributor guide  https://review.opendev.org/729642
15:56:42 <yoctozepto> mgoddard: thanks
15:57:02 <mgoddard> apparently it's the PTG in under 2 weeks...
15:57:07 <mgoddard> how did that happen?
15:57:39 <yoctozepto> aliens, Mark, aliens everywhere :D
15:58:19 <brtknr> whats the difference between https://github.com/openstack/kayobe-config and https://github.com/openstack/kayobe-config-dev
15:58:30 <mgoddard> #link https://etherpad.opendev.org/p/kolla-victoria-ptg
15:58:43 <mgoddard> brtknr: in a meeting for 2 minutes
15:59:06 <mgoddard> I'll populate boilerplate in the above etherpad
15:59:17 <yoctozepto> mgoddard: and then with me
15:59:25 <mgoddard> indeed
15:59:29 <mgoddard> lucky me
15:59:37 <yoctozepto> Mark is mine today
15:59:56 <openstackgerrit> jacky06 proposed openstack/kolla-ansible master: Switch to newer openstackdocstheme and reno versions  https://review.opendev.org/729641
16:00:22 <yoctozepto> ^ please don't approve that before we branch
16:00:31 <yoctozepto> marking rp-1 atm
16:00:40 <mgoddard> I'll ping people once I've populated, then please start adding ideas for discussion topics
16:01:03 <mgoddard> I'll raise this at the kolla klub meeting tomorrow, try to get a wider audience
16:01:04 <hrw> yoctozepto: mark as RP-1
16:01:29 <yoctozepto> hrw: yeah, I did, but do remember for other projects ('tis k-a)
16:01:41 <yoctozepto> what about k-cli?
16:01:57 <mgoddard> hmm
16:02:08 <yoctozepto> we never really talk about it except on release ;p
16:02:28 <mgoddard> I emailed Jeffrey4l about it. Seems caoyuan is no longer at 99cloud, although he seems to still be active in kolla
16:02:53 <mgoddard> but this means there isn't really enough resource at 99cloud to hepl maintain it
16:03:01 <yoctozepto> hmm
16:03:27 <mgoddard> it's probably too late to drop for ussuri, but I suggest we add a big note in the release notes that unless maintainers come forward we drop in Victoria?
16:03:39 <yoctozepto> sounds good to me
16:03:50 <mgoddard> anyone want to propose that notes?
16:04:13 <yoctozepto> (and I don't really see how k-cli is helping with using k or k-a)
16:04:27 <yoctozepto> unless you got vendor-locked :D
16:04:38 <yoctozepto> kolla-cli-locked
16:04:40 <hrw> +1
16:05:00 <yoctozepto> I'm good at bad docs
16:05:04 <yoctozepto> let it be on me
16:05:06 <mgoddard> cool
16:05:19 <mgoddard> #action yoctozepto to mark kolla-cli as deprecated in release note prelude
16:05:28 <mgoddard> we're out of time folks
16:05:40 <mgoddard> thanks
16:05:46 <yoctozepto> thanks
16:05:58 <mgoddard> See you at kolla klub tomorrow
16:06:00 <mgoddard> #endmeeting