15:01:10 <mgoddard> #startmeeting kolla
15:01:11 <openstack> Meeting started Wed Jun 10 15:01:10 2020 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:14 <openstack> The meeting name has been set to 'kolla'
15:01:18 <mgoddard> #topic rollcall
15:01:20 <mgoddard> \o
15:01:28 <priteau> o/
15:01:36 <headphoneJames> o/
15:01:48 <Wasaac> o/
15:02:01 <mgoddard> mgoddard mnasiadka hrw egonzalez yoctozepto rafaelweingartne cosmicsound osmanlicilegi
15:02:13 <yoctozepto> o/
15:02:51 <jovial[m]> \0
15:03:54 <JamesBenson> \o
15:04:03 <mgoddard> #topic agenda
15:04:12 <mgoddard> * Roll-call
15:04:15 <mgoddard> * Announcements
15:04:17 <mgoddard> ** Vote for Victoria cycle priorities https://etherpad.opendev.org/p/kolla-victoria-priorities
15:04:19 <mgoddard> ** Victoria PTG discussion notes https://etherpad.opendev.org/p/kolla-victoria-ptg
15:04:21 <mgoddard> ** Proposal for a new release model: http://lists.openstack.org/pipermail/openstack-discuss/2020-June/015342.html
15:04:23 <mgoddard> * Review action items from last meeting
15:04:25 <mgoddard> * CI status
15:04:27 <mgoddard> * Ussuri release planning (kayobe)
15:04:29 <mgoddard> * Ussuri release planning (kolla & kolla ansible)
15:04:31 <mgoddard> * Kolla klub
15:04:33 <mgoddard> #topic Announcements
15:05:15 <mgoddard> #info Vote for Victoria cycle priorities!
15:05:22 <mgoddard> #link https://etherpad.opendev.org/p/kolla-victoria-priorities
15:05:37 <mgoddard> Anyone is welcome to vote
15:05:47 <mgoddard> #info Victoria PTG discussion notes available
15:05:53 <mgoddard> #link https://etherpad.opendev.org/p/kolla-victoria-ptg
15:06:20 <mgoddard> #action mgoddard to collect actions from PTG
15:06:23 <mgoddard> meta
15:06:32 <mgoddard> #info Proposal for a new release model
15:06:39 <mgoddard> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-June/015342.html
15:07:10 <mgoddard> Interesting potential implications for us, but Thierry seems open to accomodating us
15:08:19 <mgoddard> Any others?
15:10:00 <mgoddard> #topic Review action items from last meeting
15:10:03 <mgoddard> There were none
15:10:05 <mgoddard> #topic CI status
15:10:24 <scottsol> o/
15:10:45 <mgoddard> CI looks good for kolla & kolla ansible
15:10:58 <mgoddard> Kayobe I think is fine, assuming the new stable/ussuri branch works
15:11:07 <mgoddard> Although stable/rocky is not passing
15:11:28 <priteau> Some intermittent issues for Kayobe due to Galaxy
15:11:41 <mgoddard> same same
15:11:55 <priteau> I am working on a fix for rocky & queens but requires approval in bifrost land
15:12:19 <florianleduc> Hi
15:12:29 <mgoddard> priteau: I may be able to help you there
15:12:35 <priteau> If only I knew the bifrost release manager ;-)
15:12:50 <priteau> https://review.opendev.org/#/c/734585/
15:12:51 <patchbot> patch 734585 - bifrost (stable/queens) - Fix multiple CI failures - 2 patch sets
15:13:01 <mgoddard> priteau: although they are both in EM, so no new releases
15:13:14 <mgoddard> kolla may need to switch to track stable branches to pick up fixes
15:13:45 <priteau> Didn't we talk about doing this generally for all projects?
15:13:50 <mgoddard> anyway, better move on. People get angry if you mention bifrost in these parts
15:14:03 <mgoddard> We did, but not retrospectively
15:14:20 * yoctozepto triggered (where is bikolla?!)
15:14:32 <mgoddard> I think the plan was to release ussuri GA with version pins, then switch to branches
15:14:49 * yoctozepto starts chanting war songs
15:14:54 <mgoddard> I see the logic of that, although I'd probably rather pick a path and stick to it
15:15:16 <mgoddard> we're digressing a little
15:15:26 <dking> Speaking of bifrost/ironic, mgoddard, did the Ironic team ever get with you regarding their work on containerizing Ironic?
15:16:46 <mgoddard> dking: we're in a meeting currently. They didn't speak to me about it. Who has started that work?
15:16:58 <mgoddard> I'm on the ironic core team so should probably know this
15:17:22 <dking> They mentioned it in the PTG.
15:18:33 <mgoddard> still need to read that etherpad
15:18:43 <mgoddard> anyway, let's move on
15:18:47 <mgoddard> #topic Ussuri release planning (kayobe)
15:18:56 <mgoddard> We have stable/ussuri branches
15:20:13 <mgoddard> https://docs.openstack.org/kayobe/latest/development/releases.html
15:20:38 <mgoddard> Proposal bot patches need to be approved
15:21:18 <mgoddard> Anyone want to perform the next few release tasks?
15:21:27 <jovial[m]> What needs doing?
15:21:55 <mgoddard> revert the switch to ussuri patch on master, bump previous release to ussuri
15:22:01 <mgoddard> all in the doc :)
15:22:20 <jovial[m]> I could give it a go if you like
15:22:42 <mgoddard> that would be great
15:23:13 <mgoddard> #action jovial[m] to revert the switch to ussuri patch on master, bump previous release to ussuri
15:23:51 <mgoddard> at that point it will "just" be a case of getting the patches we want/need merged to master and then backported
15:24:01 <priteau> And test test test
15:24:06 <mgoddard> indeed
15:24:20 <mgoddard> I made a stable/ussuri branch for a-universe-from-nothing
15:24:41 <mgoddard> #link https://github.com/stackhpc/a-universe-from-nothing/tree/stable/ussuri
15:25:08 <mgoddard> also a multi-host, multi-network setup which seems to mostly work
15:26:18 <priteau> Nice
15:26:19 <mgoddard> Let's try to decide which patches we want/need for the release
15:26:47 <priteau> a-multiverse-from-nothing-ussuri?
15:26:54 <mgoddard> you got it
15:27:13 <mgoddard> running out of names
15:27:24 <florianleduc> Hello guys, when will we talk about new features of kolla, i've submitted this one and I want to know if it will be taken in the next release: https://review.opendev.org/#/c/728796/
15:27:24 <patchbot> patch 728796 - kolla-ansible - Deploy mariaDB Galera arbitrator - 9 patch sets
15:27:30 <mgoddard> #link https://review.opendev.org/#/q/project:openstack/kayobe+status:open+branch:master
15:27:35 <mgoddard> florianleduc: next topic
15:27:38 <florianleduc> thx !
15:28:22 <mgoddard> let's assume all bot patches need to land
15:28:59 <mgoddard> wow there are a lot of radio buttons to choose from in gerrit
15:29:19 <mgoddard> should we aim to get https://review.opendev.org/#/c/728453/ in?
15:29:20 <patchbot> patch 728453 - kayobe - Copy custom certificates - 4 patch sets
15:29:34 <jovial[m]> I'm too used to code review being top and keep twiddling the wrong one
15:30:18 <priteau> Me too :( Who had this terrible idea of adding backport-candidate?
15:30:34 <jovial[m]> custom certs seems like a good feature to have
15:31:04 <jovial[m]> what about: https://review.opendev.org/#/c/734064/ ?
15:31:05 <patchbot> patch 734064 - kayobe - Update feature flags - 2 patch sets
15:31:05 <priteau> Custom certs almost ready to go, my comment was minor. I will look into again.
15:31:07 <mgoddard> it unlocks a lot of good work in k-a, would be a shame not to have it
15:31:16 <mgoddard> added RP+1 to that already jovial[m]
15:31:21 <mgoddard> thanks priteau
15:31:23 <priteau> jovial[m]: I'll review that one too
15:31:29 <jovial[m]> thanks :)
15:31:51 <mgoddard> https://review.opendev.org/#/c/733649/ looks pretty small, haven't reviewed yet though
15:31:51 <patchbot> patch 733649 - kayobe - Update openrc files after overcloud service upgrade - 2 patch sets
15:32:06 <mgoddard> I'll mark RP+1
15:32:32 <priteau> Thanks. That one has a question as well, about `kayobe control host upgrade`. Let's discuss on Gerrit.
15:32:39 <mgoddard> https://review.opendev.org/#/c/709689/ just has a pep8 failure, but is otherwise ready to go IMO
15:32:39 <patchbot> patch 709689 - kayobe - Add framework to deploy user-defined containers on... - 17 patch sets
15:32:40 <jovial[m]> I also need to update the list of image build regexes
15:33:02 <mgoddard> since mnasiadka is away, anyone want to fix his pep8 failure?
15:33:19 <jovial[m]> I had a quick look and it was non-trivial
15:33:29 <mgoddard> I think it will just be a case of copying some config into docs, rather than trying to be clever with a literalinclude
15:33:30 <jovial[m]> unless you disable D000
15:33:39 <jovial[m]> ahh, that would work
15:33:51 <jovial[m]> I'll do that then
15:33:55 <mgoddard> thanks
15:34:14 <mgoddard> #action jovial[m] to polish up https://review.opendev.org/#/c/709689/
15:34:14 <patchbot> patch 709689 - kayobe - Add framework to deploy user-defined containers on... - 17 patch sets
15:35:30 <mgoddard> I think they are the main patches of interest on master
15:35:35 <mgoddard> anyone have others?
15:36:03 <priteau> Multi environments will probably only be for Victoria, I expect some iterations
15:36:21 <mgoddard> I have a fix for IPA building to rewrite (thanks jovial[m] :p)
15:36:35 <mgoddard> simple enough though
15:37:11 <mgoddard> priteau: yeah, better not to rush it
15:37:19 <mgoddard> (and we're past freeze :))
15:37:46 <mgoddard> Any other thoughts before we move onto kolla?
15:38:41 <priteau> That's all from me
15:39:12 <mgoddard> #topic Ussuri release planning (kolla & kolla ansible)
15:39:57 <jovial[m]> sorry, kayobe again, but what about: https://review.opendev.org/#/c/731829/? Shouldn't we get that in?
15:39:57 <patchbot> patch 731829 - kayobe (stable/train) - CentOS 8: add docs and release note - 2 patch sets
15:40:09 <mgoddard> jovial[m]: it's for train
15:40:13 <mgoddard> but yes, we should
15:41:10 <mgoddard> I think it needs a small change to allow for the kolla_tag variable, then we can probably merge it as a mk1. Better to have something available than nothing
15:41:36 <mgoddard> florianleduc: you had a question :)
15:41:59 <jovial[m]> +1 - will help with train - ussuri upgrades
15:42:23 <mgoddard> florianleduc: thanks for the patch. We're past the point of accepting features for Ussuri, but I expect we can merge it for the Victoria release
15:42:54 <headphoneJames> https://review.opendev.org/#/c/731344/
15:42:55 <patchbot> patch 731344 - kolla-ansible - Generate Root CA for Self-Signed Certificates - 19 patch sets
15:43:06 <florianleduc> sounds nice for the victoria release , IMO
15:43:42 <florianleduc> I just need to take into account comments from Radoslaw, I hope i'll finish this week (docs and rework of the inventory modification i've made)
15:46:16 <mgoddard> great
15:46:33 <mgoddard> yoctozepto: around?
15:46:54 <yoctozepto> mgoddard: what's up? :D
15:47:01 <mgoddard> meeting :p
15:47:45 <mgoddard> #link https://launchpad.net/kolla/+milestone/10.0.0
15:47:49 <mgoddard> #link https://launchpad.net/kolla-ansible/+milestone/10.0.0
15:48:16 <mgoddard> ideally those should represent the targeted bugs to be fixed in the ussuri releas
15:48:24 <mgoddard> especially High or Critical bugs
15:50:31 <mgoddard> quite a few open bugs for k-a in particular
15:51:13 <mgoddard> any kolla folk around?
15:51:44 <mgoddard> maybe we should do this another time
15:51:59 <mgoddard> #topic Kolla klub
15:52:12 <mgoddard> #link https://docs.google.com/document/d/1EwQs2GXF-EvJZamEx9vQAOSDB5tCjsDCJyHQN5_4_Sw/edit#
15:52:41 <mgoddard> The next meeting is scheduled for next thursday (18th)
15:52:59 <mgoddard> Topics are PTG summary and open discussion
15:53:19 <mgoddard> Please propose ideas for topics for discussion in the agenda
15:54:17 <mgoddard> #topic Open discussion
15:54:25 <mgoddard> Anyone have anything to discuss this week?
15:54:30 <headphoneJames> can I have a few eyes on https://review.opendev.org/#/c/731344/
15:54:30 <patchbot> patch 731344 - kolla-ansible - Generate Root CA for Self-Signed Certificates - 19 patch sets
15:55:49 <mgoddard> yeah, we should push on that
15:56:34 <mgoddard> and more importantly https://review.opendev.org/#/c/733743, which introduces a behaviour change but is a more sensible way of defining the CA cert for the openrc file
15:56:35 <patchbot> patch 733743 - kolla-ansible - Replace internal and external VIP CA with root CA - 3 patch sets
15:57:05 <mgoddard> marked both as RP+1
15:57:11 <headphoneJames> thanks
15:57:21 <mgoddard> headphoneJames: you don't have to wait for the meeting to beg for reviews :)
15:57:31 <mgoddard> although it does provide some rate limiting
15:57:55 <headphoneJames> is there time for submitting updated TLS documentation in Ussuri?
15:58:08 <mgoddard> always time to improve documentation
15:59:16 <mgoddard> 1 minute left
16:00:16 <mgoddard> and time
16:00:22 <mgoddard> Thanks everyone
16:00:27 <mgoddard> #endmeeting