15:01:08 <mgoddard> #startmeeting kolla
15:01:09 <openstack> Meeting started Wed Jun 24 15:01:08 2020 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:12 <mgoddard> #topic rollcall
15:01:13 <openstack> The meeting name has been set to 'kolla'
15:01:20 <mgoddard> \o
15:01:29 <yoctozepto> o/
15:02:10 <jovial[m]> 0/
15:02:41 <headphoneJames> o/
15:02:58 <mnasiadka> o/
15:04:31 <mgoddard> #topic agenda
15:04:46 <mgoddard> * Roll-call
15:04:48 <mgoddard> * Announcements
15:04:50 <mgoddard> ** Kolla Ussuri released!
15:04:52 <mgoddard> * Review action items from last meeting
15:04:54 <mgoddard> * CI status
15:04:56 <mgoddard> * Ussuri release planning (kayobe)
15:04:58 <mgoddard> * Ussuri release planning (kolla & kolla ansible)
15:05:00 <mgoddard> * Kolla klub
15:05:02 <mgoddard> #topic Announcements
15:05:12 <mgoddard> #info Kolla Ussuri released!
15:05:24 <yoctozepto> yay
15:05:28 <mgoddard> Well done everyone
15:05:29 <yoctozepto> woopee
15:05:51 * yoctozepto popping champagne bottles
15:06:22 <mgoddard> we actually got kayobe out at the same time \o/
15:06:29 <yoctozepto> congrats, kayobe!
15:07:01 <headphoneJames> good work!
15:07:11 <suryasingh> @mgoddard sorry for late !!
15:07:33 <mgoddard> oh hi suryasingh :) welcome back
15:07:39 <jovial[m]> thanks for all the hard work everybody :)
15:07:50 <mgoddard> +1
15:07:51 <yoctozepto> welcome back, suryasingh!
15:08:08 <mgoddard> now we continue with Victoria development
15:08:18 <mgoddard> #topic Review action items from last meeting
15:08:23 <suryasingh> @mgoddard  @yoctozepto  +1
15:08:44 <mgoddard> there were none
15:08:50 <mgoddard> #topic CI status
15:10:34 <mgoddard> whiteboard says kolla master and ussuri are broken, but I think this is wrong
15:10:40 <mgoddard> I hope so since we just released :)
15:11:35 <mgoddard> mnasiadka: that kolla clustercheck issue resolved itself?
15:11:50 <mnasiadka> mgoddard: yes, Fedora git started working and it resolved itself
15:11:55 <mgoddard> ok
15:12:02 <mnasiadka> but a change with a curl macro is underway
15:12:10 <mnasiadka> just needs some more love
15:12:52 <mgoddard> how about stein?
15:13:11 <mgoddard> still having the tox/virtualenv issue?
15:13:23 <yoctozepto> yup
15:13:51 <mnasiadka> right, I haven't backported the changes
15:14:04 <mnasiadka> did somebody do it, or should I?
15:14:14 <mgoddard> I don't see them
15:14:17 <mgoddard> can you?
15:14:43 <yoctozepto> mnasiadka: if you can, please do
15:14:48 <yoctozepto> they are likely unclean though
15:14:55 <mnasiadka> yeah, they will need some work
15:15:02 <mnasiadka> but it shouldn't be much, will do it after the meeting
15:15:07 <mgoddard> #action mnasiadka backport stein CI fixes
15:15:08 <mgoddard> thanks
15:15:15 <yoctozepto> +1
15:16:01 <mgoddard> kolla-ansible happy
15:16:47 <mgoddard> kayobe is ok back to stein
15:16:56 <mgoddard> rocky we had to make some jobs non-voting, queens is bust
15:17:22 <mgoddard> #topic Victoria release planning (kayobe)
15:18:00 <mgoddard> Victoria...
15:18:14 <jovial[m]> What's in the pipeline?
15:18:18 <mgoddard> I think we can call time on https://etherpad.opendev.org/p/kolla-victoria-priorities
15:18:45 <mgoddard> I will spend a few minutes doing the sums
15:19:16 <openstackgerrit> Michal Nasiadka proposed openstack/kolla-ansible stable/stein: Run tox in venv in case of building images  https://review.opendev.org/737829
15:22:50 <mgoddard> ok, some big winners:
15:22:54 <mgoddard> infra images - 7
15:23:12 <mgoddard> octavia - 9
15:23:18 <mgoddard> designate - 7
15:23:30 <mgoddard> letsencrypt - 10
15:23:38 <mgoddard> docs refresh - 8
15:23:46 <mgoddard> federated keystone - 7
15:24:07 <mgoddard> health checks - 7
15:24:17 <mgoddard> kayobe docs - 7
15:24:37 <mgoddard> 4 of those involve improvements to docs. Take note :)
15:25:07 <mgoddard> any comments?
15:25:18 <mgoddard> anyone want to put their name on one?
15:25:36 <headphoneJames> I'll take letsencrypt :)
15:25:52 <mgoddard> headphoneJames: cool
15:26:00 <mgoddard> Mr TLS
15:26:41 <mgoddard> anyone else?
15:27:29 <openstackgerrit> Michal Nasiadka proposed openstack/kolla stable/stein: CI: Install python deps, fix mod_wsgi in cyborg-api, disable masakari-monitors  https://review.opendev.org/737831
15:27:34 <mnasiadka> mgoddard: I guess my name is superglued to healthchecks
15:27:42 <mgoddard> right
15:28:50 <openstackgerrit> Mark Goddard proposed openstack/kolla-ansible stable/train: barbican: Use python3 plugin in uwsgi config  https://review.opendev.org/733805
15:29:06 <mgoddard> Anything else to say about ussuri?
15:29:10 <mgoddard> sorry, victoira
15:29:35 <yoctozepto> I can put my name on designate if no better candidates exist
15:30:08 <mgoddard> cool
15:30:22 <yoctozepto> the general docs topic is great but I don't think it's one-man's job unfortunately
15:30:22 <suryasingh> i added my to few of the priority items :)
15:30:39 <openstackgerrit> Bharat Kunwar proposed openstack/kolla-ansible master: Use internalURL endpoint_type for all clients used by Magnum  https://review.opendev.org/737834
15:30:47 <yoctozepto> I can cooperate with someone on any docs, grammar fiend soul here
15:31:01 <suryasingh> yoctozepto: +1
15:31:20 <mgoddard> it doesn't have to be one person per item
15:31:55 <mnasiadka> I think about docs - it would be good to have a list of things to work on
15:32:02 <yoctozepto> ok, then mention my name
15:32:24 <yoctozepto> I guess we can mix the docs and scenarios planning as well
15:32:33 <yoctozepto> they kinda have to match anyhow
15:32:57 <mgoddard> I was thinking the docs item could start with a review of our docs
15:33:01 <mgoddard> then go from there
15:33:10 <yoctozepto> while we are on that
15:33:22 <yoctozepto> could we set up kolla dev calls for that?
15:33:31 <yoctozepto> one hour every two weeks, apart from kolla klub?
15:33:50 <yoctozepto> might be more effective than just irc meetings
15:33:58 <yoctozepto> or we could mix that in kolla klub
15:34:02 <mgoddard> for housekeeping?
15:34:11 <yoctozepto> for the reviews and planning
15:34:19 <yoctozepto> and housekeeping when done with planning
15:34:28 <yoctozepto> planning > housekeeping
15:35:09 <yoctozepto> Kolla Kalls
15:35:22 <suryasingh> Agree with yoctozepto +1 Kolla calls
15:35:33 <yoctozepto> Kalls* :D
15:35:54 <suryasingh> :) nice name
15:37:21 <mgoddard> do you want to handle setting this up yoctozepto?
15:37:39 <openstackgerrit> Michal Nasiadka proposed openstack/kolla-ansible master: Change neutron-ovs-agent deploy only with manila generic backend  https://review.opendev.org/737768
15:37:43 <mgoddard> propose the same slot as kolla klub, on alternate weeks?
15:37:59 <yoctozepto> mgoddard: sounds sane
15:38:13 <yoctozepto> mgoddard: what does "setting this up" involve?
15:38:23 <yoctozepto> mgoddard: I can post to ml about it
15:38:25 <mgoddard> good q
15:38:34 <yoctozepto> and set some agenda
15:38:51 <yoctozepto> we can reuse wiki for that obviously
15:38:53 <mgoddard> email the list to begin with
15:39:32 <mgoddard> reuse wiki? same page or different?
15:39:46 <yoctozepto> can go either way
15:39:52 <yoctozepto> pages are free to create
15:39:58 <yoctozepto> thankfully!
15:40:55 <mgoddard> separate is probably better
15:41:04 <yoctozepto> ++
15:41:10 <mgoddard> #action yoctozepto to email list about kolla dev kalls
15:41:13 <suryasingh> sorry guys this may be lame....does Kolla club same as  Kolla weekly meeting or something else :(
15:41:24 <yoctozepto> suryasingh: separate event
15:41:41 <yoctozepto> suryasingh: we meet with operators all around the world every 2nd Thursday via a video call
15:41:47 <yoctozepto> https://docs.google.com/document/d/1EwQs2GXF-EvJZamEx9vQAOSDB5tCjsDCJyHQN5_4_Sw/edit?pli=1
15:42:08 <suryasingh> wow great yoctozepto +2
15:42:29 <yoctozepto> and I proposed to fill the other weeks' Thursdays with Kolla Kalls
15:42:43 <yoctozepto> the time seems safe for most
15:42:50 <yoctozepto> kolla klub is operator-oriented
15:43:10 <yoctozepto> we might want to use kolla klub as kolla kalls food for thought generator
15:43:36 <yoctozepto> our weekly irc meetings have this standard structure where we discuss general and current thingies
15:44:00 <mgoddard> open to improvements on the structure
15:44:18 <mgoddard> it works quite well around release time, but could be improved
15:44:33 <yoctozepto> I don't think we can squeeze more efficiency from irc talks
15:45:16 <yoctozepto> or, to rephrase, I have no idea how to approach that
15:45:27 <yoctozepto> happy to discuss either
15:45:53 <yoctozepto> seems we are discussing a lot on kayobe section atm
15:45:55 <yoctozepto> ;d
15:46:04 <yoctozepto> mgoddard topic switch?
15:46:18 <mgoddard> #topic Victoria release planning (kolla & kolla ansible)
15:46:27 <mgoddard> I think we covered everything in the last one
15:46:31 <yoctozepto> indeed
15:46:35 <mgoddard> unless people have other things
15:46:47 <mgoddard> #topic Kolla klub
15:46:54 <mgoddard> https://docs.google.com/document/d/1EwQs2GXF-EvJZamEx9vQAOSDB5tCjsDCJyHQN5_4_Sw/edit#heading=h.u784zrqsv2k1
15:47:15 <mgoddard> next week we have:
15:47:16 <mgoddard> Gaƫl: Offline usage of Kolla & Kolla Ansible
15:47:18 <mgoddard> Justinas: host OS lifecycle management
15:47:25 <mgoddard> other topics welcome
15:47:45 <mgoddard> #topic open discussion
15:48:02 <yoctozepto> we might want to add the priorities summary and review discussion to that
15:49:04 <mgoddard> good idea
15:49:27 <yoctozepto> mgoddard: ack, was testing comments
15:50:45 <yoctozepto> mnasiadka: any thoughts?
15:51:34 <yoctozepto> I recently played with masakari quite a bit
15:51:46 <mgoddard> how is it?
15:52:03 <mnasiadka> thoughts? about what?
15:52:19 <yoctozepto> mnasiadka: about Victoria, life, anything
15:52:21 <suryasingh> i know it was developed by one of my friend
15:52:27 <suryasingh> what to know yoctozepto
15:52:28 * suryasingh ?
15:52:51 <yoctozepto> mgoddard: looks decent, played outside of kolla because of pacemaker
15:53:18 <yoctozepto> I might be able to pick up Gaetan's work
15:53:19 <mnasiadka> yoctozepto: no thoughts at all, priorities are one thing, life dictates another ones dynamically :)
15:53:34 <yoctozepto> mnasiadka: oh my ;d
15:53:43 <mnasiadka> so not really a fan of planning :)
15:53:51 <yoctozepto> mnasiadka: covid isolation => baby boom?
15:54:10 <mnasiadka> yoctozepto: naah, just laughing - one kid is enough :)
15:54:10 <yoctozepto> suryasingh: could be, so far no questions from me
15:54:29 <suryasingh> yoctozepto: noted +1
15:54:36 <openstackgerrit> Michal Nasiadka proposed openstack/kolla-ansible stable/stein: Run tox in venv in case of building images  https://review.opendev.org/737829
15:55:46 <yoctozepto> the major parts missing in kolla rely on pacemaker; this work has not been finished
15:55:53 <yoctozepto> in kolla-ansible
15:56:04 <mnasiadka> pacemaker in a container, ugh
15:56:05 <yoctozepto> we have some images in kolla already
15:56:13 <yoctozepto> yeah, feels wrong
15:56:13 <mgoddard> yoctozepto: do you know if the missing package is a blocker?
15:56:32 <yoctozepto> mgoddard: I know it's not, unless Gaetan planned to use it for bootstrap
15:56:37 <yoctozepto> but we can safely drop it
15:56:48 <yoctozepto> as well as the whole image with it
15:57:04 <mgoddard> ok
15:57:19 <mgoddard> if pacemaker in containers is wrong, we don't have to do it that way
15:57:38 <yoctozepto> just sounds like an overkill, but could be nice to try
15:57:53 <yoctozepto> but hey, you could argue the same with mariadb and lots of others
15:58:17 <mgoddard> quite
15:59:22 <yoctozepto> are you running HA on instances in other ways or no such need so far?
15:59:55 <mnasiadka> I think one could argue you don't need such functionality in a cloud :)
15:59:55 <mgoddard> typically it's done at a higher layer
16:00:05 <mgoddard> cattle etc
16:00:34 <mgoddard> but not everyone agrees
16:01:00 <mgoddard> ok, we're at the end of the meeting
16:01:02 <mgoddard> Thanks everyone
16:01:04 <mgoddard> #endmeeting