15:00:36 <yoctozepto> #startmeeting kolla
15:00:36 <openstack> Meeting started Wed Jul 29 15:00:36 2020 UTC and is due to finish in 60 minutes.  The chair is yoctozepto. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:39 <openstack> The meeting name has been set to 'kolla'
15:00:49 <mgoddard> patience yoctozepto :)
15:00:54 <mgoddard> o/
15:00:58 <yoctozepto> #topic rollcall
15:01:03 <yoctozepto> #chair mgoddard
15:01:03 <mgoddard> \o
15:01:04 <openstack> Current chairs: mgoddard yoctozepto
15:01:14 <yoctozepto> mgoddard mnasiadka hrw egonzalez yoctozepto rafaelweingartne cosmicsound osmanlicilegi bbezak - meeting live
15:01:15 <headphoneJames> o/
15:01:32 <dougsz> [o
15:01:39 <mgoddard> is the cuckoo pushing me out of the nest? :p
15:01:44 <hrw> \o
15:02:33 <yoctozepto> mgoddard: the nest is yours
15:02:45 <mgoddard> #topic Agenda
15:02:51 <mgoddard> * Roll-call
15:02:54 <mgoddard> * Announcements
15:02:55 <mgoddard> ** Kayobe & Kolla @ London Open infra virtual meetup tomorrow https://www.meetup.com/OpenInfra-London/events/272083028/
15:02:58 <mgoddard> * Review action items from last meeting
15:03:00 <mgoddard> * CI status
15:03:02 <mgoddard> * Victoria release planning (kayobe)
15:03:04 <mgoddard> * Victoria release planning (kolla & kolla ansible)
15:03:05 <mgoddard> * Kolla klub and kall
15:03:07 <mgoddard> #topic Announcements
15:03:10 <mgoddard> #info Kayobe & Kolla @ London Open infra virtual meetup tomorrow
15:03:14 <mgoddard> #link https://www.meetup.com/OpenInfra-London/events/272083028/
15:03:26 <mgoddard> Open to anyone to join
15:03:56 <mgoddard> The other two topics look great
15:04:07 <mgoddard> Anyone else have anything?
15:04:30 <yoctozepto> not me
15:04:47 <mgoddard> #topic Review action items from last meeting
15:04:48 <hrw> added to calendar
15:04:51 <mgoddard> There were none
15:04:55 <mgoddard> #topic CI status
15:05:21 <mgoddard> the stein issue has been fixed, thanks mnasiadka
15:06:14 <mgoddard> any new CI issues I haven't seen yet?
15:06:43 <yoctozepto> did not have much time to look at ci this week
15:07:31 <mgoddard> #topic Victoria release planning (kayobe)
15:07:45 <mgoddard> I think priteau is busy
15:08:04 <mgoddard> mnasiadka, dougsz, jovial[m]
15:08:51 <mgoddard> How is kayobe looking?
15:08:53 <mnasiadka> I’m also busy - but can respond to queries
15:08:59 <dougsz> Nothing from me on this
15:09:05 <mgoddard> https://tiny.cc/kayobe-review-dashboard2
15:09:26 <yoctozepto> mnasiadka: congrats on the core nomination :-)
15:09:50 <mgoddard> lots of nice backports with a single +2. Let's get them over the line this week
15:10:04 <mnasiadka> yoctozepto: thanks ;)
15:10:45 <mgoddard> if everyone wants to add RP+1 to a patch, that might encourage some reviews
15:11:45 <jovial[m]> should have some time on friday for reviews
15:12:38 <mgoddard> great
15:12:47 <mgoddard> #topic Victoria release planning (kolla & kolla ansible)
15:13:06 <mgoddard> Does anyone have a feature/work item they'd like to discuss?
15:13:36 <hrw> focal needs work
15:13:43 <hrw> infra too
15:14:31 <yoctozepto> I want focal for hacluster :-)
15:14:48 <hrw> CI said 'yes' on k-a change for focal and needs reviews
15:15:17 <yoctozepto> hacluster needs some cleanup and little discussion but I opt for doing that async from meeting unless you have immediate questions on it
15:15:32 <mgoddard> sorry, got disconnected
15:15:32 <yoctozepto> hrw: nice
15:15:35 <hrw> and order of kolla/kolla-ansible patches may need to be changed (now k-a depends on kolla patches)
15:15:51 <hrw> infra needs reviews
15:15:57 * hrw done
15:16:02 <yoctozepto> hrw: one patch for each or multiple (as you use plural)?
15:16:30 <yoctozepto> I haven't had much time to look at the queue, spared free cycles on hacluster
15:16:56 <mgoddard> hrw: hopefully it's not a cyclical dependency?
15:16:59 <hrw> yoctozepto: whole set of infra patches (2 for k, 1 for k-a)
15:17:13 <hrw> mgoddard: imho k-a can be done without k part
15:17:23 <mgoddard> hrw: ok
15:17:40 <mgoddard> I guess we should be able to add support for focal without immediately dropping bionic
15:17:43 <hrw> mgoddard: it is mostly move to focal on CI and some 'we want focal not bionic'
15:17:51 <yoctozepto> I can see this
15:17:52 <yoctozepto> https://review.opendev.org/738994
15:17:52 <patchbot> patch 738994 - kolla - ubuntu: move to 20.04 Focal - 13 patch sets
15:17:53 <yoctozepto> and this
15:17:58 <yoctozepto> https://review.opendev.org/#/c/743502/4
15:17:58 <patchbot> patch 743502 - kolla-ansible - ubuntu: move to 20.04 Focal - 4 patch sets
15:18:08 <hrw> and bionic is marked as supported still so upgrade job works
15:18:14 <yoctozepto> splendid
15:18:24 <hrw> yoctozepto: 502 is simple, 994 is not complicated too
15:18:47 <yoctozepto> hrw: I can't see the 2nd for kolla
15:18:49 <yoctozepto> where is it?
15:18:59 <hrw> yoctozepto: 2 for infra, 1 for focal
15:19:04 <yoctozepto> ah, ok
15:19:20 <mgoddard> do we need to consider migrating from bionic to focal?
15:19:45 <mgoddard> or rather, does kolla-ansible need to support both
15:20:22 <mgoddard> or do we assume that the OS upgrade happens between ussuri deploy and victoria upgrade?
15:20:27 <hrw> mgoddard: for v we may support both in k-a and in whiskey go for focal only
15:20:49 <hrw> so users will have a time for switch (like train did for centos)
15:20:49 <mgoddard> wallaby :) whiskey also a good name
15:20:53 <yoctozepto> I would opt for supporting both
15:21:02 <yoctozepto> whiskey lost due to alcoholism :-)
15:21:12 <mgoddard> lame
15:21:15 <hrw> mgoddard: who would remember release names... we are on vicky now, right?
15:21:25 <mgoddard> apparently
15:21:27 <yoctozepto> ubuntu plays much nicer with us than centos did
15:21:52 <hrw> yoctozepto: it is easier to migrate 2y os than 5y one
15:22:07 <yoctozepto> mostly because of 3.6->3.8 rather than 2.7->3.6 :D
15:22:08 <hrw> #continue
15:22:20 <mgoddard> so should we be running CI jobs for xenial and bionic in victoria?
15:22:21 <yoctozepto> hrw: yup, that part of ubuntu is nice
15:22:31 <yoctozepto> mgoddard: bionic and focal, yes
15:22:38 <yoctozepto> I would vote for that case
15:22:55 <yoctozepto> at least for the primary jobs
15:23:10 <mgoddard> it's not strictly necessary, if we require the OS to be upgraded
15:23:11 <yoctozepto> hacluster (so masakari with it) will require focal
15:23:19 <mgoddard> for a rolling reinstall we need to support both
15:23:24 <yoctozepto> true that
15:23:36 <hrw> mgoddard: we should abandon/drop xenial now
15:23:37 <yoctozepto> anyhow, it's easier to upgrade than centos was
15:23:44 <yoctozepto> that xenial made me smile :-)
15:23:46 <mgoddard> xenial definitely
15:23:50 <hrw> mgoddard: time for xenial->bionic was 2y ago
15:24:17 <hrw> mgoddard: we should move to focal on CI and have bionic in upgrade job
15:24:21 <mgoddard> I suppose we will at least need bionic for upgrades
15:24:41 <hrw> to show users "we want you to go focal in V but support bionic if you upgrade"
15:24:41 <yoctozepto> could use running bionic containers on focal hosts
15:24:43 <mgoddard> if we are not doing host OS uprade in CI
15:24:49 <hrw> with message that bionic is gone in W
15:24:57 <mgoddard> ussuri doesn't work on focal
15:25:03 <mgoddard> due to host OS precheck
15:25:08 <hrw> mgoddard: that's why upgrade CI job is on bionic
15:25:08 <mgoddard> (at least)
15:25:12 <yoctozepto> we can change that
15:25:14 <yoctozepto> if it works
15:25:15 <yoctozepto> ;p
15:25:16 <mgoddard> could
15:25:25 <hrw> we should not
15:25:34 <hrw> bionic->focal upgrade time is on V
15:25:54 <yoctozepto> yeah, but the question is whether this is u->os->v or u->v->os
15:26:10 <yoctozepto> well, that was lame nomenclature
15:26:14 <yoctozepto> but you get the point
15:26:34 <hrw> yoctozepto: it is u->v. with u/bionic -> v/bionic or u/bionic -> v/focal
15:26:37 <yoctozepto> os upgrade can happen before or after openstack upgrade
15:26:42 <hrw> while we do not handle OS upgrade
15:27:14 <yoctozepto> still the question is whether bionic containers work better on focal or focal ones on bionic
15:27:16 <hrw> and u/bionic -> v/bionic -> (v/focal) -> w/focal
15:27:17 <yoctozepto> :D
15:27:38 <hrw> that's my opinion but I do not deploy ubuntu ;d
15:27:48 <yoctozepto> deprecate
15:27:49 <yoctozepto> :D
15:27:50 <mgoddard> red hat page suggested host >= container is best due to kernel
15:28:20 <mgoddard> which implies upgrade to focal first, then deploy V
15:28:21 <yoctozepto> yeah, they did
15:28:30 <yoctozepto> so bionic containers on focal then
15:28:52 <yoctozepto> switch to focal and ignore precheck for upgrade jobs
15:29:04 <yoctozepto> in the pre-upgrade deploy task
15:29:14 <mgoddard> but to test that we'd need to support focal in ussuri
15:29:26 <mgoddard> so we wouldn't really be testing what we advocate
15:29:45 <mgoddard> I wonder how nasty a host OS upgrade in CI would be
15:29:51 <mgoddard> maybe it's possibel
15:30:21 <yoctozepto> infra folks will hunt us down
15:30:46 <mgoddard> is it worse than containers?
15:30:55 <mgoddard> probably
15:31:06 <yoctozepto> more cumbersome at least
15:31:09 <hrw> I would -1 OS upgrade patch
15:31:29 <yoctozepto> could use asking someone actually doing ubuntu...
15:31:31 <hrw> and -2 on second try
15:31:35 <yoctozepto> like osmanlicilegi
15:32:02 <yoctozepto> how they approach this for them
15:32:26 <yoctozepto> centos folks discussing ubuntu feels wrong ;d
15:32:34 <yoctozepto> and hrw just replaces everything :D
15:33:33 <mgoddard> it seems like the change required to support focal is minimal, so maybe it doesn't matter too much either way
15:34:29 <mgoddard> one thing is for sure - you can't follow the centos8 model
15:34:48 <yoctozepto> we don't want to ;d
15:34:49 <mgoddard> as we won't provide focal and bionic containers for any single release
15:35:40 <mgoddard> maybe the mailing list is the place for this?
15:35:47 <mgoddard> anyone want to send something out?
15:35:59 <yoctozepto> mgoddard wants to, we know it ;d
15:36:01 <mgoddard> lay out the options, see what people think
15:36:58 <mgoddard> #action mgoddard to message openstack-discuss about focal & victoria upgrade
15:37:18 <mgoddard> hrw: while you're in the hot seat
15:37:20 <mgoddard> infra images
15:37:24 <mgoddard> what's the status?
15:37:31 <mgoddard> are we blocked by tripleo?
15:37:34 <hrw> need review
15:37:47 <hrw> tripleo does not block us from reviewing and testing
15:38:00 <mgoddard> can we merge the feature in a disabled default state to avoid breaking them?
15:38:18 <hrw> we are free to ignore tripleo until merge
15:38:27 <mgoddard> yes, but it would be good to merge
15:38:37 <mgoddard> it's a big thing to leave until late in the cycle
15:38:38 <hrw> mgoddard: do review, suggest 'merge disabled'
15:38:56 <hrw> as I already forgot that you asked for such feature
15:39:34 <mgoddard> I'm just trying to find a patch to merging
15:39:48 <mgoddard> do you have no persistent memory outside of gerrit?
15:40:01 <mgoddard> I thought you had some huge NAS? :)
15:40:03 <hrw> mgoddard: too easy to forget
15:40:53 <yoctozepto> mgoddard: but it's probably not replicated well enough
15:41:43 <mgoddard> other features?
15:41:49 <mgoddard> headphoneJames: how is TLS?
15:42:04 <openstackgerrit> Marcin Juszkiewicz proposed openstack/kolla-ansible master: CI: drop not used Xenial nodeset definitions  https://review.opendev.org/743788
15:42:24 <headphoneJames> is it great!
15:42:45 <yoctozepto> is it now?
15:43:05 <yoctozepto> the next greatest thing after k-a that is
15:43:22 <headphoneJames> so far it is very secure
15:43:33 <yoctozepto> nobody can use it :-)
15:43:44 <mgoddard> headphoneJames: what are you focussing on at the moment?
15:43:58 <headphoneJames> ironic
15:44:08 <mgoddard> and what about nova backend? is it fixed with the timeout?
15:44:17 <headphoneJames> the service, not the adjective
15:44:34 <headphoneJames> nova seems clean, though now needs a rebase
15:45:05 <headphoneJames> but it passed %100, couldn't find any RemoteDisconnect
15:45:15 <mgoddard> I guess we should match the timeout to the haproxy timeout?
15:45:48 <headphoneJames> sensible
15:46:38 <mgoddard> https://etherpad.opendev.org/p/tls_tasks
15:47:06 <mgoddard> move installation of httpd etc. to openstack-base image
15:47:11 <mgoddard> that would be a nice easy win
15:47:41 <headphoneJames> ok, will do that next
15:47:55 <mgoddard> do you have an idea what you're aiming for this cycle?
15:48:37 <headphoneJames> finish supporting all core API services
15:48:50 <headphoneJames> then letsencrypt support
15:49:19 <mgoddard> diurnalist pushed letsencrypt patches
15:49:40 <mgoddard> https://review.opendev.org/741339
15:49:40 <patchbot> patch 741339 - kolla - Add LetsEncrypt images for cert request/renewal - 2 patch sets
15:49:49 <mgoddard> https://review.opendev.org/741340
15:49:50 <patchbot> patch 741340 - kolla-ansible - Add support for LetsEncrypt-managed certs - 1 patch set
15:49:54 <mgoddard> I haven't looked at them yet
15:50:01 <mgoddard> would be good if you could
15:50:19 <headphoneJames> oh nice
15:50:25 <headphoneJames> will take a look
15:50:53 <mgoddard> cool
15:50:57 <headphoneJames> added myself to review
15:51:46 <mgoddard> I feel like this one is underrated: https://blueprints.launchpad.net/kolla-ansible/+spec/mariadb-ssl-support
15:51:53 <mgoddard> and https://blueprints.launchpad.net/kolla-ansible/+spec/memcached-ssl-support
15:53:22 <mgoddard> let's move on
15:53:32 <mgoddard> #topic  Kolla klub and kall
15:53:36 <mgoddard> Klub tomorrow
15:53:52 <mgoddard> https://docs.google.com/document/d/1EwQs2GXF-EvJZamEx9vQAOSDB5tCjsDCJyHQN5_4_Sw/edit#
15:54:25 <mgoddard> If anyone has any downstream patches they think might be generally useful, please share
15:54:39 <mgoddard> (you don't need to bring the patch, just discuss it)
15:55:31 <mgoddard> #topic Open discussion
15:55:36 <mgoddard> Anyone have anything?
15:57:02 <hrw> I may be less active as I change assignment at Linaro a bit
15:57:16 <hrw> to not cloud stuff
15:58:04 <mgoddard> what are you moving to?
15:58:24 <hrw> server architecture. qemu, firmware etc
15:58:33 <yoctozepto> nice
15:58:56 <mgoddard> sounds interesting. Hopefully still some time for kolla
16:00:32 <mgoddard> times up
16:00:36 <mgoddard> thanks everyone
16:00:37 <mgoddard> #endmeeting