15:00:15 <mgoddard> #startmeeting kolla
15:00:15 <openstack> Meeting started Wed Aug 26 15:00:15 2020 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <openstack> The meeting name has been set to 'kolla'
15:00:28 <mgoddard> #topic rollcall
15:00:33 <mgoddard> \o
15:00:36 <Wasaac> o/
15:03:19 <JamesBenson> \o
15:03:23 <jovial[m]> 0/
15:03:28 <mgoddard> mgoddard mnasiadka hrw egonzalez yoctozepto rafaelweingartne cosmicsound osmanlicilegi bbezak
15:03:29 <dougsz> \o
15:03:35 <mnasiadka> o/
15:03:39 <bbezak> o/
15:03:54 <yoctozepto> o/
15:05:17 <mgoddard> #topic agenda
15:05:25 <mgoddard> * Roll-call
15:05:26 <mgoddard> * Announcements
15:05:28 <mgoddard> ** Kolla feature freeze fast approaching: Sep 28 - Oct 02
15:05:30 <mgoddard> * Review action items from the last meeting
15:05:32 <mgoddard> * CI status
15:05:34 <mgoddard> * Mundane priorities: need to enact kolla-cli deprecation
15:05:36 <mgoddard> ** https://review.opendev.org/730431 -> https://docs.openstack.org/project-team-guide/repository.html#deprecating-a-repository
15:05:36 <patchbot> patch 730431 - project-config - Retire kolla-cli project - step 1 end project gating - 2 patch sets
15:05:38 <mgoddard> * Victoria release planning (kayobe)
15:05:40 <mgoddard> * Victoria release planning (kolla ansible)
15:05:42 <mgoddard> * Victoria release planning (kolla)
15:05:44 <mgoddard> #topic announcements
15:06:17 <mgoddard> Kolla feature freeze fast approaching: Sep 28 - Oct 02
15:06:21 <mgoddard> #info https://review.opendev.org/#/c/728448/
15:06:22 <patchbot> patch 728448 - kolla-ansible - Support TLS encryption of RabbitMQ client-server t... - 8 patch sets
15:06:26 <mgoddard> #undo
15:06:27 <openstack> Removing item from minutes: #info https://review.opendev.org/#/c/728448/
15:06:31 <mgoddard> #info Kolla feature freeze fast approaching: Sep 28 - Oct 02
15:07:01 <mgoddard> Any others?
15:08:06 <mgoddard> #topic Review action items from the last meeting
15:08:20 <mgoddard> mgoddard to message openstack-discuss about focal & victoria upgrade
15:08:25 <mgoddard> This is getting silly now
15:08:28 <mgoddard> #action mgoddard to message openstack-discuss about focal & victoria upgrade
15:08:49 <mgoddard> #topic CI status
15:09:48 <mgoddard> ok, how are we looking?
15:10:02 <mgoddard> kolla train & earlier not happy
15:10:13 <mgoddard> I did start looking at the bifrost issue but didn't finish
15:10:55 <mgoddard> the ironic conductor issue looks similar
15:11:38 <mgoddard> #action mgoddard to investigate bifrost CI issue on train
15:11:52 <mgoddard> I have a feeling the ironic issue is a similar root cause
15:11:57 <mgoddard> possibly ansible related
15:12:07 <mgoddard> kolla ansible looks green
15:12:30 <mgoddard> kayobe is better now
15:13:57 <mgoddard> #topic Mundane priorities: need to enact kolla-cli deprecation
15:14:05 <mgoddard> yoctozepto: this sounds like one of yours
15:14:37 <yoctozepto> yes
15:14:40 <yoctozepto> https://review.opendev.org/730431 -> https://docs.openstack.org/project-team-guide/repository.html#deprecating-a-repository
15:14:41 <patchbot> patch 730431 - project-config - Retire kolla-cli project - step 1 end project gating - 2 patch sets
15:14:57 <mgoddard> so we need to announce to the mailing list?
15:14:58 <yoctozepto> we should follow the deprecation procedure and drop kolla-cli master branch
15:15:06 <yoctozepto> we already have a deprecation notice
15:15:17 <yoctozepto> need to move with patchsets
15:16:20 <mgoddard> ok. who wants to do this?
15:18:15 <mgoddard> #action mgoddard to continue kolla-cli deprecation
15:19:35 <wuchunyang> retire kolla-cli ?
15:20:04 <mgoddard> yes
15:20:08 <mgoddard> well deprecate first
15:20:17 <wuchunyang> maybe i can help
15:21:56 <mgoddard> ok, thanks
15:22:25 <mgoddard> #topic Victoria release planning (kayobe)
15:22:43 <mgoddard> jovial[m] dougsz mnasiadka bbezak  Wasaac
15:23:07 <mgoddard> I went through the V features on the whiteboard
15:23:09 <mgoddard> #link https://etherpad.opendev.org/p/KollaWhiteBoard
15:23:17 <mgoddard> L355
15:23:32 <dougsz> thx
15:23:40 <mgoddard> let's say kayobe has not made much progress on its priorities this cycle :)
15:24:00 <mgoddard> we have 1 month until feature freeze
15:24:12 <dougsz> yeah, other time pressures unfortunately
15:24:15 <jovial[m]> luckily ussuri was a great release ;-)
15:24:25 <mgoddard> indeed, ussuri was good
15:24:54 <mgoddard> I think we should definitely do the documented config walk though
15:25:06 <Wasaac> +1
15:25:27 <dougsz> Others like bikolla are pushing it
15:25:28 <mgoddard> multiple environments would be nice, if priteau (or anyone) gets time
15:25:43 <mgoddard> but I think docs are a must
15:25:49 <mgoddard> so plan of action
15:26:19 <mgoddard> I think we should get a few heads together to work out how best to do it
15:26:50 <mgoddard> perhaps in the kolla klub meeting slot tomorrow (15:00 UTC)
15:26:59 <mgoddard> who is interested?
15:27:12 <Wasaac> Happy to help
15:27:30 <dougsz> I have a meeting clash tomorrow
15:27:35 <mnasiadka> I'll try to join Kolla Klub for the first time :)
15:27:36 <mgoddard> I think bbezak expressed an interest
15:27:51 <mgoddard> mnasiadka: no actual kolla klub this time
15:27:59 <mnasiadka> mgoddard: damn
15:28:00 <mgoddard> summer break
15:28:17 <mnasiadka> mgoddard: but yes, Bartosz expressed interest, so I think he'll be tehre
15:28:20 <mnasiadka> *there
15:28:22 <mgoddard> ok
15:28:32 <mgoddard> dougsz: are you keen to join? If so I can send out a doodle
15:28:54 <bbezak> Sure
15:29:00 <mgoddard> I guess priteau is busy with dougsz tomrrow
15:29:18 <mgoddard> not that I wanted this to become a committee meeting :)
15:29:41 <mgoddard> but it would be good to agree on a direction before setting off
15:30:12 <mgoddard> I'll send a doodle to the mailing list
15:30:16 <dougsz> I have quite a large existing backlog so I can't commit to much apart from reviewing - feel free to host the meeting tomorrow
15:30:33 <mgoddard> ok
15:31:41 <mgoddard> we have some open reviews, if anyone has time: https://review.opendev.org/#/q/project:openstack/kayobe+status:open
15:32:12 <mgoddard> any other kayobe things?
15:33:15 <dougsz> nothing from me
15:33:39 <mgoddard> #topic Victoria release planning (kolla ansible)
15:33:41 <mgoddard> ok
15:34:11 <mgoddard> again, I have added my best guess at status updates to the whiteboard for our V prioritie
15:34:18 <mgoddard> feel free to update them
15:34:52 <mgoddard> https://etherpad.opendev.org/p/KollaWhiteBoard
15:34:54 <mgoddard> L250
15:35:02 <mgoddard> let's go through
15:35:07 <mgoddard> lets encrypt
15:35:20 <mgoddard> needs some reviews
15:35:34 <mgoddard> I did a quick skim earlier but not enough
15:36:05 <mgoddard> seems like there is a bit of a bootstrapping question about how to initially deploy haproxy
15:36:59 <headphoneJames> also, where should cert bot run? anisble controller or openstack deploy
15:37:13 <mgoddard> next to haproxy?
15:37:29 <mgoddard> ansible controller should be assumed to be ephermal
15:37:37 <mgoddard> ephemeral
15:37:42 <headphoneJames> can cert bot retrieve the same certificate across many nodes?
15:38:23 <mgoddard> could you expand?
15:40:32 <headphoneJames> how we do get the initial certificate and distribute to all the nodes? Once we want to refresh an expired certificate, how does happen across all the nodes at the same time?
15:40:51 <headphoneJames> or maybe I don't understand the problem correctly
15:42:19 <mgoddard> these are good questions
15:42:27 <mgoddard> to which I don't know the answer right now
15:42:59 <headphoneJames> would it be worth have a separate meeting about this?
15:43:01 <mgoddard> you could look at how OSA does it
15:43:03 <mgoddard> https://docs.openstack.org/openstack-ansible/latest/user/security/ssl-certificates.html#letsencrypt-certificates
15:43:25 <mgoddard> https://github.com/openstack/openstack-ansible-haproxy_server
15:44:17 <mgoddard> we could have a meeting. I think the main obstacle is that I don't know enough about it to be too helpful
15:46:19 <mgoddard> I will try to spend some time brushing up on it
15:46:25 <mgoddard> perhaps others are more familiar
15:46:32 <mgoddard> have you spoken to diurnalist about it?
15:46:44 <mgoddard> headphoneJames:
15:48:02 <mgoddard> ok, I think we need to move on
15:48:10 <mgoddard> wuchunyang: around?
15:48:17 <wuchunyang> ?
15:48:21 <mgoddard> hi
15:48:40 <mgoddard> looks like good progress with octavia, and you had some good feedback from johnsom
15:48:42 <wuchunyang> :-)
15:48:58 <mgoddard> I will put it in my browser tab queue
15:49:22 <wuchunyang> i don't get some new feedback now
15:49:58 <mgoddard> at this point in the release, I think we need to focus on features that already have good progress, and octavia is a good example
15:50:10 <johnsom> Let me know if there are patches you would like me to look at. I did an initial pass, but haven't kept up with updates.
15:50:44 <mgoddard> thanks johnsom o
15:50:55 <mgoddard> looks like no progress on designate
15:51:16 <mgoddard> federated keystone has made good progress, let's try to land it
15:51:17 <wuchunyang> johnsom i have updated ps follow up  your comments thanks
15:51:23 <mgoddard> https://review.opendev.org/695432
15:51:24 <patchbot> patch 695432 - kolla-ansible - Add support to OpenID Connect Authentication flow - 31 patch sets
15:51:48 <mgoddard> container health checks needs an update
15:52:14 <mgoddard> Ansible handlers bug is blocked on whether ansible accepts the fix
15:52:33 <mgoddard> Lots of patches up for performance & scalability.
15:52:40 <mgoddard> #link https://review.opendev.org/#/q/topic:bp/performance-improvements
15:52:43 <mgoddard> reviews appreciated
15:52:59 <mgoddard> ironic TLS backend needs an update to fix ubuntu
15:53:15 <mgoddard> rabbitMQ TLS needs reviews https://review.opendev.org/#/c/728448/
15:53:15 <patchbot> patch 728448 - kolla-ansible - Support TLS encryption of RabbitMQ client-server t... - 8 patch sets
15:53:27 <mgoddard> Anything else we should discuss for kolla ansible?
15:53:36 <mgoddard> anything not on the priority list?
15:54:41 <mgoddard> #topic Victoria release planning (kolla)
15:54:45 <mgoddard> last one
15:54:52 <mgoddard> https://etherpad.opendev.org/p/KollaWhiteBoard
15:54:54 <mnasiadka> I think it would be good to follow up to doc updates we agreed on Kolla Kall
15:54:56 <mgoddard> L204
15:55:00 <mgoddard> mnasiadka: agreed
15:55:41 <mgoddard> I think we need to organise the notes into a set of changes to be made, and each pick some up
15:56:06 <mgoddard> #link https://etherpad.opendev.org/p/kollakall
15:56:06 <headphoneJames> I might try to enable tls for neutron api
15:56:43 <headphoneJames> seems like one of the last core services without tls
15:56:48 <mgoddard> headphoneJames: ok. non-trivial as it needs the RPC worker splitting out
15:56:58 <headphoneJames> copy that
15:56:59 <mgoddard> but yes, that would I think complete the core set
15:57:45 <mgoddard> mariadb TLS seems quite important also
15:58:31 <mgoddard> anyone want to volunteer to organise the docs notes into a set of changes to be made?
15:59:12 <mgoddard> alternatively, just make some changes
15:59:55 <mgoddard> but let's focus on useful improvements, given the backlog of code reviews
16:00:10 <mgoddard> on kolla
16:00:15 <mgoddard> we have infra images
16:00:47 <mgoddard> https://review.opendev.org/#/q/topic:bp/infra-images+(status:open+OR+status:merged)
16:00:55 <mgoddard> a few patches to review
16:01:06 <mgoddard> I think the main blocker is that the CI job is now non-voting for all
16:02:06 <mgoddard> Image tiering not started
16:02:12 <mgoddard> Focal complete (ish)
16:02:22 <mgoddard> Stable branch life-cycle
16:02:26 <mgoddard> https://review.opendev.org/738906
16:02:27 <patchbot> patch 738906 - kolla - version-check: handle using of stable branch tarballs - 3 patch sets
16:02:33 <mgoddard> let's try to get that merged soon
16:04:04 <mgoddard> we're over time
16:04:15 <mgoddard> thanks everyone
16:04:22 <mgoddard> not the most interactive meeting
16:04:32 <headphoneJames> <><><>
16:04:43 <mgoddard> but the summary is, please help to review existing priority patches
16:05:04 <mgoddard> as the freeze will be here soon
16:05:08 <mgoddard> #endmeeting