15:00:21 <yoctozepto> #startmeeting kolla
15:00:22 <yoctozepto> #topic roll-call
15:00:25 <openstack> Meeting started Wed Sep  2 15:00:21 2020 UTC and is due to finish in 60 minutes.  The chair is yoctozepto. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:28 <openstack> The meeting name has been set to 'kolla'
15:00:34 <yoctozepto> o/
15:04:11 <yoctozepto> I wonder if I got delayed network split or everyone is suddenly having their parties thrown :-)
15:04:13 <hrw> o\
15:04:44 <bbezak> o/
15:07:26 <yoctozepto> #topic agenda
15:07:33 <yoctozepto> * Roll-call
15:07:33 <yoctozepto> * Announcements
15:07:33 <yoctozepto> ** Kolla feature freeze fast approaching: Sep 28 - Oct 02
15:07:33 <yoctozepto> ** Victoria vPTG schedule https://ethercalc.openstack.org/7xp2pcbh1ncb
15:07:33 <yoctozepto> ** New Docker Hub rules: https://www.docker.com/blog/scaling-dockers-business-to-serve-millions-more-developers-storage/ and https://www.docker.com/blog/scaling-docker-to-serve-millions-more-developers-network-egress/
15:07:33 <yoctozepto> ** Open infra summit forum submissions open https://cfp.openstack.org
15:07:33 <yoctozepto> * Review action items from the last meeting
15:07:34 <mnasiadka> o/
15:07:34 <yoctozepto> * CI status
15:07:34 <yoctozepto> * Victoria release planning (kayobe)
15:07:35 <yoctozepto> * Victoria release planning (kolla ansible)
15:07:35 <yoctozepto> * Victoria release planning (kolla)
15:07:36 <yoctozepto> * Kolla Kall is tomorrow (2020-09-03)
15:07:41 <yoctozepto> #topic Announcements
15:07:48 <yoctozepto> #info Kolla feature freeze fast approaching: Sep 28 - Oct 02
15:08:10 <yoctozepto> not much time for your fav new features; get them merged before it's too late :-)
15:08:35 <yoctozepto> I guess we will again allow exceptions
15:08:43 <yoctozepto> to be discussed
15:08:51 <yoctozepto> #info Victoria vPTG schedule https://ethercalc.openstack.org/7xp2pcbh1ncb
15:09:15 <yoctozepto> related to the previous bullet point; the Victoria is getting released so we will be having a vPTG for Wallaby
15:09:46 <yoctozepto> PTL (mgoddard) needed to schedule time
15:10:01 <yoctozepto> we can discuss that later when mgoddard is around again
15:10:08 <yoctozepto> #info New Docker Hub rules: https://www.docker.com/blog/scaling-dockers-business-to-serve-millions-more-developers-storage/ and https://www.docker.com/blog/scaling-docker-to-serve-millions-more-developers-network-egress/
15:10:26 <yoctozepto> please read these notices as they affect Kolla to some degree
15:10:54 <yoctozepto> tl;dr free stuff has to be limited to not overwhelm docker servers
15:11:13 <hrw> does infra has 'no limit' account or not?
15:11:28 <yoctozepto> quotes: "starting on November 1, images stored in free Docker Hub repositories that have not had their manifest pushed or pulled in the last 6 months will be removed. This policy does not apply to images stored by paid Docker Hub subscription accounts, Docker Verified Publishers , or Docker Official Images."
15:12:02 <yoctozepto> quotes: "that will take effect November 1, 2020:
15:12:02 <yoctozepto> Free plan – anonymous users: 100 pulls per 6 hours
15:12:02 <yoctozepto> Free plan – authenticated users: 200 pulls per 6 hours
15:12:02 <yoctozepto> Pro plan – unlimited
15:12:02 <yoctozepto> Team plan – unlimited"
15:12:20 <yoctozepto> tripleo is already patching their CI to avoid docker.io
15:12:25 <mnasiadka> 100 pulls per 6 hours? awesome
15:12:30 <yoctozepto> hrw: I don't know yet, good point
15:12:33 <yoctozepto> mnasiadka: indeed
15:12:44 <mnasiadka> so that means we can nearly stop publishing
15:12:49 <mnasiadka> because our CI is doing more :)
15:12:51 <yoctozepto> if we are running on a free account, which is likely, our jobs will be crippled
15:13:06 <yoctozepto> mnasiadka: stop testing ansible parts; as limits are about pulls
15:13:36 <mnasiadka> yoctozepto: true, but then it's useless we waste cpu cycles to publish
15:13:46 <mnasiadka> and network bandwidth
15:14:00 <yoctozepto> mnasiadka: well, we spend more on building but network bandwidth is indeed wasted quite a bit
15:14:19 <yoctozepto> I guess we need official opendev registry instead
15:14:30 <yoctozepto> who wants to investigate this subject?
15:14:48 <yoctozepto> the first step would be to discuss that with the infra folks
15:15:06 <yoctozepto> anyone wants to pick it ip?
15:18:06 <openstackgerrit> Radosław Piliszek proposed openstack/kolla stable/train: Revert "openstack-base: pin setuptools < 46 to get horizon working"  https://review.opendev.org/749534
15:19:19 <yoctozepto> #action yoctozepto to discuss how opendev could help with new docker.io limits
15:19:33 <yoctozepto> #info Open infra summit forum submissions open https://cfp.openstack.org
15:19:50 <yoctozepto> feel welcome to submit something*
15:19:58 <yoctozepto> * make sure it's about kolla!
15:20:04 <yoctozepto> :-)
15:21:20 <yoctozepto> #topic Review action items from the last meeting
15:21:29 <yoctozepto> mgoddard to message openstack-discuss about focal & victoria upgrade
15:21:34 <yoctozepto> he did
15:21:43 <yoctozepto> #topic CI status
15:22:00 <yoctozepto> Kolla is RED in stable branches still
15:22:14 <yoctozepto> new issues attacked Ussuri and Train, related to setuptools on debuntu
15:22:32 <mnasiadka> well, master is RED as well - due to bifrost, but it's being fixed
15:22:53 <yoctozepto> mnasiadka: yeah, I treated that as fixed already :-)
15:23:00 <yoctozepto> mnasiadka: please repropose soon
15:23:06 <yoctozepto> ansible seems happy
15:23:12 <yoctozepto> not sure about kayobe
15:23:19 <openstackgerrit> Michal Nasiadka proposed openstack/kolla master: Fix bifrost network config  https://review.opendev.org/749469
15:23:46 <mnasiadka> yoctozepto: and come on, -2?
15:23:56 <mnasiadka> I feel like smashed in the head using a brick :)
15:24:45 <yoctozepto> hrw: https://review.opendev.org/749469
15:24:45 <patchbot> patch 749469 - kolla - Fix bifrost network config - 3 patch sets
15:24:48 <yoctozepto> mnasiadka: amended
15:27:29 <yoctozepto> kayobe looks green too
15:27:33 <hrw> +2
15:27:40 <yoctozepto> so only kolla issues atm
15:27:48 <yoctozepto> #topic Victoria release planning (kayobe)
15:28:18 <yoctozepto> mnasiadka, bbezak: I can't find anyone else to discuss kayobe today :-)
15:28:51 <mnasiadka> so then let's skip it for today :)
15:29:11 <bbezak> :)
15:29:51 <yoctozepto> :-)
15:30:07 <yoctozepto> #topic Victoria release planning (kolla ansible)
15:30:38 <yoctozepto> I'm back to work on masakari/hacluster integration in kolla-ansible
15:31:02 <yoctozepto> mgoddard has marked some changes with RP+1 so please have a look at them
15:36:28 <yoctozepto> #topic Victoria release planning (kolla)
15:36:48 <yoctozepto> essentially same here
15:39:21 <yoctozepto> #topic Kolla Kall is tomorrow (2020-09-03)
15:39:43 <JamesBenson> :yay:
15:39:45 <yoctozepto> please feel welcome to join, we will likely continue the group bug triage
15:45:14 <yoctozepto> #topic Open discussion
15:49:13 <mnasiadka> seems that ussuri kolla-toolbox setuptools is failing, because of virtualenv --system-site-packages bug https://github.com/pypa/pip/issues/6264, I'll just pin setuptools to lower version - we are not alone in this...
15:51:16 <yoctozepto> mnasiadka: hmm... but what about master?
15:52:57 <mnasiadka> yoctozepto: master is focal I think, so maybe it's better there in some sort?
15:53:18 <yoctozepto> mnasiadka: but it also affects debian, but not on master
15:53:30 <mnasiadka> it's all weird :)
15:53:32 <yoctozepto> something else must have changed too
15:53:45 <yoctozepto> yeah, it's lol
15:59:15 <yoctozepto> anyhow, let's wrap it up now
15:59:21 <yoctozepto> thanks everyone
15:59:24 <yoctozepto> #endmeeting