15:00:27 <mgoddard> #startmeeting kolla
15:00:32 <openstack> Meeting started Wed Sep 23 15:00:27 2020 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:36 <openstack> The meeting name has been set to 'kolla'
15:00:38 <mgoddard> #topic rollcall
15:00:47 <mgoddard> put your hands in the air like you just don't care
15:00:49 <priteau> o/
15:00:50 <mgoddard> \o/
15:01:18 <hrw> [o]
15:01:21 <Fl1nt> \o
15:01:24 <wuchunyang> o
15:01:38 <yoctozepto> o/
15:01:41 <mgoddard> that's a new one hrw
15:01:47 <hrw> ha!
15:01:54 <yoctozepto> mgoddard: but we care :-(
15:02:07 <mnasiadka> o/
15:02:10 <Fl1nt> he's grumpy ^^
15:02:21 <hrw> Fl1nt: who is not?
15:02:34 <yoctozepto> hrw: santa claus
15:02:37 <Fl1nt> I'm not ^^
15:03:00 <mgoddard> #topic agenda
15:03:00 <yoctozepto> <sherlock-mode>Fl1nt is Santa Claus</sherlock-mode>
15:03:10 <mgoddard> * Roll-call
15:03:13 <mgoddard> * Announcements
15:03:14 <mgoddard> ** Kolla Klub meeting returns tomorrow @ 15:00 UTC! https://docs.google.com/document/d/1EwQs2GXF-EvJZamEx9vQAOSDB5tCjsDCJyHQN5_4_Sw/
15:03:16 <mgoddard> ** Kolla feature freeze fast approaching: Sep 28 - Oct 02
15:03:19 <mgoddard> ** Submit Virtual PTG topic proposals: https://etherpad.opendev.org/p/kolla-wallaby-ptg
15:03:20 <mgoddard> ** TC & PTL elections coming up: http://lists.openstack.org/pipermail/openstack-discuss/2020-September/017306.html
15:03:23 <mgoddard> ** Ubuntu qemu bug http://lists.openstack.org/pipermail/openstack-discuss/2020-September/017390.html
15:03:25 <mgoddard> * Review action items from the last meeting
15:03:27 <mgoddard> * CI status
15:03:29 <mgoddard> * Victoria release planning
15:03:31 <mgoddard> ** Bump minimum Ansible version to 2.9 but blacklist 2.10 on CentOS 8? https://github.com/ansible/ansible/issues/71786
15:03:33 <mgoddard> #topic announcements
15:03:52 <mgoddard> #info Kolla Klub meeting returns tomorrow @ 15:00 UTC!
15:04:15 <mgoddard> #link https://docs.google.com/document/d/1EwQs2GXF-EvJZamEx9vQAOSDB5tCjsDCJyHQN5_4_Sw/
15:04:36 <mgoddard> agenda:
15:04:39 <mgoddard> Quick upstream update
15:04:41 <mgoddard> Improving engagement with the community in non EU/US timezones
15:04:43 <mgoddard> Operator feedback
15:04:53 <yoctozepto> ++
15:05:54 <mgoddard> #info Kolla feature freeze fast approaching: Sep 28 - Oct 02
15:06:03 <mgoddard> Weekly reminder
15:06:24 <mgoddard> #info Submit Virtual PTG topic proposals
15:06:31 <mgoddard> #link https://etherpad.opendev.org/p/kolla-wallaby-ptg
15:06:54 <mgoddard> No topics yet :)
15:07:03 * yoctozepto proposes to copy-paste unfinished victoria ones
15:07:03 <Fl1nt> I'll had some ^^
15:07:07 <mgoddard> Great
15:07:35 <mgoddard> yoctozepto: into the Incomplete Victoria Priorities section please
15:07:48 <mgoddard> although we're not finished yet :)
15:07:52 <yoctozepto> mgoddard: sure, just closer to victoria release
15:07:55 <yoctozepto> indeed!
15:08:07 <yoctozepto> I need to get you out of my head
15:08:23 <mgoddard> cue Kylie
15:08:27 <mgoddard> #info TC & PTL elections coming up
15:08:36 <mgoddard> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-September/017306.html
15:09:09 <mgoddard> Again, anyone is free to nominate themselves to join the TC, or become PTL
15:09:27 <mgoddard> Anyone thinking of running for kolla? (you don't have to say now)
15:09:56 <yoctozepto> mgoddard: I hope you are just teasing and you are going to run for it :-)
15:10:17 <mgoddard> yoctozepto: all good things must come to an end...
15:10:20 <hrw> I do not plan to
15:10:27 <yoctozepto> mgoddard: :O :-((((((
15:10:37 <mgoddard> I do intend to run this time however
15:11:10 <yoctozepto> mgoddard: we can also use the ptl-less model if it makes you feel better
15:11:13 <hrw> mgoddard: done! you are PTL for Wcycle ;D
15:11:33 <wuchunyang> +1
15:11:54 <mgoddard> #info Ubuntu qemu bug
15:11:54 <yoctozepto> mgoddard: but you definitely have my vote whenever, wherever
15:12:16 <mgoddard> yoctozepto: are you deliberately throwing out pop lyrics?
15:12:32 <mgoddard> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-September/017390.html
15:12:35 <yoctozepto> mgoddard: singer's soul
15:13:06 <mgoddard> ^ potentially nasty bug for ubuntu users on victoria/focal
15:13:18 <yoctozepto> indeed, hence why I added it to agenda
15:13:23 <yoctozepto> not sure we can do anything about it
15:13:38 <yoctozepto> based on further discussion it's not 100% reproducible
15:14:08 <yoctozepto> so it belongs to the most feared category of bufs
15:14:10 <yoctozepto> bugs*
15:14:28 <mgoddard> #topic Review action items from the last meeting
15:14:32 <mgoddard> yoctozepto to try bumping ansible to 2.9-2.10
15:14:38 <mgoddard> he tried, he failed
15:14:48 <mgoddard> not his fault
15:14:55 <yoctozepto> it works on Ubuntu
15:14:57 <yoctozepto> and Debian
15:15:02 <mgoddard> looks like we will be sticking with 2.9
15:15:03 <yoctozepto> just not CentOS 8
15:15:04 <openstackgerrit> Michal Nasiadka proposed openstack/kolla-ansible master: Use Docker healthchecks for core services  https://review.opendev.org/676389
15:15:08 <mgoddard> py3.6 issue then
15:15:08 <yoctozepto> so I managed to bump
15:15:12 <yoctozepto> but it failed to run it
15:15:15 <yoctozepto> seems o
15:15:18 <yoctozepto> so*
15:15:30 <mgoddard> great
15:15:30 <yoctozepto> I did not get much help from the ansible community
15:15:46 <yoctozepto> and unable to reproduce minimal example
15:15:49 <mgoddard> why would they want ansible to work on RHEL distros?
15:15:50 <priteau> We won't consider bumping to 2.9 only?
15:16:03 <mgoddard> +1, that was the backup plan
15:16:10 <yoctozepto> it's the final agenda point
15:16:16 <yoctozepto> but we can discuss it now
15:16:23 <mgoddard> let's get it over with
15:16:34 <yoctozepto> anyone disagrees?
15:16:35 <mgoddard> bump minimum ansible to 2.9?
15:16:43 <yoctozepto> #vote yes
15:16:55 <mgoddard> #vote yes
15:17:03 <mnasiadka> #vote yes
15:17:19 <wuchunyang> #vote yes
15:17:21 <hrw> +
15:17:53 <yoctozepto> regarding maximum - we can bump it for deb to keep it tested but deliberately note it is not supported on centos 8
15:18:10 <mgoddard> sounds complicated
15:18:26 <yoctozepto> well, we kinda test it like this already anyway
15:18:27 <yoctozepto> ;p
15:18:34 <yoctozepto> lowest on centos
15:18:37 <yoctozepto> highest on ubuntu
15:18:43 <mgoddard> true. lucky you caught it
15:19:06 <yoctozepto> so it's a matter of documenting the failure fact
15:19:19 <yoctozepto> and *maybe* we get it fixed for centos anyway
15:19:35 <yoctozepto> testing 2.10 has the benefit of catching it bugs early
15:19:37 <yoctozepto> "benefit"
15:20:10 <yoctozepto> bump maximum ansible to 2.10?
15:20:13 <yoctozepto> #vote yes
15:20:21 <Fl1nt> Goes for the 2.9 on my own
15:20:29 <Fl1nt> sorry, I had a work call :(
15:21:02 <mgoddard> hmm, unsure
15:21:04 <Fl1nt> #vote no
15:21:41 <priteau> 2.10 was just released today if I understood correctly, and we just started testing with it
15:21:52 <Fl1nt> because I feel like it will be yet another complication to get to maintain two different syntax/requirements on different platform and it doesn't really add a lot of benefit yet.
15:21:57 <priteau> Sounds like something we should be bumping in Wallaby?
15:22:13 <priteau> (and hoping that CentOS supports it by then)
15:22:14 <Fl1nt> +1
15:22:34 <mnasiadka> well, can we bump testing on debian/ubuntu but not advertise 2.10 support in docs?
15:22:47 <Fl1nt> for testing purpose sure ^^
15:22:48 <mnasiadka> once centos 8 issues are solved, we'll fix the support note?
15:23:07 <mgoddard> it's only a loose dependency, more of a constraint. We could potentially bump to 2.10 in a minor release?
15:23:11 <Fl1nt> but be careful of any downward compatibility issue tho
15:23:32 <Fl1nt> especially on keywords etc.
15:23:40 <mgoddard> of course, it would need to be tested
15:23:40 <mnasiadka> mgoddard: sure
15:23:45 <mnasiadka> but let's get rid of 2.8 ;)
15:24:00 <Fl1nt> I already had a bad surprise with those nasty changes with keywords ^^
15:24:19 <mnasiadka> once 2.11 will be out - 2.8 will be eol anyways
15:24:23 <Fl1nt> for sure let's abbandon 2.8 :D
15:24:28 <mgoddard> seems like the general feeling is no 2.10 in V, reassess later
15:24:40 <mgoddard> anyone want to bump min to 2.9?
15:24:41 <yoctozepto> no promise of 2.10 compat
15:24:41 <openstackgerrit> Michal Nasiadka proposed openstack/kolla-ansible master: Use Docker healthchecks for core services  https://review.opendev.org/676389
15:25:02 <yoctozepto> easy stuff, folks, get your hands dirty :-)
15:25:45 <priteau> I can give it a try, I am not too familiar with this part in K-A
15:26:18 <hrw> +1 for 2.9
15:26:22 <yoctozepto> priteau: perfect, the ideal candidate
15:26:24 <mnasiadka> well, yoctozepto can guide you in how many places that's done :D
15:26:32 <mgoddard> priteau: we should do the same in kayobe
15:26:35 <yoctozepto> or my change really
15:26:41 <mgoddard> #action priteau to bump minimum Ansible to 2.9
15:26:46 <priteau> mgoddard: of course, I know where to change it in Kayobe :-)
15:27:09 <yoctozepto> https://review.opendev.org/#/c/752420/2
15:27:09 <patchbot> patch 752420 - kolla-ansible - [DNM] Test Ansible 2.10.0rc1 - 5 patch sets
15:27:15 <mgoddard> #topic CI status
15:28:56 <mgoddard> how are things looking?
15:29:07 <mgoddard> whiteboard looks ok
15:29:19 <mgoddard> ubuntu binary still unhappy
15:29:20 <priteau> Kayobe is RED :(
15:29:56 <mgoddard> priteau: any idea what the problem is? I saw you mentioned ansible 2.10
15:30:00 <priteau> I'll recheck just to be sure, but I am able to reproduce the issue reliably & locally
15:30:16 <priteau> Well I thought it was related, but it fails in my tox venv which uses 2.9.13
15:30:36 <yoctozepto> it seems k&k-a stabilised a bit
15:30:49 <priteau> so far I've only found that if we pip3 uninstall ansible, remove the site-package ansible folder and reinstall it, it works
15:30:50 <yoctozepto> sad ubuntu binary still fails but it's not really our fault...
15:31:07 <yoctozepto> priteau: :O
15:31:15 <yoctozepto> MAGIC
15:31:37 <priteau> and except for the ansible 2.10 release, there were no changes to the other packages in the last days
15:31:42 <priteau> CI was still green yesterday
15:31:59 <mgoddard> priteau: are you able to continue looking at it?
15:32:09 <priteau> yeah I'll try some more
15:32:35 <mgoddard> #action priteau to investigate kayobe kayobe-tox-molecule failures
15:32:45 <mgoddard> #topic Victoria release planning
15:32:59 <mgoddard> Victoria approaches
15:33:13 <mnasiadka> yoctozepto: I'll look into ubuntu-binary case, I think it can be fixed
15:33:28 <mgoddard> #action mnasiadka to investigate ubuntu binary CI failures
15:33:31 <yoctozepto> mnasiadka: superb
15:33:47 <yoctozepto> will it be a victory for kolla
15:34:04 <mgoddard> no doubt
15:34:41 <mgoddard> hrw: what's the current status of infra images? Do you think you'll be able to sort out the CI in time?
15:35:45 <hrw> hm. good question
15:36:18 <hrw> will look at making change to have some sort of tree
15:36:34 <hrw> https://marcin.juszkiewicz.com.pl/2020/09/23/8-years-of-my-work-on-aarch64/
15:36:37 <hrw> ops
15:36:42 <mgoddard> lol
15:36:51 <mgoddard> this is not an advertising platform :p
15:37:03 <mnasiadka> no?
15:37:24 <hrw> mgoddard: if I would like to advertise I would add #link ;D
15:37:34 <mgoddard> I think we need to decide now whether to pursue for V or not
15:37:44 <mgoddard> we have basically 1 week left
15:37:55 <yoctozepto> +/- FFE period
15:38:10 <hrw> move to W I would say
15:38:17 <yoctozepto> then W it is
15:38:17 <mgoddard> it's a big enough change that FFE seems unfriendly
15:38:27 <mgoddard> e.g. kayobe will need to react to it
15:38:30 <hrw> get kolla_infra_install_type for k-a into V
15:38:33 <mgoddard> ok
15:38:56 <yoctozepto> we can have an experimental job for infra as well
15:39:02 <yoctozepto> to just test that it exists
15:39:07 <mgoddard> the work can continue, but we can drop the review priority
15:39:08 <hrw> so if you want to be brave then you can build infra+binary/source and install it using k-a in V
15:39:10 <yoctozepto> much easier than the CI warfare
15:39:42 <openstackgerrit> Pierre Riteau proposed openstack/kolla-ansible master: Bump minimum Ansible version to 2.9  https://review.opendev.org/753776
15:39:45 <yoctozepto> I felt sad we didn't deliver any support for letsencrypt in this cycle
15:39:52 <hrw> yoctozepto: https://review.opendev.org/753260 + https://review.opendev.org/706982 and you have base for such CI job
15:39:52 <patchbot> patch 753260 - kolla - [WIP] add centos8 images for source+infra CI job - 1 patch set
15:39:54 <patchbot> patch 706982 - kolla-ansible - Introduce 'kolla_infra_install_type' variable - 13 patch sets
15:40:02 <yoctozepto> so I started upstreaming bite-sized portions of semi-automatic approach now
15:41:22 <mgoddard> yoctozepto: will it be compatible with the full approach?
15:41:42 <yoctozepto> mgoddard: yes, that's the goal
15:41:46 <mgoddard> ok
15:41:49 <yoctozepto> it just requires user intervention and docs
15:41:57 <mgoddard> better be quick then :)
15:41:58 <yoctozepto> I also left a comment where you asked about cycle
15:42:05 <yoctozepto> sure, sire
15:43:05 <mgoddard> priteau: any progress on pull/retag/push?
15:43:29 <priteau> yes. I have a very rough proof of concept, I need a bit more time to clean it up
15:43:40 <mgoddard> nice
15:43:46 <priteau> Honestly not sure we can get it ready for V now
15:45:30 <mgoddard> ok
15:45:58 <mgoddard> I would very much like to get wuchunyang's work on octavia merged
15:46:07 <mgoddard> #link https://review.opendev.org/#/q/topic:bp/implement-automatic-deploy-of-octavia+(status:open+OR+status:merged)
15:46:51 <mgoddard> reviews would be appreciated
15:46:55 <wuchunyang> need some review now..
15:47:40 <mgoddard> I will do another pass through
15:47:45 <johnsom> I think I have reviewed this stack at least once. I will try to give another pass later today. It was in good shape last time I looked.
15:48:08 <openstackgerrit> Pierre Riteau proposed openstack/kolla-ansible master: Bump minimum Ansible version to 2.9  https://review.opendev.org/753776
15:48:20 <mgoddard> thanks johnsom
15:48:20 <wuchunyang> mgoddard johnsom thanks
15:48:22 <mnasiadka> yoctozepto: seems ubuntu-binary will get solved after all - https://bugs.launchpad.net/cloud-archive/+bug/1893935
15:48:23 <openstack> Launchpad bug 1893935 in Ubuntu Cloud Archive "Missing dependency on vitrageclient and zunclient in master" [Undecided,Confirmed]
15:48:40 <mgoddard> good investigative work mnasiadka
15:48:57 <yoctozepto> mnasiadka: because it hit charms
15:49:00 <mgoddard> would also be nice to land keystone federation https://review.opendev.org/#/c/695432/34
15:49:00 <patchbot> patch 695432 - kolla-ansible - Add support to OpenID Connect Authentication flow - 34 patch sets
15:49:08 <mnasiadka> yoctozepto: yeah :)
15:49:12 <mgoddard> although that needs an update
15:49:29 <mgoddard> health checks have had some activity
15:49:36 <mgoddard> https://review.opendev.org/743958
15:49:36 <patchbot> patch 743958 - kolla-ansible - Add healthchecks option to kolla_docker - 14 patch sets
15:49:38 <mgoddard> https://review.opendev.org/676389
15:49:38 <patchbot> patch 676389 - kolla-ansible - Use Docker healthchecks for core services - 83 patch sets
15:49:47 <mgoddard> more reviews welcome
15:50:31 <mgoddard> https://review.opendev.org/#/c/728448/ has a +2...
15:50:32 <patchbot> patch 728448 - kolla-ansible - Support TLS encryption of RabbitMQ client-server t... - 12 patch sets
15:51:02 <mgoddard> priteau: do you plan to work on kayobe multiple envs before V?
15:53:00 <priteau> I would like to but it's getting quite late now
15:53:33 <priteau> (in the cycle)
15:54:18 <mgoddard> indeed
15:54:49 <mgoddard> I could see if I can spare some cycles, if that helps?
15:55:26 <priteau> It would help for sure
15:55:58 <mgoddard> let's see how the next week goes
15:56:30 <mgoddard> any other features for V?
15:56:48 <wuchunyang> designate ?
15:57:10 <wuchunyang> the designate default_pool_id bug has fixed.
15:57:12 <yoctozepto> that did not happen, unfortunately
15:57:49 <wuchunyang> i can work on it .. tomorrow.
15:58:15 <mgoddard> #topic open discussion
15:58:50 <yoctozepto> wuchunyang: that would be awesome
15:58:58 <mgoddard> kplant mentioned ozzzo is a new colleague, who will be spending some time upstream
15:59:02 <mgoddard> welcome ozzzo :)
15:59:24 <yoctozepto> welcome ozzzo indeed
15:59:27 <kplant> :-)
15:59:35 <kplant> welcome ozzzo
15:59:36 <yoctozepto> time to wrap up (for me at least)
15:59:37 <mgoddard> feel free to drop questions into IRC as you climb the learning curve
15:59:40 * yoctozepto afk
15:59:56 <mgoddard> indeed, time for us all to wrap up
15:59:58 <mgoddard> thanks all
16:00:12 <mgoddard> #endmeeting