15:00:32 <mgoddard> #startmeeting kolla
15:00:33 <openstack> Meeting started Wed Feb  3 15:00:32 2021 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:36 <openstack> The meeting name has been set to 'kolla'
15:00:44 <mgoddard> #topic rollcall
15:00:47 <mgoddard> \o
15:01:19 <priteau> o/
15:01:43 <mnasiadka> o/
15:02:12 <bbezak> o/
15:02:16 <hrw> ]o[
15:03:43 <yoctozepto> o/
15:03:56 <eliaswimmer> hej
15:04:17 <mgoddard> #topic agenda
15:04:27 <mgoddard> * Roll-call
15:04:29 <mgoddard> * Announcements
15:04:31 <mgoddard> ** Google Summer of Code applications now open https://summerofcode.withgoogle.com/get-started/
15:04:33 <mgoddard> * Review action items from the last meeting
15:04:35 <mgoddard> * CI status
15:04:37 <mgoddard> * Wallaby release planning
15:04:39 <mgoddard> * Review requests
15:04:41 <mgoddard> #topic announcements
15:04:43 <mgoddard> #info Google Summer of Code applications now open
15:04:48 <mgoddard> #link https://summerofcode.withgoogle.com/get-started/
15:05:25 <yoctozepto> if anyone is interested in tutoring
15:05:33 <yoctozepto> I am overwhelmed nowadays
15:06:15 <hrw> I did gsoc twice. will not repeat
15:06:59 <mgoddard> a glowing review
15:07:06 <mgoddard> #topic Review action items from the last meeting
15:07:15 <mgoddard> hrw to document allowed to fail & unbuildable images in contributor docs
15:07:17 <hrw> sorry, forgot about it
15:07:28 <mgoddard> #action hrw to document allowed to fail & unbuildable images in contributor docs
15:07:29 <mgoddard> np
15:07:36 <mgoddard> #topic CI status
15:07:43 <mgoddard> Things seem happy this week
15:08:05 <mgoddard> someone must have made the necessary sacrifices to CI gods
15:08:14 <hrw> CentOS 8 Stream nodes are already present on CI. for x86-64 and aarch64
15:10:17 <mgoddard> Kayobe train CentOS7 upgrade job is unhappy
15:10:24 <mgoddard> hopefully https://review.opendev.org/c/openstack/kayobe/+/773635 improves it
15:10:29 <hrw> https://review.opendev.org/c/openstack/kolla/+/772841 adds C8S for kolla stuff
15:12:18 <mgoddard> looks like kolla-ansible-debian-source has been failing on master since saturday
15:12:20 <mgoddard> https://zuul.openstack.org/builds?job_name=kolla-ansible-debian-source&branch=master
15:12:32 <priteau> We have occasional failures with baremetal testing in kayobe as well
15:13:29 <hrw> "manifest for primary:4000/lokolla/debian-source-mariadb-server:change_773881 not found: manifest unknown: manifest unknown
15:13:32 <hrw> weird
15:13:48 <mgoddard> hrw: I think that may be a legit failure of mine
15:13:54 <hrw> ha! was not built
15:14:26 <mgoddard> Nova requires libvirt version 6.0.0 or greater
15:14:30 <mgoddard> https://776b4a03b1967a29b7db-a2819ce1e1d01d4ba47cf0d26d5585a5.ssl.cf2.rackcdn.com/772841/3/check/kolla-ansible-debian-source/ebe2f2e/primary/logs/kolla/nova/nova-compute.txt
15:14:48 <hrw> ok
15:15:09 <hrw> will backport 6.x then at Linaro repo
15:15:27 <hrw> 7.0.0 is in Debian 'testing'
15:15:33 <mgoddard> hmm, seems this was already on the whiteboard but status was GREEN so didn't see it
15:16:14 <mgoddard> ok, move on
15:16:16 <mgoddard> #topic Review requests
15:16:40 <mgoddard> I added this to the agenda
15:17:01 <mgoddard> I was thinking we could allow everyone one patch to request reviews on
15:17:34 <mgoddard> anyone have a patch they'd like to be prioritised?
15:18:02 <hrw> https://review.opendev.org/c/openstack/kolla/+/765864 would be nice
15:18:13 <yoctozepto> not at the moment
15:18:17 <yoctozepto> but good idea :-)
15:18:27 <hrw> https://review.opendev.org/c/openstack/kolla/+/772507 is also nice touch
15:19:17 <mgoddard> hrw: one patch only :p
15:19:46 <hrw> ;D
15:19:57 <hrw> they are so small ;d
15:20:15 <hrw> ok, let's see how libvirt 7.0.0 backports ;D
15:22:24 <wuchunyang> does centos 8 could use libvirt 7.0 ?
15:23:02 <hrw> wuchunyang: it has 6.0.0
15:23:34 <mgoddard> I'll request https://review.opendev.org/c/openstack/kolla-ansible/+/650853
15:23:51 <mgoddard> #topic Wallaby release planning
15:24:32 <mgoddard> #info Kolla feature freeze: Mar 29 - Apr 02
15:24:40 <hrw> https://review.opendev.org/c/openstack/kolla/+/772841 moves us to CentOS 8 Stream
15:25:03 <hrw> so far by using centos:8 -> stream move. it is easier than going ubi8 -> stream (checked both)
15:25:42 <hrw> wuchunyang: note that centos 8.2 had 4.5.0 so we are fine when it comes to centos
15:25:53 <mgoddard> hmm
15:26:08 <mgoddard> so centos stream says it does not produce container images
15:26:13 <hrw> mgoddard: #action hrw to build libvirt 7.0.0 for Debian
15:26:15 <wuchunyang> ok
15:26:21 <mgoddard> #action hrw to build libvirt 7.0.0 for Debian
15:26:52 <hrw> mgoddard: I got mixed info. some say that there will be, official rh info iirc is 'use ubi8'
15:27:00 <mgoddard> https://wiki.centos.org/FAQ/CentOSStream
15:27:04 <hrw> ubi8->stream is easy
15:27:46 <hrw> https://lists.centos.org/pipermail/centos-devel/2021-February/076420.html
15:28:02 <mgoddard> I guess we just follow tripleo
15:28:03 <hrw> that's my email with both methods
15:28:54 <hrw> RDO may switch to Ceph Octopus but all packages/repos are present so easy change for us in kolla images
15:30:04 <mgoddard> I think tripleo use ubi images for their CentOS testing?
15:30:35 <hrw> no idea
15:30:38 <hrw> not checked yet
15:31:13 <mgoddard> I think that is what they said when switching away from kolla
15:33:23 <hrw> ok
15:34:37 <mgoddard> should we just do the switch, or wait to see what tripleo/RDO do?
15:35:17 <hrw> I can move my patch to ubi8
15:35:27 <mgoddard> well
15:35:36 <mgoddard> unclear if that is the right plan
15:36:12 <hrw> will see
15:36:20 <mgoddard> we should probably ask RDO how they expect packages to be installed in containers
15:36:31 <mgoddard> or rather, which base image they expect people to use
15:38:05 <mgoddard> let's move on
15:38:47 <hrw> yep
15:38:49 <mgoddard> working through kolla-ansible priorities on the whiteboard
15:38:52 <mgoddard> Cinder removing v2 API
15:38:57 <mgoddard> anyone picked that up?
15:39:06 <mgoddard> #link
15:39:09 <mgoddard> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018697.html
15:40:05 <mgoddard> guess not
15:40:18 <mgoddard> HAProxy hitless reload?
15:40:28 <mgoddard> TLS in other services
15:40:44 <mgoddard> Implement TLS Backend for all remaining API services with externally exposed API
15:40:51 <mgoddard> Modernise the old skool Swift role
15:41:51 <mgoddard> Upgrade checkers
15:41:59 <mgoddard> More fine grained skipping of tasks, e.g. allow to skip service registration
15:42:05 <mgoddard> Replace use of Docker with Podman
15:42:11 <mgoddard> Support extensions to deployment
15:42:16 <mgoddard> Performance improvements
15:42:37 <mgoddard> Node removal (decommission)
15:43:03 <mgoddard> ^ I just picked out a few items that don't currently have owners or have not been started
15:43:11 <wuchunyang> More fine grained skipping of tasks, e.g. allow to skip service registration    i would like to add a tag for those tasks. if we need skip, just skip-tags
15:43:12 <mgoddard> does anyone want to work on any of these?
15:43:43 <wuchunyang> if this is right , this task can assign to me .
15:43:48 <hrw> mgoddard: not me
15:44:27 <mgoddard> wuchunyang: correct. we agreed to add tags for register & bootstrap
15:44:47 <wuchunyang> ok,  assign to me. i will do it in my holiday.
15:45:39 <mgoddard> wuchunyang: thank you. Assigned
15:45:56 <wuchunyang> it's nothing
15:46:06 <mgoddard> wuchunyang: I suggest putting up a WIP patch for one service so we can discuss before doing it for all services
15:46:22 <wuchunyang> ok, no problem.
15:48:16 <mgoddard> are there particular in progress features that we should be focussing on?
15:48:41 <yoctozepto> I think you have looked on all mine
15:48:47 <yoctozepto> most are currently stalled
15:49:49 <mgoddard> For kayobe, I think we need to focus on Support multiple environments from a single kayobe configuration
15:50:14 <mgoddard> dougsz, mnasiadka, bbezak: ^
15:50:42 <mgoddard> would love to see us do another Document configuration walk through this cycle too
15:51:32 <bbezak> mgoddard: doc part is on my list ;)
15:51:39 <mgoddard> lovely
15:51:54 <mgoddard> #topic Open discussion
15:52:05 <mgoddard> Does anyone have anything else to discuss today?
15:52:57 <hrw> nope
15:53:00 <wuchunyang> no
15:53:58 <mgoddard> ok, let's finish up then
15:54:00 <mgoddard> thanks all
15:54:04 <mgoddard> #endmeeting