15:01:41 <mgoddard> #startmeeting kolla
15:01:43 <openstack> Meeting started Wed Mar 31 15:01:41 2021 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:46 <openstack> The meeting name has been set to 'kolla'
15:01:59 <openstackgerrit> Pierre Riteau proposed openstack/kayobe master: Support multiple environments from a single configuration  https://review.opendev.org/c/openstack/kayobe/+/734867
15:02:02 <hrw> o\
15:02:03 <openstackgerrit> Pierre Riteau proposed openstack/kayobe master: Add a command to create a new Kayobe environment  https://review.opendev.org/c/openstack/kayobe/+/770553
15:02:08 <openstackgerrit> Pierre Riteau proposed openstack/kayobe master: Support passing multiple Kayobe inventory arguments  https://review.opendev.org/c/openstack/kayobe/+/773718
15:02:16 <openstackgerrit> Pierre Riteau proposed openstack/kayobe master: Detect multiple inventories automatically  https://review.opendev.org/c/openstack/kayobe/+/773719
15:02:20 <mgoddard> #topic rollcall
15:02:23 <mgoddard> \o
15:02:24 <yoctozepto> \o/
15:02:26 <openstackgerrit> Pierre Riteau proposed openstack/kayobe master: Add documentation for multiple environments  https://review.opendev.org/c/openstack/kayobe/+/770554
15:02:34 <openstackgerrit> Pierre Riteau proposed openstack/kayobe master: Exit when environment clashes are detected  https://review.opendev.org/c/openstack/kayobe/+/783114
15:03:08 <osmanlicilegi> o/
15:03:20 <priteau> o/
15:04:19 <mgoddard> #topic agenda
15:04:28 <mgoddard> * Roll-call
15:04:29 <mgoddard> * Announcements
15:04:31 <mgoddard> ** PTG 19th - 23rd April, registration open | https://april2021-ptg.eventbrite.com | https://www.openstack.org/ptg/
15:04:33 <mgoddard> * Review action items from the last meeting
15:04:35 <mgoddard> * CI status
15:04:37 <mgoddard> * Review requests
15:04:39 <mgoddard> * PTG team signup http://lists.openstack.org/pipermail/openstack-discuss/2021-March/020915.html
15:04:41 <mgoddard> * Quay.io
15:04:43 <mgoddard> * Wallaby release planning
15:04:45 <mgoddard> #topic announcements
15:04:47 <mgoddard> #info PTG 19th - 23rd April, registration open
15:04:52 <mgoddard> #link https://april2021-ptg.eventbrite.com
15:04:58 <mgoddard> #link https://www.openstack.org/ptg/
15:05:55 <mgoddard> #info Kolla feature freeze at the end of this week
15:06:01 <mgoddard> Any others?
15:07:11 <yoctozepto> howto FFE
15:07:34 <mgoddard> ask
15:07:37 <mgoddard> FFE me
15:07:56 * yoctozepto asks mgoddard for FFE on masakari-hostmonitor and pacemaker stack
15:08:02 <mgoddard> FFE = Feature Freeze Extension
15:08:11 <yoctozepto> Exception*
15:08:39 <mgoddard> Typical requirements for FFE are general agreement from core team, and two cores willing to review the code
15:08:51 <mgoddard> indeed, you are right
15:09:10 * yoctozepto is willing to review that code :-)
15:09:29 <mgoddard> yoctozepto doesn't count in this cas
15:09:35 <mgoddard> let's cover FFEs later
15:09:36 * yoctozepto sad
15:09:45 <mgoddard> #topic Review action items from the last meeting
15:09:55 <mgoddard> mgoddard email openstack-discuss about quay.io credentials
15:09:59 <mgoddard> mgoddard did not
15:10:02 <mgoddard> #action mgoddard email openstack-discuss about quay.io credentials
15:10:04 <hrw> yoctozepto: we did not froze yet so no FFE
15:10:30 <mgoddard> I think we can proceed with quay.io using the proposed approach, ML can discuss potential improvements
15:10:40 <yoctozepto> ok, then I will
15:10:45 <yoctozepto> I was confused last time
15:10:55 <yoctozepto> and then was busy
15:11:22 <mgoddard> #topic CI status
15:12:14 <yoctozepto> mnasiadka was on that cephadm
15:12:23 <yoctozepto> possibly it's related to space usage
15:12:23 <mgoddard> yes, but now on holiday
15:12:36 <yoctozepto> yeah, I summarised for him ;-)
15:12:52 <mgoddard> debian patches still open IIRC
15:13:06 <yoctozepto> ok, I will review
15:13:21 <hrw> Debian open for ussuri/victoria/master
15:14:02 <yoctozepto> all merged in kolla it seems
15:14:03 <mgoddard> master looks fixed
15:14:14 <mgoddard> or merged at least
15:14:59 <hrw> https://review.opendev.org/c/openstack/kolla/+/783698 https://review.opendev.org/c/openstack/kolla/+/783713 are master
15:15:24 <mgoddard> NFV job passing again
15:15:38 <mgoddard> hrw: I'm just going by the whiteboard...
15:16:32 <hrw> ah. have to update it
15:17:21 <mgoddard> I'm not aware of any kayobe CI issues
15:17:22 <yoctozepto> I will drop the Train workarounds from whiteboard
15:17:24 <yoctozepto> nobody cared
15:17:31 <mgoddard> ok
15:17:41 <mgoddard> #topic Review requests
15:18:00 <mgoddard> Does anyone have a patch they would like to be reviewed this week?
15:18:58 * yoctozepto does not :-(
15:19:10 * yoctozepto wishes he had a clone
15:19:18 <headphoneJames> https://review.opendev.org/c/openstack/kolla-ansible/+/741340/
15:19:22 <headphoneJames> almost there!
15:19:25 <mgoddard> yoctozepto.copy()
15:19:34 <yoctozepto> mgoddard: I wish!
15:19:42 <mgoddard> one yoctozepto is plenty
15:19:45 <mgoddard> :P
15:19:50 <yoctozepto> :D
15:20:00 <headphoneJames> https://review.opendev.org/#/c/741339
15:20:06 <hrw> ok. added issues to whiteboard
15:20:31 <mgoddard> thanks hrw
15:20:53 <yoctozepto> ++
15:21:23 <mgoddard> will try to take a look at letsencrypt
15:21:58 <headphoneJames> thx
15:22:16 <mgoddard> #topic PTG
15:22:17 <hrw> I got my set of patches and do not have any specific one to request
15:22:37 <mgoddard> #link https://etherpad.opendev.org/p/kolla-xena-ptg
15:22:47 <mgoddard> ^ remember to add your name if attending
15:23:15 <mgoddard> it's still light on topics
15:23:40 <mgoddard> what do we need to discuss as a community?
15:24:04 <yoctozepto> how to survive the pandemics
15:25:11 <mgoddard> I'm not sure that's in our mission statement
15:25:15 <hrw> what to deprecate next
15:25:27 <mgoddard> always a good topic
15:25:36 <hrw> what we do wrong (as there are no new cores)
15:25:40 <yoctozepto> oh, must amend the mission statement
15:25:55 <mgoddard> wuchunyang is a fairly recent core
15:25:56 <yoctozepto> hrw: deprecate - what do you have in mind already? :D
15:26:20 <mgoddard> but more cores would be nice
15:26:28 <hrw> yoctozepto: binary images?
15:26:53 <yoctozepto> hrw: honestly? I would; I feel the spirit of kolla is in the source images
15:27:32 <yoctozepto> so yeah, we can discuss that thing
15:27:38 <hrw> we would still have images and 2-3 teams less to cooperate with
15:27:58 <mgoddard> added
15:28:50 <mgoddard> any other suggestions?
15:29:07 <muhaha> would be 32core ( epyc 7452 ), 256g ram ok for multinode openstack ( running on single bare metal - via ovirt ) for 2-3 kubernetes clusters ok ? seem that ~200g ram should be available for kubernetes clusters inside openstack, ( 4g ram will consume ovirt ) , openstack will probably consume in 2+3 ~50g ram ? i will have 64vCores avalable, i am not
15:29:08 <muhaha> planning anything excesive just a buch of cloud native tools for testing in k8s
15:29:19 <yoctozepto> muhaha: we are in a meeting
15:29:33 <mgoddard> muhaha: ask again in 30m
15:29:53 <yoctozepto> mgoddard: not really
15:29:59 <yoctozepto> we can recycle some old ones
15:30:09 <yoctozepto> but I believe there is not much to discuss, mostly to do
15:30:13 <mgoddard> Is anyone considering attending the PTG but unsure? Want to know more about it?
15:31:35 <hrw> yoctozepto: replied to review
15:32:26 <mgoddard> yoctozepto: agree that it can be frustrating that we talk about lots of things but only have time for a fraction. I think it's important to have these discussions though, and allow new ideas to surface
15:32:54 <mgoddard> it feels quite frequent, but every 6 months is not too often
15:32:56 <yoctozepto> mgoddard: yes, I have never said we should discuss *new* ideas
15:33:06 <yoctozepto> never said we should not*
15:33:10 <hrw> ;D
15:33:10 <yoctozepto> :-)
15:33:22 <yoctozepto> not enough negations
15:33:23 <yoctozepto> :D
15:33:58 <mgoddard> sure. Going over old ideas can be worthwhile sometimes. Sometimes things have changed since the last time, or a new person brings a fresh perspective
15:34:23 <mgoddard> #topic Quay.io
15:34:23 <hrw> I want to officially end infra images idea
15:34:45 <mgoddard> #undo
15:34:46 <openstack> Removing item from minutes: #topic Quay.io
15:34:59 <mgoddard> hrw: well, killing binary images would make it redundant
15:35:27 <mgoddard> it's a shame, it's quite close to done, but needs work on CI
15:35:41 <hrw> mgoddard: it is just a name
15:35:50 <mgoddard> no
15:35:54 <hrw> our infra images are what we wanted. just doubled
15:36:16 <hrw> centos-source-mariadb content == centos-binary-mariadb
15:36:32 <mgoddard> we still upload two almost identical images to dockerhub
15:36:48 <hrw> ok
15:36:59 <hrw> go on with agenda
15:37:01 <mgoddard> one of the main goals was to keep infra happy by reducing uploads
15:37:10 <mgoddard> ok
15:37:15 <mgoddard> #topic Quay.io
15:37:25 <yoctozepto> will be done
15:37:27 <mgoddard> yoctozepto: anything more to discuss since last time?
15:37:30 <yoctozepto> nope
15:37:32 <mgoddard> ok
15:37:40 <mgoddard> #topic Wallaby release planning
15:38:05 <mgoddard> now seems like a good time for FFEs
15:38:18 <yoctozepto> masakari stuff for me
15:38:23 <yoctozepto> it's almost done
15:38:35 <mgoddard> linx?
15:38:35 <yoctozepto> just struggling with time
15:38:40 <yoctozepto> hax
15:39:20 <yoctozepto> hacluster/pacemaker ~> https://review.opendev.org/c/openstack/kolla-ansible/+/670104
15:39:30 <yoctozepto> masakari-hostmonitor ~> https://review.opendev.org/c/openstack/kolla-ansible/+/744235
15:40:09 <mgoddard> I can review the pacemaker one
15:40:46 <mgoddard> I created the other, so can't
15:40:51 <mgoddard> yoctozepto could though
15:41:08 <mgoddard> so we need one more core available for reviewing
15:41:14 <yoctozepto> mgoddard: need to coordinate both and test
15:41:22 <yoctozepto> but yeah, we can go like you said
15:42:32 <mgoddard> I expect if you ask mnasiadka nicely when he's back he'll agree
15:42:47 <mgoddard> FFE pending :)
15:42:49 <mgoddard> Anyone else?
15:43:40 <headphoneJames> not sure if I need one for Let's Encrypt yet. Whens the cut off?
15:43:53 <mgoddard> end of this week
15:44:11 <mgoddard> Friday is a holiday here
15:44:11 <headphoneJames> so . . . maybe!
15:44:20 <yoctozepto> I am willing to review that thing
15:44:25 <mgoddard> +1
15:44:27 <yoctozepto> so FFE will likely be granted if needed
15:45:23 <headphoneJames> sweet pickles
15:45:31 <mgoddard> any others?
15:46:24 <hrw> go on
15:47:12 <mgoddard> ok
15:47:24 <mgoddard> Let's go through Wallaby priorities
15:47:26 <mgoddard> https://etherpad.opendev.org/p/KollaWhiteBoard
15:47:27 <yoctozepto> headphoneJames: are sweet pickles tasty?
15:47:29 <mgoddard> L259
15:47:42 <mgoddard> CentOS 8 stream
15:47:46 <yoctozepto> oh, wall of shame
15:47:46 <mgoddard> needs a k-a patch
15:47:58 <mgoddard> hrw: are you planning to do it?
15:48:10 <yoctozepto> mnasiadka restored mine to life I think
15:48:19 <yoctozepto> hrw can continue on that
15:48:24 <hrw> mgoddard: we have patch which moves CI to stream
15:48:34 <mgoddard> ok
15:48:44 <hrw> and I worked with IanW to get aarch64 stream running
15:48:46 <yoctozepto> https://review.opendev.org/c/openstack/kolla-ansible/+/759121
15:50:27 <mgoddard> I guess we should switch kayobe too
15:50:36 <mgoddard> #action mgoddard switch kayobe to c8s
15:50:39 <hrw> I have fun looking as 'aaa, stream will be broken and unusable' panic
15:50:48 <mgoddard> lol c8s k8s
15:51:00 <hrw> mgoddard: cs8 is preferred form
15:51:06 <mgoddard> maybe this is all an elaborate joke
15:51:10 <hrw> CentOS Stream 8
15:51:28 <mgoddard> k
15:51:37 <hrw> as there is work on CentOS Stream 9 already
15:52:57 <yoctozepto> mgoddard: yeah, let's move it all to k8s
15:53:03 <mgoddard> tried that
15:53:07 <hrw> revive kolla-k8s!
15:53:33 <yoctozepto> mgoddard: how was it?
15:53:36 <hrw> looking at list in whiteboard we may not need new ideas for ptg
15:53:49 <mgoddard> well, I didn't personally try it :)
15:54:06 <yoctozepto> O-K
15:54:19 <priteau> hrw: there was a lengthy thread where they discussed naming. I believe it is c8s but "CentOS Stream 8" (go figure)
15:54:40 <priteau> https://lists.centos.org/pipermail/centos-devel/2021-March/076631.html
15:54:42 <yoctozepto> does not matter
15:54:48 <yoctozepto> are we deprecating it?
15:54:55 <mgoddard> not yet
15:54:57 * yoctozepto votes yes
15:55:04 <yoctozepto> sad
15:55:21 <hrw> priteau: k
15:55:30 <mgoddard> Anything else on Wallaby?
15:55:45 <hrw> priteau: I skipped most of stream discussions. too much noise
15:55:52 <hrw> mgoddard: #goon
15:56:09 <mgoddard> #topic Open discussion
15:56:18 <mgoddard> Does anyone have anything this week?
15:56:19 <yoctozepto> hrw: have you hired a goon? what for?
15:56:41 <hrw> yoctozepto: #go-on looks better?
15:57:17 <yoctozepto> hrw: ooh, much better
15:57:18 <hrw> Debian fails in libvirt
15:57:31 <hrw> cgroup stuff
15:58:06 <hrw> need to sit and debug it more. just had several other tasks
16:00:44 <mgoddard> time's up
16:00:47 <yoctozepto> thanks mgoddard for chairing
16:00:47 <mgoddard> thanks all
16:00:51 <hrw> thanks
16:00:52 <mgoddard> #endmeeting