15:00:49 <mgoddard> #startmeeting kolla
15:00:49 <openstack> Meeting started Wed Apr 28 15:00:49 2021 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:52 <openstack> The meeting name has been set to 'kolla'
15:01:47 <yoctozepto> \o/
15:01:50 <mgoddard> #topic rollcall
15:01:58 <mnasiadka> o/
15:01:59 <yoctozepto> \o\
15:02:04 <yoctozepto> /o/
15:02:16 <hrw> [o]
15:02:23 <yoctozepto> ]o[
15:02:34 <mgoddard> Oo/
15:02:56 <yoctozepto> ooh, is that a baby head?
15:02:57 <priteau> \o/
15:03:42 <wuchunyang> o
15:04:37 <mgoddard> #topic agenda
15:04:40 <mgoddard> * Roll-call
15:04:42 <mgoddard> * Agenda
15:04:44 <mgoddard> * Announcements
15:04:46 <mgoddard> ** Xena PTG completed https://etherpad.opendev.org/p/kolla-xena-ptg
15:04:48 <mgoddard> ** Kolla Wallaby RC1 & stable/wallaby created
15:04:50 <mgoddard> * Review action items from the last meeting
15:04:52 <mgoddard> * CI status
15:04:54 <mgoddard> * Wallaby release planning
15:04:56 <mgoddard> ** Deprecate the Tempest image
15:04:58 <mgoddard> * Xena cycle planning
15:05:00 <mgoddard> ** Ansible (prepackaged collections) vs ansible-base/core
15:05:02 <mgoddard> ** Ansible 2.10 and auto transformation of invalid group names (https://github.com/ansible/ansible/issues/56930)
15:05:04 <mgoddard> * Open discussion
15:05:06 <mgoddard> #topic announcements
15:05:41 <mgoddard> #info Xena PTG completed
15:05:50 <mgoddard> #link https://etherpad.opendev.org/p/kolla-xena-ptg
15:06:02 <mgoddard> #action mgoddard to write up Xena PTG summary for openstack-discuss
15:06:13 <mgoddard> #info Kolla Wallaby RC1 & stable/wallaby created
15:06:28 <mgoddard> The master branch is still frozen for features
15:06:34 <yoctozepto> and in launchpad as well
15:06:39 <mgoddard> indeed, thanks
15:06:46 <mgoddard> Any others?
15:07:06 <yoctozepto> not really
15:07:13 <mgoddard> small one
15:07:19 <mgoddard> #info OpenStack wallaby released
15:07:21 <mgoddard> #link https://www.openstack.org/software/wallaby/
15:07:39 <mgoddard> #link https://docs.openstack.org/wallaby/
15:07:47 <mgoddard> #topic Review action items from the last meeting
15:07:58 * yoctozepto thinks we had it announced already
15:08:05 <yoctozepto> but meh
15:08:11 <openstackgerrit> Radosław Piliszek proposed openstack/kolla stable/wallaby: neutron: Remove vmware-nsx and networking-mlx from binary  https://review.opendev.org/c/openstack/kolla/+/788455
15:08:15 <yoctozepto> gerrit slow
15:08:21 <mgoddard> mgoddard email openstack-discuss about quay.io credentials
15:08:23 <mgoddard> yoctozepto deprecate enable_host_ntp
15:08:32 <mgoddard> mgoddard still did not
15:08:37 * yoctozepto did it
15:08:48 <mgoddard> #action mgoddard email openstack-discuss about quay.io credentials
15:08:55 <mgoddard> #topic CI status
15:09:14 <yoctozepto> and now in wallaby
15:09:25 <yoctozepto> oh well, gerrit slow
15:10:09 <yoctozepto> https://etherpad.opendev.org/p/KollaWhiteBoard
15:10:28 <openstackgerrit> Radosław Piliszek proposed openstack/kolla-ansible stable/wallaby: Deprecate enable_host_ntp  https://review.opendev.org/c/openstack/kolla-ansible/+/788516
15:11:48 <mgoddard> Kolla looks ok from the whiteboard
15:12:02 <mgoddard> I wonder if monasca-grafana still fails
15:12:40 <yoctozepto> it does
15:12:44 <yoctozepto> we are dropping it
15:12:51 <yoctozepto> just cleaned the issues on kolla, yes
15:12:54 <yoctozepto> ;-)
15:13:27 <mgoddard> well, we have deprecated it in Wallaby
15:13:51 <mgoddard> not dropped just yet
15:13:58 <yoctozepto> yes
15:14:53 <mgoddard> are we still seeing that 'Operation not permitted' issue on Centos stream?
15:15:06 <mnasiadka> I haven’t
15:15:23 <yoctozepto> I have not either, must have got fixed
15:15:38 <yoctozepto> cephadm neither, no?
15:15:39 <yoctozepto> mnasiadka?
15:15:53 <mnasiadka> Yup
15:15:53 <yoctozepto> I remember we joked about it
15:15:57 <mnasiadka> Only Ubuntu
15:16:07 <mnasiadka> But that is getting worked around
15:16:12 <yoctozepto> rmq also quite stable
15:16:27 <yoctozepto> just remember we have the staggered upgrade
15:16:31 <yoctozepto> if it starts again
15:16:43 <mnasiadka> Ubuntu upgrade in UCA change
15:16:51 <mnasiadka> But today it did not fail
15:17:02 <mnasiadka> mgoddard: just rechecked it
15:17:14 <mnasiadka> If it won’t fail it’s good to go
15:17:39 <mnasiadka> So no persistent CI issues
15:18:04 <yoctozepto> mnasiadka: I approved it :/
15:18:18 <mgoddard> the prometheus alertmanager one sounds worthy of a bug
15:18:43 <mnasiadka> I’m thinking if we should raise bugs for CI issues with CI tag
15:18:46 <mgoddard> who would like to create one?
15:18:56 <yoctozepto> prometheus yes
15:19:13 <mgoddard> #action yoctozepto create a bug for alertmanager issue
15:19:25 <mgoddard> CI tag seems like a good idea
15:19:39 <mgoddard> although let's not assume it means CI only
15:20:01 <yoctozepto> but prometheus is not only in CI
15:20:07 <mgoddard> indeed
15:20:12 <yoctozepto> though the others are
15:20:19 <yoctozepto> I will report bug on prometheus
15:20:22 <mgoddard> k
15:20:23 <yoctozepto> and not the others
15:20:31 <mgoddard> what's the tacker/aodh one?
15:20:51 <yoctozepto> just I am not fixing nfv if nobody cares
15:20:59 <mgoddard> missing from GATE_IMAGES?
15:21:00 <yoctozepto> needs to add aodh to the built images
15:21:04 <yoctozepto> yes ;-)
15:21:09 <mgoddard> k
15:21:15 * yoctozepto was waiting for nfv caring ppl
15:21:44 <mnasiadka> Drop nfv job?
15:21:51 <mnasiadka> If nobody cares?
15:22:02 <mgoddard> #action mgoddard fix one line nfv job
15:22:28 <yoctozepto> mnasiadka: seemingly mgoddard cared enough :D
15:22:47 <mnasiadka> yoctozepto: good for him:)
15:23:01 <yoctozepto> good for mgoddard indeed
15:23:10 <mgoddard> care enough to fix one line
15:23:54 <mnasiadka> And then you’ll realise you opened a box of issues?:)
15:23:57 <mgoddard> I think kayobe CI is fine now, thanks to priteau for fixing this week's fire
15:24:17 <mgoddard> #topic Wallaby release planning
15:24:27 <mgoddard> First item: Deprecate the Tempest image?
15:24:48 <mgoddard> and presumably rally with it?
15:25:07 <mnasiadka> Rally is being used
15:25:17 <openstackgerrit> Merged openstack/kayobe stable/victoria: Disable Bifrost cleaning by default  https://review.opendev.org/c/openstack/kayobe/+/788281
15:25:20 <mnasiadka> At least by me :)
15:25:26 <mgoddard> Why would we delete one without the other?
15:25:35 <mgoddard> s/delete/deprecate/
15:25:38 <yoctozepto> why not?
15:25:43 <mnasiadka> mgoddard: rally doesn’t use tempest docker image?
15:26:03 <mgoddard> no, but if tempest is out of scope for kolla then so is rally
15:26:03 <mnasiadka> Rally installs tempest during runtime
15:26:21 <yoctozepto> mgoddard, mnasiadka: can we just document
15:26:23 <yoctozepto> how to use them
15:26:27 <yoctozepto> from a regular venv?
15:26:35 <yoctozepto> how they are normally used 99.9% of the time
15:26:44 <mnasiadka> Why would we document it?
15:26:56 <mnasiadka> Is it Kolla or Tempest/Rally?
15:26:58 <yoctozepto> s/document/link to the proper documentation
15:27:30 <yoctozepto> in that sense I would drop both
15:27:39 <yoctozepto> well, deprecate in W and drop in X
15:27:43 <yoctozepto> but you know the drill :-)
15:28:07 <hrw> quick job
15:28:16 <mgoddard> personally I don't think kolla is the right place for them, and we don't do a great job with them
15:28:24 <yoctozepto> we do no job with them
15:28:27 <mgoddard> OTOH, it seems some people use them
15:28:35 <yoctozepto> but these are clients
15:28:46 <yoctozepto> we will never deploy them as services ;-)
15:28:56 <mgoddard> k-a has roles for them
15:29:50 <yoctozepto> yeah, but they are not services
15:30:00 <mgoddard> rally is a bit more than a client - it has state. Agreed it's not a service though
15:30:27 <yoctozepto> perhaps a spinoff project?
15:30:36 <yoctozepto> with only the master branch
15:30:43 <yoctozepto> we can pull it off ;-)
15:31:03 <yoctozepto> kolla-stressor
15:31:21 <hrw> yoctozepto: and you will be PTL there to stress yourself
15:31:22 <mgoddard> https://opendev.org/openstack/rally/src/branch/master/DOCKER_README.md
15:31:35 <yoctozepto> hrw: no, under kolla we have one PTL - the great mgoddard
15:31:48 <yoctozepto> all others are just usurpers
15:32:18 <yoctozepto> ok, just link to the documentation
15:32:22 <yoctozepto> and we are golden
15:32:25 <yoctozepto> who is with me
15:33:05 <jovial[m]> Personally I find docker execing into a sleep infinity container a bit clunky
15:33:30 <mgoddard> We normally try to get some feedback before going for deprecation
15:34:00 <hrw> deprecate++
15:34:19 <yoctozepto> deprecate > feedback
15:34:26 <hrw> mgoddard: we may deprecate in W and hold with dropping
15:34:31 <mgoddard> ok
15:34:35 <hrw> in worst case we de-deprecate it
15:34:43 <yoctozepto> hrw++
15:34:51 <yoctozepto> we don't have to drop right away
15:34:54 <yoctozepto> just during the cycle
15:34:54 <mgoddard> but I feel feel that rally and tempest are in the same bucket
15:34:59 <yoctozepto> mgoddard++
15:35:04 <yoctozepto> deprecate both
15:35:04 <mgoddard> *still
15:35:12 <mgoddard> mnasiadka may be unhappy
15:35:28 <mnasiadka> Well, I have one year to update a simple playbook
15:35:33 <mnasiadka> I’ll manage
15:35:34 <hrw> we have gazillion of images. we marked some as 'maybe someone support but not us'
15:35:46 <mgoddard> ok, let's move on
15:35:56 <yoctozepto> mgoddard: mnasiadka will be better off with the common way rather than sleep infinity
15:36:00 <mgoddard> #action yoctozepto deprecate rally & tempest
15:36:07 <yoctozepto> what an honor, sir!
15:36:12 <mnasiadka> yoctozepto: I like sleeping!
15:36:15 * yoctozepto Lord Deprecator
15:36:34 <mgoddard> now onto actual wallaby release stuff :)
15:36:43 <mgoddard> https://etherpad.opendev.org/p/KollaWhiteBoard
15:36:45 <hrw> Bullseye is in ;D
15:36:45 <mgoddard> L166
15:36:51 <yoctozepto> merging, merging
15:39:35 <mgoddard> hmm
15:39:39 <mgoddard> why did we abandon https://review.opendev.org/c/openstack/kolla/+/785622 ?
15:39:51 <mgoddard> (centos-release-openstack-wallaby on master)
15:40:03 <hrw> yoctozepto, mnasiadka: your work
15:40:22 <yoctozepto> mgoddard: we do it directly on wallaby
15:40:30 <yoctozepto> pointless on master since branched
15:41:19 <mgoddard> I thought we were planning to keep master == wallaby for a while this cycle?
15:42:12 <yoctozepto> mgoddard: well, it would make things like the bifrost job irrelevant
15:42:37 <yoctozepto> I guess what we need is
15:42:45 <yoctozepto> k-a testing voting with w images
15:42:48 <mgoddard> but this is just RDO packages
15:43:07 <mnasiadka> We already have RDO packages in master
15:43:07 <yoctozepto> mgoddard: won't we revert all other kolla changes?
15:43:24 <yoctozepto> to get kolla master == world master ?
15:43:28 <mgoddard> this is Xena chat. Let's revisit later
15:43:38 <mnasiadka> And we didn’t conclude on the approach for master
15:43:41 <yoctozepto> yeah, perhaps we misunderstood
15:43:48 <yoctozepto> let's chat later
15:43:59 <yoctozepto> some things still merging on master
15:44:03 <yoctozepto> as we want them there
15:44:07 <yoctozepto> and then backported to wallaby
15:44:17 <yoctozepto> some pending merge on wallaby/stable
15:44:30 <yoctozepto> https://review.opendev.org/q/project:openstack%252Fkolla+branch:stable%252Fwallaby
15:44:34 <yoctozepto> well, stable/wallaby
15:44:41 * yoctozepto head spin
15:45:08 <yoctozepto> https://review.opendev.org/q/project:openstack%252Fkolla-ansible+branch:stable%252Fwallaby
15:45:55 <mgoddard> kevko: do you have time to address the mariadb shards docs?
15:47:19 <hrw> https://review.opendev.org/c/openstack/kolla/+/784923 - do we want sorted-out APT keys in wallaby?
15:48:25 <yoctozepto> we may
15:49:08 <mgoddard> seems like a big change for this point in the cycle
15:49:46 <mnasiadka> Does it affect users?
15:49:54 <yoctozepto> well, then we need to revert that deprecation
15:50:05 <yoctozepto> as we know it's phony
15:50:12 <mgoddard> which deprecation?
15:50:14 <hrw> should not affect as repos are the same
15:50:23 <yoctozepto> mgoddard: the one reverted in that commit
15:50:26 <yoctozepto> https://review.opendev.org/c/openstack/kolla/+/784923/15/releasenotes/notes/deprecate-apt-keys-eff6e68272923b6b.yaml
15:50:52 <hrw> ah. have to rephrase it to version in 10th revision
15:51:14 <hrw> or rewrite
15:51:28 <hrw> as it turns out that apt_keys will stay with us for longer ;(
15:53:23 <mgoddard> looks like we need to revert that deprecation then
15:54:28 <openstackgerrit> Marcin Juszkiewicz proposed openstack/kolla master: Revert "deprecate use of GnuPG ids for APT keys"  https://review.opendev.org/c/openstack/kolla/+/788519
15:55:00 <hrw> done
15:55:05 <yoctozepto> fast
15:55:13 <mgoddard> I think that unless there is some nice benefit to the change in APT key usage we should keep it for Xena
15:55:28 <yoctozepto> approved
15:55:37 <hrw> mgoddard: and we need https://review.opendev.org/c/openstack/kolla/+/784923 for that - so we have keys linked to repos
15:55:41 <mgoddard> we have other big changes going on
15:56:18 <mgoddard> hrw: I thought that's the patch we're talking about
15:56:23 <yoctozepto> big boys with their big... changes
15:56:42 <hrw> mgoddard: si
15:57:10 <mgoddard> almost out of time for this week
15:57:17 <mgoddard> #topic Open discussion
15:57:38 <headphoneJames> can I get some initial reviews for: https://review.opendev.org/c/openstack/kolla-ansible/+/787420
15:57:51 <headphoneJames> broke up the LE work
15:58:41 <mgoddard> what happened to the old patch?
15:59:03 <headphoneJames> still there, not yet abandoned
15:59:31 <headphoneJames> if more useful, I can rework this into the old one
15:59:56 <mnasiadka> mgoddard: what happened with the Xena topics?
16:00:05 <mgoddard> mnasiadka: out of time
16:00:10 <mgoddard> next week
16:00:13 <mnasiadka> ok then
16:00:21 <yoctozepto> need to push wallaby
16:00:26 <yoctozepto> thanks mgoddard for chairing
16:00:38 <mgoddard> headphoneJames: it might be nice to keep the history, but it's up to you
16:00:47 <hrw> push wallaby and then days of new development before moving to Xena sources/binaries
16:00:53 <mgoddard> perhaps you're tired of that patch number :)
16:01:20 <mnasiadka> hrw: development before going on vacation you mean ;)
16:01:44 <mgoddard> Thanks all
16:01:47 <mgoddard> #endmeeting