15:00:56 <mgoddard> #startmeeting kolla
15:00:57 <openstack> Meeting started Wed May 12 15:00:56 2021 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <openstack> The meeting name has been set to 'kolla'
15:01:44 <mgoddard> #topic rollcall
15:02:03 <hrw> /o\
15:02:45 <wuchunyang> o
15:02:47 <mgoddard> \o
15:02:52 <jpward> o/
15:02:58 <headphoneJames> o/
15:03:03 <kemopq> I'm new here.
15:03:20 <jamesbenson> o/
15:04:05 <kemopq> Hello to all!
15:04:27 <wuchunyang> welcome
15:04:40 <hrw> kemopq: during this hour we have a meeting. stay, ask questions if they fit agenda.
15:05:00 <mgoddard> #topic agenda
15:05:12 <mgoddard> * Roll-call
15:05:15 <mgoddard> * Agenda
15:05:17 <mgoddard> * Announcements
15:05:19 <mgoddard> * Review action items from the last meeting
15:05:21 <mgoddard> * CI status
15:05:23 <mgoddard> * Wallaby release planning
15:05:25 <mgoddard> ** Debian bullseye
15:05:27 <mgoddard> ** monasca-grafana
15:05:29 <mgoddard> ** chrony
15:05:31 <mgoddard> * Xena cycle planning
15:05:33 <mgoddard> ** master branch life cycle
15:05:35 <mgoddard> * Open discussion
15:05:37 <mgoddard> #topic announcements
15:06:37 <mgoddard> Please welcome kemopq (Klemen Pogacnik)
15:07:04 <mgoddard> Klemen responded to the request for help that I added to the PTG summary email
15:07:37 <headphoneJames> welcome kemopq!
15:07:48 <wuchunyang> welcome
15:07:54 <jamesbenson> Welcome Kemopq!  :-D
15:07:56 <kemopq> Thanks! I really appreciated your work.
15:07:56 <mgoddard> kemopq offers some time to help with reviews, development, docs, bugs, etc
15:08:25 <mgoddard> So please help if kemopq has any questions while getting up and running
15:08:25 <hrw> cool ;D
15:08:49 <kemopq> We were already talking with mgoddard to start with docs and reviews.
15:09:03 <mgoddard> kemopq: do you have a 1-2 line intro?
15:09:43 <kemopq> OK, I have a reach history of programing in C and C++.
15:10:07 <kemopq> I was specialized on providing high availability of embedded systems
15:10:30 <kemopq> In recent times I'm working on cloud platforms.
15:10:48 <kemopq> I use kolla and kolla-ansible since Rocky release.
15:10:56 <mgoddard> Thanks kemopq, looking forward to working with you
15:11:22 <kemopq> I'm looking forward too
15:11:23 <mgoddard> If anyone else would like to get more involved upstream, please do speak up - we are more than happy to help get you up and running
15:11:50 <mgoddard> Let's get going, we have a few topics today
15:11:52 <mgoddard> mnasiadka: ping
15:12:01 <mgoddard> #topic Review action items from the last meeting
15:12:18 <mgoddard> mgoddard email openstack-discuss about quay.io credentials
15:12:21 <mgoddard> :(
15:12:22 <mgoddard> #action mgoddard email openstack-discuss about quay.io credentials
15:12:26 <mgoddard> one day
15:12:30 <mgoddard> #topic CI status
15:13:13 <mgoddard> https://etherpad.opendev.org/p/KollaWhiteBoard
15:13:18 <mgoddard> L40
15:13:55 <mgoddard> we had a fix for prometheus land today, backports in progress
15:14:19 <mgoddard> same with the elasticsearch issue
15:15:00 <mgoddard> easy one to fix the nfv job: https://review.opendev.org/c/openstack/kolla-ansible/+/788687
15:15:41 <mgoddard> #topic Wallaby release planning
15:15:50 <mgoddard> #topic Debian bullseye
15:16:16 <mgoddard> https://etherpad.opendev.org/p/KollaWhiteBoard
15:16:19 <mgoddard> L187
15:17:14 <mgoddard> mnasiadka looked at this
15:17:20 <mgoddard> the libvirt/cgroups issue
15:17:41 <mgoddard> he created https://gitlab.com/libvirt/libvirt/-/issues/163
15:18:39 <mgoddard> he also started a patch to configure the kernel for cgroups v1 and reboot in CI: https://review.opendev.org/c/openstack/kolla-ansible/+/790922
15:18:49 <mgoddard> which looks like it passes
15:18:57 <mgoddard> so that might be the simplest option
15:19:22 <hrw> at least it works
15:19:55 <mgoddard> right
15:20:15 <mgoddard> we might still consider a host libvirtd, but don't need to be blocked by it
15:20:42 <mgoddard> he then found the same OVS 2.15 issue we had in Ubuntu
15:21:11 <mgoddard> only problem is that in Debian bullseye there is no 2.13 to pin to
15:21:33 <mgoddard> so I think that's the new blocker
15:21:37 <hrw> kevko: any help/ideas?
15:22:12 <mgoddard> debian openstack team must have the same issue, so suggest we collaborate
15:22:43 <kevko> sorry, didn't follow ...what's a problem ?
15:24:53 <mgoddard> our debian upgrade jobs fail on bullseye due to OVS 2.15
15:28:00 <mgoddard> well, I don't think we'll solve it here
15:28:11 <mgoddard> kevko: mariadb docs pls
15:28:26 <mgoddard> #topic monasca-grafana
15:28:48 <kevko> mgoddard: tomorrow i will process
15:28:52 <mgoddard> thanks
15:29:09 <kevko> and i have to leave guys ..i am already late :(
15:29:17 <mgoddard> k, bye kevko
15:29:39 <mgoddard> currently the monasca-grafana image doesn't build
15:29:48 <mgoddard> but we still try to deploy it in the monasca role
15:29:55 <mgoddard> so we need to either fix it, or drop it
15:30:07 <hrw> drop
15:30:18 <mgoddard> no surprises from hrw :)
15:30:38 <mgoddard> it's not quite that simple
15:31:06 <mgoddard> before dropping we would need to switch the monasca role to use the vanilla grafana image
15:31:17 <mgoddard> which is started here: https://review.opendev.org/c/openstack/kolla-ansible/+/788228
15:31:23 <hrw> I know, joking
15:31:43 <mgoddard> dougsz is not available today sadly
15:31:47 <hrw> monasca-grafana was known to be timebomb since ussuri or earlier
15:31:58 <hrw> we just kept ignoring it's low quality
15:32:36 <mgoddard> thanks openstackstatus
15:33:32 <mgoddard> I think we need to speak to dougsz for this one
15:33:48 <mgoddard> #topic chrony
15:34:02 <mgoddard> We deprecated the chrony container in Wallaby
15:34:12 <mgoddard> But we didn't add the code to remove it
15:34:25 <mgoddard> So we need to do that
15:34:28 <mgoddard> anyone want to pick it up?
15:34:39 <hrw> it is k-a so not me, sorry
15:35:34 <wuchunyang> i can do it
15:35:51 <mgoddard> great, thanks wuchunyang
15:36:18 <mgoddard> probably we can use the common role, in upgrade.yml
15:36:41 <mgoddard> #topic master branch life cycle
15:36:54 <hrw> o, good one
15:36:57 <mgoddard> yes
15:37:08 <mgoddard> we have missed this the last few weeks
15:37:25 <mgoddard> I think we're lacking mnasiadka and yoctozepto6 though, which could make it tough
15:37:40 <mgoddard> let's see how we go
15:38:00 <mgoddard> we're probably at the stage where we should open up the master branch for development
15:38:27 <hrw> but stay on wallaby sources to have some sanity
15:38:36 <mgoddard> that was the proposal at the PTG
15:38:42 <hrw> yep
15:38:49 <hrw> https://etherpad.opendev.org/p/kolla-xena-ptg L283
15:40:07 <mgoddard> so what do we need to do? Disable binary CI jobs?
15:40:20 <hrw> we can leave them as they are
15:40:53 <hrw> I am more thinking what to do about publishing
15:41:54 <hrw> as for next month or two master == wallaby openstack so some users may find it weird. on the other side - their problem. master was never meant for production and can eat your kitten
15:42:33 <mgoddard> right - nobody should be using master except for development
15:43:19 <hrw> and we can have some changes which alter binary images as well. so when we keep them on ci it gets caught now instead months later
15:44:23 <mgoddard> +1
15:44:44 <mgoddard> so all we need to do for now is announce that master is open for development?
15:45:40 <hrw> basically yes
15:45:54 <mgoddard> ok
15:46:02 <mgoddard> anyone have questions or thoughts?
15:46:19 <hrw> and then we do development. in 2 months from now we move to Xena sources, and then to binaries
15:46:41 <hrw> UCA/Xena exists already btw. builds even
15:47:36 <mgoddard> I think we need to write this down, then send it to openstack-discuss
15:47:56 <hrw> yep
15:47:59 <mgoddard> I'll try to come up with something, then we can look at it in next week's meeting
15:48:14 <hrw> ok
15:48:16 <hrw> thanks
15:48:45 <mgoddard> #action mgoddard draft proposal for new release process
15:49:14 <mgoddard> #topic Open discussion
15:49:32 <hrw> we managed to squeeze it into meeting time ;D
15:49:54 <mgoddard> that's what happens when yoctozepto6 is away :)
15:50:00 <hrw> ;P
15:50:34 <hrw> anyone has some patch needing review?
15:50:51 <headphoneJames> well . . . .
15:50:59 <headphoneJames> https://review.opendev.org/c/openstack/kolla-ansible/+/741340
15:51:12 <hrw> mgoddard: once we open master I would love to see all those drops merged.
15:51:26 <hrw> Let's Decrypt?
15:52:21 <headphoneJames> Decrypt to the moon
15:52:37 <hrw> it is all certs all way down
16:00:54 * hrw off
16:04:40 <mgoddard> thanks all
16:04:42 <mgoddard> #endmeeting