15:00:14 <mgoddard> #startmeeting kolla
15:00:14 <opendevmeet> Meeting started Wed Aug 18 15:00:14 2021 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:14 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <opendevmeet> The meeting name has been set to 'kolla'
15:00:18 <mgoddard> #topic rollcall
15:00:22 <mgoddard> \o
15:01:40 <priteau> o/
15:02:13 <headphoneJames> o/
15:02:25 <yoctozepto> o/
15:04:05 <mgoddard> #topic agenda
15:04:13 <mgoddard> * Roll-call
15:04:14 <mgoddard> * Agenda
15:04:16 <mgoddard> * Announcements
15:04:18 <mgoddard> * Review action items from the last meeting
15:04:20 <mgoddard> * CI status
15:04:22 <mgoddard> * Release tasks
15:04:24 <mgoddard> * Xena cycle planning
15:04:26 <mgoddard> ** Prepare cycle highlights
15:04:28 <mgoddard> ** Inspur's Venus proposed to Kolla and Kolla Ansible
15:04:30 <mgoddard> ** Xena feature prioritisation https://docs.google.com/spreadsheets/d/1BuVMwP8eLnOVJDX8f3Nb6hCrNcNpRQl57T2ENU9Xao8
15:04:32 <mgoddard> * Open discussion
15:04:34 <mgoddard> #topic announcements
15:04:46 <yoctozepto> mnasiadka will be our PTL
15:04:52 <yoctozepto> long live kolla :D
15:04:55 <mgoddard> hold fire yoctozepto
15:05:04 <mgoddard> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-August/024191.html
15:05:06 <yoctozepto> ok, sorry :D
15:05:25 <mgoddard> #info TC & PTL elections are in progress
15:05:39 <mgoddard> Kolla PTL position is open
15:05:48 <mgoddard> We have a nomination from mnasiadka
15:06:22 <yoctozepto> thanks mgoddard for those 5 cycles and thanks mnasiadka for nominating himself
15:06:25 <priteau> +1
15:06:39 <mgoddard> But of course this is a (weird) democracy, so nominations are still possible!
15:07:17 <mgoddard> #topic Review action items from the last meeting
15:07:31 <mgoddard> priteau to Switch binary images to current release
15:07:32 <mgoddard> clean up whiteboard priorities
15:07:34 <mgoddard> mgoddard check in with RDO re CS9
15:07:41 <mgoddard> priteau did his
15:07:54 <priteau> Sort of. Ubuntu blocked on UCA
15:08:11 <priteau> I've asked on their IRC channel but no one replied to me
15:08:18 <mgoddard> ah
15:08:59 <priteau> I will try email contact
15:09:04 <mgoddard> thanks
15:09:14 <mgoddard> looks like yoctozepto cleaned up the whiteboard
15:09:24 <mgoddard> I did  check in with RDO re CS9
15:09:38 <mgoddard> tl;dr CS9 can wait until yoga
15:10:14 <mgoddard> Xena may get CS9 support in RDO, but it will probably arrive after initial release
15:10:22 <yoctozepto> I did clean up, yes
15:11:08 <mgoddard> #topic CI status
15:11:59 <mgoddard> CI seems ok
15:12:07 <mgoddard> is anyone aware of issues?
15:12:28 <yoctozepto> just regular randoms
15:12:33 <yoctozepto> nothing blocked as far as I saw
15:12:39 * yoctozepto glad
15:12:57 <priteau> Same in Kayobe
15:12:58 <mgoddard> can someone approve https://review.opendev.org/c/openstack/kolla-ansible/+/804455 to fix debian upgrades?
15:15:07 <mgoddard> #topic Release tasks
15:15:41 <mgoddard> we are in R-7
15:15:54 <mgoddard> cycle highlights deadline is 2 weeks away
15:16:27 <mgoddard> let's look at those now
15:16:31 <mgoddard> #topic Prepare cycle highlights
15:16:58 <mgoddard> #link https://docs.openstack.org/releasenotes/kolla/unreleased.html
15:17:04 <mgoddard> #link https://docs.openstack.org/releasenotes/kolla-ansible/unreleased.html
15:17:08 <mgoddard> #link https://docs.openstack.org/releasenotes/kayobe/unreleased.html
15:17:41 <mgoddard> we need 4-5 highlights
15:19:55 <yoctozepto> kolla ansible looks most promising
15:20:12 <yoctozepto> though most are wallaby as well
15:20:26 <mgoddard> * Hashi vault integration
15:21:00 <mgoddard> * ansible performance
15:21:36 <yoctozepto> work on performance and reliability yes
15:21:57 <mgoddard> that's all I'm seeing
15:22:00 <yoctozepto> multiple inventories perhaps?
15:22:09 <yoctozepto> it's simple but perhaps nice to let users know
15:22:28 <mgoddard> I expect (hope) we'll have more by the end of our cycle
15:22:56 <mgoddard> we don't need to use fillers at this point
15:23:37 <yoctozepto> ok
15:23:54 <yoctozepto> then I agree on both bullets so far
15:24:26 <opendevreview> Merged openstack/kolla stable/wallaby: Config: allow to set group for user  https://review.opendev.org/c/openstack/kolla/+/804855
15:25:29 <mgoddard> let's leave it there then
15:25:38 <mgoddard> #action mgoddard propose initial cycle highlights
15:25:42 <mgoddard> #topic Inspur's Venus proposed to Kolla and Kolla Ansible
15:26:11 <mgoddard> yoctozepto?
15:27:03 <yoctozepto> yes
15:27:17 <yoctozepto> what is our stance on that?
15:27:31 <yoctozepto> venus has proposed to become an official OpenStack project
15:27:43 <yoctozepto> they have proposed patches to add venus to kolla and kolla-ansible
15:27:57 <yoctozepto> I invited them to join our meeting for any questions but unsure if they are around
15:28:09 <yoctozepto> brinzhang_ seems to be here
15:28:29 <yoctozepto> from my POV, there is nothing blocking us policy-wise from accepting Venus
15:28:36 <yoctozepto> just need a regular code review
15:28:38 <yoctozepto> wdyt?
15:28:53 <mgoddard> we can add any code we like
15:29:11 <yoctozepto> https://review.opendev.org/q/topic:%22venus%22+(status:open%20OR%20status:merged)
15:29:20 <mgoddard> I'd say it's more from a sustainability perspective, an official project it more likely to survive
15:29:27 <yoctozepto> mgoddard: yeah, but I remember there were some sustainability questions
15:29:27 <yoctozepto> yes
15:30:00 <yoctozepto> https://review.opendev.org/c/openstack/governance/+/804824
15:30:55 <yoctozepto> I think TC would also be eager to accept Venus
15:31:04 <yoctozepto> but I need to wait till tomorrow's meeting to know more
15:31:40 <yoctozepto> any doubts to solve at this point?
15:33:37 <mgoddard> should we wait for a green light from the TC?
15:34:30 <yoctozepto> I don't think we need to
15:34:37 <yoctozepto> as we can easily unblock our gates
15:35:04 <yoctozepto> the question is perhaps whether we don't want to request venus scenario
15:35:30 <yoctozepto> recently we've been adding new projects with scenarios (vide masakari)
15:36:44 <mgoddard> how would we prioritise it?
15:37:13 <mgoddard> according to renos we haven't merged any significant features this cycle...
15:38:43 <yoctozepto> yeah, honestly, I would prioritise this
15:39:14 <yoctozepto> we have the proxysql stack from kevko that looks reasonable
15:39:28 <yoctozepto> and the tls work by headphoneJames
15:39:34 <yoctozepto> and this Venus
15:39:50 <mgoddard> we have a ton of things
15:41:28 <mgoddard> how would venus interact with our existing fluentd/elastic setup?
15:42:40 <yoctozepto> yeah, that's a good question; I understand it replaces it
15:42:41 <yoctozepto> but can
15:42:50 <yoctozepto> can't tell for sure
15:43:04 <yoctozepto> I have not seen it in action in k-a yet
15:43:33 <mgoddard> do we want to rip out what we have and replace it?
15:45:41 <mgoddard> For me this comes back to the issue of prioritisation
15:46:07 <mgoddard> we don't have a good way to visualise our work in progress, and prioritise it
15:46:09 <yoctozepto> yeah, I'm thinking
15:46:27 <mgoddard> how can we weigh up venus against everything else in flight?
15:46:31 <yoctozepto> as a side note, I remember you had issues with monasca
15:46:38 <yoctozepto> I understand this would replace monasca as well
15:46:51 <yoctozepto> that's a very good question that you have
15:46:53 <mgoddard> does it provide an API to users?
15:47:50 <yoctozepto> mgoddard: last inspur's answer to that was inconclusive
15:48:03 <yoctozepto> perhaps let's collect questions to ask and ask them
15:48:59 <mgoddard> I'd like to see a paragraph or two about how it fits into kolla, what it replaces, and what it adds
15:48:59 <yoctozepto> as for stuff prioritisation; I asked kevko to sum up the patches that make up his proxysql effort
15:49:15 <yoctozepto> so that at least helps to grasp where the parts are
15:49:20 <yoctozepto> we used the whiteboard for that
15:49:56 <yoctozepto> ok, I'm writing down what to ask for
15:52:37 <mgoddard> ok
15:52:53 <mgoddard> #action yoctozepto to get more info about venus
15:53:00 <yoctozepto> ok
15:53:17 <mgoddard> seems like whatever we want to know the TC should also know before accepting
15:53:30 <yoctozepto> not really
15:53:42 <yoctozepto> TC does not care whether it replaces elasticsearch (-:
15:53:49 <yoctozepto> but yeah, mostly
15:54:13 <yoctozepto> I will be their liaison anyhow so will get most interaction
15:54:19 <mgoddard> TC should have a reasonable idea of how the thing works and what it does IMO
15:54:28 <yoctozepto> yeah, that part yes
15:54:39 <yoctozepto> but I was playing on that "whatever" ;p
15:54:52 <mgoddard> #topic Open discussion
15:55:04 <mgoddard> Does anyone have anything to discuss?
15:55:16 <yoctozepto> not me
15:55:18 <mgoddard> Do we need to change the time of the meeting/
15:55:28 <mgoddard> mnasiadka is rarely here for it
15:55:36 <yoctozepto> yeah, do you know why?
15:55:41 <yoctozepto> you work together
15:55:42 <mgoddard> which may become a problem in a few weeks
15:56:14 <yoctozepto> or should I interrogate him in our mother tongue?
15:56:15 <yoctozepto> :D
15:56:16 <mgoddard> well, it's 17:00 - 18:00 so I guess he's being a dad
15:56:37 <yoctozepto> yeah, you can probably relate
15:56:41 <yoctozepto> I can't
15:57:47 <mgoddard> #action mgoddard ask mnasiadka about meeting time
15:58:24 <yoctozepto> great
15:58:39 <mgoddard> let's finish early, have 2 minutes back
15:58:41 <priteau> Regarding Xena binary images, I have email two people at Canonical
15:58:41 <mgoddard> thanks all
15:58:52 <priteau> Hopefully it will be unblocked soon
15:58:58 <mgoddard> thanks priteau
15:59:03 <mgoddard> #endmeeting