15:00:22 <mnasiadka> #startmeeting kolla
15:00:22 <opendevmeet> Meeting started Wed Aug 25 15:00:22 2021 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:22 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:22 <opendevmeet> The meeting name has been set to 'kolla'
15:00:31 <yoctozepto> \o/
15:00:32 <mnasiadka> #topic rollcall
15:00:35 <yoctozepto> \o/
15:00:48 <mnasiadka> o/
15:01:06 <mgoddard> \o
15:01:47 <headphoneJames> hopefully some system scope o/
15:01:51 <jd2021> ignaziocassano: that's what we would like to do (dell volume example). I'll will look into it. ~
15:01:58 <parallax> o/
15:02:32 <jd2021> thanks
15:03:00 <mnasiadka> jd2021: we're holding a meeting now, please follow up on non-meeting topics after it ends :)
15:03:09 <mnasiadka> #topic agenda
15:03:09 <yoctozepto> headphoneJames: system scope? ;o
15:03:26 <mnasiadka> * Announcements
15:03:26 <mnasiadka> ** Congratulations to mnasiadka on becoming PTL :)
15:03:26 <mnasiadka> * Review action items from the last meeting
15:03:26 <mnasiadka> * CI status
15:03:26 <mnasiadka> * Release tasks
15:03:28 <mnasiadka> * Xena cycle planning
15:03:28 <mnasiadka> ** Xena feature prioritisation https://docs.google.com/spreadsheets/d/1BuVMwP8eLnOVJDX8f3Nb6hCrNcNpRQl57T2ENU9Xao8
15:03:30 <mnasiadka> * handling of APT keys - https://review.opendev.org/c/openstack/kolla/+/784923 (hrw, Fl1nt)
15:03:30 <mnasiadka> * Yoga PTG planning
15:03:30 <ignaziocassano> jd2021: so you must look at cinder driver documentation for netapp model you are using, and the create the cinder.conf for it and put it in /etc/kolla/config/cinder.conf. I think there is also somthing to enable multipath for libvirt
15:03:32 <mnasiadka> * Open discussion
15:03:48 <headphoneJames> congrads to mnasiadka!!
15:04:06 <parallax> :)
15:04:15 <mnasiadka> #topic Announcements
15:04:49 <yoctozepto> congrats to mnasiadka <3
15:04:53 <mgoddard> +1
15:05:03 <mnasiadka> Thanks for all the good votes, hoping mgoddard will help during the transition period :-)
15:05:17 <mgoddard> of course!
15:05:28 * yoctozepto will be there to ensure mgoddard helps
15:05:33 <yoctozepto> :-)
15:05:36 <ignaziocassano> jd2021: kolla add only some automation to openstack and for configuration of single cinder driver you must look at its documentation
15:05:40 <jd2021> The cinder netapp driver has dropped the support for the e-series a few years ago (unified driver)
15:05:46 <yoctozepto> ignaziocassano, jd2021: please don't interrupt the meeting
15:05:49 <opendevreview> Merged openstack/kolla master: Revert "Update code to Jinja 3.0 style"  https://review.opendev.org/c/openstack/kolla/+/805897
15:05:58 <ignaziocassano> sorry
15:06:10 <ignaziocassano> good bye
15:06:20 <mnasiadka> Ok then, let's continue
15:06:31 <mnasiadka> #topic Review action items from the last meeting
15:06:39 <jd2021> sorry, bye
15:07:31 <mnasiadka> seems none outstanding from last time
15:07:47 <mnasiadka> oh, mgoddard to propose cycle highlights
15:08:06 <yoctozepto> he did not :O
15:08:08 <mgoddard> hmm, I think I did not
15:08:30 <mgoddard> action me again
15:08:52 <mnasiadka> #action mgoddard to propose initial cycle highlights
15:08:52 <yoctozepto> mortal stack : action him!
15:09:27 <mnasiadka> did we merge the binary switch to current release? there was some problem with UCA
15:09:31 <yoctozepto> (come on, no mortal kombat players?)
15:10:13 <mnasiadka> yoctozepto: high school times, nearly forgot about it ;)
15:10:27 <yoctozepto> mnasiadka: :D
15:10:33 <mgoddard> yes, UCA is now Xena
15:10:36 <yoctozepto> I think we merged the relevant patches
15:10:53 <yoctozepto> debian will release when openstack does
15:11:07 <mnasiadka> ok then
15:11:21 <mnasiadka> #topic CI status
15:12:11 <mnasiadka> seems it's green-ish
15:12:22 <mnasiadka> do we need to discuss any particular CI issue?
15:12:49 <mgoddard> I'm not aware of any new ones
15:12:54 <yoctozepto> nope
15:13:01 <yoctozepto> everything known
15:13:19 <mnasiadka> great to hear/see
15:13:27 <mnasiadka> #topic Release tasks
15:14:02 <knockknock> hello
15:14:31 <mnasiadka> R-5 cycle highlights deadline - that we have action on mgoddard
15:15:00 <mgoddard> knockknock: we're in a meeting currently, should end in ~45m
15:15:18 <knockknock> I'm setting up openstack for the first time with kolla and I either misconfigured something or found a bug. It looks like a file either isn't being downloaded or is missing from the docker image. Any suggestions on figuring out if I screwed something up or if it's an actual bug?
15:15:20 <mnasiadka> R-1: Prepare for RC1 & stable branch creation - that will be next
15:15:22 <knockknock> ah sorry
15:15:56 <yoctozepto> how far till feature freeze
15:16:09 <yoctozepto> I might want to drop in support for consul (for masakari)
15:16:31 <mnasiadka> R-5 is feature freeze - so next week
15:17:16 <mnasiadka> should we identify features we want to push in, maybe hashtag them (?) and focus on reviewing?
15:17:36 <mgoddard> crikey, feature freeze next week
15:17:58 <mnasiadka> that's what they say here: https://releases.openstack.org/xena/schedule.html
15:18:38 <mgoddard> ah, that's openstack ff
15:18:41 <mgoddard> we have our own
15:19:13 <mgoddard> I don't think it's included in the timeline
15:19:16 <yoctozepto> mnasiadka: stop scaring poor people
15:19:34 <mgoddard> "There is no official feature freeze date for the cycle-trailing model, but we aim to freeze three weeks after the common feature freeze"
15:19:37 <yoctozepto> mgoddard: when do we want it then? I need ~month I guess?
15:19:41 <mgoddard> R-2
15:19:49 <mnasiadka> mgoddard: it's not in https://docs.openstack.org/kolla/latest/contributor/release-management.html#release-schedule - should we add it there?
15:19:52 <yoctozepto> then that should be enough + asking for FFE
15:19:56 <yoctozepto> ack
15:19:57 <mgoddard> yes, we should add
15:20:07 <mnasiadka> any volunteer for adding? ;)
15:20:24 <mgoddard> go on then
15:22:33 <mnasiadka> ok then, let me take this, should be easyfix
15:22:46 <mgoddard> I meant I can do it
15:22:52 <mnasiadka> ah
15:23:03 <mnasiadka> #action mgoddard to add FFE on R-2 to release-management docs
15:23:07 <mnasiadka> thank you mgoddard
15:23:20 <opendevreview> Mark Goddard proposed openstack/kolla master: docs: add feature freeze to release management  https://review.opendev.org/c/openstack/kolla/+/806013
15:23:21 <mgoddard> done :D
15:23:38 <mnasiadka> that's the spirit!
15:23:43 <mnasiadka> #topic Xena cycle planning
15:23:54 <mnasiadka> Xena feature prioritisation https://docs.google.com/spreadsheets/d/1BuVMwP8eLnOVJDX8f3Nb6hCrNcNpRQl57T2ENU9Xao8
15:24:43 <mnasiadka> This has been edited last a week ago by mgoddard, should we work into converting this into a feature list with links to Gerrit topic/changes? Or what's the plan?
15:25:25 <mgoddard> maybe this cycle we should be a bit less rigorous, with only 4 weeks until freeze?
15:25:55 <headphoneJames> Also, in the other direction, how does one propose a feature to the list?
15:25:57 <mgoddard> e.g. if you can think of a feature (or find one in that sheet) that you'd like in Xena, add it to the whiteboard
15:25:58 <mnasiadka> no rigor, surely - but it would be nice for reviewers to have a ,,focus list''
15:26:09 <yoctozepto> yes, let's not use up too many sources on this part; let's try to clean up the whiteboard to get more focus
15:26:27 <yoctozepto> well, cleanup and more links and status reports
15:26:34 <yoctozepto> as delivered by kevko for proxysql
15:26:42 <mgoddard> headphoneJames: the list is all open patches as of a few weeks ago. it hasn't been massaged yet
15:27:15 <yoctozepto> no massages, no fun
15:28:39 <Fl1nt> sorry, get TZed
15:28:42 <Fl1nt> :(
15:29:20 <mgoddard> I've added some sections to the Xena priorities list on the whiteboard
15:29:26 <yoctozepto> ++
15:29:48 <mgoddard> is there anything in wallaby leftovers we should move across?
15:30:31 <yoctozepto> mgoddard: proxysql? letsencrypt?
15:30:32 <mgoddard> i.e. someone available to work on it in the next 4 weeks, cores likely to review it
15:30:35 <mgoddard> sure
15:31:22 <mnasiadka> for letsencrypt I posted a change to bump up haproxy to 2.2, so if we could get this properly working in Xena - it would be a very good achievement
15:31:55 <yoctozepto> mnasiadka: ++
15:32:07 <yoctozepto> we could go straight best approach I guess?
15:32:20 <mgoddard> swift may happen
15:32:30 <yoctozepto> ubuntu 2.0 though
15:32:46 <yoctozepto> perhaps there is a ppa to unify?
15:32:54 <yoctozepto> swift yeah
15:32:57 <mnasiadka> yoctozepto: Debian has 2.2 straight out of it's repos, Ubuntu has 2.2 from PPA, CentOS 8S has nfv repo
15:33:21 <mnasiadka> yoctozepto: I updated the change with PPA usage
15:33:27 <mnasiadka> a couple days back I think
15:33:58 <mgoddard> headphoneJames: I know it's hard, but realistically, which of your features would you prefer to merge in Xena
15:34:00 <mgoddard> ?
15:34:12 <yoctozepto> mnasiadka: ah, I did not notice, great!
15:34:25 <mgoddard> realistically we are unlikely to see some huge surge in reviewer time in the next 4 weeks
15:35:00 <mgoddard> but we could try to ignore non-critical bug fixes an maintenance for a while
15:35:01 <headphoneJames> mgoddard: preferably the system scope one
15:35:06 <mgoddard> ack
15:35:25 <yoctozepto> ok
15:37:29 <mnasiadka> I'll work on the Ansible bump and moving kolla-toolbox to ansible-core/base/however it's called - unless somebody is working on that already.
15:37:43 <mgoddard> useful maintenance
15:38:03 <mgoddard> I think that looks like all the likely candidates from wallaby leftovers
15:38:10 <mgoddard> are there other features that are not on there?
15:38:38 <yoctozepto> ++, I had hopes for podman but it stalled
15:38:47 <yoctozepto> remind me please
15:38:55 <yoctozepto> are we going to go ubuntu 22.04 with yoga?
15:39:37 <mgoddard> 4 cycles after bionic, whenever that was
15:39:38 <mnasiadka> I think so, doing that now is a bit risky I guess.
15:39:54 <mnasiadka> ah, 2022
15:39:57 <mnasiadka> April
15:39:59 <mgoddard> it's a bit impossible given it's 21.08 :D
15:40:14 <yoctozepto> yeah, I was wondering what mnasiadka answered to
15:40:25 <yoctozepto> anyhow, if yoga is going to target 22.04 finally
15:40:26 <mnasiadka> yoctozepto: I misread 2022 as 2021 :D
15:40:34 <yoctozepto> then working on podman could be a lovely priority
15:40:42 <yoctozepto> as all the platforms will support it natively
15:40:51 <mnasiadka> but this is a discussion for Yoga PTG I guess :)
15:41:07 <yoctozepto> you know me, I love to digress :D
15:41:15 <mgoddard> timing could be tight, yoga release is probably in 22.04
15:41:21 <yoctozepto> yeah
15:41:28 <yoctozepto> lemme check when we switched previously
15:41:36 <mnasiadka> ok then, do we have any kayobe features planned for Xena?
15:41:43 <yoctozepto> in vicky
15:42:04 <yoctozepto> so october
15:42:05 <yoctozepto> so Z
15:42:29 <mnasiadka> yes, I remember doing that, and the crazy dance with passing ansible_python_interpreter
15:42:45 <yoctozepto> I want to kill that variable but it dropped to lo prio
15:42:59 <mnasiadka> We can discuss that feature on the PTG :)
15:43:01 <yoctozepto> it's doable but requires some effort
15:43:09 <yoctozepto> :-)
15:43:12 <yoctozepto> let's move on
15:43:25 <yoctozepto> whiteboard cleaned up
15:43:32 <yoctozepto> thanks mgoddard for driving this mostly
15:43:34 <mgoddard> added ceph rgw to the list
15:43:45 <yoctozepto> nice
15:44:06 <mgoddard> mgoddard was searching for perfection with priorities, but I think this approach is ok
15:45:13 <yoctozepto> thanks for appreciating my lower standards in some cases :-)
15:45:48 <opendevreview> Mark Goddard proposed openstack/kolla-ansible master: Add kolla-ansible gather-facts command  https://review.opendev.org/c/openstack/kolla-ansible/+/794610
15:46:06 <mgoddard> ^ found a merge conflict while looking through my patches :)
15:46:27 <mnasiadka> so, clean up done, lower standards accepted, do we have anything else for Xena priorities?
15:46:57 <mgoddard> I could add pages of patches :)
15:47:32 <mnasiadka> I don't know if scrolling through pages of patches is what we want to do - but we can discuss this approach :)
15:47:42 <mgoddard> indeed
15:48:01 <mgoddard> I might dump a list of XS patches
15:48:11 <mgoddard> as I'm tired of looking at them
15:48:24 <yoctozepto> do a festival of XS patches review?
15:48:29 <yoctozepto> like some other teams do?
15:48:38 <mgoddard> that would be nice
15:48:40 <yoctozepto> 1 hour a week on video call?
15:48:50 <mnasiadka> we could just add a link in the whiteboard and encourage other community members to review them
15:48:54 <mnasiadka> yoctozepto: reviving Kolla Kall?
15:48:56 <yoctozepto> (to joke about the quality)
15:49:11 <yoctozepto> mnasiadka: kind of, but specifically for cores to handle this stuff and enjoy each other
15:49:59 <mnasiadka> We can try, anything new might work for a couple of times ;)
15:50:29 <mnasiadka> ok, we have two topics left for 10 minutes
15:50:52 <mnasiadka> #topic handling of APT keys - https://review.opendev.org/c/openstack/kolla/+/784923 (hrw, Fl1nt)
15:51:03 <mnasiadka> hrw, Fl1nt: stage is yours
15:51:46 <yoctozepto> mnasiadka: it's gating now
15:51:56 <mnasiadka> ah, so no stage, unless it breaks CI :)
15:52:04 <yoctozepto> I gave +2 on ps26
15:52:13 <yoctozepto> and only reno changed a bit
15:52:18 <yoctozepto> so re-gave +2
15:52:20 <yoctozepto> and approved
15:52:21 <mnasiadka> good work
15:52:31 <yoctozepto> minor nit on reno if someone cares about commas
15:52:57 <yoctozepto> I'm glad it gets merged
15:53:06 <mnasiadka> we'll fix those renos again before release
15:53:31 <mnasiadka> #topic Yoga PTG planning
15:53:38 <yoctozepto> (for the next meeting, I will want to discuss some debian stuff)
15:54:30 <mnasiadka> So, PTG is somewhere in October  (18th-22nd)
15:54:52 <yoctozepto> yeah
15:55:03 <mnasiadka> I'll create the usual etherpads, what's the other usual drill?
15:55:19 <mgoddard> we have some slots already
15:55:32 <mgoddard> so mostly we need to decide on agenda & discussion topics
15:55:35 <yoctozepto> ++
15:55:40 <yoctozepto> and we do that in the etherpad
15:55:52 <mgoddard> #link https://etherpad.opendev.org/p/kolla-yoga-ptg
15:56:25 <mgoddard> not populated
15:56:38 <yoctozepto> I suggest restoring Xena one on this and going from there
15:56:54 <yoctozepto> action mnasiadka to populate the etherpad?
15:57:22 <mnasiadka> #action mnasiadka to populate the etherpad
15:57:57 <yoctozepto> btw, I don't know if you noticed
15:58:02 <mnasiadka> I'll copy paste the Xena one, clean it up/rework and we'll have a solid foundation\
15:58:05 <yoctozepto> but Monasca went leaderless (again?)
15:58:20 <mnasiadka> I'm afraid Monasca doesn't have a bright future.
15:58:24 <yoctozepto> me too
15:58:37 <yoctozepto> I'm mostly propagating this to you because you are deploying it
15:59:11 <mnasiadka> This is changing, so we might rethink if we need that CI coverage (for the job that is failing all the time).
15:59:12 <dtantsur> hi folks! I'm struggling to understand if this https://zuul.opendev.org/t/openstack/build/eb452f5af8024837a35e92a5ab8e8f1f/log/primary/logs/ansible/deploy-bifrost#12032 is caused by my Bifrost change or is a breakage in Kolla proper. Could someone give me a hint?
16:00:01 <mnasiadka> ok, the meeting time is up, dtantsur thanks for joining for the last minute ;-)
16:00:09 <dtantsur> ooops :)
16:00:16 <mgoddard> thanks mnasiadka
16:00:19 <mnasiadka> If anybody has any open discussion points - let's continue after the meeting
16:00:24 <yoctozepto> thanks mnasiadka
16:00:27 <mnasiadka> #endmeeting kolla