15:01:11 <mnasiadka> #startmeeting kolla
15:01:11 <opendevmeet> Meeting started Wed Sep 22 15:01:11 2021 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:11 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:11 <opendevmeet> The meeting name has been set to 'kolla'
15:01:46 <mnasiadka> #topic Roll-call
15:01:56 <yoctozepto> o/.
15:02:02 <headphoneJames> o/
15:02:03 <yoctozepto> .\o
15:02:04 <mnasiadka> \o
15:04:35 <mnasiadka> #topic Agenda
15:04:44 <mnasiadka> * Announcements
15:04:44 <mnasiadka> * Review action items from the last meeting
15:04:44 <mnasiadka> * CI status
15:04:44 <mnasiadka> * Discuss "Transition Keystone admin user to system scope" https://review.opendev.org/c/openstack/kolla-ansible/+/692179/
15:04:44 <mnasiadka> * Should we switch CentOS to upstream MariaDB as well? And should we try to sync version for all in Xena? And which one? https://review.opendev.org/c/openstack/kolla/+/810161
15:04:46 <mnasiadka> * Should we support Rocky in images?
15:04:46 <mnasiadka> * Release tasks
15:04:48 <mnasiadka> * Xena cycle planning
15:04:48 <mnasiadka> * Yoga PTG planning
15:04:50 <mnasiadka> * Open discussion
15:05:09 <hrw> [°][o]
15:05:56 <mnasiadka> #topic Announcements
15:06:04 <mnasiadka> I have none, let's move on.
15:06:11 <mnasiadka> #topic Review action items from the last meeting
15:06:31 <mnasiadka> mnasiadka to update docs encouraging to build your own containers and run your own registry
15:06:31 <mnasiadka> mnasiadka to create pull-retag-push blueprint based on kayobe RFE: https://storyboard.openstack.org/#!/story/2007731
15:06:31 <mnasiadka> yoctozepto to fix multinode docs after defaulting to secure registry
15:06:31 <mnasiadka> mnasiadka to send a mail to ML about Kolla PTG
15:06:36 <mnasiadka> haven't done mine - yoctozepto ?
15:07:32 <yoctozepto> mnasiadka: fixed in the change
15:07:43 <yoctozepto> need to merge it
15:08:00 <mnasiadka> ok
15:08:06 <mnasiadka> fair enough :)
15:08:17 <mnasiadka> #topic CI status
15:08:49 <mnasiadka> Green, but I see a note about Train failing?
15:10:23 <yoctozepto> someone cares about train then
15:10:27 <yoctozepto> (not me)
15:10:48 <mnasiadka> Well, let's see if somebody has the will to fix it then.
15:10:59 <mnasiadka> #topic  Discuss "Transition Keystone admin user to system scope" https://review.opendev.org/c/openstack/kolla-ansible/+/692179/
15:11:14 <mnasiadka> headphoneJames - so what's the current status?
15:12:00 <headphoneJames> https://www.irccloud.com/pastebin/HZG1PxBZ/
15:12:29 <headphoneJames> I scaled the patch back to the proposed scope
15:13:01 <mnasiadka> I saw that, seems CI hasn't broken - I think we're waiting for mgoddard to review next week.
15:13:15 <headphoneJames> it got an initial review from mgoddard - it should now reflect all requested changes
15:13:51 <headphoneJames> and I agree - now it needs mgoddard stamp of approval
15:14:53 <headphoneJames> of course open to any other comments/feedback
15:15:30 <mnasiadka> Ok, are there any other chunks we want to try to squeeze in for Xena?
15:15:49 <headphoneJames> I assume not if the door is closing
15:16:03 <mnasiadka> Ok, situation is clear.
15:16:16 <mnasiadka> Next topic
15:16:19 <mnasiadka> #topic Should we switch CentOS to upstream MariaDB as well? And should we try to sync version for all in Xena? And which one? https://review.opendev.org/c/openstack/kolla/+/810161
15:16:56 <mnasiadka> yoctozepto: from my perspective - if all other distros use upstream MariaDB - it would be a bit weird if we would keep CentOS using distro MariaDB rpms?
15:17:40 <yoctozepto> mnasiadka: same here
15:17:47 <yoctozepto> now
15:17:51 <yoctozepto> switch only on master
15:17:52 <yoctozepto> or everywhere
15:17:56 <yoctozepto> ?
15:18:12 <mnasiadka> Do we have any bugs opened/issues around MariaDB in stable branches?
15:18:23 <yoctozepto> yes, for debian
15:18:25 <hrw> victoria and below
15:18:29 <yoctozepto> yes
15:18:38 <mnasiadka> ok, so we need to sync up Debian with Ubuntu, right?
15:18:47 <yoctozepto> yes
15:18:56 <yoctozepto> that's what I'm doing already
15:19:07 <yoctozepto> want to continue that down to affected ussuri
15:19:12 <yoctozepto> then do the other switches
15:19:19 <yoctozepto> let's plan the other ones
15:20:02 <mnasiadka> So we have no reason to switch CentOS anywhere else than master - so probably let's not do this - unless I'm mistaken.
15:20:12 <yoctozepto> definitely works for me
15:20:53 <yoctozepto> so #agreed ?
15:21:13 <mnasiadka> #agreed to switch CentOS and Debian to MariaDB upstream repo, and only backport Debian change to stable branches to sync up with Ubuntu and close existing bug.
15:21:24 <yoctozepto> great
15:21:25 <mnasiadka> If I haven't mixed up anything, I guess this is what we agreed to :)
15:21:25 <yoctozepto> there are two more questions there
15:21:30 <yoctozepto> yeah
15:21:36 <yoctozepto> the next q is
15:21:44 <yoctozepto> "And should we try to sync version for all in Xena?"
15:21:54 <yoctozepto> now we have debian 10.5 and others 10.3
15:22:00 <yoctozepto> we can't go down obviously
15:22:04 <yoctozepto> the current stable is 10.6
15:22:22 <yoctozepto> either do not sync or sync to 10.5 or 10.6
15:23:06 <mnasiadka> seems OSA reverted their jump to 10.6 a month ago
15:23:11 <mnasiadka> due to some upgrade problems
15:23:14 <hrw> wallaby was 10.5 in Debian at least so what about sync all to 10.5 now and higher in Y?
15:23:28 <mnasiadka> https://review.opendev.org/c/openstack/openstack-ansible-galera_server/+/805822
15:24:05 <mnasiadka> I think since it's close to feature freeze and other fantastic events in X release - we should just bump everything to 10.5
15:24:51 <yoctozepto> makes sense to me
15:25:08 <mnasiadka> #agreed to sync MariaDB on all distros to 10.5 and pursue 10.6 in next cycle
15:25:28 <mnasiadka> any more questions for that topic?
15:25:32 <yoctozepto> mnasiadka: re osa - they rely on deb to upgrade so... you know ;-)
15:25:45 <yoctozepto> not from me
15:25:59 <mnasiadka> galera_repo_host: "downloads.mariadb.com" in their role defaults/
15:26:15 <mnasiadka> ah, you meant something else
15:26:21 <yoctozepto> mnasiadka: I mean, they upgrade it with apt/dpkg
15:26:24 <yoctozepto> yeah
15:26:29 <mnasiadka> now I get it :)
15:26:32 <yoctozepto> :D
15:26:32 <mnasiadka> #topic Should we support Rocky in images?
15:26:52 <yoctozepto> I'm not sure there are clear benefits
15:26:58 <yoctozepto> what's wrong with stream images on rocky?
15:27:16 <yoctozepto> drivers go on host anyway
15:27:29 <mnasiadka> I don't know if I would feel safe in running that combination, but maybe it would work.
15:27:40 <yoctozepto> then run debian (-:
15:27:43 <hrw> Wasn't Rocky EOL already?
15:27:52 <mnasiadka> OpenStack Rocky? Maybe :)
15:28:06 <yoctozepto> khekhe
15:29:55 <yoctozepto> it seems we are unsure on the decision to make
15:29:59 <yoctozepto> hmm
15:30:29 <mnasiadka> i think we should also have mgoddard for the discussion, and hrw seems to have no opinion ;-)
15:30:45 <hrw> I think that it wwe should rather concentrate on Rocky Linux as host in k-a
15:30:52 <hrw> if RL at all
15:31:05 <yoctozepto> then hrw sounds like me
15:31:25 <hrw> note that for images you need also to convince infra to mirror RockyLinux repos
15:31:44 <hrw> otherwise you eat lot of bandwidth on CI
15:31:55 <mnasiadka> True, I was not thinking of merging it this cycle, easy.
15:32:12 <mnasiadka> Let's just maybe add this as a PTG topic, maybe we'll have more opinions then.
15:32:15 <yoctozepto> ok, then we can postpone this discussion
15:32:17 <yoctozepto> yeah
15:32:17 <hrw> it does not matter which cycle
15:32:25 <mnasiadka> For now DIB/bindep/etc don't support Rocky Linux
15:32:28 <hrw> lot of work for nearly no gain
15:32:37 <hrw> as you want source images only
15:32:53 <yoctozepto> hrw sounds like a harsher version of me
15:33:00 <yoctozepto> but true that
15:33:18 <hrw> we have like 2-4 developers, 3 distros, 2 build types...
15:33:30 <yoctozepto> precisely
15:33:43 <hrw> I would rather drop binary images than add another distro
15:33:54 <mnasiadka> I was thinking about that the other day ;-)
15:34:02 <yoctozepto> I know kevko might be unhappy about that
15:34:06 <yoctozepto> need to persuade him
15:34:11 <mnasiadka> Ok, let's postpone this discussion to the PTG.
15:34:18 <yoctozepto> I'm all in to drop everything and leave one distro and source only ;p
15:34:25 <hrw> he always can apply for core membership.
15:34:29 <yoctozepto> I mean, for images
15:34:46 <hrw> Rocky/Alma are good candidates for host distro
15:34:56 <yoctozepto> yeah, host is fine
15:35:03 <yoctozepto> as long as it has decent kernel
15:35:05 <yoctozepto> and runs docker
15:35:12 <yoctozepto> we should be good
15:35:22 <hrw> and that's k-a job. where it will be mostly s/centos/any-rhel-clone/
15:35:31 <yoctozepto> yup
15:35:45 <mnasiadka> That's not complicated, question what happens with CentOS Stream 9 and Yoga - will we be able to run Stream9 images on RHEL 8 compatible operating systems.
15:35:48 <hrw> with small "shit, rocky" or "meh, centos stream"
15:36:02 <yoctozepto> mnasiadka: test with debian images only
15:36:26 <yoctozepto> what's the need for stream in images? ;d
15:36:43 <mnasiadka> I would ask who needs Stream at all :)
15:36:46 <yoctozepto> I would say we should change a bit our scope
15:36:50 <yoctozepto> mnasiadka: that too! lol
15:37:25 <hrw> *if* we do binary images then we need Stream
15:37:41 <yoctozepto> yeah, I assume source-only for any further discussion
15:37:47 <hrw> unless you want to drop rhel family
15:38:15 <hrw> good topic for PTG then: Should we drop binary images?
15:38:17 <mnasiadka> I'll add a couple of related topics to the PTG etherpad, like dropping binary, using one distro as base, etc
15:38:21 <hrw> mnasiadka: #action?
15:38:24 <yoctozepto> ok
15:38:37 <mnasiadka> #action mnasiadka to add topics to PTG around dropping binary, using one distro as base, etc
15:38:47 <mnasiadka> and let's close this pandora box
15:39:07 <mnasiadka> #topic Release tasks
15:39:26 <mnasiadka> hrw: I saw a change around adding binary packages to Debian in Xena?
15:39:44 <yoctozepto> correct
15:40:12 <mnasiadka> Ok, I guess it would be nice to get that merged as part of release tasks.
15:40:26 <hrw> yep
15:40:27 <yoctozepto> also correct
15:40:34 <mnasiadka> good
15:40:42 <mnasiadka> #topic Xena cycle planning
15:40:56 <mnasiadka> I need to update the last of Ansible bump up changes
15:41:25 <mnasiadka> kevko seems to have updated some of his changes, I'll try to review tomorrow
15:41:49 <mnasiadka> yoctozepto: what about the Swift role remodeling? Can we stick to one change? Whiteboard mentions two :)
15:42:15 <yoctozepto> mnasiadka: not following that one atm
15:42:34 <mnasiadka> ok, so unlikely to get merged I guess
15:42:52 <yoctozepto> we can always try
15:42:59 <yoctozepto> it does not change the interface for the users
15:43:05 <yoctozepto> and shouldn't change experience so
15:43:18 <yoctozepto> for me it's a bugfix really
15:43:32 <yoctozepto> fixing the ugliness of the role (-:
15:43:38 <mnasiadka> yoctozepto: https://review.opendev.org/c/openstack/kolla-ansible/+/776662 seems to be waiting for you
15:43:50 <yoctozepto> oh boy
15:44:01 <yoctozepto> why am I not in "reviewers" then? :D
15:44:51 <yoctozepto> leaving it in a tab to review at some point
15:44:57 <mnasiadka> ok, good
15:45:15 <mnasiadka> seems we've got covered most of the Xena items in kolla/kolla-ansible
15:45:28 <mnasiadka> the rest is Kayobe, and we've got no representation from them today...
15:45:40 <mnasiadka> #topic Yoga PTG planning
15:45:55 <mnasiadka> There's an action on me to send email, populate etherpad with some ideas
15:46:08 <mnasiadka> #link https://etherpad.opendev.org/p/kolla-yoga-ptg
15:46:17 <mnasiadka> If anybody has any ideas for topics - please add them as well
15:46:21 <yoctozepto> is mnasiadka not a representation of kayobe?
15:46:48 <mnasiadka> I am :)
15:47:02 <yoctozepto> then mnasiadka is a little liar :-)
15:47:14 <mnasiadka> But I'll update the status of the changes after the meeting and chase reviewers using a different medium ;-)
15:47:23 <yoctozepto> ok!
15:48:26 <mnasiadka> ok then, last but not least
15:48:31 <mnasiadka> #topic Open discussion
15:48:36 <mnasiadka> 12 minutes left in the meeting, incredible.
15:48:42 <yoctozepto> :O
15:48:53 <yoctozepto> perhaps we skipped some important topic and did not notice
15:49:15 <hrw> do we have any potential candidates for core?
15:49:30 <yoctozepto> afaik kevko is trying
15:50:39 <hrw> good
15:50:50 <mnasiadka> I think it's good he's trying, but he needs to at least double his review numbers...
15:51:11 <hrw> also outside of his interests
15:51:17 <mnasiadka> correct
15:51:28 <yoctozepto> ++
15:53:44 <mnasiadka> Ok, seems no other topics
15:54:37 <mnasiadka> Or maybe I'll start one - regarding Monasca CI - I don't want to be rude, but I feel we're trying to keep it alive, but one of the components is failing - one that calculates thresholds and alerts on those thresholds (like cpu busy).
15:54:53 <yoctozepto> just propose to drop the job
15:54:56 <yoctozepto> I'll accept that
15:55:02 <yoctozepto> I mean +2
15:55:38 <mnasiadka> I'm not into deprecating it now, but let's drop the job and ensure there's a bug raised claiming Monasca does not work in Y or even W (maybe even reflect that in Support Matrix)
15:55:43 <mnasiadka> Ok, I'll do that.
15:55:55 <yoctozepto> good thinking
15:55:57 <yoctozepto> ++
15:55:59 <hrw> +2
15:56:06 <yoctozepto> I'm also working on that
15:56:15 <yoctozepto> "ugly projects"
15:56:28 <yoctozepto> to document and hide behind a var barrier
15:56:39 <yoctozepto> will propose later this week or next one
15:56:48 <mnasiadka> ok
15:57:02 <mnasiadka> so let's end this fine meeting
15:57:05 <mnasiadka> #endmeeting kolla