15:01:18 <mnasiadka> #startmeeting kolla
15:01:18 <opendevmeet> Meeting started Wed Oct  6 15:01:18 2021 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:18 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:18 <opendevmeet> The meeting name has been set to 'kolla'
15:01:30 <mnasiadka> #topic rollcall
15:01:47 <hrw> [°][_]
15:02:12 <yoctozepto> o/
15:02:24 <yoctozepto> call ppl
15:02:27 <mnasiadka> o/
15:02:39 <mnasiadka> mgoddard mnasiadka hrw egonzalez yoctozepto rafaelweingartne cosmicsound osmanlicilegi bbezak parallax Fl1nt - meeting now
15:03:01 <mgoddard> \o
15:03:32 <yoctozepto> much better
15:03:49 <priteau> o/
15:03:52 <Fl1nt> O/
15:04:55 <mnasiadka> #topic agenda
15:05:04 <mnasiadka> * Announcements
15:05:04 <mnasiadka> * Review action items from the last meeting
15:05:04 <mnasiadka> * CI status
15:05:04 <mnasiadka> * Release tasks
15:05:04 <mnasiadka> * Xena cycle planning
15:05:06 <mnasiadka> * Yoga PTG planning
15:05:06 <mnasiadka> * Open discussion
15:05:13 <mnasiadka> #topic Announcements
15:05:32 <mnasiadka> Xena has been released - http://lists.openstack.org/pipermail/openstack-announce/2021-October/002056.html
15:05:47 <mnasiadka> Any more announcements?
15:06:29 <mnasiadka> No? Then let's go on
15:06:31 <mgoddard> Use #info for announcements?
15:06:41 <mnasiadka> #info Xena has been released - http://lists.openstack.org/pipermail/openstack-announce/2021-October/002056.html
15:06:49 <mnasiadka> thank you mgoddard
15:06:51 <mgoddard> also note that the release excludes kolla deliverables
15:07:21 <frickler> o/
15:07:25 <mnasiadka> #info Kolla deliverables are cycle trailing, we are still working towards RC1.
15:07:33 <mnasiadka> ok, I guess that's enough.
15:07:40 <mnasiadka> #topic Review action items from the last meeting
15:07:55 <mnasiadka> There was one: mnasiadka to add topics to PTG around dropping binary, using one distro as base, etc
15:07:57 <mnasiadka> I did that
15:08:12 <mnasiadka> #topic CI status
15:08:37 <mnasiadka> green as grass according to whiteboard
15:09:06 <mnasiadka> #topic Release tasks
15:09:07 <priteau> Still a few occasional disk full failures in Kayobe, you can recheck when you see them
15:09:36 <mnasiadka> I doubt we're going to fix that in a couple of days, but still makes sense to understand what is causing them and fix it in the longer run...
15:10:28 <yoctozepto> yeah, CI is happy on k&k-a
15:10:47 <yoctozepto> <champagne showers>
15:11:05 <mnasiadka> So, we agreed on the last meeting today we are going to plan cutting RC1 for Kolla and Kolla-Ansible at least
15:11:29 <mnasiadka> Are there any outstanding patches that have to get in before we do that?
15:11:37 <yoctozepto> as far as I am concerned, letmerge our
15:11:45 <yoctozepto> let's merge our treasure chests*
15:12:05 <yoctozepto> https://etherpad.opendev.org/p/KollaWhiteBoard
15:12:10 <yoctozepto> L278 and below
15:12:25 <yoctozepto> (well, perhaps except the docs as highlighted)
15:12:33 <hrw> according to tools/version-check.py we have versioned tarballs for everything
15:13:25 <mnasiadka> that's good
15:13:32 <mnasiadka> yoctozepto: https://review.opendev.org/c/openstack/kolla-ansible/+/812677 - is that prometheus statement a stopper?
15:14:02 <priteau> I don't think it's on the white board but it would be nice to merge https://review.opendev.org/c/openstack/kolla-ansible/+/810017
15:14:03 <yoctozepto> mnasiadka: no, just need to check if that exporter does not complain
15:14:18 <yoctozepto> priteau: it's not, will add
15:14:49 <yoctozepto> added
15:14:53 <yoctozepto> and others review
15:14:53 <mnasiadka> yoctozepto: seems multinode (ceph) jobs are complaining
15:15:11 <yoctozepto> looking
15:15:16 <mgoddard> those treasure chest items don't really look like features
15:15:49 <mgoddard> a few of them give me that 'this could easily break us in a weird way' feeling
15:16:03 <mnasiadka> I think the most important one is the mariabackup bugfix after Ansible upgrade - but we can always sort it out after RC1 in a backport
15:16:17 <yoctozepto> RUNNING HANDLER [mariadb : Wait for MariaDB service to sync WSREP] *************
15:16:39 <mnasiadka> yoctozepto: cluster broke?
15:16:48 <mgoddard> yeah, bugfixes don't need to wait for RC1
15:17:20 <yoctozepto> mnasiadka: looks like some random issue
15:17:51 <yoctozepto> yeah, they are bugfixes
15:18:16 <mnasiadka> dropping workarounds and other things - I agree with mgoddard, would be easier to push them to master after branching stable/xena and backport if needed
15:18:27 <mnasiadka> well, maybe not easier - but safer
15:18:38 <mnasiadka> I'm pretty sure we'll have some other bugfixes to fix
15:19:12 <yoctozepto> ok, as you prefer
15:20:22 <mgoddard> they could go on a list of release blockers / wants
15:20:40 <mnasiadka> Ok, any volunteer to run the preparations for RC1?
15:20:54 <mnasiadka> #link https://docs.openstack.org/kolla/latest/contributor/release-management.html
15:21:27 <mgoddard> sounds like a rite of passage for a new PTL :)
15:22:02 <mnasiadka> Well, it's not the first time I'll be doing this, but so be it :)
15:22:20 <hrw> first time as PTL
15:22:34 <mnasiadka> #action mnasiadka to run through the release checklist
15:23:08 <yoctozepto> :-)
15:23:29 <mgoddard> priteau suggested a change to the schedule to move kayobe RC1 after kolla
15:23:50 <mnasiadka> I think that's reasonable, and for some reason Kayobe tasks are last in the doc
15:23:55 <mgoddard> we do a sync of config & flags & stuff, so it's nice to know it shouldn't change
15:24:36 <mgoddard> action me to make that update mnasiadka
15:25:18 <mnasiadka> update the docs to reflect that Kayobe is a next step?
15:25:27 <mgoddard> yes
15:25:51 <mnasiadka> #action mgoddard to update release docs to reflect Kayobe should be branched/cut RC1 after we have Kolla/Kolla-Ansible RC1s
15:26:30 <yoctozepto> makes sense to me
15:26:34 <mnasiadka> ok then, I think it concludes release tasks topic
15:26:42 <mnasiadka> #topic Xena cycle planning
15:26:51 <mnasiadka> I think that one is over, right? ;)
15:27:20 <hrw> s/cycle/release/
15:27:26 <mgoddard> +1
15:27:33 <hrw> and release is part of cycle ;D
15:27:54 <mnasiadka> #topic Yoga PTG planning
15:28:07 <mnasiadka> #link https://etherpad.opendev.org/p/kolla-yoga-ptg
15:28:18 <mnasiadka> And I have send a reminder email to openstack-discuss ML
15:29:45 <mnasiadka> We have some people on the attendee list - some topics - I'll populate the Xena PTG actions list and not-picked-up priorities
15:30:53 <mnasiadka> The PTG is in less than two weeks - for those that haven't noticed ;-)
15:31:26 <mnasiadka> Ok, I think I exhausted the topic
15:31:33 <mnasiadka> #topic Open discussion
15:31:41 <mnasiadka> Anybody wants to discuss anything?
15:31:52 <mgoddard> are there any other PTG topics we should cover?
15:32:08 <yoctozepto> yeah, that would be good to discuss today and next meeting
15:32:11 <hrw> for RC we go with versioned tarballs or stable-xena ones?
15:32:37 <yoctozepto> I wonder if frickler is around, he may have some I guess
15:32:39 <mnasiadka> I think we've done stable for some time now, right?
15:32:45 <mgoddard> yes
15:32:53 <frickler> I'd like to shortly introduce myself, for those who don't know me yet
15:32:56 <frickler> yoctozepto: some what?
15:33:07 <yoctozepto> frickler: ptg discussion points
15:33:11 <mnasiadka> Anybody is free to add any topic they like to the PTG Etherpad, we don't have a lot there currently
15:33:35 <frickler> I know cberendt had something, but I'm not up to speed yet regarding that
15:33:47 <yoctozepto> ok
15:33:48 <mgoddard> frickler: go ahead with an intro
15:33:57 <yoctozepto> intro, intro
15:34:08 <frickler> so ... I've changed sides now, I was doing openstack-chef for quite some time
15:34:26 <frickler> but since Friday I'm now working for osism
15:34:55 <frickler> and that will imply a considerate amount of upstream work, i.e. kolla*
15:35:16 <frickler> I'll also continue my other things, like infra-root etc.
15:35:32 <yoctozepto> another devstack core on board ;d
15:35:43 <frickler> that too, yes ;)
15:36:19 <frickler> and I guess that's enough for now
15:36:21 <mgoddard> welcome frickler, looking forward to working with you more
15:36:30 <frickler> thx
15:36:45 <mnasiadka> welcome :)
15:37:19 <priteau> Welcome frickler
15:38:00 <priteau> Also just in: OpenInfra Summit, returning to Berlin on June 7-9, 2022 at the Berlin Congress Center
15:38:09 <yoctozepto> welcome frickler
15:38:23 <yoctozepto> glad to have you on our side :D
15:38:28 <frickler> oh, nice. I'm located in Berlin btw. ;)
15:38:35 <mnasiadka> Berlin again - good it's close ;)
15:38:54 <hrw> ja
15:39:03 <yoctozepto> oh, oh, I'll try to organise something with my employers
15:39:11 <yoctozepto> so that I can go there as well
15:39:52 <yoctozepto> immer besser persönlich :D
15:40:29 <priteau> What is this "travel" thing you're talking about?
15:40:33 <hrw> someone remembers how much openinfra summit entry costed?
15:40:53 <hrw> priteau: 150km is not travel :D
15:41:24 <mgoddard> hrw could commute
15:42:15 <mnasiadka> yeah, it's twice the distance for me - still no tragedy
15:42:24 <frickler> hrw: wasn't it still free for ATCs?
15:43:32 <hrw> frickler: no idea, long time since was
15:43:52 <hrw> frickler: when it is in other continent then travel costs...
15:44:02 <frickler> priteau: do you have a link for that announcement?
15:44:15 <priteau> https://openinfra.dev/summit/
15:45:14 <yoctozepto> I'm subscribing the newsletter
15:45:28 <priteau> Back in 2019 for the Berlin summit this was the policy:
15:45:31 <priteau> All ATCs who had at least one contribution merged during the Rocky development cycle will receive a Full Access pass to the Berlin Summit for USD $300.
15:45:35 <yoctozepto> will let you know when I have any news too
15:45:39 <priteau> But they may have changed, we'll see
15:45:54 <priteau> Also if you are a speaker it's usually free
15:46:57 * frickler is more of a listener than a speaker
15:47:15 * yoctozepto too
15:47:25 <mnasiadka> As well all most probably are ;)
15:47:37 <mnasiadka> Ok, any more topics in the open discussion - or should we wrap up the meeting?
15:48:01 <mgoddard> re PTG, the topics are a little loosely defined currently
15:48:15 <mgoddard> maybe the proposers could add some context
15:48:24 <mgoddard> links to bugs/patches etc
15:49:34 <mgoddard> otherwise, yes - all done
15:49:44 <opendevreview> Pierre Riteau proposed openstack/kayobe master: Add support for configuring tuned profile  https://review.opendev.org/c/openstack/kayobe/+/811424
15:49:55 <mnasiadka> ok then
15:49:58 <mnasiadka> thanks for attending!
15:50:00 <mnasiadka> #endmeeting