15:00:11 <mnasiadka> #startmeeting kolla
15:00:11 <opendevmeet> Meeting started Wed Nov 17 15:00:11 2021 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:11 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <opendevmeet> The meeting name has been set to 'kolla'
15:00:21 <mnasiadka> #topic rollcall
15:01:19 <adrian-a> \o
15:01:35 <mgoddard> \o
15:01:36 <yoctozepto> o/
15:02:18 <halomiva> o/
15:02:25 <Martin_Hiner> o/
15:03:08 <hrw> [°][o]
15:05:21 <mnasiadka> #topic agenda
15:05:21 <mnasiadka> * Announcements
15:05:21 <mnasiadka> * Review action items from the last meeting
15:05:21 <mnasiadka> * CI status
15:05:21 <mnasiadka> * Release tasks
15:05:22 <mnasiadka> * Backports & stable releases
15:05:22 <mnasiadka> * Yoga cycle planning
15:05:24 <mnasiadka> * [infra] Need to fix Zuul errors
15:05:24 <mnasiadka> * CentOS plans
15:05:26 <mnasiadka> * Open discussion
15:05:39 <mnasiadka> #topic Announcements
15:06:46 <mnasiadka> No announcements today.
15:06:52 <mnasiadka> #topic Review action items from the last meeting
15:08:11 <mnasiadka> action on mnasiadka to action security bugs - did nada - because I was on vacation :)
15:08:24 <mnasiadka> action on yoctozepto to  hide properly init-runonce
15:08:26 <yoctozepto> I have not done mine either
15:08:38 <mnasiadka> #action mnasiadka to triage security bugs and update them with resolution plan (if needed)
15:08:45 <mnasiadka> #action yoctozepto hide properly init-runonce
15:08:55 <mnasiadka> #topic CI Status
15:09:18 <mnasiadka> I see all green
15:09:40 <mnasiadka> (we'll cover the zuul config errors later)
15:09:44 <mnasiadka> #topic Release tasks
15:10:00 <yoctozepto> we should release xena
15:10:27 <priteau> There are a few backports still waiting merge for kayobe
15:10:27 <mnasiadka> Yes, but we need an RC3 for Kayobe first
15:10:50 <priteau> https://review.opendev.org/c/openstack/kayobe/+/818217/
15:11:11 <mnasiadka> we can although release finals for Kolla and Kolla-Ansible, right?
15:12:11 <yoctozepto> yeah, that's my point
15:12:15 <yoctozepto> let's do it
15:12:20 <mnasiadka> priteau: let's get a list of Kayobe RC3 pending changes on the whiteboard
15:12:48 <mnasiadka> It's R-19 week for Yoga, we have some R-17 items on our list - but I think there are some changes raised by mgoddard (looking at previous meeting logs)
15:12:50 <hrw> mnasiadka: make kaybobe-release-blockers topic?
15:12:52 <mnasiadka> So we should be fine
15:13:09 <mnasiadka> hrw: yes, that also works, we'll work it out :)
15:13:19 <hrw> that way one link to put ;D
15:14:05 <mnasiadka> ok then, let's continue
15:14:14 <mnasiadka> #topic Backports & stable releases
15:14:30 <mnasiadka> the whiteboard says: "We are probably overdue a backport session (see L248 for last checked commits)."
15:14:37 <mnasiadka> After backports merge, we should release stable branches.
15:15:00 <mnasiadka> So - any volunteer to go through backports and make sure those are done?
15:15:03 <yoctozepto> so many backports to be seen then :D
15:15:28 <yoctozepto> not me, /me has too much on his plate atm
15:16:39 <mnasiadka> I have a lot on my plate as well, so would prefer someone else to take it ;)
15:17:06 <yoctozepto> need more plates :D
15:17:20 <mnasiadka> to break ;)
15:17:30 <yoctozepto> hopefully not
15:18:36 <mnasiadka> Well, if there are no volunteers, it will just need to wait a bit
15:19:12 <mnasiadka> #action not forget to go through backports for stable branches (L248 on Whiteboard) and do stable releases afterwards.
15:19:34 <mnasiadka> #topic Yoga cycle planning
15:20:13 <mnasiadka> I think we need to go through the prereqs for deprecating binary - if we're going to deprecate it early this cycle.
15:21:32 <mnasiadka> L349 in https://etherpad.opendev.org/p/kolla-yoga-ptg
15:23:30 <mnasiadka> Any volunteers for the tasks there?
15:25:27 <yoctozepto> tough crowd today
15:25:44 <mnasiadka> I guess
15:26:07 <mnasiadka> Anybody wants to write the reno about deprecating?
15:26:09 <hrw> I want to stay in quiet corner and wait for end of the world.
15:26:45 <mnasiadka> Ok then, so let's wait until binary deprecates by itself :)
15:27:36 <mnasiadka> Let's continue if there are no volunteers
15:27:38 <mnasiadka> #topic [infra] Need to fix Zuul errors
15:27:55 <yoctozepto> for stein and rocky
15:27:57 <mnasiadka> seems we have bad configs in kolla-ansible stable/rocky and stable/stein
15:28:08 <yoctozepto> so I guess it's best to eol them
15:28:13 <mnasiadka> We had a discussion earlier today about it, and I think we EOL
15:28:15 <yoctozepto> as train is still unhappy ;-)
15:28:27 <yoctozepto> all right, I agree
15:28:32 <yoctozepto> anyone disagrees?
15:28:33 <mnasiadka> priteau: is on a mission to save the train, but maybe not now ;)
15:29:01 <priteau> I made some progress during train upgrades, but once all our customers are beyond train I don't know if there will be much motivation :P
15:29:19 <mnasiadka> then we can EOL Train and forget about Python2 :)
15:29:28 <hrw> what is a name of Z cycle?
15:29:42 <priteau> not decided yet
15:29:45 <hrw> ok
15:30:19 <mnasiadka> ok, no protests, I'll raise EOL changes for rocky and stein
15:30:36 <mnasiadka> for both k-a and kolla, right?
15:31:29 <opendevreview> Marcin Juszkiewicz proposed openstack/kolla master: reno: binary images are now deprecated  https://review.opendev.org/c/openstack/kolla/+/818240
15:31:42 <mnasiadka> #action mnasiadka to EOL rocky and stein for both kolla and kolla-ansible
15:31:52 <hrw> patch landed. message needs rewriting probably but patch exists
15:31:59 <mnasiadka> ok, that's a start
15:32:00 <mnasiadka> thanks hrw
15:32:15 <mnasiadka> #topic CentOS plans
15:32:39 <mnasiadka> binary images gets deprecated in Y, dropped in Z
15:32:44 <mnasiadka> that was the plan I guess
15:32:50 <mnasiadka> but
15:32:53 <mnasiadka> RDO moves from CS8 to CS9 in Y cycle
15:32:53 <mnasiadka> packages for both will be provided to simplify migration
15:33:16 <mnasiadka> that means Yoga is the last cycle with cs8+binary for Kolla? Since we opted-out of cs9 migration?
15:33:43 <hrw> so if we decide to go CS8 to the end of CentOS in Kolla then Y is cs8/binary+source and Z is cs8/source only
15:34:32 <hrw> and as we migrate to "latest binary" in R-late then it looks like sane plan
15:35:18 <mnasiadka> seems sane to me
15:35:22 <mnasiadka> anybody disagrees?
15:35:50 <yoctozepto> makes sense
15:35:55 <yoctozepto> just need to deprecate it properly
15:36:02 <yoctozepto> and glad we can support it until then
15:36:33 <hrw> looks like quick track: Yoga: cs8/binary+source, u2004/binary+source, d11/binary+source. Z: cs8/source, u2004/source, d11/source, A: d11/source is still possible
15:37:39 <hrw> Yoga has binary deprecation, Z has binary drop and !debian deprecation, A has only one set of images
15:37:48 <mnasiadka> Yes, but let's focus on getting rid of binary for now.
15:37:58 <hrw> yes, just wanted to mention
15:38:16 <mnasiadka> ok, no protesters again
15:38:33 <hrw> so cs8 to the end
15:39:11 <mnasiadka> #agreed to not pursue cs9 (as agreed on the PTG) and Z release will use cs8+source (for centos)
15:39:37 <mnasiadka> I guess that concludes the CentOS discussion
15:39:43 <mnasiadka> #topic Open discussion
15:39:50 <hrw> now #action inform openstack ml about binary deprecation and centos plans
15:39:53 <hrw> ?
15:40:05 <mnasiadka> that's already in agreed PTG action items
15:40:11 <hrw> ah, right
15:40:16 <mnasiadka> So it's on my list :)
15:40:35 <mnasiadka> so - open discussion - anybody has any points?
15:40:41 <hrw> kevko goes for core - vote on ML if not done yet
15:41:34 <mgoddard> have we done the necessary user feedback gathering to start deprecating things?
15:42:15 <mnasiadka> looking at the PTG etherpad - we wanted first to deprecate binary, and then send a mail - should we do it other way around?
15:42:30 <hrw> we not merged it yet
15:43:05 <mgoddard> I think we wanted to deprecate in Xena, but it didn't happen
15:43:12 <mgoddard> in which case I'd say discuss first
15:44:21 <mnasiadka> Well, I think it will finish like the kolla-ceph code removal, but I can send a mail to openstack-discuss and kolla-klub around a plan to deprecate binary and if anyone wants to step up and keep it maintained
15:44:38 <mnasiadka> Is that what we want to do?
15:46:22 <mgoddard> I'd suggest including the single distro plan too
15:46:24 <hrw> "Dear (potential and present) users. Due to size of our team we decided to drop support for building binary images. What do you think about it? Your beloved Kolla team"
15:46:44 <hrw> sorry, too much [sarcasm emoji] recently
15:46:45 <mnasiadka> I'm not in favor of sending two bombs at the same time.
15:47:31 <mgoddard> you'd rather send another one next week, saying 'oh, by the way, you can't use your current distro either?'
15:47:33 <mgoddard> it's one plan
15:48:44 <mnasiadka> I don't believe it's one plan, it's not as in we do both or nothing.
15:49:17 <hrw> it is more or less one plan. just split on 3-4 cycles
15:49:19 <mnasiadka> I can include both in one mail, but I think it will bring more confusion than real user feedback.
15:49:35 <hrw> from what is now"
15:49:43 <hrw> from "what is now" to "one set of images"
15:49:58 <mgoddard> we are reducing 6 sets of images to one
15:50:19 <mnasiadka> that's long way to go
15:50:25 <hrw> but that's one plan
15:50:52 <hrw> here is a plan. we split it to parts. this cycle gets part1, then part2, then part3
15:50:54 <mgoddard> yes, and people need to know how their setup will end up. Why let them think they can use centos/source?
15:51:20 <hrw> especially when they jump releases
15:51:44 <mgoddard> most people would want to switch straight to the chosen image config, rather than via another type
15:52:20 <hrw> wallaby centos/binary -> xena centos/binary -> yoga centos/binary -> zeus centos/source -> athena debian/source would require planning
15:53:17 <hrw> One Set to rule them all
15:55:31 <mnasiadka> Honestly, we all know it's going to be shooting contest in the user feedback - but let me agree to send it out in one mail.
15:56:45 <hrw> ok, can I get other topic?
15:56:49 <mnasiadka> Sure
15:57:00 <hrw> did someone use docker squash support?
15:57:17 <headphoneJames> I have a patch to towards system scope in keystone ready for review: https://review.opendev.org/c/openstack/kolla-ansible/+/815577
15:57:26 <hrw> can we kill it?
15:58:14 <mnasiadka> what's the problem with it?
15:58:52 <mgoddard> headphoneJames: I reviewed today
15:59:24 <headphoneJames> mgoddard: thanks!
15:59:54 <hrw> mnasiadka: just wondering how much it is used. if no one uses it then we do not even know does it work
16:00:28 <mnasiadka> well, I would say it might be useful for some people, but if it's not tested - then probably it doesn't work ;)
16:01:24 <mnasiadka> What's the usual number of Kolla image layers nowadays? Does it make sense to squash them if you add some things on top?
16:02:45 <hrw> mnasiadka: test2/nova-libvirt:13.1.0 has 29 layers
16:02:52 <mnasiadka> ok, we're over time, let's continue after the meeting
16:02:53 <mgoddard> hrw: I don't think it's hurting anyone
16:02:53 <mnasiadka> #endmeeting