15:01:04 <mnasiadka> #startmeeting kolla
15:01:04 <opendevmeet> Meeting started Wed Dec 22 15:01:04 2021 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:04 <opendevmeet> The meeting name has been set to 'kolla'
15:01:30 <mnasiadka> #topic rollcall
15:01:48 <mnasiadka> mgoddard mnasiadka hrw egonzalez yoctozepto rafaelweingartne cosmicsound osmanlicilegi bbezak parallax Fl1nt frickler adrian-a - meeting
15:01:53 <mnasiadka> o/
15:02:07 <mgoddard> mnasiadka: didn't you cancel it?
15:02:28 <mnasiadka> No, I wanted - but you said you'll be here ;-)
15:02:35 <mnasiadka> let's see how many people will show up.
15:02:40 <opendevreview> Merged openstack/kolla-ansible stable/xena: Added upgrade note for separate nova and cinder keys.  https://review.opendev.org/c/openstack/kolla-ansible/+/822623
15:02:42 <opendevreview> Merged openstack/kolla-ansible stable/wallaby: Added upgrade note for separate nova and cinder keys.  https://review.opendev.org/c/openstack/kolla-ansible/+/822624
15:02:44 <opendevreview> Merged openstack/kolla-ansible stable/victoria: Added upgrade note for separate nova and cinder keys.  https://review.opendev.org/c/openstack/kolla-ansible/+/822625
15:03:40 <yoctozepto> o/
15:03:42 <parallax> \o
15:04:12 * yoctozepto in for a Christmas meeting
15:04:42 * yoctozepto starts singing carols
15:05:20 <parallax> 🥲
15:05:22 <opendevreview> Merged openstack/kolla-ansible stable/ussuri: Added upgrade note for separate nova and cinder keys.  https://review.opendev.org/c/openstack/kolla-ansible/+/822626
15:05:49 <mnasiadka> #topic agenda
15:06:02 <mnasiadka> * Review action items from the last meeting
15:06:02 <mnasiadka> * CI status
15:06:02 <mnasiadka> * Release tasks
15:06:02 <mnasiadka> * Current cycle planning
15:06:02 <mnasiadka> * Additional agenda (from whiteboard)
15:06:03 <mnasiadka> * Open discussion
15:06:15 <mnasiadka> #topic Review action items from the last meeting
15:06:33 <mnasiadka> mnasiadka to triage security bugs and update them with resolution plan (if needed)
15:06:33 <mnasiadka> mnasiadka post a patch for docs - standard topics that should be discussed over PTG and then revisited in mid-cycle
15:06:33 <mnasiadka> anybody not forget to go through backports for stable branches (L248 on Whiteboard) and do stable releases afterwards
15:06:33 <mnasiadka> parallax look into Grafana Kolla build failures on Ussuri/CentOS
15:06:33 <mnasiadka> yoctozepto to remove CentOS 8 based CI jobs and manage communication (ML and renos)
15:06:35 <mnasiadka> parallax_ apply jvm option mitigation for log4shell in elasticsearch
15:06:41 <mnasiadka> I haven't done mine
15:06:57 <yoctozepto> I have started the thread on ml
15:06:57 <mnasiadka> yoctozepto seems to managed the communication - but didn't remove the CI jobs, right?
15:07:05 <yoctozepto> no, I didn't
15:07:06 <parallax> but you've done one of mine :)
15:07:21 <mnasiadka> Ah, I fixed Grafana?
15:07:26 <parallax> I think so
15:07:35 <parallax> that Go thing
15:07:45 <mnasiadka> Right, I just applied the fix what we did in stable/victoria once doing c8s
15:07:53 <yoctozepto> should I go and just drop the jobs?
15:07:57 <mnasiadka> parallax: what about the jvm option mitigation?
15:08:04 <parallax> merged
15:08:10 <mnasiadka> yoctozepto: I think so
15:08:18 <parallax> probably backports need reviewing
15:08:20 <yoctozepto> mnasiadka: ok, will be done
15:08:38 <mnasiadka> mgoddard: I saw you went with some backports - did you go as far as doing that for all commits, or just yours?
15:08:50 <mnasiadka> #action mnasiadka to triage security bugs and update them with resolution plan (if needed)
15:08:58 <mnasiadka> #action mnasiadka post a patch for docs - standard topics that should be discussed over PTG and then revisited in mid-cycle
15:08:59 <yoctozepto> backports merged, no?
15:09:12 <mnasiadka> #action yoctozepto remove CentOS 8 based CI jobs
15:09:27 <parallax> well, merged, just except for Train
15:09:41 <mnasiadka> Train is problematic :)
15:09:53 <mnasiadka> But maybe once CentOS 8 CI is removed, it will be easier ;)
15:09:59 <yoctozepto> :D
15:10:12 <mnasiadka> Ok, let's move on.
15:10:15 <mnasiadka> #topic CI status
15:10:23 <mnasiadka> How is it?
15:10:29 <mgoddard> mnasiadka: I just backported some things that merged recently, not all
15:10:51 <mnasiadka> mgoddard: ok
15:10:58 <mnasiadka> so, whiteboard says the CI is green
15:11:07 <yoctozepto> frickler, mgoddard and /me collaborated to get kolla master CI fixed
15:11:20 <yoctozepto> backports seem merging so stable branches should be good as well
15:11:39 <mnasiadka> ok then, good to know
15:11:46 <mnasiadka> #topic Release tasks
15:12:11 <mnasiadka> It's R-14
15:12:30 <mnasiadka> nearest task is R-8
15:12:31 <mnasiadka> so we're fine
15:12:49 <mnasiadka> Do we need to do any kolla/kolla-ansible stable point releases?
15:13:11 <mgoddard> probably
15:13:30 <yoctozepto> yeah, let's prepare an xmas release bomb
15:14:15 <mnasiadka> ok, any volunteer to raise the changes?
15:16:19 <mgoddard> I can do it
15:16:37 <mnasiadka> #action mgoddard raise changes for stable point releases
15:16:40 <mnasiadka> thanks
15:16:50 <mnasiadka> #topic Current cycle planning
15:17:56 <mnasiadka> Ok then, have we done everything to deprecate binary images?
15:19:19 <mnasiadka> Seems some patches are merged, we are still to backport the deprecation reno (to warn about future deprecation in Xena) and Look into "What do we need to make sure that users like kevko are not left on ice with their issues with source images
15:19:41 <mnasiadka> I think frickler volunteered, so let's see how it plays out in January/February
15:19:49 <mnasiadka> Any other work we should be discussing?
15:19:55 <mnasiadka> mgoddard: How's it going with baremetal role breakout?
15:20:06 <mgoddard> fairly well
15:20:10 <mgoddard> lots of patches to review
15:20:20 <mgoddard> at least the early ones are ready
15:20:31 <mgoddard> the /etc/hosts part is giving me headaches
15:21:29 <mgoddard> I'm just looking at RBAC stuff
15:21:31 <mgoddard> https://review.opendev.org/c/openstack/kolla-ansible/+/815577
15:22:04 <mgoddard> seems keystone will be changing the default to enforce_scope=True in yoga
15:22:23 <mgoddard> so we're going to need to make sure that doesn't break us
15:22:36 <mgoddard> #link https://opendev.org/openstack/governance/src/branch/master/goals/selected/consistent-and-secure-rbac.rst#yoga-timeline-7th-mar-2022
15:23:20 <mnasiadka> I'd like to also raise attention for the NSXP part - we promised alecorps to take a look into his changes in Yoga cycle - are there any reviewers that could sign up for this?
15:24:02 <mnasiadka> mgoddard: added the link to the whiteboard in the system scope feature section
15:24:56 <mgoddard> thank
15:26:11 <mnasiadka> ok, let's move to open discussion
15:26:13 <mnasiadka> #topic Open discussion
15:26:53 <mnasiadka> For those people that are OVN-interested - Neutron is now backporting a fix to a problem they created (enforce UUID for system-id in OVSDB) - so no actions needed on our side, just wait for the fix.
15:27:34 <mnasiadka> Which reminds me - that we could be better in testing OVN (as in checking if all required agents are up from Neutron point of view)
15:27:45 <mnasiadka> And possibly move the ovn jobs from experimental to normal queue?
15:27:56 <mnasiadka> mgoddard, yoctozepto: opinions?
15:28:56 <mgoddard> +1 for better testing, anywhere and everywhere
15:29:04 <yoctozepto> +1 as well
15:29:16 <mgoddard> ovn jobs aren't experimental, they just only trigger if you touch the right code
15:29:22 <yoctozepto> +1
15:29:31 <mgoddard> I think that's still reasonable
15:29:38 <mnasiadka> Ah, they are experimental on Kolla side
15:29:51 <mgoddard> yeah, all scenarios are
15:30:42 <yoctozepto> ++
15:30:47 <yoctozepto> except for basic ones
15:30:51 <yoctozepto> for gating
15:31:00 <mnasiadka> Well, in this case we haven't broken that, it was Neutron - just thinking if we should have some ,,usual'' scenarios using OVN
15:31:08 <yoctozepto> on that note, I proposed to test ironic on debian
15:31:11 <mnasiadka> or at least a periodic
15:31:56 <mnasiadka> Yeah, mgoddard asked if we need to test ironic on every single distribution :)
15:32:28 <yoctozepto> I think the schedule is fine, just need to strengthen the testing if you know how to
15:32:49 <yoctozepto> we want to test debian well :-)
15:33:21 <mnasiadka> Ok then, I'll update the testing a bit, so it would show such breakage next time.
15:33:43 <mnasiadka> Any other topics?
15:35:41 <mnasiadka> Ah, I have one - what about the meeting next week?
15:36:07 <yoctozepto> I can be there
15:36:10 <mgoddard> I'll be away
15:36:20 <yoctozepto> but if it's going to be only me, then it does not make sense :-)
15:36:45 <mnasiadka> Yeah, I'll cancel it - and we'll meet again next year (5th Jan)
15:36:52 <yoctozepto> ++
15:37:04 <mnasiadka> Ok, that's all from me.
15:37:10 <mnasiadka> Merry Christmas and a happy new Year ;-)
15:37:28 <parallax> Likewise
15:37:35 <mnasiadka> #endmeeting