15:01:20 <mnasiadka> #startmeeting kolla
15:01:20 <opendevmeet> Meeting started Wed Jan  5 15:01:20 2022 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:20 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:20 <opendevmeet> The meeting name has been set to 'kolla'
15:01:28 <yoctozepto> :-)
15:01:29 <yoctozepto> o/
15:01:42 <priteau> o/
15:01:47 <opendevreview> Radosław Piliszek proposed openstack/kolla-ansible master: [CI] Drop unused nodeset  https://review.opendev.org/c/openstack/kolla-ansible/+/823548
15:02:03 <opendevreview> Radosław Piliszek proposed openstack/kolla-ansible stable/xena: [CI] Drop unused nodeset  https://review.opendev.org/c/openstack/kolla-ansible/+/823466
15:02:06 <mnasiadka> #topic rollcall
15:02:07 <mnasiadka> o/
15:02:22 <opendevreview> Radosław Piliszek proposed openstack/kolla-ansible stable/wallaby: [CI] Drop unused nodeset  https://review.opendev.org/c/openstack/kolla-ansible/+/823467
15:02:40 <mgoddard> \o
15:04:35 <frickler> o/
15:05:40 <mnasiadka> #topic agenda
15:06:12 <mnasiadka> * Roll-call
15:06:12 <mnasiadka> * Agenda
15:06:12 <mnasiadka> * Announcements
15:06:12 <mnasiadka> * Review action items from the last meeting
15:06:12 <mnasiadka> * CI status
15:06:13 <mnasiadka> * Release tasks
15:06:13 <mnasiadka> * Current cycle planning
15:06:15 <mnasiadka> * Additional agenda (from whiteboard)
15:06:15 <mnasiadka> * Open discussion
15:06:20 <mnasiadka> #topic Announcements
15:06:44 <mnasiadka> Point releases for Kolla deliverables (stable branches) are out
15:06:59 <mnasiadka> #topic Review action items from the last meeting
15:07:37 <mnasiadka> mnasiadka to triage security bugs and update them with resolution plan (if needed)
15:07:37 <mnasiadka> mnasiadka post a patch for docs - standard topics that should be discussed over PTG and then revisited in mid-cycle
15:07:37 <mnasiadka> yoctozepto remove CentOS 8 based CI jobs
15:07:37 <mnasiadka> mgoddard raise changes for stable point releases
15:07:44 <mnasiadka> I've started to triage the sec bugs
15:07:55 <mnasiadka> mgoddard did his
15:08:01 <opendevreview> Merged openstack/kolla-ansible stable/xena: Add ironic-inspector policy configuration  https://review.opendev.org/c/openstack/kolla-ansible/+/823209
15:08:10 <mnasiadka> yoctozepto: yours is in progress, right?
15:08:15 <yoctozepto> yes
15:08:24 <yoctozepto> but you can drop the action point
15:08:33 <mnasiadka> ok
15:08:42 <mnasiadka> #action mnasiadka to triage security bugs and update them with resolution plan (if needed)
15:08:49 <mnasiadka> #action mnasiadka post a patch for docs - standard topics that should be discussed over PTG and then revisited in mid-cycle
15:09:03 <mnasiadka> #topic CI Status
15:09:09 <mnasiadka> How's the CI?
15:09:23 <frickler> arm64 debian builds are repaired
15:10:30 <mnasiadka> mgoddard, priteau: what about the kayobe-tox-ansible job failing on setuptools?
15:11:28 <priteau> When did this happen?
15:12:02 <priteau> https://zuul.openstack.org/builds?job_name=kayobe-tox-ansible
15:12:04 <mnasiadka> https://etherpad.opendev.org/p/KollaWhiteBoard - L148
15:12:43 <priteau> I was not aware. Is it resolved
15:12:48 <mnasiadka> failed around christmas time
15:12:53 <mnasiadka> but now it seems it's good
15:13:12 <yoctozepto> holidays to blame
15:13:17 <priteau> https://zuul.openstack.org/builds?job_name=kayobe-tox-ansible&branch=stable%2Fwallaby
15:13:25 <priteau> Last failure 2021-12-28 14:48:44
15:13:41 <mnasiadka> so let's mark as GREEN and revisit if needed.
15:13:56 <priteau> Same for victoria
15:14:19 <mnasiadka> updated on the whiteboard
15:14:20 <mnasiadka> let's move on
15:14:33 <mnasiadka> #topic Release tasks
15:15:10 <mnasiadka> Today is R-12 week
15:15:33 <mnasiadka> next task is at R-8 (beginning of Feb)
15:15:43 <mnasiadka> #topic Current cycle planning
15:16:39 <mnasiadka> Anybody wants to discuss any of their feature changes?
15:17:54 <mnasiadka> We have a lot of prio items on the Whiteboard without any owner - maybe somebody wants to sign up to something?
15:18:03 <mnasiadka> Line 312
15:19:15 <yoctozepto> I can't commit more time
15:21:37 <mnasiadka> yoctozepto: understandable
15:24:14 <mnasiadka> ok then, let's move on
15:24:39 <mnasiadka> #topic CentOS 8 testing removal on Kayobe pre-Victoria means removing all Kayobe testing - per https://review.opendev.org/c/openstack/kayobe/+/823266
15:25:20 <mnasiadka> Does that mean we should EOL Kayobe pre-Victoria?
15:26:57 <priteau> I know of a company using Kayobe which still has customers on older releases
15:27:11 <mnasiadka> We all know that company
15:27:38 <priteau> So should we keep ussuri and train open for commits with minimal testing only?
15:27:50 <priteau> Or should that company switch to use a fork
15:27:55 <mnasiadka> minimal testing means unit testing and ansible lint at most ;-)
15:28:02 <priteau> Better than nothing
15:28:14 <mnasiadka> Question what would break, if we would run the same testing on c8s in pre-Victoria
15:28:30 <opendevreview> Merged openstack/kayobe stable/wallaby: ipa: Use openstack_branch instead of master  https://review.opendev.org/c/openstack/kayobe/+/823354
15:28:38 <yoctozepto> if it's ok for you, I will proceed with removal
15:28:39 <opendevreview> Merged openstack/kayobe stable/wallaby: Build neutron-sriov-agent image when enabled  https://review.opendev.org/c/openstack/kayobe/+/823460
15:29:03 <mnasiadka> mgoddard: opinions?
15:29:52 <priteau> It might be good to be able to merge fixes for other Kayobe users too. There might be people still on Ussuri and Train.
15:30:26 <priteau> But we should add warnings that it is not actively tested / maintained
15:30:29 <mgoddard> I'd suggest we keep these branches open with whatever testing is available
15:30:56 <mgoddard> we'll just need to take a bit more care when merging
15:31:38 <yoctozepto> it is what I wanted to know
15:32:06 <priteau> Would we be able to run some jobs on c8s without massive changes?
15:32:18 <mnasiadka> Seems reasonable, just wanted a discussion.
15:32:25 <yoctozepto> if you want to go that route, then I'm not doing it ;-)
15:32:50 <mnasiadka> Well, the change in Victoria needs to be merged, that's logical.
15:33:54 <mnasiadka> I can invest little time in trying to run Ussuri on Stream, if that works - we can survive with that - if not - we just remove the CI depending on CentOS Linux 8.
15:35:13 <mnasiadka> So - let's merge the Victoria change and hold off before the next meeting with removing those jobs pre-Victoria - I'll do a dumb try to run Ussuri on Stream.
15:35:57 * yoctozepto likes this
15:36:34 <mgoddard> I'm not sure how much we'd gain
15:37:09 <mgoddard> unless we're going to do it properly and support ussuri on stream
15:37:11 <opendevreview> Merged openstack/kayobe stable/xena: Build neutron-sriov-agent image when enabled  https://review.opendev.org/c/openstack/kayobe/+/823459
15:37:24 <mgoddard> might be issues with RDO?
15:37:27 <mnasiadka> Ussuri and beyond are EM, so we wouldn't be able to post point releases - but I'm not a fan of keeping something alive with basically no testing
15:38:21 <priteau> mgoddard: I thought we would keep using c8 containers, using the latest that are published on docker hub, but use c8s host from opendev
15:38:36 <mnasiadka> Yes, true - for sure some packaging issues - if we use RDO in Kayobe (and I thought we don't)
15:38:59 <mgoddard> ok, c8 containers would be easier
15:41:48 <mnasiadka> Ironically... those operators that use C7 and Train are in a better position than C8 ones :)
15:41:58 <yoctozepto> indeed
15:43:20 <yoctozepto> all the more reasons to go debian-only :-)
15:43:20 <mgoddard> not really - they are basically stuck there
15:43:29 <yoctozepto> and even more :-)
15:44:37 <mnasiadka> so, c8 containers on c8s, I'm willing to try if that works in CI - if it doesn't we just keep them in bare testing regime (them = Train + Ussuri)
15:44:42 <mnasiadka> agreed?
15:44:45 <priteau> +1
15:45:08 <mgoddard> +1
15:45:45 <mnasiadka> goodie, then I'll try (on Monday/Tuesday) - I'm off for the next two days (like probably most of PL people)
15:45:51 <mgoddard> would at least provide a route from train to ussuri
15:46:07 <mnasiadka> true, for those poor people
15:46:27 <mnasiadka> Ok, last topic
15:46:31 <mnasiadka> #topic Open discussion
15:47:58 <mnasiadka> Anyone? Anything?
15:48:04 <yoctozepto> not a thing
15:48:13 <frickler> fluentd cleanup and unpin stack should be ready for reviews
15:48:15 <frickler> https://review.opendev.org/c/openstack/kolla/+/821695
15:48:41 <yoctozepto> well, except for shameless plugs it seems :D
15:49:28 <mnasiadka> Downgrade ES gems, oh boy
15:49:43 <priteau> The move from Elasticsearch to OpenSearch has become more important due to the log4j issues, because we are locked on old packages
15:49:47 <mnasiadka> So we upgrade td-agent, but downgrade ES plugins? Is it even worth it? ;-)
15:51:09 <frickler> would opensearch have their own gems?
15:51:16 <yoctozepto> it would be good to unpin td-agent
15:51:19 <yoctozepto> that's one thing
15:51:30 <yoctozepto> elasticsearch is pita atm
15:52:23 <yoctozepto> let's roll out rsyslog-based solution lol
15:55:05 <mnasiadka> Or replace Elasticsearch with something else ;)
15:56:24 <mnasiadka> frickler: https://github.com/opensearch-project/opensearch-ruby - there is this, don't know if that can be used with td-agent
15:56:25 <yoctozepto> well, rsyslog is that thing (o_o)'
15:56:49 <mnasiadka> https://github.com/uken/fluent-plugin-elasticsearch/issues/915
15:56:58 <yoctozepto> mnasiadka, frickler: it would need support in the plugin
15:57:00 <yoctozepto> or another plugin
15:57:01 <yoctozepto> yeah
15:57:04 <mnasiadka> I feel OpenSearch is a bit of a hell hole today
15:57:16 <spatel> How about - Venus (Log management service)
15:57:51 <yoctozepto> spatel: we don't know yet what it really offers; it seems to integrate with elasticsearch so it leaves it around
15:58:16 <yoctozepto> mnasiadka: yeah, that is one fugly situation
15:58:36 <yoctozepto> also, venus does not exist on earlier branches
15:58:43 <yoctozepto> it's still in review on master heh
15:59:34 <mnasiadka> ehh, maybe we need to start thinking what to do with this crap
15:59:35 <spatel> ES is pretty solid solution for logging, I am new here so not sure what is the difficulty to run it with kolla :)
15:59:52 <mnasiadka> time to finish the meeting
15:59:54 <mnasiadka> thanks for coming!
15:59:56 <mnasiadka> #endmeeting