15:00:42 <yoctozepto> #startmeeting kolla
15:00:42 <opendevmeet> Meeting started Wed Jan 12 15:00:42 2022 UTC and is due to finish in 60 minutes. The chair is yoctozepto. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:42 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:42 <opendevmeet> The meeting name has been set to 'kolla'
15:01:13 <yoctozepto> mgoddard mnasiadka hrw egonzalez yoctozepto rafaelweingartne cosmicsound osmanlicilegi bbezak parallax Fl1nt frickler adrian-a
15:01:26 <yoctozepto> #topic Roll-call
15:01:29 <yoctozepto> o/
15:02:26 <frickler> \o
15:03:06 <mgoddard> \\o
15:03:39 <yoctozepto> guessing we can start
15:03:41 <yoctozepto> #topic Agenda
15:03:55 <yoctozepto> * Roll-call
15:03:55 <yoctozepto> * Agenda
15:03:55 <yoctozepto> * Announcements
15:03:55 <yoctozepto> * Review action items from the last meeting
15:03:55 <yoctozepto> * CI status
15:03:57 <yoctozepto> * Release tasks
15:03:57 <yoctozepto> * Current cycle planning
15:03:59 <yoctozepto> * Additional agenda (from whiteboard) - nothing today
15:03:59 <yoctozepto> * Open discussion
15:04:08 <yoctozepto> #topic Announcements
15:04:20 <yoctozepto> nothing worthy of this name from my side
15:04:21 <yoctozepto> others?
15:06:30 <yoctozepto> guessing not
15:06:57 <yoctozepto> #topic Review action items from the last meeting
15:07:10 <yoctozepto> mnasiadka to triage security bugs and update them with resolution plan (if needed)
15:07:10 <yoctozepto> mnasiadka post a patch for docs - standard topics that should be discussed over PTG and then revisited in mid-cycle
15:07:23 <yoctozepto> I have seen neither but could miss something
15:07:30 <yoctozepto> anyone?
15:10:02 <mgoddard> nope
15:10:27 <yoctozepto> retriggering
15:10:33 <yoctozepto> #action mnasiadka to triage security bugs and update them with resolution plan (if needed)
15:10:38 <yoctozepto> #action mnasiadka post a patch for docs - standard topics that should be discussed over PTG and then revisited in mid-cycle
15:10:54 <yoctozepto> #topic CI status
15:12:08 <yoctozepto> k and k-a look green
15:12:13 <frickler> I think the ansible-lint issue still affects kayobe?
15:12:14 <yoctozepto> what about k-o-b?
15:12:23 <yoctozepto> hmm
15:12:25 <yoctozepto> how so
15:12:28 <frickler> at least for victoria
15:12:38 <frickler> because it is capped somehow
15:12:50 <mgoddard> we have a patch
15:13:10 <yoctozepto> oh, they have a patch
15:13:15 <mgoddard> in recheck land
15:13:15 <yoctozepto> but they no share it
15:13:24 <yoctozepto> "recheck land" <3
15:13:26 <mgoddard> https://review.opendev.org/c/openstack/kayobe/+/824103
15:13:37 <yoctozepto> #link https://review.opendev.org/c/openstack/kayobe/+/824103
15:13:42 <yoctozepto> ok
15:14:18 <yoctozepto> all right, CI mostly green, only kayobe victoria temporarily sad
15:14:49 <yoctozepto> leaving it green as it should merge soon
15:14:54 <yoctozepto> ok, let's continue
15:15:00 <yoctozepto> #topic Release tasks
15:15:24 <yoctozepto> we have R-11
15:15:57 <yoctozepto> still waiting for R-8: "Switch binary images to current release"
15:16:13 <yoctozepto> we are looking good
15:16:22 <yoctozepto> nice to have this formalised
15:16:25 <yoctozepto> ok, let's go
15:16:36 <yoctozepto> #topic Current cycle planning
15:16:52 <yoctozepto> so we had some movement in the podman department
15:17:05 <yoctozepto> the first refactor is in
15:17:38 <yoctozepto> anyone working on Yoga priorities wants to report/discuss something?
15:18:15 <mgoddard> I have a long patch chain for the kolla kollection
15:18:24 <mgoddard> thanks for the reviews so far
15:18:40 <yoctozepto> yw, what do you think about mine?
15:18:50 <mgoddard> only skimmed it
15:18:56 <yoctozepto> ok
15:19:00 <mgoddard> will probably get to it next week
15:19:14 <yoctozepto> fine by me, no rush
15:19:38 * frickler should take a look at those, too
15:19:52 <yoctozepto> yes, that would be appreciated
15:20:18 <yoctozepto> we are basically talking about this stack
15:20:20 <yoctozepto> #link https://review.opendev.org/c/openstack/ansible-collection-kolla/+/820165
15:22:05 <mgoddard> how about dropping binaries?
15:22:11 <mgoddard> (images)
15:22:52 <yoctozepto> oh my, that stalled, right?
15:22:59 <yoctozepto> who remembers the current state best?
15:23:02 <yoctozepto> let's see the whiteboard
15:23:08 <mgoddard> TODO(frickler): Look into "What do we need to make sure that users like kevko are not left on ice with their issues with source images?"
15:23:14 <mgoddard> any progress frickler?
15:23:17 <yoctozepto> mgoddard a bit faster
15:23:36 <frickler> I was waiting to get some info from kevko about their problems.
15:23:40 <yoctozepto> I think it really is at kevko with
15:23:40 <yoctozepto> TODO(): How do the requirements look like exactly?
15:23:47 <yoctozepto> precisely
15:23:54 <frickler> from my pov the setup we have for osism is good enough
15:24:44 <yoctozepto> I wonder where kevko is and if other schedule of the meeting would make him join them more often
15:24:59 <mgoddard> TODO(): better document the differences between them, so that users can transition more easily
15:25:13 <mgoddard> classic docs todo
15:25:22 <yoctozepto> yeah, docs hard
15:25:25 <yoctozepto> nobody wants to do them
15:25:39 <frickler> I'm currently working on adding a local copy of pypi into our build process, so that we could also easily add patches for wheels
15:25:40 <mgoddard> I've been docsing most of this week
15:26:08 <yoctozepto> well, I have https://review.opendev.org/c/openstack/kolla-ansible/+/809445 proposed but no reviews
15:26:27 <yoctozepto> mgoddard: docsing hard, partying hard
15:26:44 <frickler> oh, I missed that patch, will review
15:26:58 <yoctozepto> thanks frickler
15:29:00 <yoctozepto> kevko is not around but I will action him so that we don't forget it
15:29:17 <yoctozepto> #action kevko to let frickler know whether osism's solution is fine for his use case
15:30:03 <mgoddard> is there anything in the osism solution that should be in kolla?
15:32:30 <frickler> hmm, not sure, it's mostly wrapped around the build to be able to add extra patches in that didn't make it upstream (yet)
15:33:34 <mgoddard> I haven't looked closely, but how are you getting those patches in?
15:33:52 <mgoddard> I remember seeing something about an overlay directory
15:34:08 <mgoddard> that could solve a few use cases
15:34:44 <frickler> some are for kolla, those are applied before executing it. other are applied to tarballs before deploying them
15:35:07 <yoctozepto> what about pypi deps?
15:35:14 <frickler> the latter might be added to kolla, but I'll need to take a deeper look
15:35:32 <yoctozepto> are you able to manipulate them? I think that was kevko's main point
15:35:36 <yoctozepto> as far as I understood him
15:35:39 <frickler> for pypi I'm just adding a local wheel store
15:35:58 <frickler> so one could upload modified wheels there if needed
15:36:19 <yoctozepto> sounds like problem solved to me
15:36:29 <frickler> that kind of what we do in CI already be using infra-built wheels
15:36:39 <frickler> s/be/by/
15:37:30 <mgoddard> what about the tarballs?
15:37:40 <mgoddard> or git repos
15:37:53 <mgoddard> do you have local git repos that you patch?
15:38:35 <frickler> I didn't get to those yet, but I assume that that part should be the easiest, just pointing to a different source that one can control
15:38:46 <mgoddard> ok
15:40:31 <frickler> the one valid argument that remains is that for source builds there are different types of source that one must handle, while binary would be all debs/rpms
15:41:57 <frickler> but I'd say that's just the nature of things
15:42:43 <mgoddard> such is life :)
15:43:09 <yoctozepto> well, I think the issue was that nature ;-)
15:43:23 <yoctozepto> as in making pip use the other magical place
15:43:24 <frickler> mostly one would need the other sources in the process of building ones own debs anyway
15:43:46 <yoctozepto> yeah, kevko just have it for himself as he is debian dev
15:47:31 <yoctozepto> all right, I think we are out of the binary topic
15:47:36 <yoctozepto> #topic Open discussion
15:47:39 <yoctozepto> go wild
15:48:48 <mgoddard> vehdlkse;lgmrdg\sg/m\a
15:48:59 <yoctozepto> \m/
15:53:01 <yoctozepto> oh well, we can end early
15:53:07 <yoctozepto> thank you
15:53:12 <yoctozepto> #endmeeting