15:00:16 <mnasiadka> #startmeeting kolla
15:00:16 <opendevmeet> Meeting started Wed Feb  9 15:00:16 2022 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <opendevmeet> The meeting name has been set to 'kolla'
15:00:24 <mnasiadka> #topic rollcall
15:00:40 <mnasiadka> o/
15:02:08 <mgoddard> \o
15:02:22 <hinermar> o/
15:02:25 <halomiva> \o
15:02:59 <yoctozepto> o/
15:05:44 <mnasiadka> #topic agenda
15:05:44 <mnasiadka> * Announcements
15:05:44 <mnasiadka> * Review action items from the last meeting
15:05:44 <mnasiadka> * CI status
15:05:44 <mnasiadka> * Release tasks
15:05:45 <mnasiadka> * Current cycle planning
15:05:45 <mnasiadka> * Additional agenda (from whiteboard)
15:05:47 <mnasiadka> * Open discussion
15:05:48 <mnasiadka> #topic Announcements
15:06:08 <mnasiadka> FYI - The combined PTL and TC elections have started.
15:06:27 <mnasiadka> I've already put my name in the Kolla subdir for Z - if anybody else wants to run - feel free ;-)
15:06:48 <yoctozepto> mnasiadka go go go o/
15:07:06 <mnasiadka> #topic Review action items from the last meeting
15:08:01 <mnasiadka> (anybody) to triage security bugs and update them with resolution plan (if needed)
15:08:01 <mnasiadka> mnasiadka post a patch for docs - standard topics that should be discussed over PTG and then revisited in mid-cycle
15:08:01 <mnasiadka> mnasiadka to triage security bugs and update them with resolution plan (if needed)
15:08:01 <mnasiadka> hrw to discuss with pynacl upstream to release binary wheel of 1.4.0 for aarch64
15:08:01 <mnasiadka> mnasiadka to propose a reno and change in docs claiming that CentOS 8 is EOL and we don't support it anymore on train/ussuri/victoria - and users are on their own... + stop any CI related to CentOS 8 (non-stream)
15:08:03 <mnasiadka> yoctozepto to remove debian master binary images from container registry
15:08:09 <mnasiadka> well, not anybody but me
15:08:25 <mnasiadka> but yes, triaging sec bugs is nearly done, will update them tomorrow with closure
15:08:37 <mnasiadka> I haven't posted patch for docs, promise to really do it this week
15:08:53 <mnasiadka> hrw is not here, I have no clue what's with pynacl and aarch
15:09:24 <mnasiadka> CentOS 8 patch series is done, allegedly centos-release-ceph-nautilus package is fixed, so I will pursue removal of the temporary RDO repo
15:09:27 <yoctozepto> I removed the images
15:09:33 <mnasiadka> fantastic
15:09:40 <mnasiadka> #action mnasiadka post a patch for docs - standard topics that should be discussed over PTG and then revisited in mid-cycle
15:09:48 <mnasiadka> #action mnasiadka to triage security bugs and update them with resolution plan (if needed)
15:09:58 <mnasiadka> that's about it I guess
15:10:02 <yoctozepto> and hrw's
15:10:06 <mnasiadka> ah right
15:10:12 <mnasiadka> #action hrw to discuss with pynacl upstream to release binary wheel of 1.4.0 for aarch64
15:10:18 <mnasiadka> #topic CI Status
15:10:55 <mnasiadka> I think it looks green-ish - not counting the Ceph jobs which I need to put some efforts in, seems Ceph devs like to break setups like ours (with public Ceph network over a vxlan fabric)
15:11:27 <opendevreview> Merged openstack/kolla stable/ussuri: Drop CentOS Linux 8 image builds  https://review.opendev.org/c/openstack/kolla/+/828403
15:11:46 <mnasiadka> Is there anything else that needs attention in CI?
15:11:51 <yoctozepto> what's wrong with vxlan fabric?
15:11:53 <mnasiadka> Can we update the status from RED to GREEN now?
15:12:00 <yoctozepto> yes, let's do it
15:12:14 <mnasiadka> yoctozepto: they assume the entry in /etc/hosts should point to your public Ceph cluster network...
15:12:42 <mnasiadka> Anyway, let's not spend time on this, need put some minutes in finding out how to fix it and get over with it.
15:12:46 <yoctozepto> oh my
15:13:20 <mnasiadka> #topic Release tasks
15:13:42 <mnasiadka> So, we had some R-8 tasks - hrw was on them, I think only Ubuntu had some issues?
15:13:53 <yoctozepto> yeah, with horizon
15:14:19 <mnasiadka> https://review.opendev.org/c/openstack/kolla/+/826488
15:14:23 <mnasiadka> seems that's merged
15:15:12 <mnasiadka> R-2 is feature freeze - Mar 14 - Mar 18
15:15:16 <mnasiadka> as a reminder
15:15:56 <mnasiadka> #topic Current cycle planning
15:17:01 <mnasiadka> So, looking at priorities - RMQ 3.9 needs a second review https://review.opendev.org/c/openstack/kolla/+/827656
15:17:48 <mnasiadka> The Ceph upstream repos seems to be a conflict now - because Kayobe has removed EPEL support and mgoddard's libvirt on host feature needs to install some Ceph packages for libvirt...
15:18:02 <mnasiadka> TL;DR - Ceph upstream repos need EPEL
15:18:27 <mnasiadka> And I'm not happy about it - at least not much.
15:18:57 <yoctozepto> meh
15:19:03 <yoctozepto> let's just drop centos and get over it
15:19:28 <mnasiadka> that's also a possibility
15:20:07 <mnasiadka> Opendev nodes with Rocky Linux 8 are coming soon, so we might want to discuss later how much CI would we like to run there as part of the RL8 support in Yoga.
15:20:48 <mnasiadka> But let's be realistic, we can't kill of CS8 before we move on to Rocky Linux 9 or something similar ;-)
15:20:53 <mnasiadka> *kill off
15:21:15 <yoctozepto> no, we can - move to debian like planned, or ubuntu if you like to have a company backing your system
15:22:24 <mnasiadka> Of course.
15:22:41 <mnasiadka> So - what about Podman? Should we discuss it now, or in the ,,additional topics'' slot?
15:22:52 <yoctozepto> either way works for me
15:23:10 <mgoddard> we're not dropping centos stream 8
15:23:45 <opendevreview> Michal Nasiadka proposed openstack/kolla master: rabbitmq: update to 3.9  https://review.opendev.org/c/openstack/kolla/+/827656
15:24:13 <mnasiadka> halomiva, hinermar: ready?
15:24:21 <yoctozepto> mgoddard: sadly~
15:24:30 <hinermar> yep
15:24:38 <mnasiadka> Adding podman: Docker systemd patchset https://review.opendev.org/c/openstack/kolla-ansible/+/816724
15:24:38 <mnasiadka> dbus testing issues
15:24:38 <mnasiadka> requirements issues
15:24:38 <mnasiadka> adding abstract class
15:25:36 <mnasiadka> so, what are the issues, and are we able to fix them before mid March?
15:26:17 <hinermar> regarding the dbus problems, the dbus package is dependent on system packages so it can't be trivially installed on virtual environment
15:26:59 <yoctozepto> hmm
15:27:03 <halomiva> these issues are only for testing, deployment works fine
15:27:05 <yoctozepto> should not it be mocked out?
15:27:17 <yoctozepto> unit tests should not use system dbus
15:27:17 <mgoddard> +1
15:29:45 <hinermar> I should have asked sooner because I have already finished unit test for it, which works in Python 3.6 but not in 3.9 as you can see in the Zuul report
15:29:45 <yoctozepto> anybody home? :D
15:29:50 <opendevreview> Merged openstack/kolla-ansible master: [docs] Rewrite operating-kolla upgrade-wise  https://review.opendev.org/c/openstack/kolla-ansible/+/809445
15:29:58 <yoctozepto> hmm
15:31:48 <hinermar> the problem seems to be somewhere in the difference of the python versions
15:32:12 <yoctozepto> ModuleNotFoundError: No module named '_dbus_bindings'
15:32:24 <yoctozepto> File "/usr/lib/python3/dist-packages/dbus/types.py", line 8, in <module>
15:32:24 <yoctozepto> from _dbus_bindings import (
15:34:15 <hinermar> yes, when I looked up that error, people said it vas caused by changing the python version
15:34:50 <mgoddard> could be some C module
15:35:50 <yoctozepto> yeah, it is
15:35:53 <mgoddard> or because it needs to match the system python version which has dbus?
15:36:10 <yoctozepto> it's compiled for py3.6 and tried to be used with py3.9
15:36:15 <yoctozepto> we can't really do that
15:36:20 <mnasiadka> it seems it's a CPython binding library
15:36:48 <mnasiadka> The 3.9 CI unit test job runs on Ubuntu?
15:37:00 <yoctozepto> yeah
15:37:44 <opendevreview> Merged openstack/kayobe master: Remove deprecated kolla_tls_cert variable  https://review.opendev.org/c/openstack/kayobe/+/821607
15:37:48 <opendevreview> Merged openstack/kayobe master: Update documentation about CentOS support  https://review.opendev.org/c/openstack/kayobe/+/824141
15:38:08 <mnasiadka> then it won't work for 3.9
15:38:41 <yoctozepto> yeah, I guess we are testing at the wrong level
15:39:34 <mgoddard> I'd suggest we do a python mock of the dbus object, and do a more end to end test in the integration jobs
15:39:48 <opendevreview> Verification of a change to openstack/kayobe master failed: Support building multiple disk images  https://review.opendev.org/c/openstack/kayobe/+/812516
15:39:52 <opendevreview> Verification of a change to openstack/kayobe master failed: Support elements repositories for overcloud host images  https://review.opendev.org/c/openstack/kayobe/+/821413
15:41:18 <mnasiadka> Sounds like a good plan - any other issues to tackle for Podman support?
15:41:35 <yoctozepto> btw, why can't we just install https://pypi.org/project/dbus-python/
15:41:40 <yoctozepto> inside the venv
15:41:43 <yoctozepto> what fails?
15:42:28 <halomiva> yea, what should be the next step? adding an abstract class or adding podman with that class in one commit?
15:44:05 <hinermar> yoctozepto: it seems that it can't see some system packages and fails at that
15:44:57 <yoctozepto> hinermar: did you try installing the dev package for dbus?
15:45:41 <hinermar> yeah, it was already present
15:45:55 <yoctozepto> odd
15:46:22 <mgoddard> halomiva: re next step, I don't mind. I expect there will be a few itertions, and it may be easier to put it all in one patch to begin with
15:46:33 <yoctozepto> hinermar: let me edit your patch, ok?
15:47:08 <hinermar> how do i do that? :D
15:47:54 <mgoddard> yoctozepto: or run unit tests locally?
15:48:31 <halomiva> so we can continue patching this one ? https://review.opendev.org/c/openstack/kolla-ansible/+/799229
15:48:48 <yoctozepto> mgoddard: yeah, it works for me with the dev pkg so I assume it's a CI issue
15:49:06 <yoctozepto> hinermar: just don't mind when I do ;-)
15:49:22 <hinermar> ahh, that's alright then
15:49:40 <mgoddard> halomiva: yes, rebase that onto systemd
15:50:00 <opendevreview> Radosław Piliszek proposed openstack/kolla-ansible master: Systemd container control  https://review.opendev.org/c/openstack/kolla-ansible/+/816724
15:51:17 <mnasiadka> Ok, anything else to add, or can we move on?
15:51:33 <hinermar> just a quick help
15:52:05 <hinermar> how do I add requirement in openstack/requirements?
15:52:20 <hinermar> based on this error from Zuul: ERROR: Requirement '{Requirement(package='python-dbusmock', location='', specifiers='>=0.25', markers='', comment='# GPLv3', extras=frozenset())}' not in openstack/requirements
15:53:04 <opendevreview> Radosław Piliszek proposed openstack/kolla-ansible master: Systemd container control  https://review.opendev.org/c/openstack/kolla-ansible/+/816724
15:53:27 <opendevreview> Radosław Piliszek proposed openstack/kolla-ansible master: Systemd container control  https://review.opendev.org/c/openstack/kolla-ansible/+/816724
15:54:54 <yoctozepto> hinermar: ahm, you need to propose it against the openstack/requirements repo
15:56:08 <hinermar> okay, thanks
15:56:14 <mgoddard> hinermar: could just add it to the blacklist: https://opendev.org/openstack/requirements/src/branch/master/blacklist.txt
15:56:47 <yoctozepto> yeah, best there
15:57:14 <hinermar> alright, that's all from us
15:57:52 <mnasiadka> ok then, it's two minutes until the end
15:58:07 <mnasiadka> yoctozepto: we'll talk about your topic next week, is that ok?
15:58:16 <yoctozepto> that's ok
15:58:18 <yoctozepto> no hurry
15:58:27 <mnasiadka> Ok, then let's finish for today.
15:58:31 <yoctozepto> thanks mnasiadka
15:58:37 <yoctozepto> have a nice evening
15:58:37 <mnasiadka> Thanks for attending and see you next week :)
15:58:39 <mnasiadka> #endmeeting