14:00:01 <mnasiadka> #startmeeting kolla
14:00:01 <opendevmeet> Meeting started Wed Apr 20 14:00:01 2022 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:01 <opendevmeet> The meeting name has been set to 'kolla'
14:00:03 <mnasiadka> #topic rollcall
14:00:06 <mnasiadka> o/
14:08:31 <hrw> /o\/o\
14:09:26 <mnasiadka> #topic agenda
14:09:26 <mnasiadka> * CI status
14:09:26 <mnasiadka> * Release tasks
14:09:27 <mnasiadka> * Current cycle planning
14:09:27 <mnasiadka> * Additional agenda (from whiteboard)
14:09:27 <mnasiadka> * Open discussion
14:09:38 <mnasiadka> #topic CI Status
14:09:48 <mnasiadka> I think that's quite ok now, since we fixed Victoria and Ussuri?
14:10:59 <hrw> Yoga will be ready once CI mirror centOS
14:11:14 <mnasiadka> yup, that's release task :D
14:11:32 <hrw> I would say that CI is fine
14:12:30 <mnasiadka> #topic Release tasks
14:12:53 <mnasiadka> So the only patch that needs to be merged is the CentOS one - and we're waiting for infra mirror sync
14:13:03 <mnasiadka> I haven't seen other disturbing issues
14:13:09 <mnasiadka> hrw: what about the Ubuntu horizon thing?
14:13:17 <hrw> UCA horizon is a problem
14:13:28 <hrw> not heard anything from UCA team on irc. will reask
14:13:39 <mnasiadka> ok, do they have a bug filed for this?
14:14:34 <hrw> not by me and not checked
14:14:38 <mnasiadka> ok
14:14:50 <mnasiadka> #topic Current cycle planning
14:15:19 <mnasiadka> We're on a good path to get rid of binary once and for all
14:15:37 <hrw> we got rid of it
14:15:40 <mnasiadka> So I guess that's the ,,theme'' that is progressing now
14:15:44 <hrw> we are now on cleaning
14:15:55 <mnasiadka> Yeah, I was thinking about cleaning and getting rid of -source in the image name
14:16:05 <hrw> yep. short names as we call it
14:16:36 <hrw> uhttps://review.opendev.org/c/openstack/kolla-ansible/+/837293 needs merge and then I do one patch to kolla and we are on source only with short names
14:16:45 <mnasiadka> great
14:16:52 <hrw> then upgrade paths need work but that in 'additional agenda'
14:16:58 <mnasiadka> ok
14:17:02 <mnasiadka> #topic Additional agenda (from whiteboard)
14:17:18 <mnasiadka> let's start with yours
14:17:19 <mnasiadka> (hrw) Yoga->Zed upgrades
14:17:34 <hrw> paste rest
14:17:43 <mnasiadka> new CI job: Y/binary -> Z/source
14:17:51 <mnasiadka> we need to handle removal of old images (Y/binary ones or Y/source ones as we will have shorter names in Z)
14:17:54 <hrw> ok
14:18:05 <hrw> so for now we only test Y/source -> Z/source on CI
14:18:29 <hrw> as there is no Y/binary -> Z/binary path we need to test Y/binary -> Z/source one
14:18:59 <hrw> and then we need a way to get rid of old containers as names are changed in both scenarios
14:19:18 <hrw> kolla/ubuntu-binary-nova-compute -> kolla/ubuntu-nova-compute etc
14:19:25 <mnasiadka> image names have changed, so that should be handled semi-automatically in existing code
14:19:37 <hrw> would be bad to have both copies running
14:19:39 <mnasiadka> if the image name variable gets templated properly
14:19:46 <hrw> NOTE: I never did upgrades
14:20:02 <mnasiadka> Ok, I guess we (me, yoctozepto, mgoddard) can help with this one
14:20:36 <hrw> yoctozepto: you here or not yet?
14:21:04 <mnasiadka> we don't have CI for binary-upgrade currently, but it makes sense to test the move from binary to source
14:21:17 <hrw> we need to have it as this will be popular path
14:21:47 <hrw> and better get it running in first weeks of cycle before we grab Z changes from projects
14:22:18 <mnasiadka> yup, agree
14:22:34 <mnasiadka> seems yoctozepto is very late ;)
14:22:44 <mnasiadka> should we move his topics to next week?
14:23:07 <hrw> we can discuss them now too
14:23:12 <hrw> it is EM/EOL
14:23:19 <mnasiadka> (yoctozepto) EM Victoria
14:23:22 <mnasiadka> that's obvious
14:23:35 <mnasiadka> do we need to merge any Victoria patches before we do that last release and mark as EM?
14:23:45 <hrw> iirc we did but moment
14:24:01 <hrw> nothing in queue
14:24:10 <hrw> so we can #action
14:24:29 <mnasiadka> no open changes in Kolla, one open in K-A (make kolla-build quiet)
14:24:41 <hrw> ok, merge it and release
14:24:46 <mnasiadka> and two in Kayobe
14:25:23 <mnasiadka> mgoddard: https://review.opendev.org/c/openstack/kayobe/+/782703 and https://review.opendev.org/c/openstack/kayobe/+/830069 - either let's merge them or abandon
14:25:54 <mnasiadka> (yoctozepto) EOL Train
14:25:59 <mnasiadka> that's more complicated
14:26:25 <hrw> I vote for EOL despite it being migration point
14:26:58 <mnasiadka> we have some (not a lot, just a couple) customers on Train, I'll check internally if there are any reasons for not doing EOL - but I doubt there are
14:27:06 <hrw> ok
14:27:32 <hrw> #note EMHPC Train then
14:27:33 <hrw> ;D
14:27:43 <mnasiadka> #action mnasiadka work on marking Train EOL
14:28:00 <mnasiadka> ok then, seems like we're done
14:28:03 <mnasiadka> #topic Open discussion
14:28:08 <mnasiadka> anything?
14:28:30 <hrw> ubuntu 22.04 is coming - another thing to your plate ;D
14:28:48 <mnasiadka> yeah, we know, we'll manage it
14:28:56 <hrw> external repos will be main pain probably
14:29:04 <yoctozepto> o/
14:29:33 <hrw> infra team will mirror main repos, you need to add UCA mirror probably (I did most of previous ones iirc)
14:29:38 <mnasiadka> yoctozepto: you just made it to open discussion ;-)
14:30:01 <hrw> one thing: do we checked core members lists?
14:30:02 <yoctozepto> mnasiadka: to close the meeting :-)
14:30:29 <hrw> there are people who I have not seen for a while there
14:30:39 <mnasiadka> we did, last cycle, I did not remove some people that promised to continue working on Kolla
14:30:45 <hrw> ok
14:30:51 <mnasiadka> I can review if they did anything
14:31:19 <hrw> yoctozepto: re-read meeting and add what you want
14:32:05 * yoctozepto finished reading
14:32:14 <yoctozepto> I agree that we should revisit the cores' list
14:32:37 <yoctozepto> as other projects do
14:33:13 <yoctozepto> re upgrades from binary to source (typeless) - will do
14:33:31 <opendevreview> Maksim Malchuk proposed openstack/kayobe master: Cleanup old and deprecated Swift configuration  https://review.opendev.org/c/openstack/kayobe/+/838730
14:33:56 <mnasiadka> I have a question - we're left with admin endpoint for keystone (removed all the others) - what's the ultimate plan with it?
14:34:56 <hrw> btw - ussuri is EM already?
14:35:37 <mnasiadka> yes
14:35:50 <mnasiadka> Ifa0b1b059ca8aafb76b2c25c1dd03209bc001f2d
14:36:32 <hrw> ok. have to remember 'ignore <W'
14:36:33 <yoctozepto> mnasiadka: remove it
14:36:46 <yoctozepto> mnasiadka: it even has a random bug (on the whiteboard)
14:36:49 <yoctozepto> as it uses a high port
14:36:59 <yoctozepto> anything can randomly pick it up and block the deploy
14:37:22 <mnasiadka> yoctozepto: I stumbled upon Magnum having issues with lack of admin endpoint today, I think keystoneclient/keystoneauth1 defaults to that...
14:37:56 <yoctozepto> mnasiadka: ugh? lack of admin endpoint for what?
14:39:17 <mnasiadka> yoctozepto: lack for admin endpoint for keystone :)
14:39:28 <yoctozepto> mnasiadka: but it's not removed (-:
14:39:46 <yoctozepto> or do you mean it is somewhere where you support it?
14:39:48 <mnasiadka> Yeah, I know - but it's not created by default in devstack
14:40:00 <yoctozepto> devstack, devstack
14:40:01 <mnasiadka> Used devstack to test out one thing in Magnum and stumbled across this
14:40:02 <yoctozepto> this is kolla meeting
14:40:12 <mnasiadka> So just asked, if we are planning to remove admin endpoint in keystone
14:40:13 <yoctozepto> just use kolla to test out one thing...
14:40:18 <mnasiadka> if yes - I need to fix it there :D
14:40:30 <yoctozepto> are you sure it's not devstack's misconfig?
14:40:30 <mnasiadka> yoctozepto: write tempest tests in Kolla? come on
14:40:50 <yoctozepto> mnasiadka: we should run tempest at some point tbh
14:40:58 <yoctozepto> no need to write, just run
14:41:19 <mnasiadka> write NEW tests for Magnum, calm down :)
14:41:24 <hrw> mnasiadka: https://bugs.launchpad.net/cloud-archive/+bug/1969630 is yoga/uca/horizon bug
14:41:42 <hrw> deprecate magnum in yoga, remove in zed
14:41:55 <mnasiadka> Tempest in K-A CI? Well, sure, why not
14:42:04 <hrw> tomorrow we will only worry of Magnum as guns ;D
14:42:31 <mnasiadka> deprecate and remove OpenStack, why not ;)
14:42:37 <yoctozepto> mnasiadka: well, you write tempest tests and run them against k-a; I think I am missing the point you are trying to make by running devstack ;-)
14:42:58 <mnasiadka> yoctozepto: replicate CI and find new problems in devstack :D
14:43:03 <yoctozepto> mnasiadka: well, magnum is not necessarily the best faring project
14:43:16 <yoctozepto> mnasiadka: ah, you are now a devstack fanboy, very well
14:43:19 <mnasiadka> yoctozepto: there's a couple of them, trying to make it better
14:43:22 <yoctozepto> go get those bash scripts
14:43:31 <mnasiadka> yoctozepto: don't even get me started :)
14:43:35 <mnasiadka> anyway, let's finish
14:43:35 <yoctozepto> :-)
14:43:38 <mnasiadka> thanks for the meeting!
14:43:39 <yoctozepto> thus go kolla
14:43:42 <mnasiadka> #endmeeting