14:00:21 <frickler> #startmeeting kolla
14:00:21 <opendevmeet> Meeting started Wed Apr 27 14:00:21 2022 UTC and is due to finish in 60 minutes.  The chair is frickler. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:21 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:21 <opendevmeet> The meeting name has been set to 'kolla'
14:00:34 <frickler> #topic rollcall
14:01:07 <frickler> anyone up for a meeting? /me is doing this for the first time, so please bear with me
14:01:37 <hrw> o/
14:02:26 <mgoddard> \o
14:04:18 <frickler> #topic agenda
14:04:23 <frickler> * Roll-call
14:04:23 <frickler> * Agenda
14:04:23 <frickler> * Announcements
14:04:23 <frickler> * Review action items from the last meeting
14:04:23 <frickler> * CI status
14:04:25 <frickler> * Release tasks
14:04:28 <frickler> * Current cycle planning
14:04:30 <frickler> * Additional agenda (from whiteboard)
14:04:33 <frickler> * Open discussion
14:04:40 <frickler> #topic Announcements
14:04:55 <frickler> nothing that I know about, anyone anything to mention?
14:05:08 <hrw> Ubuntu 22.04 released
14:05:39 <hrw> infra mirror exists, we lack external repos so k-a CI will not pass
14:05:45 <frickler> yes, image is available in infra (no arm yet)
14:06:15 <hrw> no fluentd, influxdb, mariadb
14:06:37 <frickler> I've started testing devstack, that also has some issues in neutron it seems
14:07:06 <frickler> hrw: can we use focal repos for those?
14:07:22 <hrw> no idea
14:07:37 <hrw> I left ubuntu update for someone else this time
14:07:54 <hrw> we have similar issues with cs9 update
14:08:02 <frickler> o.k., maybe just wait and see, then. I can look at it once I get devstack working
14:08:18 <hrw> next topic?
14:08:29 <frickler> #topic Review action items from the last meeting
14:08:37 <frickler> I didn't see any
14:08:48 <frickler> #topic CI status
14:09:18 <frickler> the grafana dashboard need updating
14:09:22 <frickler> #link https://grafana.opendev.org/d/c0d59dad13/kolla-failure-rate?orgId=1
14:09:34 <frickler> lots of binary job references
14:09:40 <hrw> I wonder is anyone using it
14:10:20 <frickler> it would be a good view on CI status if it were up to date, I'll take an action to try and update it
14:10:36 <frickler> #action frickler update grafana dashboard
14:11:18 <frickler> anything else on CI things?
14:11:19 <hrw> frickler: we have new names in Zed so it would be nice to have
14:11:46 <hrw> https://review.opendev.org/c/openstack/kolla-ansible/+/839047 needs second check - adds binary->source upgrade job
14:12:20 <hrw> not remember other issue
14:12:21 <frickler> o.k., I'll look at that later
14:12:39 <frickler> #topic Release tasks
14:12:51 <frickler> I must admit I don't know where to look for these
14:13:19 <hrw> https://docs.openstack.org/kolla/latest/contributor/release-management.html iirc
14:14:12 <hrw> https://review.opendev.org/q/project:openstack%252Fkolla-ansible+branch:stable%252Fyoga lists 3 patches not merged yet
14:14:29 <frickler> seems we are at R-23 now https://docs.openstack.org/kolla/latest/contributor/release-management.html#r-23-development-begins
14:14:40 <hrw> kolla and kayobe are fine in stable/yoga
14:15:06 <frickler> [all] Communicate end of feature freeze via IRC meeting
14:15:07 <hrw> frickler: R-23 for Zed. But did we released Yoga?
14:15:40 <frickler> hrw: hmm, good point
14:16:08 <hrw> we need to review and merge/reject 3 k-a patches and do RC or release
14:16:52 <frickler> mgoddard: do you know how to proceed with that? otherwise I guess we'll need to wait for mnasiadka being well again
14:17:09 <frickler> I'll look at the open patches
14:18:01 <frickler> anyway, I guess let's move on, then
14:18:15 <mgoddard> I don't think any of the patches are critical - just bugfix backports
14:18:23 <mgoddard> so in theory we could release
14:19:07 <mgoddard> feels a bit too soon though. Where are the usual release blockers?
14:19:18 <mmalchuk> mgoddard 817076 is not bugfix
14:19:43 <mmalchuk> https://review.opendev.org/c/openstack/kolla-ansible/+/817076
14:20:21 <hrw> mmalchuk: that's master. not stable/yoga
14:20:47 <mmalchuk> oops
14:21:27 <mmalchuk> sorry
14:21:30 <hrw> np
14:22:37 <frickler> #topic Current cycle planning
14:23:05 <hrw> now we talk Zed
14:23:26 <hrw> we need a task in k-a to cleanup old containers after upgrade
14:23:51 <frickler> hrw: containers or just images?
14:24:04 <hrw> https://review.opendev.org/c/openstack/kolla-ansible/+/839047 job shows old ubuntu-binary-* images on hosts
14:24:07 <hrw> frickler: images, right
14:25:50 <frickler> do you want to do that or do we need to find someone?
14:26:08 <hrw> I did not checked, maybe k-a has something for it already
14:26:14 <mgoddard> hrw: this is how it always is
14:26:15 <hrw> long time since my last deployment
14:26:24 <hrw> mgoddard: ok
14:26:31 <mgoddard> hrw: after wallaby -> xena upgrade you still have wallaby images
14:26:36 <mgoddard> they're just not running
14:27:00 <hrw> ok, so something for me in spare time ;D
14:28:21 <frickler> anything else or should we go to hrw's topic?
14:29:05 <hrw> frickler: the ones in whiteboard are for last week
14:29:21 <frickler> oh, so we can drop them?
14:30:04 <hrw> dropped all as we discussed them week ago
14:30:13 <frickler> then we'd just have ...
14:30:21 <frickler> #topic Open discussion
14:30:45 <hrw> RDO team just announced Yoga release
14:30:56 <hrw> for CS8 and CS9
14:32:30 <jamesbenson> Q: Do we want to offer any support to ceph in ka or just purely the docs?
14:32:55 <jamesbenson> I know it used to be supported many moons ago, just a thought.
14:33:11 <frickler> jamesbenson: iiuc it was removed and assumed to be handled externally
14:33:57 <hrw> jamesbenson: ceph is only external. we dropped installing it and no way back
14:34:20 <mmalchuk> agree, there are more tools to deploy ceph, eg. cephadm, ceph-ansible, ceph-deploy... users should use any
14:34:25 <jamesbenson> okay, so no bringing it back then. thanks
14:36:18 <frickler> another note: nova dropped support for py36, so once we switch to zed/master, forced end of CS8 support I guess unless
14:36:34 <frickler> unless someone wants to bring in py38 there?
14:37:31 <hrw> we agreed on move to CS9
14:37:45 <hrw> external repos are problem
14:38:13 <hrw> we have same issue with CS9 and ubuntu 22.04 - no external repos yet
14:39:05 <hrw> for fluentd image we need td-agent build with openssl 3 which also means ruby 3 so upstream has some stuff to handle
14:39:30 <hrw> https://github.com/fluent/fluentd/discussions/3704 for more
14:41:51 <frickler> yeah, seems we only can wait for that and maybe start testing initially with a reduced set of external stuff
14:43:18 <hrw> frickler: https://review.opendev.org/c/openstack/kolla/+/836664 moves to cs9
14:43:31 <frickler> jammy comes with mariadb 10.6 at least natively
14:43:33 <hrw> added you
14:44:16 <frickler> hrw: do you mean to W-1 instead of review -1?
14:44:30 <frickler> but I'll have a look at that anyway
14:44:38 <hrw> effect is the same - ignore zuul, not ready for merge, ready for review
14:45:01 <hrw> w-1 is too much "work in progress, can ignore"
14:45:21 <hrw> r-1 is more 'I do not like it, review to check do you agree'
14:45:22 <frickler> hrw: review -1 isn't technically blocking, though, so if you want to avoid it getting merged, I'd prefer W-1
14:45:46 <frickler> o.k., asking for more negative feedback is a valid use
14:46:13 <hrw> moved to w-1
14:46:59 <hrw> will restore k-a job to make sure it does not pass zuul ;D
14:47:45 <frickler> after looking at the patch, I hope noone would approve something that removes so much testing
14:48:13 <frickler> but better be safe than sorry, yes
14:48:42 <frickler> anything else? otherwise we could end a bit early
14:49:45 <hrw> nothing more from my side
14:49:53 <frickler> o.k., thx everyone
14:50:03 <frickler> #endmeeting