14:00:03 <mnasiadka> #startmeeting kolla
14:00:03 <opendevmeet> Meeting started Wed Jun 22 14:00:03 2022 UTC and is due to finish in 60 minutes. The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:03 <opendevmeet> The meeting name has been set to 'kolla'
14:00:04 <mnasiadka> #topic rollcall
14:00:12 <mnasiadka> o/
14:01:35 <frickler> \o
14:02:11 <ra-rau> o/
14:02:47 <yoctozepto> o/
14:03:13 <mnasiadka> #topic agenda
14:03:13 <mnasiadka> * Review action items from the last meeting
14:03:13 <mnasiadka> * CI status
14:03:13 <mnasiadka> * Release tasks
14:03:13 <mnasiadka> * Regular stable releases (first meeting in a month)
14:03:15 <mnasiadka> * Current cycle planning
14:03:15 <mnasiadka> * Additional agenda (from whiteboard)
14:03:17 <mnasiadka> * Open discussion
14:03:19 <mnasiadka> #topic Review action items from the last meeting
14:03:28 <mnasiadka> frickler to continue working on Grafana dashboards
14:03:28 <mnasiadka> hrw to look for aarch64 failures in yoga/master
14:03:28 <mnasiadka> mnasiadka add more release liasons
14:03:31 <mnasiadka> I did mine
14:03:37 <mnasiadka> hrw is not here
14:03:44 <mnasiadka> #action hrw to look for aarch64 failures in yoga/master
14:03:47 <mnasiadka> frickler: ?
14:03:53 <frickler> I did some dashboard updates, but not finished yet
14:04:01 <mnasiadka> ok, in progress then
14:04:07 <mnasiadka> #action frickler to continue working on Grafana dashboards
14:04:21 <mnasiadka> #topic CI status
14:04:32 <mnasiadka> yoctozepto: CI all green I guess?
14:04:42 <yoctozepto> seems so
14:04:48 <mnasiadka> at least once
14:04:55 <mnasiadka> #topic Release tasks
14:05:26 <mnasiadka> This week is R-15
14:05:31 <mnasiadka> Yoga Cycle-Trailing Release Deadline
14:06:00 <mnasiadka> And I think we merged the R-17 patches (switching back to master)
14:06:35 <mnasiadka> I need to check if we did that for Kayobe
14:06:44 <mnasiadka> #topic Regular stable releases (first meeting in a month)
14:07:03 <mnasiadka> frickler: did we merge the regular stable release - first patch that you raised?
14:07:09 <frickler> yes
14:07:12 <mnasiadka> fantastic
14:07:23 <mnasiadka> do we need another one now, or not yet?
14:07:38 <frickler> in two weeks would be first meeting of July
14:07:43 <mnasiadka> ok
14:07:49 <mnasiadka> I'm going to be off first two weeks of July
14:07:59 <mnasiadka> yoctozepto/frickler: can you run the meetings?
14:08:19 <frickler> the first one yes, I may be off after that, too
14:08:27 <yoctozepto> I will be there
14:08:48 <mnasiadka> ok, I'm leaving 30th (next week Thu - so will run next meeting) - coming back 18th July
14:09:06 <mnasiadka> #topic Current cycle planning
14:09:57 <frickler> do we want to discuss Jammy under this topic or later?
14:10:04 <mnasiadka> That's the topic for it
14:10:17 <mnasiadka> Thanks for picking up this topic as a joint effort ;-)
14:10:46 <frickler> well thanks for breaking the things that I had working :-P
14:11:04 <mnasiadka> Well, I think it makes sense to have the init-runonce patch as separate
14:11:12 <frickler> first thing: tzdata vs. /etc/timezone, I would suggest to keep it in bindep
14:11:22 <mnasiadka> I'll raise it later today (unless you've done that already).
14:11:39 <mnasiadka> Well, bindep is for CI - what about regular users?
14:11:40 <frickler> btw. we should fix kolla bindep getting used in kolla-ansible jobs
14:11:58 <yoctozepto> we should probably disable it
14:11:59 <frickler> the ssh key type patch I didn't do yet
14:12:20 <frickler> yoctozepto: and then set up the CI environment how?
14:12:33 <yoctozepto> anyhow, do we still need to mount /etc/timezone?
14:12:35 <mnasiadka> ok, I'll do it today (the ssh key type patch) as promised
14:12:45 <mnasiadka> yoctozepto: that's probably a good question
14:12:46 <yoctozepto> frickler: I think that file is actually just cargoculting stuff
14:13:19 <frickler> o.k., so make a patch to drop it and we can base jammy on top
14:13:34 <yoctozepto> roger that
14:14:40 <frickler> then there are the monasca issues. does anyone really care about monasca?
14:15:43 <frickler> or phrased differently, who would block just dropping it?
14:15:56 <yoctozepto> not me
14:16:56 <mnasiadka> Let's post a patch for it, and see what's the result - but probably would be worth sending a mail to the mailing list.
14:17:09 <mnasiadka> my company is not relying on it anymore
14:17:11 <yoctozepto> how badly is it broken?
14:17:23 <yoctozepto> mnasiadka: wow, that's good to hear
14:17:25 <mnasiadka> it requires some confluent/kafka libs that are not in distros
14:17:31 <yoctozepto> ack
14:17:39 <mnasiadka> I mean it requires newer versions than in distros
14:18:09 <mnasiadka> So unless somebody wants to put cycles in making it work - we just make it unbuildable for now and try to seek any people wanting to make it alive in Kolla
14:18:34 <mnasiadka> at least that's my proposal
14:18:43 <frickler> +1
14:18:47 <mnasiadka> anybody wants to take care of this?
14:19:27 <frickler> I can make a patch but I don't like sending mail
14:19:36 <mnasiadka> Ok, I can send the mail
14:19:42 <mnasiadka> probably no answers as always :)
14:20:27 <frickler> do you want the patch first in order to reference it in the mail? or the other way round?
14:20:39 <mnasiadka> #action frickler/mnasiadka to handle Monasca being unbuildable (mark as unbuildable, send mail to ML around volunteers to fix, if not submit a patch to drop)
14:21:03 <mnasiadka> I think we can. create the patch as a result, too much work if somebody wants to pick it up I think
14:21:10 <mnasiadka> too much work in creating a patch dropping everything ;-)
14:21:49 <mnasiadka> ok, I guess Jammy topic is more or less clear how to proceed
14:21:50 <frickler> ok, so I'll wait for answers until next week
14:22:03 <mnasiadka> are there any other features/patches we'd like to discuss?
14:22:38 <frickler> does anyone know the state of the podman work?
14:22:47 <priteau> I would like to discuss the openstack-exporter patch
14:22:56 <frickler> some time ago they said they are reworking things
14:23:07 <mnasiadka> I have no clue
14:23:10 <mnasiadka> priteau: sure, go on
14:23:21 <mnasiadka> I think yoctozepto and frickler are the reviewers
14:23:28 <priteau> Indeed
14:23:45 <priteau> So as a summary: we currently have an old prometheus openstack-exporter, 1.3.0
14:23:57 <priteau> I have contributed an update to the latest, 1.6.0
14:24:30 <priteau> Problem is that now, by default, openstack-exporter will use the latest Nova API microversion, which makes some metrics unavailable or changes some metadata
14:24:56 <frickler> #link https://review.opendev.org/c/openstack/kolla-ansible/+/828902
14:24:59 <priteau> The microversion can be customised with an environemtn variable
14:25:03 <priteau> That's the patch
14:25:11 <priteau> The debate is around the default microversion to use
14:25:28 <priteau> I was proposing to use 2.1 so metrics stay the same as what we have in Yoga and previous releases
14:25:50 <priteau> But if the majority thinks we should use latest, I can update my patch
14:26:07 <priteau> And add an upgrade note explaining how to set the microversion to keep metrics unchanged
14:27:04 <frickler> so I'm the one with the -1 on it, but open to hearing other opinions
14:27:47 <mnasiadka> I understand new API is not returning some data?
14:28:12 <frickler> it doesn't return data that is possibly wrong
14:28:26 <priteau> They dropped some metrics in Wallaby: https://docs.openstack.org/nova/latest/reference/api-microversion-history.html#maximum-in-wallaby
14:28:30 <frickler> like the flavor id that a server was created with
14:28:36 <frickler> which may no longer exist
14:28:40 <priteau> But also flavor_id is missing
14:29:25 <priteau> That's an older change, Pike microversion I think, but only visible through openstack-exporter with latest versions
14:30:26 <frickler> so my argument is nova made these changes for a reason and we shouldn't override them by default
14:30:38 <frickler> I'm fine with keeping the old behavior in stable backports
14:31:22 <frickler> deployers can still override if they choose to going forward
14:31:40 <priteau> Would we update openstack-exporter in stable?
14:32:15 <frickler> not sure, would we? we did backport the skydive update
14:32:15 <priteau> I believe I checked the output of metrics, if we use Nova API 2.1, the existing metrics are not modified
14:32:25 <priteau> Well, skydive was fixing a bug
14:32:52 <mnasiadka> We normally bump versions of those external infra components in stable branches
14:32:56 <priteau> openstack-exporter update would add a number of new metrics, but shouldn't be a problem
14:33:49 <mnasiadka> As long as it does not break anything it’s fine
14:34:08 <frickler> there are some bugfixes in 1.4.0 at least, so I think we do want to backport
14:34:37 <mnasiadka> So, default to latest microversion in Zed, backport with old microversion (but overridable) - does that sound ok?
14:34:39 <priteau> In a way I would have preferred if the exporter used 2.1 as default, which I believe is what CLI clients do? You need to explicitly give the microversion you want to use if not default
14:34:50 <priteau> mnasiadka: yes, I think so.
14:35:09 <mnasiadka> Good :)
14:35:12 <frickler> that's a bug in OSC rather than a feature
14:35:25 <priteau> I understand frickler's arguments, no one else agrees or disagrees strongly, so I'll adapt the patch
14:35:36 <mnasiadka> Thanks
14:36:07 <priteau> Thanks for taking the time to discuss this
14:36:21 <mnasiadka> frickler: podman state is unknown to me - yoctozepto probably is the assigned reviewer
14:36:30 <yoctozepto> I dont
14:36:32 <yoctozepto> know either
14:36:33 <yoctozepto> sorry
14:36:48 <mnasiadka> So be it
14:36:59 <mnasiadka> #topic Open discussion
14:37:14 <mnasiadka> Anybody anything?
14:37:40 <frickler> I revived an old patch to use clouds.yaml instead of openrc https://review.opendev.org/c/openstack/kolla-ansible/+/452005
14:38:42 <frickler> also the test with updated ansible version in zuul went well, so we are prepared for that
14:38:51 <mnasiadka> Ok, makes sense, but we’re still going to template out openrc? Kayobe uses that
14:39:14 <frickler> we will do it for now, but IMO we should deprecate it
14:39:29 <yoctozepto> I agree with frickler
14:39:33 <frickler> but not urgent, so maybe a topic for next ptg
14:39:40 <mnasiadka> Deprecation is ok, we just need to adapt
14:39:47 <yoctozepto> I think we can deprecate this cycle
14:40:02 <mnasiadka> +1
14:40:23 <frickler> it also mainly is about CI I think
14:40:46 <frickler> not about how deployments use it. we have clouds.yaml in OSISM for quite some time
14:41:35 <headphoneJames> if possible, a review of Let's Encrypt is still most welcome: https://review.opendev.org/c/openstack/kolla-ansible/+/741340
14:43:21 <mnasiadka> headphoneJames: thanks for reminding
14:43:31 <mnasiadka> Ok, thanks for attending
14:43:36 <mnasiadka> See you next week
14:43:44 <mnasiadka> #endmeeting