14:00:54 <mnasiadka> #startmeeting kolla
14:00:54 <opendevmeet> Meeting started Wed Jun 29 14:00:54 2022 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:54 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:54 <opendevmeet> The meeting name has been set to 'kolla'
14:01:02 <mnasiadka> #topic rollcall
14:01:04 <mnasiadka> o/
14:01:15 <ra-rau> o/
14:01:24 <kevko> \o/
14:01:27 <mgoddard> \o
14:01:31 <yoctozepto> o/
14:02:27 <mnasiadka> #topic agenda
14:02:27 <mnasiadka> * Announcements
14:02:27 <mnasiadka> * Review action items from the last meeting
14:02:27 <mnasiadka> * CI status
14:02:27 <mnasiadka> * Release tasks
14:02:29 <mnasiadka> * Regular stable releases (first meeting in a month)
14:02:29 <mnasiadka> * Current cycle planning
14:02:31 <mnasiadka> * Additional agenda (from whiteboard)
14:02:31 <mnasiadka> * Open discussion
14:02:33 <mnasiadka> #topic Announcements
14:02:45 <mnasiadka> I'm off on vacation starting tomorrow - will be back 18th July
14:03:04 <yoctozepto> have fun, mnasiadka
14:03:17 <mnasiadka> yoctozepto, frickler, mgoddard: would be nice if you could run the meetings - or just cancel them if you can't ;-)
14:03:36 <mnasiadka> #topic Review action items from the last meeting
14:03:56 <mnasiadka> hrw to look for aarch64 failures in yoga/master
14:03:56 <mnasiadka> frickler to continue working on Grafana dashboards
14:03:56 <mnasiadka> frickler/mnasiadka to handle Monasca being unbuildable (mark as unbuildable, send mail to ML around volunteers to fix, if not submit a patch to drop)
14:04:13 <mnasiadka> I think hrw did look into aarch failures, just ubuntu aarch64 is broken
14:04:32 <frickler> no progress on the dashboards yet, let me know if you want any changes
14:04:32 <mnasiadka> the fault is somewhere in erlang/rabbitmq repos - but he doesn't have a priority on working on this
14:04:58 <yoctozepto> I am unsure how many arm64 users we have; especially ubuntu arm64 users
14:05:15 <frickler> there wasn't any reply to the mail from hrw unless I missed something
14:05:20 <yoctozepto> since the only reliably supported distro is debian
14:05:22 <mnasiadka> Around Monasca - I feel we just leave it as unbuildable on aarch64, and see how the x86 situation evolves (wheel for python3.10 and so on)
14:05:33 <yoctozepto> we should probably just focus on supporting it
14:05:56 <mnasiadka> yoctozepto: hrw mentioned a plan to deprecate support for Ubuntu aarch64
14:06:02 <frickler> action: yoctozepto supports monasca ;)
14:06:11 <yoctozepto> mnasiadka: makes sense
14:06:19 <yoctozepto> frickler: I was talking debian arm64
14:06:27 <yoctozepto> as our only supported arm64 distro
14:06:27 <mnasiadka> ok, so aarch situation is more or less clear
14:06:31 <yoctozepto> kill monasca
14:06:38 <mnasiadka> can anybody work with frickler on those dashboards?
14:06:42 <frickler> ah, o.k. then
14:06:49 <mnasiadka> As in evaluate if those are useful and propose changes to them?
14:07:54 <frickler> we can also drop it if nobody wants the data
14:08:38 <mnasiadka> I see there are no volunteers ;-)
14:09:12 <mnasiadka> Let's leave that topic for now
14:09:58 <yoctozepto> so, monasca
14:10:02 <yoctozepto> what do we expect?
14:10:27 <mnasiadka> Currently in x86 we have two distros in master - Ubuntu and Debian
14:10:50 <mnasiadka> I understand it works on Debian, missing wheels on Ubuntu Jammy (don't remember if we finally have merged the support)
14:11:10 <yoctozepto> missing wheels and not buildable from sources?
14:11:10 <mnasiadka> missing wheels on aarch64, but that's another story
14:11:15 <yoctozepto> ok
14:11:25 <frickler> missing wheels for py3.10, too
14:11:29 <yoctozepto> I don't think we merged jammy
14:11:34 <mnasiadka> so let's wait until we get Jammy and CS9/RL9 stable-ish
14:11:48 <mnasiadka> and see if it only works on Debian/x86 - because if it does, it's kind of sad
14:12:12 <yoctozepto> well, it's one-man's solution still, no?
14:12:17 <yoctozepto> and not their priority
14:12:28 <mnasiadka> yeah, PTL pushes patches and does +2+w to his own patches :)
14:12:40 <mnasiadka> That's what I mean as let's reevaluate later.
14:12:46 <mnasiadka> mgoddard: opinion?
14:13:31 <mnasiadka> As in I guess there are some users - we'd prefer for this to maybe survive another cycle in Kolla.
14:13:57 <mgoddard> IMO: mark unbuildable where necessary, evaluate later
14:14:36 <mgoddard> dependency problems sometimes resolve themselves
14:14:45 <mgoddard> if not, we can have another talk
14:15:05 <mnasiadka> Ok then - I'll check the Jammy patches if we mark it as unbuildable there - and let's leave it as is for now.
14:15:39 <mnasiadka> #action mnasiadka Monasca - ensure it's marked as unbuildable where it should be and evaluate later in the cycle if situation fixed itself
14:15:40 <yoctozepto> we can alert the community that it has issues
14:15:53 <yoctozepto> I did not see the promised mails
14:16:07 <mnasiadka> yoctozepto: hrw did send a mail that it does not build, no answers
14:17:09 <mnasiadka> let's go further
14:17:11 <mnasiadka> #topic CI status
14:17:23 <yoctozepto> mnasiadka: ack, I missed it
14:17:36 <mnasiadka> apart from Neutron in upper-constraints.txt breaking stable/yoga - I think we're mainly fine.
14:17:41 <yoctozepto> yup
14:18:34 <mnasiadka> but the situation that upper-constraints.txt pins neutron and neutron-lib - means we need to analyse our builds to see if there are other things that are pinned (which then makes our source builds a bit incosistent)
14:19:22 <mnasiadka> e.g. we install neutron-lib from pypi (pinned in upper-constraints) - not the latest version from opendev's git
14:19:29 <mnasiadka> but let's leave it for now I guess
14:19:55 <mnasiadka> #topic Release tasks
14:20:26 <mnasiadka> We have R-14 Jun 27 - Jul 01
14:20:45 <mnasiadka> nothing in release calendar, nothing in Kolla contributor docs around that
14:20:57 <mnasiadka> #topic Regular stable releases (first meeting in a month)
14:21:10 <mnasiadka> I think it's for next meeting
14:21:12 <frickler> not yet, will do next week
14:21:20 <mnasiadka> #topic Current cycle planning
14:22:09 <mnasiadka> So, Jammy needs some love - the tzdata thing - if nobody will pick it up - I'll work on it after my vacation.
14:22:46 <mnasiadka> What about systemd/podman?
14:23:09 <mnasiadka> mgoddard, yoctozepto - you're listed as reviewers - any movement there?
14:23:18 <mgoddard> not here
14:23:53 <mnasiadka> Do you have some time to look into it for the next 2-3 weeks?
14:23:57 <frickler> there was a mention about things getting reworked some weeks ago, but I haven't seen any of that happening
14:24:56 <kevko> and proxysql ? :/
14:25:05 <yoctozepto> mnasiadka: not here either
14:25:11 <mnasiadka> Basically there are two patches - one is not touched since March, second is failing CI
14:25:30 <mnasiadka> Ok, so let's try proxysql
14:25:35 <mnasiadka> yoctozepto: you're listed as reviewer ;-)
14:25:45 <yoctozepto> yeah, I know, I feel bad about it
14:26:10 <yoctozepto> I have it in my TODOs for this week again but I'm usually force to postpone it, week by week
14:26:19 <yoctozepto> this one looks more promising but I can't guarantee
14:26:37 <mnasiadka> Ok, anyone else can commit to reviewing it?
14:26:58 <yoctozepto> yeah, we need a 2nd pair of eyes on that
14:27:12 <kevko> i can help with podman/systemd maybe .. several times i already do some review ..
14:27:52 <mgoddard> it could use some testing
14:27:59 <mnasiadka> I think now we need to understand what changes need to be done and we need some testing
14:28:02 <mnasiadka> around podman
14:28:38 <mnasiadka> anyway, proxysql would be nice to get it in finally
14:28:43 <mnasiadka> let's move on
14:28:55 <mnasiadka> #topic Additional agenda (from whiteboard)
14:29:08 <mnasiadka> (yoctozepto) EOL Train (the CI is dead)
14:29:33 <yoctozepto> may we?
14:29:51 <mnasiadka> looks like we should
14:29:56 <mnasiadka> any arguments why not?
14:33:20 <mnasiadka> ok
14:33:20 <kevko> nope ..sounds like a good idea
14:33:22 <mnasiadka> yoctozepto: will you?
14:33:49 <yoctozepto> ok
14:33:57 <yoctozepto> though I don't remember how
14:33:58 <yoctozepto> :D
14:34:43 <frickler> pull the red handle, that should stop the train *scnr*
14:35:01 <yoctozepto> :D
14:35:20 <yoctozepto> I will figure it out though, no biggies
14:36:00 <yoctozepto> https://review.opendev.org/c/openstack/releases/+/818920
14:36:12 <yoctozepto> seems easy :D
14:38:51 <kevko> btw, anyone for +2 and +w for https://review.opendev.org/c/openstack/kolla/+/818727 ?
14:40:38 <mgoddard> just to rock the boat on that one, would a new label make more sense?
14:40:51 <mgoddard> kolla_commit
14:41:23 <yoctozepto> makes sense
14:41:29 <yoctozepto> though the original change is also fine by me
14:41:34 <yoctozepto> (as indicated by CR+2)
14:42:00 <mgoddard> I don't really use the label, so didn't weigh in
14:42:06 <mgoddard> and won't push it
14:45:08 <mnasiadka> #topic Open discussion
14:45:17 <mnasiadka> (Since you already started it)
14:45:19 <kevko> well, i wanted to add new label kolla_commit ..but hrw i think didn't want to add new label
14:46:07 <kevko> but from my perspective of view it makes sense to identify by a label from which commit image was build .. also ..kolla is releasing version from time to time ..while bugfixes etc are released as a commits ..
14:47:02 <kevko> because kolla_version=X.Y.Z is totally useless if I am building from a git with some fix ..but version is same
14:48:35 <yoctozepto> yeah, it's at least confusing
14:48:40 <yoctozepto> perhaps useless indeed
14:49:06 <yoctozepto> I agree we need to merge something
14:49:08 <mnasiadka> I think let's reuse the existing label, the logic in the patch looks reasonable
14:49:09 <frickler> might be a sign we should release more often, though
14:49:25 <mnasiadka> instead of having two variables and confusing users
14:49:34 <mnasiadka> (which probably have no clue that label exists)
14:49:43 <yoctozepto> frickler: well, it does not solve kevko's issue but surely we should for all those who still use releases for some reason
14:50:16 <yoctozepto> mnasiadka: well, I guess the issue with the second label is that it might not exist when it's not from git
14:50:30 <yoctozepto> otoh, the format of the current one changes so parsing might fail
14:50:48 <yoctozepto> yet, I would bet users using this label are kolla-savvy enough to handle this hiccup
14:51:05 <yoctozepto> so it's a very hypothetical discussion
14:51:31 <yoctozepto> could we though improve it to show dirty state?
14:51:46 <yoctozepto> or better yet what frickler proposed in the comment
14:51:55 <yoctozepto> that would be better
14:52:18 <mnasiadka> well, surely we need to resolve the conversation there :)
14:53:26 <kevko> hmm, so X.Y-Z-commit if build from git, X.Y.Z if built from source not from git ?
14:53:53 <yoctozepto> I guess so?
14:54:02 <yoctozepto> could use including the examples that it will generate
14:55:45 <mnasiadka> ok, solve it somehow, I need to start packing :)
14:55:51 <mnasiadka> Thanks for coming!
14:55:53 <mnasiadka> #endmeeting