14:00:10 <yoctozepto> #startmeeting kolla
14:00:10 <opendevmeet> Meeting started Wed Jul 13 14:00:10 2022 UTC and is due to finish in 60 minutes.  The chair is yoctozepto. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:10 <opendevmeet> The meeting name has been set to 'kolla'
14:00:28 <yoctozepto> #topic Roll-call
14:00:29 <yoctozepto> o/
14:00:38 <mmalchuk> hi
14:01:00 <hrw> o\
14:02:24 <yoctozepto> crowds today
14:02:27 <yoctozepto> #topic Agenda
14:02:52 <yoctozepto> * Roll-call
14:02:52 <yoctozepto> * Agenda
14:02:52 <yoctozepto> * Announcements
14:02:52 <yoctozepto> * Review action items from the last meeting
14:02:52 <yoctozepto> * CI status
14:02:53 <yoctozepto> * Release tasks
14:02:53 <yoctozepto> * Regular stable releases (first meeting in a month)
14:02:55 <yoctozepto> * Current cycle planning
14:02:55 <yoctozepto> * Additional agenda (from whiteboard)
14:02:57 <yoctozepto> * Open discussion
14:03:14 <yoctozepto> in the additional agenda we have
14:03:23 <yoctozepto> (hrw) CentOS Stream 9
14:03:29 <yoctozepto> (frickler) Virtual PTG planning
14:03:33 <yoctozepto> (m.hiner) tmpfs comparison in kolla_docker
14:03:37 <yoctozepto> (headphoneJames) please review let's encrypt patch: https://review.opendev.org/c/openstack/kolla-ansible/+/741340
14:03:40 <TimBeermann[m]> o/
14:03:55 <yoctozepto> #topic Announcements
14:03:59 <yoctozepto> nothing to announce
14:04:07 <yoctozepto> #topic Review action items from the last meeting
14:04:33 <yoctozepto> mnasiadka Monasca - ensure it's marked as unbuildable where it should be and evaluate later in the cycle if situation fixed itself
14:04:38 <yoctozepto> not handled, mnasiadka not around
14:04:41 <yoctozepto> readding
14:04:44 <yoctozepto> #action mnasiadka Monasca - ensure it's marked as unbuildable where it should be and evaluate later in the cycle if situation fixed itself
14:04:51 <yoctozepto> #topic CI status
14:05:09 <ra-rau> o/
14:05:26 <yoctozepto> the CI seems green unless anyone noticed differently
14:05:37 <yoctozepto> unsure about kayobe
14:06:36 <yoctozepto> ok, let's move on
14:07:22 <yoctozepto> #topic Release tasks
14:07:44 <yoctozepto> https://releases.openstack.org/zed/schedule.html
14:07:55 <yoctozepto> R-12
14:08:01 <yoctozepto> Zed-2 milestone
14:08:30 <yoctozepto> we don't have any related tasks in kolla projects
14:09:04 <yoctozepto> #topic Regular stable releases (first meeting in a month)
14:09:18 <yoctozepto> it's not the first meeting in a month, nothing to discuss; the patch is pending
14:09:28 <yoctozepto> #topic Current cycle planning
14:10:25 <yoctozepto> how do we look with the different priorities?
14:10:34 <yoctozepto> I know some are in additional agenda
14:10:39 <yoctozepto> so we can discuss then
14:10:52 <yoctozepto> unless someone did not include theirs and wishes to discuss them now
14:11:02 <hrw> ;D
14:11:24 <yoctozepto> ok, so I can report that kevko's proxysql is very close now
14:11:34 <kevko> hi
14:11:35 <hrw> and is not provided for cs9
14:11:51 <yoctozepto> yeah, that's a good topic; cs9 being proxysql-less is sad
14:11:53 <hrw> last time I checked
14:12:04 <kevko> i already reported to authors ..
14:12:16 <kevko> and they replied they don't have a plans to build for cs9
14:12:27 <yoctozepto> duh
14:12:38 <mmalchuk> for Kayobe please review https://review.opendev.org/c/openstack/kayobe/+/845338 and https://review.opendev.org/c/openstack/kayobe/+/840033
14:13:17 <yoctozepto> well, we could default to using non-cs9 images for proxysql
14:13:23 <hrw> mmalchuk: we are in a meeting now
14:13:27 <kevko> From what I see, CentOS 9 Stream is a rolling distro.
14:13:27 <kevko> It's difficult for 3rd parties to support, as any components of the system can change/update/upgrade to unexpected versions and have unforeseen impact on the product.
14:13:27 <kevko> You can try to install the RPM packages to see if any are compatible, still, long term it is a gamble.
14:13:27 <kevko> You can also compile from source yourself.
14:13:28 <kevko> For production I would recommend one of the distros we support, and matching packages from our repository.
14:13:28 <yoctozepto> some debian fallback or whatever
14:13:46 <kevko> ^^ from author
14:13:57 <hrw> kevko: then let them build for alma9 or rhel9 etc
14:14:20 <yoctozepto> ^
14:14:23 <hrw> kevko: fluentd image uses td-agent built in alma9 container
14:14:30 <kevko> I don't think we will support CentOS Stream 9,
14:14:30 <kevko> but we will support Almalinux 9 which is compatible with RHEL 9
14:14:30 <kevko> ETA, next release in a few weeks.
14:14:40 <yoctozepto> awesome
14:15:08 <kevko> yeah, they replying fast :P
14:17:13 <yoctozepto> ok, guessing nothing else to discuss here
14:17:16 <yoctozepto> let's move on
14:17:36 <yoctozepto> and thank you for handling the situation, hrw & kevko
14:17:50 <yoctozepto> #topic (hrw) CentOS Stream 9
14:18:01 <yoctozepto> go
14:18:05 <hrw> ;D
14:18:50 <hrw> we can build images (no ELK, Grafana, proxysql) but default k-a fails due to lack of mariadb-clustercheck (due to lack of xinetd in cs9)
14:19:29 <hrw> official way for rhel9 family is 'use systemd instead of xinetd'
14:19:35 <hrw> but we have dumb-init '
14:19:45 <hrw> meh++
14:20:44 <kevko> hmm
14:21:13 <yoctozepto> does anyone know of another solution?
14:21:25 <yoctozepto> maybe we could go with xinetd from source? ;d
14:21:38 <hrw> I do not even know what clustercheck does and why we need it ;D
14:21:57 <yoctozepto> it checks whether mariadb sever is in sync with the galera cluster
14:22:08 <yoctozepto> and haproxy uses it to avoid broken replicas
14:22:14 <kevko> well, clustercheck is reading status of wsrep in mariadb and returning 200/500 so haproxy now which is healtthy
14:22:26 <kevko> because output is HTTP reply
14:22:30 <yoctozepto> kevko: does proxysql require clustercheck?
14:22:33 <kevko> nope
14:22:52 <yoctozepto> ok, so we could also "force" users wishing to use cs9 to use proxysql
14:22:55 <yoctozepto> kevko would not mind
14:22:58 <yoctozepto> nor me
14:23:06 <hrw> I have a feeling that Z release will slip quite a while due to distro updates
14:23:38 <opendevreview> Michal Arbet proposed openstack/kolla-ansible master: Add proxysql support for database  https://review.opendev.org/c/openstack/kolla-ansible/+/770215
14:23:40 <opendevreview> Michal Arbet proposed openstack/kolla-ansible master: Edit services roles to support database sharding  https://review.opendev.org/c/openstack/kolla-ansible/+/770216
14:23:40 <opendevreview> Michal Arbet proposed openstack/kolla-ansible master: [CI] Test ProxySQL with shards in the nova cells scenario  https://review.opendev.org/c/openstack/kolla-ansible/+/770621
14:23:41 <opendevreview> Michal Arbet proposed openstack/kolla-ansible master: [DNM] Trigger cells job  https://review.opendev.org/c/openstack/kolla-ansible/+/838916
14:23:41 <opendevreview> Michal Arbet proposed openstack/kolla-ansible master: Use Docker healthchecks for mariadb-server service  https://review.opendev.org/c/openstack/kolla-ansible/+/805616
14:27:36 <yoctozepto> hrw: anything else to discuss?
14:27:42 <hrw> nope
14:28:33 <yoctozepto> let's move on then
14:28:47 <yoctozepto> #topic (frickler) Virtual PTG planning
14:28:52 <yoctozepto> frickler not around
14:29:02 <yoctozepto> does anyone want to discuss this topic?
14:30:24 <TimBeermann[m]> Not from my side
14:31:11 <ra-rau> Not from my side. Frickler is on vacation
14:31:53 <hrw> when vPTG takes place? October?
14:33:28 <yoctozepto> not sure
14:33:33 <yoctozepto> but that makes sense
14:34:03 <yoctozepto> it was usually (if not always) mid-October
14:35:21 <hrw> so maybe we did not dropped that entry from march?
14:35:26 <hrw> s/from/since
14:37:32 <yoctozepto> no, frickler wanted to discuss it
14:37:43 <yoctozepto> you all can see the discussion from the last meeting
14:37:50 <hrw> ok, just wanted to be usre ;d
14:37:51 * yoctozepto moving on
14:37:55 <yoctozepto> sure
14:38:08 <yoctozepto> #topic (m.hiner) tmpfs comparison in kolla_docker
14:39:18 <m_hiner> So I have this issue where in the JSON we get from container inspect, the tmpfs is represented as a dictionary with keys being the directory names and values are it's settings
14:40:26 <m_hiner> then in the kolla_docker module we compare that dictionary by converting it to set which only takes the keys so we basically just compare the directory names and not also their settings
14:40:50 <m_hiner> My question is, is this intententional and non-issue?
14:41:49 <opendevreview> Sergei Raiskii proposed openstack/kolla-ansible master: Allow cinder-backup to be configured to use S3 backend.  https://review.opendev.org/c/openstack/kolla-ansible/+/849711
14:42:56 <yoctozepto> m_hiner: that is certainly possible
14:43:13 <yoctozepto> I don't remember by heart what tmpfs settings are
14:43:25 <yoctozepto> if asked, I would probably say there are none
14:43:29 <yoctozepto> maybe they are dummies?
14:43:37 <yoctozepto> let's check
14:44:47 <yoctozepto> it seems it originally did not support options but now it does https://docs.docker.com/storage/tmpfs/#specify-tmpfs-options
14:45:01 <yoctozepto> that said, I am pretty sure kolla-ansible does not use them
14:45:08 <yoctozepto> hence why they are ignored
14:45:26 <yoctozepto> did I help you?
14:45:57 <m_hiner> so what you are saying is that it is fine as is, right?
14:46:02 <yoctozepto> right
14:46:17 <m_hiner> Okay, that's all, thank you
14:46:38 <yoctozepto> ok, let's move on
14:46:46 <hrw> yoctozepto: does it makes sense?: enable_mariadb_clustercheck: "{{ enable_haproxy if kolla_base_distro != 'centos' else 'false' }}"
14:47:15 <kevko> i don't think this is ok
14:47:24 <yoctozepto> hrw: you need "false" without quote marks
14:47:41 <yoctozepto> but you can also do
14:47:54 <mgoddard> yoctozepto, m_hiner: we can use tmpfs, although not by default
14:48:01 <yoctozepto> "{{ enable_haproxy | bool and kolla_base_distro != 'centos' }}"
14:48:03 <mgoddard> for cinder volume conversion
14:48:17 <yoctozepto> mgoddard: but not its options
14:48:22 <hrw> yoctozepto: thx
14:48:25 <mgoddard> perhaps not
14:48:42 <yoctozepto> #topic (headphoneJames) please review let's encrypt patch: https://review.opendev.org/c/openstack/kolla-ansible/+/741340
14:49:27 <opendevreview> Marcin Juszkiewicz proposed openstack/kolla-ansible master: [WIP] add CentOS Stream 9 support  https://review.opendev.org/c/openstack/kolla-ansible/+/839715
14:49:38 <yoctozepto> I guess this one is pretty self-explanatory
14:50:09 <headphoneJames> Would love to get patch in this release
14:58:38 <opendevreview> Michal Arbet proposed openstack/kolla-ansible master: Edit services roles to support database sharding  https://review.opendev.org/c/openstack/kolla-ansible/+/770216
14:58:38 <opendevreview> Michal Arbet proposed openstack/kolla-ansible master: [CI] Test ProxySQL with shards in the nova cells scenario  https://review.opendev.org/c/openstack/kolla-ansible/+/770621
14:58:39 <opendevreview> Michal Arbet proposed openstack/kolla-ansible master: [DNM] Trigger cells job  https://review.opendev.org/c/openstack/kolla-ansible/+/838916
14:58:39 <opendevreview> Michal Arbet proposed openstack/kolla-ansible master: Use Docker healthchecks for mariadb-server service  https://review.opendev.org/c/openstack/kolla-ansible/+/805616
15:02:35 <hrw> #endmeeting?