14:00:06 <frickler> #startmeeting kolla
14:00:06 <opendevmeet> Meeting started Wed Aug  3 14:00:06 2022 UTC and is due to finish in 60 minutes.  The chair is frickler. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:06 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <opendevmeet> The meeting name has been set to 'kolla'
14:00:16 <frickler> #topic rollcall
14:00:47 <frickler> mnasiadka has excused themselves for the remainder of this week
14:00:51 <yoctozepto> o/
14:01:05 <hrw> o\
14:02:24 <frickler> \o/ not too crowded today it seems, so let's start
14:02:26 <frickler> #topic agenda
14:02:39 <frickler> * Roll-call
14:02:39 <frickler> * Agenda
14:02:39 <frickler> * Announcements
14:02:39 <frickler> * Review action items from the last meeting
14:02:39 <frickler> * CI status
14:02:41 <frickler> * Release tasks
14:02:44 <frickler> * Regular stable releases (first meeting in a month)
14:02:46 <frickler> * Current cycle planning
14:02:49 <frickler> * Additional agenda (from whiteboard)
14:02:51 <frickler> * Open discussion
14:03:02 <frickler> #topic Announcements
14:03:40 <frickler> as hrw has mentioned earlier, we are making good progress on creating a new cirros release, you may hold your breath
14:04:06 <frickler> anything else?
14:04:09 <yoctozepto> ok, the breath is being held
14:04:15 <yoctozepto> what can we expect from the new release?
14:04:21 <yoctozepto> will it run 10x faster?
14:04:23 <yoctozepto> :-)
14:04:36 <frickler> it will run the idle loop much faster, indeed
14:04:44 <yoctozepto> <3 it
14:04:49 <frickler> also better support for ipv6 and some other things
14:05:00 <frickler> maybe we should gather things and write a releasenote
14:05:15 <frickler> also about dropping some strange arches
14:05:38 <frickler> but maybe keep breathing for a bit, may take another day or so
14:05:43 <yoctozepto> ok
14:06:02 <frickler> #topic Review action items from the last meeting
14:06:13 <frickler> I didn't see any, something I missed?
14:06:26 <yoctozepto> likely none created
14:06:44 <frickler> #topic CI status
14:07:05 <frickler> I'm not aware of any issues, but I didn't look deeply
14:07:18 <frickler> I was happy to find the Jammy things merged when I returned
14:07:24 <yoctozepto> :-)
14:08:12 <frickler> the grafana dashboards are seemingly completely broken now, guess I'll just remove ours
14:08:21 <yoctozepto> I will not mind
14:08:35 <frickler> anything else on CI?
14:08:57 <yoctozepto> nada
14:09:09 <frickler> #topic Release tasks
14:09:21 <opendevreview> James Kirsch proposed openstack/kolla-ansible master: Add support for LetsEncrypt-managed certs  https://review.opendev.org/c/openstack/kolla-ansible/+/741340
14:09:43 <frickler> I didn't prepare well for this, any known tasks?
14:10:02 <yoctozepto> what week is this
14:10:25 <yoctozepto> Aug 01 - Aug 05
14:10:25 <yoctozepto> R-9
14:10:50 <yoctozepto> R-8: Switch images to current release¶
14:10:52 <yoctozepto> next week
14:11:02 <frickler> "R-8: Switch images to current release" is obsolete with source images only, right?
14:11:14 <frickler> because source was switched in R-17
14:11:19 <hrw> now quite
14:11:25 <yoctozepto> still relevant for deps
14:11:32 <hrw> R-8 means RDO/UCA for deps
14:11:42 <hrw> so may get newer libvirt/qemu/ceph etc
14:11:51 <yoctozepto> with jammy we are probably already there
14:11:59 <yoctozepto> and CS depends on CS9 support
14:12:06 <yoctozepto> so nothing extra to do I guess?
14:12:19 <frickler> jammy should have yoga pkgs natively, yes
14:12:25 <yoctozepto> ah
14:12:30 <yoctozepto> so UCA for Zed
14:12:52 <yoctozepto> CS9 to be seen
14:13:04 <frickler> but does canonical build that before the actual release?
14:13:05 <yoctozepto> also soon
14:13:06 <yoctozepto> R-5: Cycle highlights deadline¶
14:13:14 <frickler> I can try to check until next week
14:13:16 <yoctozepto> need to think about these in the upcoming meetings
14:13:30 <yoctozepto> frickler: I think yes, since we added this bullet there
14:13:35 <yoctozepto> and only excluded debian
14:13:40 <hrw> frickler: they build binary packages during cycle
14:13:49 <yoctozepto> they brave then
14:14:12 <frickler> #action frickler check availability of zed UCA for Jammy
14:14:53 <hrw> frickler: http://ubuntu-cloud.archive.canonical.com/ubuntu/dists/jammy-updates/zed/
14:15:20 <yoctozepto> well, that was quick
14:15:44 <frickler> thx hrw
14:16:03 <frickler> anything else release-wise?
14:16:45 <frickler> #topic Regular stable releases (first meeting in a month)
14:16:56 <frickler> yoctozepto: did you tackle that yet?
14:17:04 <yoctozepto> no, did not touch it
14:17:22 <frickler> do you want to? otherwise I'll do it after the meeting
14:17:40 <yoctozepto> ok, I'll try the instructions :-)
14:18:00 <frickler> ping me if it doesn't work
14:18:23 <frickler> #topic Current cycle planning
14:19:13 <frickler> any updates here?
14:20:08 <frickler> or should we rather move through the additional items?
14:20:08 <yoctozepto> proxysql got farther
14:20:29 <yoctozepto> yeah, let's go over those others unless someone speaks up
14:21:06 <frickler> #topic Additional agenda (from whiteboard)
14:21:23 <frickler> (yoctozepto) Remove nova_legacy endpoint
14:21:42 <frickler> I'm +1 on that, discussed that internally recentish
14:22:02 <yoctozepto> any objections?
14:22:15 <yoctozepto> as far as I am concerned, we can make it optional and default to not enabled
14:22:21 <frickler> maybe have a flag for someone who still needs it?
14:22:24 <yoctozepto> so that new deployments do not get it
14:22:26 <frickler> yes
14:22:31 <yoctozepto> by default at least
14:22:39 <yoctozepto> and old deployments can remove it
14:22:40 <yoctozepto> themselves
14:23:03 <frickler> did we do the same for admin endpoints?
14:23:18 <yoctozepto> no, we have just scrubbed them
14:23:25 <yoctozepto> only for keystone it is done
14:23:31 <yoctozepto> still in review
14:23:48 <yoctozepto> (someone start reviewing my patches, they are gold)
14:23:58 <frickler> the question is whether we want to delete on upgrade or not
14:23:59 <yoctozepto> (yes, I know I'm humble)
14:24:09 <frickler> the former would ensure consistent setups
14:24:16 <yoctozepto> we default to being lazy
14:24:22 <frickler> the latter would be nicer for legacy envs
14:24:22 <yoctozepto> and letting users delete themselves
14:24:55 <frickler> ok, then that should be fine for nova_legacy, too
14:25:06 <yoctozepto> btw, keystone is in https://review.opendev.org/c/openstack/kolla-ansible/+/843730
14:25:32 <frickler> yes, I'll take a look at that. soon. ish.
14:25:41 <yoctozepto> roger that
14:25:59 <frickler> (yoctozepto) The status of the dynamic OVS role assignment https://review.opendev.org/c/openstack/kolla-ansible/+/840895
14:26:13 <yoctozepto> here, we would need further input from mgoddard
14:26:18 <yoctozepto> not sure if he's around
14:26:29 <yoctozepto> I think the change is sane
14:27:04 <yoctozepto> it is a different approach to the current ones but aligns better with what we need this role for
14:27:09 <frickler> I must admit that I'm not confident approving this without some local testing, would prefer if mgoddard could re-review
14:27:51 <yoctozepto> the best test is test on a production environment, you know; weeds out the bugs fastest :-)
14:28:06 <frickler> so I guess we'll keep this topic for next time
14:28:12 <yoctozepto> indeed
14:28:25 <frickler> (frickler) Virtual PTG planning
14:28:41 <frickler> not much we can decide with again low attendance I guess
14:28:52 <yoctozepto> agreed
14:29:04 <yoctozepto> but let's do it soonish
14:29:08 <frickler> (headphoneJames) please review let's encrypt patch: https://review.opendev.org/c/openstack/kolla-ansible/+/741340
14:29:26 <yoctozepto> James has recently updated the patch
14:29:40 <yoctozepto> it's an ever-standing wish to get this merged
14:29:50 <yoctozepto> I guess it's just the right thing to look at after proxysql
14:29:57 <yoctozepto> just right
14:30:27 <frickler> oh, that's a new version now that still waits for CI results
14:30:49 <yoctozepto> yup
14:31:05 <frickler> mnasiadka: mgoddard: ^^ you set RP+1 on this one
14:31:23 <frickler> (i.halomi) Podman and systemd support status
14:31:31 <yoctozepto> the agenda point stays as a good reminder that we have low review throughput for bigger changes
14:31:39 <frickler> review of systemd with docker a current status on podman version : https://review.opendev.org/c/openstack/kolla-ansible/+/816724
14:31:52 <yoctozepto> I mean, I can easily squeeze in smaller stuff but biggur things need to wait and stand in a queue
14:32:16 <yoctozepto> yesh, this is the 3rd biggie after the proxysql and le
14:32:37 <frickler> maybe we want to create a more explicit queue like nova does?
14:32:55 <yoctozepto> what do they do?
14:33:03 <opendevreview> Mark Goddard proposed openstack/kayobe master: Support configuration of swap  https://review.opendev.org/c/openstack/kayobe/+/851195
14:33:34 <frickler> I have to look up the details, but something like two slots for stacks under priority review
14:33:45 <frickler> and a queue for thinks to enter these slots
14:33:47 <frickler> things
14:34:23 <frickler> and the expectation that items in those slots get reviewed and merged within like two weeks
14:34:25 <yoctozepto> hmm, I have on slot for myself and it was occupied by proxysql thus far :D
14:34:35 <yoctozepto> ah, that surely differs
14:35:01 <frickler> so a bit more coordination between cores maybe
14:35:16 <frickler> not sure that would work for us with our diverging interests though
14:36:11 <yoctozepto> me neither
14:36:19 <frickler> anyway I guess these two patches should get some priority if possible
14:36:34 <frickler> anything to discuss about the contents yet?
14:37:14 <yoctozepto> I don't see the relevant folks here so I doubt
14:37:27 <frickler> else we'd have
14:37:30 <frickler> (frickler) Discuss Horizon/JS/xstatic situation
14:37:48 <frickler> https://lists.openstack.org/pipermail/openstack-discuss/2022-August/029825.html
14:38:14 <headphoneJames> The let's encrypt patch should be ready as far as I know
14:38:31 <hrw> frickler: this one feels tricky
14:38:35 <frickler> IMO the essence of this is that we may want to look into replacing xstatic pkgs with native JS from npm or whatever
14:39:05 <hrw> frickler: I have a feeling that we need to do 'pip install' as we have now, then track all those JS, drop them and fetch from upstreams
14:39:06 <frickler> but no idea how to actually do that
14:39:13 <frickler> or we wait for osa to implement the same and just copy what they do
14:39:14 <yoctozepto> yup, but I suppose we need guidance from the Horizon team if we don't want to spend time reverse-engineering
14:39:37 <hrw> best would be to see horizon having code for it ;d
14:39:48 <frickler> I think horizon team is mostly non existent, I wouldn't bet on them
14:40:05 <hrw> 'pip install horizon-python-stuff' + 'npm install horizon-js-stuff'
14:40:53 <yoctozepto> yeah, I'm afraid frickler is right
14:41:01 <frickler> hrw: are you interested in investigating this further?
14:41:13 <yoctozepto> tbh, the most time/cost-effective would be to get rid of horizon in the first place ;p
14:41:21 <hrw> never dealt with npm stuff etc
14:41:25 <yoctozepto> not sure how skyline fares though
14:41:30 <yoctozepto> and what pandora boxes it opens
14:42:13 <frickler> also the situation seems to have been the same over the last 10 years or so, so not sure how urgent this actually is
14:42:25 <yoctozepto> ++
14:42:56 <frickler> maybe plan for some joint session (with distros and other deployers) at the PTG or something might be fast enough
14:43:53 <yoctozepto> agreed
14:44:28 <frickler> o.k., so I mainly wanted others be aware of the situation, which I think I achieved
14:44:44 <frickler> #topic Open discussion
14:44:56 <frickler> anything else?
14:45:08 <yoctozepto> nope
14:46:04 <yoctozepto> btw, I'm going on vacations the following 2 weeks so my availability will vary
14:46:10 <yoctozepto> and I will not be there for the meetings
14:46:28 <frickler> enjoy your time off
14:46:38 <yoctozepto> thanks
14:46:39 <hrw> yoctozepto: have fun
14:46:43 <yoctozepto> thanks
14:47:26 <frickler> o.k., then also enjoy the 12 minutes I'm returning you now, everyone ;)
14:47:32 <frickler> #endmeeting