14:00:16 <mnasiadka> #startmeeting kolla
14:00:16 <opendevmeet> Meeting started Wed Sep 14 14:00:16 2022 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:16 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:16 <opendevmeet> The meeting name has been set to 'kolla'
14:00:20 <mnasiadka> #topic rollcall
14:00:32 <frickler> \o
14:00:46 <hrw> (°Y.)
14:01:02 <mnasiadka> o/
14:01:08 <opendevreview> Rafal Lewandowski proposed openstack/kayobe master: updated  write_bifrost_clouds_yaml logic  https://review.opendev.org/c/openstack/kayobe/+/857594
14:02:03 <yoctozepto> o/
14:03:11 <mnasiadka> #topic agenda
14:03:11 <mnasiadka> * CI status
14:03:11 <mnasiadka> * Release tasks
14:03:11 <mnasiadka> * Regular stable releases (first meeting in a month)
14:03:11 <mnasiadka> * Current cycle planning
14:03:13 <mnasiadka> * Additional agenda (from whiteboard)
14:03:13 <mnasiadka> * Open discussion
14:03:15 <mnasiadka> #topic CI status
14:03:26 <mnasiadka> whiteboard says green
14:03:45 <yoctozepto> it is
14:03:47 <mnasiadka> but I noticed k-a jobs that depend on kolla patch are failing on c9s and rl9
14:03:56 <yoctozepto> I have also run today all jobs on all supported branches
14:04:16 <yoctozepto> message:"[DNM] [CI] Run it all" status:open
14:04:22 <yoctozepto> or:
14:04:23 <yoctozepto> https://review.opendev.org/q/message:%2522%255BDNM%255D+%255BCI%255D+Run+it+all%2522+status:open
14:04:32 <mnasiadka> anyway CI green
14:04:36 <mnasiadka> #topic Release tasks
14:04:36 <matfechner> o/
14:05:14 <bbezak> o/
14:05:21 <mnasiadka> next week feature freeze
14:05:54 <mnasiadka> opensearch and rocky 9 related will probably need an exception
14:06:08 <mnasiadka> #topic Current cycle planning
14:06:11 <mnasiadka> speaking of the devil
14:06:28 <mnasiadka> I worked on opensearch, still in progress
14:06:35 <mnasiadka> missing opensearch-dashboards deployment
14:06:42 <mnasiadka> but opensearch with fluentd works properly
14:07:01 <mnasiadka> hrw: how are we with cs9 Kolla patch? ready to merge?
14:07:50 <opendevreview> Bartosz Bezak proposed openstack/kayobe master: Move to CentOS Stream 9 / Rocky Linux 9  https://review.opendev.org/c/openstack/kayobe/+/855656
14:07:55 <mnasiadka> https://review.opendev.org/c/openstack/kolla/+/836664
14:08:04 <hrw> mnasiadka: I would say that it is and then needs some improvements on top
14:08:19 <mnasiadka> ELK and Grafana should be fixed by OpenSearch
14:08:29 <hrw> we use cron for logrotate but there is no cron in el9
14:08:45 <mnasiadka> and what's the replacement?
14:08:50 <hrw> systemd timers
14:08:56 <mnasiadka> fantastic
14:08:57 <hrw> which we lack in container
14:09:42 <mnasiadka> then we would need to run a container with systemd and use timers
14:09:47 <mnasiadka> seems like a followup to the original change
14:09:57 <yoctozepto> mnasiadka: or the host one
14:10:02 <hrw> or use host one
14:10:09 <mnasiadka> yes, that's another option
14:10:23 <hrw> install logrotate in host OS and point to kolla logs
14:10:41 <opendevreview> Bartosz Bezak proposed openstack/kayobe master: Move to CentOS Stream 9 / Rocky Linux 9  https://review.opendev.org/c/openstack/kayobe/+/855656
14:10:46 <hrw> and then we can deprecate logrotate image
14:11:00 <mnasiadka> ok then
14:11:24 <yoctozepto> hrw: well, we need logrotate somewhere
14:11:33 <yoctozepto> host systemd could run the container
14:11:55 <yoctozepto> I guess for now it would be easier to introduce systemd in that container?
14:12:03 <mnasiadka> it might be
14:12:28 <hrw> yoctozepto: we keep logs on host OS disk so why host's logrotate can not handle it for us?
14:12:47 <yoctozepto> hrw: no idea
14:12:57 <mnasiadka> or look for some small alternatives
14:13:11 <hrw> present in el9 or epel9?
14:13:31 <mnasiadka> nobody says it needs to be present there, if it's a small Go binary or similar, we can just curl it
14:13:44 <yoctozepto> cron go?
14:14:17 <mnasiadka> gocron, clockwork, others, anything :)
14:14:19 <hrw> mnasiadka: "while true; do logrotate; sleep 1h;done"?
14:14:45 <mnasiadka> if we move to systemd this cycle - we can use systemd timer on logrotate container :)
14:15:09 <hrw> CS9 images worked with systemd as init
14:15:23 <mnasiadka> yes, but if we need that, it should be an exception, not standard
14:15:24 <yoctozepto> hrw's loop might work well enough
14:15:51 <hrw> or using host OS logrotate
14:16:15 <mnasiadka> ok, so - discussion is fine - is there anybody that wants to look into making that work?
14:16:16 <hrw> each of them has it. and runs it somehow
14:17:15 <yoctozepto> yeah, I guess kolla might have overcontainerised some services
14:17:58 <hrw> mnasiadka: assign it to me
14:18:25 <mnasiadka> #action hrw work on cron alternative
14:18:28 <mnasiadka> ok then
14:18:42 <opendevreview> Rafal Lewandowski proposed openstack/kayobe master: updated  write_bifrost_clouds_yaml logic  https://review.opendev.org/c/openstack/kayobe/+/857594
14:18:42 <mnasiadka> so second thing around CS9 Kolla patch - in Zed PTG we decided to not publish cs9 images
14:19:03 <mnasiadka> and run cs9 jobs as non-voting or experimental to see what's ahead
14:19:23 <mnasiadka> are we changing that?
14:19:36 <hrw> I would keep it that way - no publishing
14:19:57 <mnasiadka> ok, so the patch needs to be updated I guess - there are publish jobs defined
14:19:59 <hrw> we merge them very late in a cycle so not tested as much yet as usual stuff was tested
14:20:21 <mnasiadka> well, I guess we want to publish rocky9 images instead - that was the plan
14:20:37 <hrw> once we have rl9 merged working
14:20:37 <mnasiadka> maybe not initially
14:20:40 <mnasiadka> yeah
14:20:51 <mnasiadka> I'll push a patch based on cs9 one to add rl9
14:20:57 <mnasiadka> ok that is solved
14:21:03 <mnasiadka> bbezak: how's it going with rl9 for Kayobe?
14:21:43 <bbezak> lovely :). Biggest hurdle till now was dummy interfaces in network manager with network-interfaces role
14:22:00 <bbezak> but looks promising
14:22:14 <mnasiadka> so basically network-scripts missing in EL9
14:22:20 <mnasiadka> nice
14:22:38 <mnasiadka> yoctozepto: I noticed you started some reviews on systemd approach - do you think we can merge it this cycle?
14:23:00 <yoctozepto> mnasiadka: yes, it seems pretty ready; I would go with an exception for it
14:23:02 <yoctozepto> can review
14:23:14 <bbezak> however there is compatibility layer NetworkManager-initscripts-updown - https://www.redhat.com/en/blog/rhel-9-networking-say-goodbye-ifcfg-files-and-hello-keyfiles
14:23:16 <yoctozepto> I just can't commit much time this and the next week
14:23:20 <mnasiadka> ok, is there any other core that has cycles to review?
14:23:29 <mnasiadka> because we need a second one
14:23:38 <yoctozepto> in other words
14:23:50 <yoctozepto> any other core to review this by the end of September?
14:23:56 <mnasiadka> yoctozepto: sure, I would probably feel more comfortable to merge it on beginning of Antelope, but it's been hanging there for some time
14:24:05 <yoctozepto> same thinking here
14:24:25 <yoctozepto> maybe it's more motivating to merge at the last minute :D
14:25:05 <mnasiadka> ok, enough about that
14:25:22 <mnasiadka> Let's Encrypt is also eager to get some reviews, but maybe we need to postpone it as well
14:25:35 <mnasiadka> ok, let's go forward
14:25:38 <mnasiadka> #topic Additional agenda (from whiteboard)
14:25:57 <mnasiadka> (yoctozepto) systemd container control https://review.opendev.org/c/openstack/kolla-ansible/+/816724
14:26:02 <yoctozepto> already discussed
14:26:05 <mnasiadka> ok
14:26:10 <yoctozepto> please help review, seems reasonable
14:26:21 <mnasiadka> (mnasiadka) Monasca status
14:26:47 <mnasiadka> I think hrw mentioned we've had multiple issues with Monasca (not buildable on Jammy, now buildable, similar situation on EL9 I think)
14:26:47 <hrw> monasca... napalm or thermite?
14:27:04 <mnasiadka> and then somebody would need to make it work with OpenSearch
14:27:12 <hrw> we have monasca buildable on x86-64 in Zed
14:27:34 <hrw> will it be buildable in next cycle? probably after half of cycle
14:27:38 <mnasiadka> I think we could deprecate this cycle, and if nobody steps up - remove next cycle together with removal of Elasticsearch
14:27:44 <hrw> +3
14:28:11 <yoctozepto> +2
14:28:27 <mnasiadka> anybody wants to raise the patch and send a mail to openstack-ml or should I?
14:28:39 <hrw> and monasca is yet-another-monitoring-as-a-service stuff
14:30:13 <mnasiadka> ok, so let me do that
14:30:29 <mnasiadka> #action mnasiadka deprecate Monasca and send mail to ML asking for contributors to step up
14:30:53 <bbezak> +1 (non core) :)
14:30:59 <mnasiadka> (yoctozepto) Topics for the PTG (I propose a discussion of Zens of Kolla)
14:31:25 <mnasiadka> #link https://etherpad.opendev.org/p/kolla-antelope-ptg
14:31:28 <mnasiadka> I created that
14:31:54 <mnasiadka> please add topics for the PTG
14:32:03 <mnasiadka> we also should book an operator hour it seems
14:32:22 <mnasiadka> should it be last hour of Tue session?
14:32:57 <yoctozepto> ok
14:33:07 <mnasiadka> ok, will arrange
14:33:14 <mnasiadka> #topic Open discussion
14:33:17 <mnasiadka> any open topics?
14:33:46 <hrw> I sent patch to use shutil.copytree() better
14:33:59 <hrw> have one to send which moves from os.path to pathlib
14:34:18 <yoctozepto> please do
14:34:19 <mnasiadka> nice, will review
14:34:36 <opendevreview> Marcin Juszkiewicz proposed openstack/kolla master: Switch from os.path to pathlib  https://review.opendev.org/c/openstack/kolla/+/857720
14:34:46 <mnasiadka> ok then, let's finish for today
14:34:49 <mnasiadka> thanks for coming
14:34:51 <mnasiadka> #endmeeting