14:00:52 <mnasiadka> #startmeeting kolla
14:00:52 <opendevmeet> Meeting started Wed Sep 21 14:00:52 2022 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:52 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:52 <opendevmeet> The meeting name has been set to 'kolla'
14:00:57 <mnasiadka> #topic rollcall
14:00:58 <mnasiadka> o/
14:01:15 <matfechner> o/
14:01:35 <opendevreview> Rafal Lewandowski proposed openstack/kolla-ansible master: designate: allow disabling notifications  https://review.opendev.org/c/openstack/kolla-ansible/+/825718
14:02:24 <frickler> \o
14:02:52 <yoctozepto> o/
14:03:20 <mnasiadka> #topic agenda
14:03:20 <mnasiadka> * Review action items from the last meeting
14:03:20 <mnasiadka> * CI status
14:03:20 <mnasiadka> * Release tasks
14:03:20 <mnasiadka> * Regular stable releases (first meeting in a month)
14:03:22 <mnasiadka> * Current cycle planning
14:03:22 <mnasiadka> * Additional agenda (from whiteboard)
14:03:24 <mnasiadka> * Open discussion
14:03:27 <mnasiadka> #topic Review action items from the last meeting
14:03:37 <mnasiadka> hrw work on cron alternative
14:03:41 <mnasiadka> mnasiadka deprecate Monasca and send mail to ML asking for contributors to step up
14:03:55 <mnasiadka> hrw probably installed cronie in the image
14:04:01 <mnasiadka> I didn't do mine, but will this week
14:04:23 <mnasiadka> #action mnasiadka deprecate Monasca and send mail to ML asking for contributors to step up
14:04:28 <mnasiadka> #topic CI Status
14:04:52 <mnasiadka> So, after the Zuul dance - do we have any changes to zuul config that haven't been merged?
14:05:09 <mnasiadka> I know about the kayobe one for ussuri, but that branch is long broken there I think
14:05:43 <yoctozepto> xena
14:05:59 <yoctozepto> centos upgrades no worky
14:06:31 <mnasiadka> ah right
14:06:39 <mnasiadka> dhcp not worky after upgrade
14:07:05 <yoctozepto> indeed
14:07:09 <yoctozepto> any clues>
14:07:31 <mnasiadka> nope, at least not for now
14:07:40 <mnasiadka> #topic Release tasks
14:07:45 <mnasiadka> I think it's feature freeze week
14:08:27 <mnasiadka> Yes, R-2 Feature Freeze
14:08:39 <hrw> o\
14:08:44 <mnasiadka> So what's the list of features that need FFE?
14:08:49 <bbezak> \o
14:08:50 <frickler> forget to mention the linting blocker for CI
14:09:01 <mnasiadka> CS9/RL9, OpenSearch, what else?
14:09:10 <hrw> LE?
14:09:10 <frickler> I'd like to get the ovn exporter in, since we already have the image in kolla
14:09:16 <mnasiadka> frickler: right, sorry - but that's being worked upon so I assume it's nearly fixed
14:09:32 <frickler> and it should not break anything else
14:09:34 <mnasiadka> frickler: as long as there are core reviewers happy to review, then I see no issues
14:11:22 <yoctozepto> systemd
14:11:26 <yoctozepto> we need to merge it finally
14:11:30 <mnasiadka> hrw: would be nice, but I can't see any reviewers doing any reviews
14:11:31 <yoctozepto> I think it is generally fine
14:11:38 <mnasiadka> let me make a list on whiteboard
14:11:43 <yoctozepto> but I will have more time next 2 weeks
14:12:04 <mnasiadka> this cycle is more like a regular cycle, lot of FFEs and nothing working on freeze ;-)
14:12:25 <bbezak> :)
14:13:24 <mnasiadka> https://etherpad.opendev.org/p/KollaWhiteBoard - L390
14:13:32 <yoctozepto> :D
14:14:21 <hrw> #link https://etherpad.opendev.org/p/KollaWhiteBoard#L390 then?
14:14:25 <mnasiadka> Please add yourselves as reviewers there - according to our policy, if there are no two reviewers assigned - FFE is not granted
14:14:33 <mnasiadka> hrw: thanks for linking :)
14:15:27 <mnasiadka> ok then, let's move on
14:15:37 <mnasiadka> #topic Current cycle planning
14:15:53 <mnasiadka> So, let's start with Kolla - CentOS 9 Stream images
14:16:17 <mnasiadka> I think it's ready to merge, there will be followups with Grafana and arm64 rabbitmq
14:16:37 <mnasiadka> Grafana's repo doesn't support SHA1 gpg although hrw raised the issue long time ago
14:16:49 <mnasiadka> I think the best approach for now is disabling gpg check on that repo as a followup
14:16:56 <hrw> yep
14:17:06 <mnasiadka> #link https://review.opendev.org/c/openstack/kolla/+/836664
14:17:09 <hrw> otherwise we are stuck with 7.5 instead of 9
14:17:16 <hrw> (grafana, not cs)
14:17:32 <mnasiadka> yes, elasticsearch will be ,,fixed'' by opensearch implementation
14:17:46 <hrw> we can also mark SHA1 as fine for grafana container only
14:18:01 <mnasiadka> Any other core willing to review that change soon-ish?
14:18:58 <yoctozepto> next week?
14:19:40 <mnasiadka> sure- that patch should not change now - I can upload the RL9 patch on top
14:19:48 <mnasiadka> hrw: will you work on the followup with grafana?
14:19:56 <hrw> yes
14:20:08 <mnasiadka> good, that's more or less covered
14:20:12 <yoctozepto> then next week I will review it
14:20:18 <yoctozepto> please stabilise it by then
14:21:15 <mnasiadka> ok then, next is OpenSearch
14:22:00 <mnasiadka> Kolla part is building and functional, the only thing I dislike is the removal of the security plugin (as in it gets removed from the running container)
14:22:17 <mnasiadka> and then if we enable tls - it gets installed once again from the internet
14:22:31 <mnasiadka> #url https://review.opendev.org/c/openstack/kolla/+/830373
14:22:38 <hrw> can we disable it and enable?
14:23:03 <mnasiadka> unfortunately not, opensearch plugin manager only accepts remove and install
14:23:13 <yoctozepto> lol
14:23:22 <yoctozepto> is it a newer feature btw?
14:23:24 <mnasiadka> I'll try to find a way to store it in some directory so we don't need internet access to enable it back :)
14:23:37 <hrw> mnasiadka: store binary in image and then install from an image?
14:23:41 <mnasiadka> security plugin in OpenSearch requires TLS certificates and gives you authentication
14:23:48 <mnasiadka> hrw: that's the plan
14:23:51 <hrw> +1
14:23:57 <mnasiadka> if you don't have a TLS certificate - there's no authentication
14:24:11 <mnasiadka> but for ES today we have haproxy based authentication for Kibana
14:24:22 <mnasiadka> so nothing changes
14:24:29 <mnasiadka> anyway, on track I would say
14:24:45 <mnasiadka> but data migration/upgrade from ES to OS will rather be done in Antelope and then backported
14:24:59 <hrw> no kibana for cs9/rl9
14:25:12 <hrw> unless we do 'no gpg' trick
14:25:30 <mnasiadka> basically people will need to redeploy from cs8 to rl9
14:25:50 <mnasiadka> so wonder if ES will shard with OpenSearch
14:26:17 <mnasiadka> but that's a different story
14:26:58 <hrw> :)
14:27:00 <mnasiadka> so then - yoctozepto is telling us systemd patch is more or less ready to go, so ideally we'd need a second reviewer for it
14:27:10 <yoctozepto> ++
14:28:21 <frickler> I have that on my list, but I can't promise anything yet
14:29:11 <mnasiadka> ok
14:29:11 <frickler> still wanted to run in a local setup
14:29:21 <mnasiadka> any other features we should discuss?
14:30:21 <yoctozepto> frickler: it passed deploy, I wonder more how well it fares in upgrades now
14:30:33 <yoctozepto> food for thought when you find the time
14:31:01 <opendevreview> Marcin Juszkiewicz proposed openstack/kolla master: grafana: ignore SHA1 gpg key on CentOS Stream 9 (and family)  https://review.opendev.org/c/openstack/kolla/+/858738
14:31:06 <frickler> ack
14:32:47 <mnasiadka> ok then, no additional agenda
14:33:00 <mnasiadka> #topic Open discussion
14:33:06 <yoctozepto> no open discussion from me today either
14:34:13 <hrw> who review linters patch?
14:34:28 <hrw> https://review.opendev.org/c/openstack/kolla-ansible/+/858571
14:34:39 <opendevreview> Michal Nasiadka proposed openstack/kolla-ansible master: CI: Fix init-swift  https://review.opendev.org/c/openstack/kolla-ansible/+/858669
14:34:55 <opendevreview> Michal Nasiadka proposed openstack/kolla-ansible master: Fix issues introduced by ansible-lint 6.6.0  https://review.opendev.org/c/openstack/kolla-ansible/+/858571
14:35:36 <mnasiadka> ok, empty line in j2 file was needed
14:35:48 <mnasiadka> should pass now
14:36:01 <yoctozepto> oh my ansible
14:36:03 <mnasiadka> I rebased the swift CI fix on that one
14:36:11 <yoctozepto> now we need template instead of templated copy?
14:36:23 <mnasiadka> ansible-lint says so
14:36:24 <yoctozepto> mnasiadka: init swift seems to break regular jobs
14:36:26 <yoctozepto> so needs work
14:36:37 <mnasiadka> yoctozepto: will look into that later
14:36:42 <mnasiadka> probably missing variable
14:36:46 <yoctozepto> likely
14:37:46 <hrw> yoctozepto: ansible manual also suggests template if content in copy is used with variables
14:38:12 <yoctozepto> hrw: thankfully the two ansible knowledge sources agree ;-)
14:38:14 <frickler> mnasiadka: you removed not only the empty line but also the newline at the end of the first line
14:38:21 <frickler> linter complained about the latter
14:39:05 <mnasiadka> frickler: I used Gerrit UI, maybe that's why
14:39:23 <frickler> ah, possible. let me push another update, then
14:39:30 <mnasiadka> anyway, let's progress this and get it merged, without that there's nothing else
14:40:00 <mnasiadka> ok, I think it's enough for today
14:40:02 <mnasiadka> thanks for coming
14:40:05 <mnasiadka> #endmeeting