14:06:35 <mnasiadka> #startmeeting kolla
14:06:35 <opendevmeet> Meeting started Wed Nov  2 14:06:35 2022 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:35 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:06:35 <opendevmeet> The meeting name has been set to 'kolla'
14:06:40 <mnasiadka> #topic rollcall
14:06:41 <mnasiadka> o/
14:07:36 <frickler> \o
14:08:08 <mnasiadka> kevko, mgoddard, hrw
14:08:24 <TimBeermann[m]> O/
14:08:32 <ihalomi> \o
14:08:37 <m_hiner> o/
14:10:22 <mgoddard> \o
14:12:32 <mnasiadka> #topic agenda
14:12:32 <mnasiadka> * CI status
14:12:32 <mnasiadka> * Release tasks
14:12:32 <mnasiadka> * Regular stable releases (first meeting in a month)
14:12:32 <mnasiadka> * Current cycle planning
14:12:33 <mnasiadka> * Additional agenda (from whiteboard)
14:12:33 <mnasiadka> * Open discussion
14:12:37 <mnasiadka> #topic CI status
14:12:58 <mnasiadka> whiteboard says green
14:13:22 <mnasiadka> I haven't seen any spectacular failures today, so let's assume it is
14:13:35 <mnasiadka> #topic Regular stable releases (first meeting in a month)
14:13:53 <mnasiadka> I think Wallaby went EM, so no more stable releases there
14:14:14 <mgoddard> did we have a final release?
14:15:27 <mnasiadka> hmm, seems not since 6th Oct
14:16:01 <mnasiadka> I'll speak with the release team later if we can still do that - I was pretty sure we did
14:16:26 <mnasiadka> Argh, I missed one topic
14:16:35 <mnasiadka> #topic Release tasks
14:16:48 <mnasiadka> We can't branch yet, still kolla/kolla-ansible/kayobe needs opensearch
14:17:15 <mnasiadka> #topic Current cycle planning
14:17:34 <frickler> what about other stable branch releases?
14:17:44 <frickler> I can create a patch unless someone else wants to
14:17:52 <mnasiadka> Ah right, we should do other stable branch releases as we do every month
14:18:47 <frickler> ok, so I'll do that
14:18:51 <mnasiadka> thanks
14:19:02 <mnasiadka> Ok, so current cycle for us is still Zed
14:19:21 <mnasiadka> We have opensearch to review and test - I'll try to do that this week
14:19:30 <mnasiadka> There's skyline that probably could get in
14:19:38 <mnasiadka> And the systemd patch in kolla-ansible
14:19:59 <mnasiadka> Anyone willing to review skyline or systemd patch thoroughly?
14:20:18 <frickler> I will do skyline, but no timeline yet
14:22:09 <mnasiadka> ok then
14:22:17 <mnasiadka> systemd also waiting for somebody :)
14:22:37 <mnasiadka> I'll try to review all of them, but surely not everything at once
14:23:22 <mnasiadka> #topic Additional agenda (from whiteboard)
14:24:02 <mnasiadka> the first two were covered last week, left them to make sure jhorstmann adds Loki to the PTG etherpad, so I can groom that and paste as priorities in the whiteboard (will check later today)
14:25:09 <mnasiadka> m_hiner: I know you wanted to discuss systemd patch, but I don't know if we don't need to postpone that next week - usually it was mgoddard and yoctozepto reviewing your patch when they could - but with Radek not spending time here anymore - it seems I need to look into that in more depth
14:25:21 <mnasiadka> mgoddard: comfortable to talk about the systemd patch, or should we move it to next week?
14:26:31 <m_hiner> I think the templating could be discussed right now
14:27:53 <mnasiadka> If it comes to me - I don't think allowing users to modify the template is required, what would be the case for it?
14:28:47 <kevko> i wanted to review skyline also ...but don't know if i will have a time :(
14:30:12 <m_hiner> I also think so, as it wouldn't have any significant use cases (at least as far as I can think of)
14:31:46 <m_hiner> and also to when customizing the template file, the users would also have to edit the kolla_systemd_worker.py which uses that template
14:32:25 <mnasiadka> So let's leave it out, we can revisit if we can find a case for it
14:33:05 <mnasiadka> Seems the remaining review comments clarification - we need to move for the next meeting - I'll look at the patch and let's discuss it next week
14:33:08 <mnasiadka> m_hiner: is that ok?
14:34:02 <m_hiner> yes, but please do
14:34:13 <m_hiner> we would really like to have it merged already
14:35:28 <mnasiadka> I understand, but now there's less reviewers than last cycle, so it will be harder...
14:35:35 <mnasiadka> anyway, let's talk about it next week
14:35:45 <m_hiner> alright
14:35:47 <mnasiadka> #topic Open discussion
14:36:48 <mnasiadka> Now the question is - should we have the meeting now at 3pm CET (which is 2pm UK time and 2pm UTC it seems)?
14:37:00 <mnasiadka> Or should I move it in the repository for an hour later?
14:37:14 <mnasiadka> (at least until next daylight saving changes)
14:37:37 <frickler> I would like to stay at this time, since the largescale sig meeting is immediately following
14:38:02 <ihalomi> i want to ask about splitting https://review.opendev.org/c/openstack/kolla-ansible/+/799229 , should I also create smaller patchest introducing container_worker?
14:38:09 <mnasiadka> mgoddard, kevko: anyone opposing?
14:38:53 <mnasiadka> ihalomi: looks huge, would be nice
14:39:16 <mgoddard> as for meeting time, I don't mind
14:40:27 <mnasiadka> Ok then, let's try this for now
14:40:45 <mnasiadka> Any other open discussion topics?
14:41:15 <frickler> just a question, did anyone ever discuss the ubuntu license terms?
14:41:28 <ihalomi> these two patchest are ready to merge https://review.opendev.org/c/openstack/kolla-ansible/+/862883 , https://review.opendev.org/c/openstack/kolla-ansible/+/862751
14:41:53 <frickler> if I read them correctly, Ubuntu may only be distributed unmodified, not patched like in our containers
14:42:29 <frickler> https://ubuntu.com/legal/intellectual-property-policy
14:44:27 <mnasiadka> that's interesting...
14:44:45 <mnasiadka> Does it mean we need to stop publishing Ubuntu images? ;-)
14:45:20 <frickler> that might be the result, but ianal and so on
14:46:03 <mnasiadka> Should we ask somebody? e.g. foundation?
14:46:07 <frickler> that page claims it was last updated in 2015, so not a new situation
14:46:32 <frickler> so my first thinking was surely this has somehow been discussed long ago
14:47:08 <frickler> but if it hasn't, maybe TC first and have them talk to foundation if needed might be good
14:48:14 <mnasiadka> Ok, how do we contact the TC? a mail to the usual openstack-discuss ML will suffice?
14:48:31 <frickler> I would usually just ask in #openstack-tc
14:48:43 <frickler> highlight "tc-members"
14:49:10 <kevko> frickler: is it "modified" if we just adding packages and code ?
14:49:41 <frickler> kevko: that's my understanding, yes
14:49:57 <mnasiadka> well, we use the base Ubuntu image, we're not modifying it in theory - but let's ask just to be sure
14:50:30 <kevko> i would say that if you change some code already landed in ubuntu or patch it somehow ...maybe yes ..but i don't know if it is our case ...hard question
14:51:20 <kevko> we are not modifing the image ..we are just adding layers with changes ..not modifiing the first layer which is image ..vanilla image
14:51:52 <kevko> but i don't  care ubuntu :D
14:52:37 <frickler> hmm, the layers argument might work, but might be good to have this checked by someone with more legal experience
14:52:41 <mnasiadka> ok then, I'll pick it up in some ,,spare'' time
14:53:21 <mnasiadka> #action mnasiadka ask TC for guidance regarding Ubuntu distribution policy (https://ubuntu.com/legal/intellectual-property-policy)
14:53:33 <mnasiadka> I guess that's all for today
14:53:35 <mnasiadka> thanks for coming!
14:53:37 <ihalomi> mnasiadka: about your comment in patchset, where should i add it? is site.yml best options?
14:53:37 <mnasiadka> #endmeeting