14:01:10 <mnasiadka> #startmeeting kolla
14:01:10 <opendevmeet> Meeting started Wed Nov 30 14:01:10 2022 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:10 <opendevmeet> The meeting name has been set to 'kolla'
14:01:14 <TimBeermann[m]> o/
14:01:14 <mnasiadka> #topic rollcall
14:01:15 <mnasiadka> o/
14:01:16 <matfechner> o/
14:01:17 <frickler> \o
14:01:21 <ramona-beermann[m]> o/
14:01:28 <mhiner> o/
14:03:09 <bbezak> o/
14:03:47 <mnasiadka> #topic agenda
14:03:47 <mnasiadka> * Review action items from the last meeting
14:03:47 <mnasiadka> * CI status
14:03:47 <mnasiadka> * Release tasks
14:03:47 <mnasiadka> * Regular stable releases (first meeting in a month)
14:03:49 <mnasiadka> * Current cycle planning
14:03:49 <mnasiadka> * Additional agenda (from whiteboard)
14:03:51 <mnasiadka> * Open discussion
14:03:54 <mnasiadka> #topic Review action items from the last meeting
14:04:19 <mnasiadka> none
14:04:33 <mnasiadka> #topic CI status
14:04:41 <mnasiadka> Whiteboard says green
14:04:50 <hrw> [_][-]
14:04:52 <mnasiadka> #topic Release tasks
14:05:06 <hrw> we have telegraf failed on el9
14:05:15 <mnasiadka> oh - what happened?
14:05:17 <hrw> external repo issue
14:05:23 <hrw> 14:07 < opendevreview> Verification of a change to openstack/kolla master failed: Fix plugin builds with sources using type=git  https://review.opendev.org/c/openstack/kolla/+/865516
14:05:27 <hrw> this change
14:05:38 <hrw> probably recheck solve the problem, not looked yet
14:05:44 <mnasiadka> ok
14:05:52 <hrw> mmalchuk did recheck
14:06:05 <mnasiadka> So, let's check the road to kolla/kolla-ansible rc1
14:06:06 <mmalchuk> rocky9 jobs failed again(
14:06:23 <frickler> do we have no-empty-recheck policy, too?
14:06:24 <thelounge44> is skyline still candidate for zed release?
14:06:43 <mnasiadka> frickler: we do, but it's sometimes hard to follow
14:07:01 <mnasiadka> basically - let's not do bare rechecks and remind other developers in Kolla reviews to not do them
14:07:06 <hrw> thelounge44: week ago it was postponed iirc
14:07:19 <frickler> just mentioning the failed job at least shouldn't be too difficult
14:07:36 <mnasiadka> so - opensearch - thanks for reviews, I think we're on a good way - I'll update today and call for reviews once again
14:08:04 <opendevreview> Pierre Riteau proposed openstack/kolla-ansible master: CI: Run validate-config at the end of deploy  https://review.opendev.org/c/openstack/kolla-ansible/+/865331
14:08:06 <thelounge44> hrw: the release was postponed, or skyline PR ?
14:08:13 <mnasiadka> skyline - I don't know if we have capacity to review and get it merged this cycle
14:08:25 <mnasiadka> I remember kevko was unhappy after testing out skyline
14:09:03 <thelounge44> ah, too bad
14:09:34 <thelounge44> i would like to see skyline in zed release tho
14:09:55 <hrw> core team shrinked during Zed ;(
14:09:56 <mnasiadka> He's offline, but you can get in touch with him to understand what are his concerns
14:10:24 <mnasiadka> if we'll have two cores happy to merge the patches before cutting rc1 - then I guess we're good to add it
14:10:39 <mnasiadka> second thing - systemd
14:10:59 <mnasiadka> I did some reviews to podman related patches, I did test out the systemd one - basically looks ok
14:11:08 <mnasiadka> But I don't know if we're happy to merge it last minute
14:12:00 <mnasiadka> Do we postpone it to early Antelope and merge it there (and keep an eye on failures)?
14:12:07 <mnasiadka> well, CI failures mainly
14:13:04 <mnasiadka> frickler: opinion?
14:13:04 <frickler> likely that is the safest way, yes
14:13:14 <mnasiadka> the same second, nice ;)
14:13:20 <mnasiadka> Ok
14:13:46 <mnasiadka> #agreed to postpone systemd to first days of Antelope cycle, merge it then and monitor CI failures throughout the cycle
14:14:18 <mnasiadka> so, what's left from priorities
14:14:58 <frickler> I have a question about that timing, rc1 is when zed will be branched, right? when will final zed release happen then?
14:15:14 <mnasiadka> kolla whiteboard says that for kolla we have opensearch (nearly done), tweaks to upper constraints (not done), pipenv/poetry (not done)
14:15:21 <mnasiadka> so not bad, one out of three
14:15:27 <frickler> or phrased differently: is the deadline in two weeks for rc1 or for final?
14:15:55 <mnasiadka> frickler: yes, rc1 is when branching is done, final should be soon afterwards after we're happy - usually a week or two behind
14:16:22 <mnasiadka> so basically let's merge opensearch and branch
14:16:59 <mnasiadka> all four kolla-ansible priorities have been postponed to Antelope
14:17:07 <frickler> o.k. but systemd would then wait until after final?
14:17:21 <mnasiadka> systemd/podman, secure rbac, let's encrypt and modernising swift role
14:17:44 <hrw> mnasiadka: do we have patches for u-c and pipenv/poetry at all? if not then maybe it is far too late for them?
14:17:47 <mnasiadka> I think so, we usually merge new stuff after final stable
14:18:08 <mnasiadka> hrw: yes, it's too late, I'm just summarising if there's anything we HAVE TO do ;)
14:18:24 <hrw> ok
14:18:44 <mnasiadka> ok, now Kayobe
14:18:59 <mnasiadka> bbezak Rocky Linux 9 - when can we merge it, and why not now :)
14:20:17 <bbezak> soon :). RL 9.1 and CS9 works fine now - as far as overcloud job is concerned, however NM role needs to be polished and one feature needs to be added. Ongoing with ebbex
14:21:25 <mnasiadka> We have two weeks until the deadline - will you make it? :)
14:22:05 <bbezak> that is probable, yes ;)/
14:22:07 <mnasiadka> hrw: rocky is failing, because we have 9.1
14:22:08 <mgoddard> I'll look at the NM patch again today
14:22:19 <mnasiadka> hrw: and pretty name does not match
14:22:29 <hrw> mnasiadka: simple patch and done?
14:22:38 <mnasiadka> yup
14:23:01 <mnasiadka> any volunteer to fix it?
14:23:33 <mnasiadka> oh well, I'll do it myself then
14:23:36 <hrw> will do
14:25:04 <opendevreview> Michal Nasiadka proposed openstack/kolla master: rocky: update pretty name to match 9.1  https://review.opendev.org/c/openstack/kolla/+/866170
14:25:11 <mnasiadka> ok then, seems like we have a way towards branching soon
14:25:24 <opendevreview> Marcin Juszkiewicz proposed openstack/kolla master: base: Rocky Linux 9.1 was released  https://review.opendev.org/c/openstack/kolla/+/866171
14:25:36 <mnasiadka> lol, I'll abandon mine
14:25:55 <mnasiadka> #topic Current cycle planning
14:25:58 <hrw> dropped already
14:26:18 <mnasiadka> I'll update the Kolla whiteboard with Antelope priorities
14:26:26 <hrw> restored mine
14:26:53 <mnasiadka> and we'll start mentioning them on weekly meetings after we branch
14:27:04 <mmalchuk> mnasiadka maybe need to support 9.x ?
14:27:40 <mnasiadka> It might be, but it can be a follow up later - let's just fix the CI now
14:27:45 <mnasiadka> #topic Additional agenda (from whiteboard)
14:27:54 <mmalchuk> ok
14:27:58 <hrw> https://github.com/influxdata/telegraf/issues/12303 is telegraf bug we are blocked by
14:28:19 <mnasiadka> Only systemd patchset is there - and we decided to postpone it
14:28:21 <opendevreview> Maksim Malchuk proposed openstack/kolla master: Fix plugin builds with sources using type=git  https://review.opendev.org/c/openstack/kolla/+/865516
14:28:39 <mnasiadka> #topic Open discussion
14:28:46 <mnasiadka> Ok, any open topics for today?
14:29:24 <ramona-beermann[m]> I have one question: Is it possible that someone can review this PR? https://review.opendev.org/c/openstack/kolla-ansible/+/861953
14:31:00 <mnasiadka> commented, I'll keep an eye on it
14:31:05 <ramona-beermann[m]> Only if anyone has time. Maybe a discussion is needed if this fits for all, or someone have other opinions
14:31:11 <ramona-beermann[m]> ty
14:31:55 <ramona-beermann[m]> There is a second one from me for development: https://review.opendev.org/c/openstack/kolla-ansible/+/863982
14:32:00 <mnasiadka> any core or non-core volunteer to review it? would be nice if  somebody fresh could take a look and tell us if it helps :)
14:32:36 <mnasiadka> ravlew: up for it?
14:34:07 <mnasiadka> or anybody else, anyway - let's make that better - maybe we can more people be interested if that's written easier :)
14:34:10 <frickler> I'll also revisit, but would be nice to see other feedback first
14:34:13 <mnasiadka> ramona-beermann[m]: thanks for working on this
14:34:22 <hrw> ramona-beermann[m]: +1 and comment
14:34:22 <mmalchuk> will take a look
14:35:38 <ramona-beermann[m]> mnasiadka: your welcome :)
14:36:05 <mnasiadka> any other open topics?
14:36:55 <mmalchuk> my reviews in Kayobe
14:36:56 <mmalchuk> https://review.opendev.org/q/owner:maksim.malchuk%2540gmail.com+status:open+project:openstack/kayobe
14:37:10 <mmalchuk> anyone please
14:38:45 <mnasiadka> mgoddard: any idea if you or anyone else can have a look?
14:40:42 <ramona-beermann[m]> My +1 wouldn't help or?
14:41:04 <hrw> ramona-beermann[m]: and +1 on other one
14:41:19 <mnasiadka> Well +1 always helps, a constructive review helps even more :)
14:41:41 <ramona-beermann[m]> hrw: thanks a lot
14:42:22 <mnasiadka> ok then, let's finish for today - thanks for coming :)
14:42:25 <mnasiadka> #endmeeting