14:01:28 <mnasiadka> #startmeeting kolla
14:01:28 <opendevmeet> Meeting started Wed Mar 22 14:01:28 2023 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:28 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:28 <opendevmeet> The meeting name has been set to 'kolla'
14:01:32 <mnasiadka> #topic rollcall
14:01:43 <mnasiadka> o/
14:02:42 <bbezak> o/
14:03:04 <mhiner> o/
14:03:05 <frickler> \o
14:03:39 <ihalomi> \o
14:04:44 <opendevreview> Michal Nasiadka proposed openstack/kolla-ansible master: octavia: Fix hm-interface after bumping openstack collection  https://review.opendev.org/c/openstack/kolla-ansible/+/878209
14:04:46 <mnasiadka> #topic agenda
14:05:00 <mnasiadka> * Announcements
14:05:00 <mnasiadka> * Review action items from the last meeting
14:05:00 <mnasiadka> * CI status
14:05:00 <mnasiadka> * Release tasks
14:05:00 <mnasiadka> * Regular stable releases (first meeting in a month)
14:05:01 <mnasiadka> * Current cycle planning
14:05:01 <mnasiadka> * Additional agenda (from whiteboard)
14:05:03 <mnasiadka> * Open discussion
14:05:03 <mnasiadka> #topic Announcements
14:05:36 <mnasiadka> A reminder that this weekend it's DST time change in Europe - so next weeks meetings are going to be at 4pm CET / 3pm UK time
14:05:57 <mnasiadka> Do we want to change it back to 3pm, or do we want to leave it at 4pm?
14:06:41 * frickler would prefer the earlier option
14:07:08 * mnasiadka too, but can adapt
14:07:11 <mnasiadka> bbezak: ?
14:07:44 <frickler> we don't have any regulars from the US anymore, do we?
14:07:50 <mnasiadka> Not really
14:08:16 <bbezak> 3pm was better for me
14:08:33 <mnasiadka> it's going to be 9am ET, so not bad
14:08:45 <mnasiadka> ok, so let's switch that in the repo
14:09:17 <mnasiadka> #action mnasiadka switch meeting time after DST time change
14:09:20 <mnasiadka> #topic CI Status
14:09:29 <mnasiadka> Overall green I guess, openeuler has some issues
14:09:41 <mnasiadka> tried to solve them in ansible-collection-kolla, but it seems it has some cgroup v2 issues
14:10:53 <mnasiadka> not going to pursue it, will send a mail to openstack-discuss about it, and if it's not going to be picked up by somebody else before branching antelope - I'll propose deprecating openeuler
14:11:06 <mnasiadka> #topic Release tasks
14:11:39 <mnasiadka> We're a cycle trailing project, basically we have a lot of time to branch, but would be nice if we could do it this time sooner than later
14:11:53 <frickler> 2023.1 is just being released today
14:12:07 <mnasiadka> I've been chasing some CI breakages after we bumped openstacksdk and ansible-collection-openstack
14:12:20 <mnasiadka> but apart of that I don't see any real issues to branch
14:12:22 <frickler> and yes, not waiting too long seems reasonable
14:12:45 <mnasiadka> we should merge ovn-agent so it's ready for Antelope deployments (although now it only does QoS on hardware offloaded ports)
14:12:54 <mnasiadka> we should aim at getting podman in
14:13:08 <mnasiadka> and the usual Ansible bump patches
14:13:26 <mnasiadka> I'll go through things, mark them as RP+1 and notify here when done
14:13:35 <mnasiadka> so we can focus our review efforts on those patches
14:14:10 <frickler> sounds like a good plan, thx
14:15:08 <mnasiadka> I also need to submit patches for RL9 migration docs in Yoga, and then we could propose stable releases (probably beginning of April sounds ok for our regular releases)
14:15:24 <mnasiadka> #topic Current cycle planning
14:15:31 <mnasiadka> Well, I think we've done that in previous topic
14:15:56 <mnasiadka> For PTG planning we have https://etherpad.opendev.org/p/kolla-bobcat-ptg
14:15:57 <mnasiadka> #link https://etherpad.opendev.org/p/kolla-bobcat-ptg
14:16:17 <mnasiadka> Currently we have no topics, so maybe let's use next 5-10 minutes to fill out anything
14:16:32 <mnasiadka> I'll also add incomplete priorities from Zed so we can discuss them again on the PTG
14:18:51 <ihalomi> I wanted to ask about proposed solution on mounting run directory in podman, that was proposed here https://review.opendev.org/c/openstack/kolla-ansible/+/799229/52/ansible/roles/nova-cell/defaults/main.yml
14:20:34 <mnasiadka> ihalomi: I think it should be fine, as long as we properly test it - but you should propose it as a separate patch (and not podman specific)
14:21:46 <ihalomi> okay, will look into it, is somewhere list of all files we need from run mount?
14:22:25 <mnasiadka> basically this is libvirt container, I don't think there's a list somewhere
14:22:45 <frickler> I would start with the list in the comment and then test what might break
14:22:53 <mnasiadka> yes, that's a good idea
14:25:12 <frickler> this might also be interesting for kolla. didn't look in detail yet, though https://review.opendev.org/q/topic:reg-proxy
14:25:41 <frickler> in essence a proxy to access container images, to make us independent from the choice of backend registry
14:27:01 <mnasiadka> I proposed dropping Docker Hub publishing, I think we need a reno and a mail to openstack-discuss
14:27:17 <mnasiadka> What is still unclear to me - is if we should remove the images on our Kolla DockerHub account - or not
14:27:29 <mnasiadka> Anybody has an opinion about that?
14:27:38 <opendevreview> Merged openstack/kolla master: neutron: Add iproute-tc  https://review.opendev.org/c/openstack/kolla/+/872270
14:28:00 <frickler> if we don't push there anymore, we should drop old images rather than let them rot
14:28:16 <mnasiadka> Yes, that's why I was thinking about it
14:28:29 <mnasiadka> Ok, I'll include that on the mail to ML
14:28:44 <bbezak> +1 to dropping
14:29:04 <mnasiadka> ok then
14:29:21 <mnasiadka> #topic Open discussion
14:29:45 <mhiner> I want to ask regarding the migration patch. Original problem still remains as described in comment thread: https://review.opendev.org/c/openstack/kolla-ansible/+/836941/comments/1f50c241_7b290601
14:30:05 <mhiner> tldr: VMs in migrated Openstack are left in error state and cannot be started or rescued, only rebuilt, which I guess is not feasible to put in ansible tasks
14:31:42 <frickler> can we have a deployment mixing docker and podman (on different hosts)? then maybe we don't need a migration at all?
14:32:04 <mnasiadka> And as I mentioned we need some CI jobs testing this, instead of doing manual tests.
14:35:12 <mhiner> Regarding the CI jobs, I can try to basically clone existing voting jobs with podman as parameter. Would that be enough for start?
14:35:58 <mnasiadka> yes, debian/ubuntu/rocky9 as a start is ok (just base it on the general job, no specific scenario)
14:36:24 <mnasiadka> should be easy to define, in case of any problems just reach out to us
14:36:56 <mhiner> okay thanks
14:38:03 <mnasiadka> ok, I think it's enough for today
14:38:09 <mnasiadka> I already cancelled the weekly meeting next week
14:38:29 <mnasiadka> and we meet on the PTG slots (Mon and Tue for Kolla/Kolla-Ansible and Thu for Kayobe)
14:38:44 <mnasiadka> Please try to spend some time populating topics for the PTG
14:39:18 <mnasiadka> If we won't have enough topics, I think we'll use the rest of the time to do bug triaging/reviews on the meeting time - if that's feasible
14:39:28 <mnasiadka> Thanks for coming, and have a nice day
14:39:31 <mnasiadka> #endmeeting