13:02:23 <mnasiadka> #startmeeting kolla
13:02:23 <opendevmeet> Meeting started Wed May 10 13:02:23 2023 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:23 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:23 <opendevmeet> The meeting name has been set to 'kolla'
13:02:28 <mnasiadka> #topic rollcall
13:02:34 <ramona-beermann[m]> o/
13:02:39 <mnasiadka> o/
13:02:44 <bbezak> o/
13:03:06 <mmalchuk> \o
13:03:34 <SvenKieske> o/
13:03:36 <opendevreview> Maksim Malchuk proposed openstack/kayobe master: Add custom user_data content configuration for Bifrost  https://review.opendev.org/c/openstack/kayobe/+/879554
13:03:42 <SvenKieske> sorry, my laptop just crashed..
13:04:51 <mnasiadka> #topic agenda
13:04:51 <mnasiadka> * CI status
13:04:51 <mnasiadka> * Release tasks
13:04:51 <mnasiadka> * Regular stable releases (first meeting in a month)
13:04:51 <mnasiadka> * Current cycle planning
13:04:53 <mnasiadka> * Additional agenda (from whiteboard)
13:04:53 <mnasiadka> * Open discussion
13:04:55 <mnasiadka> #topic CI Status
13:05:04 <mnasiadka> seems we're green now
13:05:11 <mnasiadka> after all those weird breakages
13:05:18 <mnasiadka> #topic Release tasks
13:05:28 <mnasiadka> Basically 1st of June is release deadline for cycle-trailing projects
13:05:29 <mmalchuk> Kayobe CI red
13:05:41 <mnasiadka> mmalchuk: so please update the whiteboard
13:05:42 <mmalchuk> fix: https://review.opendev.org/c/openstack/kayobe/+/882820
13:06:25 <mmalchuk> lets merge it and it will be green
13:06:31 <mnasiadka> So we need to start cutting corners - for the 1st June deadline
13:06:39 <mnasiadka> I had a look in the Ansible bump issue
13:07:03 <mnasiadka> Found the commit in ansible-core that broke us, will start thinking how to overcome it
13:07:09 <mmalchuk> it not ansible, it molecule
13:07:31 <mnasiadka> #link https://github.com/ansible/ansible/issues/79776
13:07:35 <mmalchuk> setup.cfg have ansible-compat >= 2.2.0
13:07:37 <mnasiadka> mmalchuk: I'm not speaking about your patch
13:07:53 <mmalchuk> ok. sorry
13:08:26 <SvenKieske> this is the patch in question mnasiadka talks about afaik: https://review.opendev.org/c/openstack/kolla-ansible/+/881018
13:09:02 <SvenKieske> mnasiadka: if I could speed up something/help somewhere, just ask :)
13:09:04 <mnasiadka> yup, updated it with a link to a bug that broke us ;-)
13:09:10 <SvenKieske> nice
13:10:16 <mnasiadka> There is one patch in Kolla that will need merging, but first Rocky needs to have centos-release-openstack-antelope - I raised a bug in Rocky bug tracker and it seems it's in progress
13:10:20 <SvenKieske> there's an upstream fix already merged it seems? https://github.com/ansible/ansible/pull/79804
13:10:30 <mnasiadka> SvenKieske: it's the fix that broke us :)
13:10:35 <SvenKieske> ouch :D
13:10:55 <mnasiadka> testing now with force_handlers: true/false if that's an easy fix
13:10:58 <mnasiadka> but probably not
13:11:33 <SvenKieske> ok
13:13:47 <mmalchuk> mnasiadka whiteboard updated
13:13:59 <mnasiadka> Would be nice to get some reviews on https://review.opendev.org/c/openstack/kolla/+/882343 - it seems the version check is broken now ;-)
13:14:59 <mnasiadka> and we need it for https://review.opendev.org/c/openstack/kolla/+/825786/27
13:15:32 <SvenKieske> I can review that. in general it would be nice if dependencies are tracked/mentioned somewhere in the commit message or the bugtracker
13:16:03 <mnasiadka> well, those patches are stacked one on another, you can see that in the gerrit ui
13:16:18 <mnasiadka> relation chain - top right
13:16:49 <mnasiadka> #topic Current cycle planning
13:16:59 <mnasiadka> I think we've done that in the release tasks (I mean the planning)
13:17:09 <mnasiadka> #topic Additional agenda (from whiteboard)
13:17:17 <SvenKieske> yeah, in this case it's there, but not always ;) related to that: WIPs are often initially not marked as WIP, but maybe I'm just to fast to review.
13:17:47 <mnasiadka> SvenKieske: well, some people mark WIP in commit message, some people mark it as a flag in Gerrit, some people do both, some people do none :)
13:18:01 <mnasiadka> (mattcrees): With this precheck now added, should we enable RabbitMQ HA queues by default in Antelope? Precheck: https://review.opendev.org/c/openstack/kolla-ansible/+/880274
13:18:03 <mnasiadka> mattcrees: around?
13:18:08 <mattcrees> Yep
13:18:42 <mattcrees> Basically as the topic says, if people are happy that the precheck is enough then IMO we should enable RabbitMQ HA queues by default
13:19:14 <mnasiadka> I think it would be good to change the default, I already squashed 5+ bugs from people running non-HA on multinode with known problems
13:19:37 <SvenKieske> yeah, that would be nice, was there already a change open for that?
13:19:45 <mattcrees> There's also backports of the precheck ongoing
13:20:06 <mattcrees> SvenKieske: I don't think so, I'll propose one now
13:20:30 <mnasiadka> I just merged the backports
13:20:30 <SvenKieske> nice, will review, you can ping me about it
13:20:57 <mattcrees> Will do
13:21:03 <mnasiadka> #agreed to change the RMQ HA queues by default in Antelope
13:21:21 <SvenKieske> the backports already all have one +2 and are just missing workflow/verified, so I guess I can't do much there
13:21:23 <mnasiadka> There's a topic by ihalomi - but he's not around
13:21:39 <mnasiadka> so I'll leave it for next week
13:21:47 <mnasiadka> #topic Open discussion
13:21:54 <mnasiadka> Anyone, anything?
13:21:55 <SvenKieske> yeah  regarding: https://review.opendev.org/c/openstack/kolla/+/825786 he asked for help but there are still unadressed comments, so.
13:22:04 <mmalchuk> Kayobe reviews
13:22:13 <mmalchuk> 1. https://review.opendev.org/c/openstack/kayobe/+/882820
13:22:19 <mmalchuk> 2. https://review.opendev.org/c/openstack/kayobe/+/881679
13:22:25 <mmalchuk> both CI
13:23:12 <mmalchuk> mgoddard ask to fix kayobe-seed-images-* jobs ^^^ it fixed
13:23:32 <mmalchuk> molecule broken recently
13:23:44 <mmalchuk> also fixed
13:24:05 <mnasiadka> I've sent that on a different communication channel to Kayobe cores inside StackHPC, let's see if that gets reviewed.
13:24:24 <mmalchuk> thanks
13:24:30 <mnasiadka> SvenKieske: I have a feeling we need to push it over so it gets merged
13:26:35 <SvenKieske> yeah, might be, the docs comments can be addressed by us, I think. the tests not passing is the bigger issue I guess.
13:27:28 <mnasiadka> I'll have a look, probably we need to mock the docker version in more places
13:27:42 <mnasiadka> or once for everything that is not pre3.0.0
13:28:04 <SvenKieske> appreciated, as I'm still not very familiar with this part of the code.
13:28:50 <mnasiadka> I started triaging the bugs, kolla and kayobe look fine, kolla-ansible is another 180 bugs to triage
13:29:14 <mnasiadka> but I should get there before the summit, and we could start having weekly bug reports on the ML
13:30:00 <mnasiadka> or bugs managed in a proper way
13:30:26 <mnasiadka> Ok, anything else? or should we call it a day?
13:30:34 <SvenKieske> yeah, bug reports on the ML might be nice, I like that when neutron et al do this
13:30:50 <SvenKieske> I have the next meeting already scheduled, so..
13:31:05 <mnasiadka> Ok then, thanks for coming - see you next week :)
13:31:07 <mnasiadka> #endmeeting