14:00:07 <mnasiadka> #startmeeting kolla
14:00:07 <opendevmeet> Meeting started Wed Feb 19 14:00:07 2025 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <opendevmeet> The meeting name has been set to 'kolla'
14:00:10 <mnasiadka> #topic rollcall
14:00:11 <mnasiadka> o/
14:00:19 <MattCrees[m]> o/
14:00:20 <bbezak> o/
14:00:37 <mhiner> o/
14:00:41 <mmalchuk> o/
14:00:53 <r-krcek> o/
14:01:02 <koperg[m]> o/
14:01:10 <frickler> \o
14:01:14 <mnasiadka> #topic agenda
14:01:16 <yuval_> 0/
14:01:24 <mnasiadka> * Announcements
14:01:29 <mnasiadka> * CI status
14:01:40 <mnasiadka> * Release tasks
14:01:46 <mnasiadka> * Current cycle planning
14:01:51 <mnasiadka> * Additional agenda (from whiteboard)
14:01:57 <mnasiadka> * Open discussion
14:02:00 <mnasiadka> #topic Announcements
14:02:33 <mnasiadka> Since me and bbezak will be going for OpenInfra Days US Pasadena - the weekly meeting on 5th March will be cancelled.
14:02:46 <mnasiadka> (unless anybody has an urge to host the meeting, but I assume not)
14:02:49 <mnasiadka> #topic CI status
14:03:22 <mnasiadka> podman-py has released a new version and has broken our CI - since they already fixed that in the main branch code - we'll wait until tomorrow for a new release instead of pinning it now
14:04:01 <mnasiadka> Overall the CI looks ok, but I have a feeling we have a lot of failures related to proxysql running in a resource constrained env
14:04:33 <mnasiadka> frickler, bbezak for some stability I would probably think about disabling proxysql in our CI and work out the issues in a dedicated patch
14:04:50 <mnasiadka> instead of wasting OpenDev resources on rechecks...
14:05:02 <mnasiadka> Did you notice the same - or is it only me?
14:06:09 <mnasiadka> Ok, let's move forward, we can discuss that after the meeting.
14:06:09 <frickler> I didn't look at failures a lot recently, but I'm fine with your proposal unless kevko wants to pick up a fight with zuul once again ;)
14:06:30 <mnasiadka> Well, I did some things, but they haven't fixed the issues
14:06:46 <mnasiadka> I'm thinking about disabling mariadb healthchecks in proxysql, that should ease some of the load
14:07:14 <mnasiadka> But I'd prefer we regain clean CI jobs for the sake of couple of last months of the release cycle
14:07:18 <frickler> disable or just reduce the frequency?
14:07:18 <mnasiadka> I'll try that out
14:07:42 <mnasiadka> reducing the frequency makes the proxysql watchdog behave in a weird way
14:07:51 <mnasiadka> we could just disable the watchdog, maybe that helps
14:08:04 <mnasiadka> I'll experiment
14:08:10 <mnasiadka> #topic Release tasks
14:08:25 <mnasiadka> It's R-6
14:08:52 <mnasiadka> R-8: Switch images to current release¶
14:09:09 <mnasiadka> Any volunteer for carrying out https://docs.openstack.org/kolla/latest/contributor/release-management.html#r-8-switch-images-to-current-release ?
14:09:40 <frickler> didn't we talk about that last week and someone already volunteered?
14:10:17 <frickler> bbezak ?
14:10:39 <mnasiadka> Ah, I didn't check the logs
14:10:54 <frickler> but I haven't seen a patch yet, so maybe it got lost
14:11:13 <bbezak> I did indeed. But just did the releases. I look into that next.
14:11:22 <opendevreview> Piotr proposed openstack/kolla-ansible master: Added vault support to barbican as back-end secret  https://review.opendev.org/c/openstack/kolla-ansible/+/935704
14:11:42 <mnasiadka> bbezak: maybe koperg or somebody else from SHPC could have a look? it's a simple enough job :)
14:11:55 <koperg[m]> no problem
14:11:58 <bbezak> Makes sense
14:11:58 <mnasiadka> goodie
14:12:56 <mnasiadka> #action koperg to carry out R-8: switch images to current release
14:13:07 <mnasiadka> #topic Current cycle planning
14:13:20 <mnasiadka> Anybody wants to raise any feature patches they have been working on?
14:13:53 <jovial> One I was hoping to get in: https://review.opendev.org/c/openstack/kolla-ansible/+/920294
14:14:11 <jovial> So we can remove the need for sudo on the control host with Kayobe
14:14:59 <mnasiadka> Do you want to backport this?
14:15:39 <yuval_> https://review.opendev.org/c/openstack/kolla-ansible/+/938649
14:16:19 <jovial> If upstream are happy to backport, then I'd be all for it, but otherwise I can cherry pick back to our fork
14:16:33 <jovial> Hoping to use it with Caracal myself
14:16:50 <frickler> oh, it's almost a year that I looked at that, can check again
14:16:58 <mnasiadka> jovial: There's a valid comment by Sven - if you want to get it backported - raise a bug :)
14:17:08 <mnasiadka> if not, we can merge it as is I think
14:17:39 <jovial> OK, I'll make a bug report if backporting is acceptable
14:17:55 <jovial> Will try and get that done after this meeting
14:17:59 <mnasiadka> frickler: I know that we agreed to rework all Cinder backends support to something more generic (+ Ceph because that's the most used one) - but I have a feeling that it won't happen this cycle - and don't want to block yuval_ - what do you think?
14:18:14 <mnasiadka> jovial: thanks
14:19:42 <opendevreview> Piotr proposed openstack/kolla-ansible master: Added vault support to barbican as back-end secret  https://review.opendev.org/c/openstack/kolla-ansible/+/935704
14:19:43 <frickler> mnasiadka: hmm, difficult question, if we just keep delaying it we'll need to add ever more deprecations. but I also don't wan't to block ppl
14:19:56 <mmalchuk> mnasiadka: another one brick (backend) on the wall)
14:21:20 <yuval_> I am new here, just want to say I really love kolla-ansible.
14:21:23 <mnasiadka> Well, how do we think it's going to happen? we have a high number of backends - people use this, do we expect to have a generic method of copying in additional files plus an additional config override fully written by people? (I mean the cinder.conf backend section)
14:21:41 <yuval_> I would glad to help with making generic solution, but I need some guidelines
14:22:04 <mnasiadka> For now there's simplicity, if we drop that all in one cycle - we might make a lot of people angry - and also now we have sort of control over ''the recommended kolla-ansible way to configure those backends''
14:22:17 <mnasiadka> I have a feeling we need to rethink it in details on the next PTG
14:22:40 <jovial> Also its a lot harder to keep out of tree config up to date
14:23:05 <mnasiadka> I'll try to draft out something for the next meeting and we can discuss what are the options to make it more generic, but still keep the simplicity
14:23:24 <mnasiadka> For now let's review yuval_ 's patch and try to get it in Epoxy
14:23:35 <mnasiadka> Ok, there's one more I see from mhiner
14:23:48 <mnasiadka> [2025-02-12] (mhiner): Move to high level client in DockerWorker | https://review.opendev.org/c/openstack/kolla-ansible/+/908295... (full message at <https://matrix.org/oftc/media/v1/media/download/AWL9HsVOlOuCRXM643x6ythC_7IRTDuK5i4VrfYQV_Xf7WFIEBGibpYEfWeGPdUHrq9Vb7cxbIVQh3NrhzutFLhCeVZrD3gAAG1hdHJpeC5vcmcvZ2p4Vk9oVXZ1S21RdUVIRFh3cHRldmtx>)
14:24:31 <mnasiadka> mhiner: I think easiest would be to try to get Canonical to update the python3-docker package - forcing people to use venvs is a bit of a major move
14:24:40 <mnasiadka> so let's try the easier way for now
14:25:31 <mhiner> I have trouble forcing even our CI to use it, so I agree :)
14:25:33 * mmalchuk removed -1 from yuval_ review
14:25:43 <mnasiadka> They have a lot newer version in oracular, so it should be possible
14:25:54 <mnasiadka> mhiner: so please try and let us know :)
14:26:00 <mhiner> Alright
14:26:09 <mnasiadka> #topic Additional agenda (from whiteboard)
14:26:22 <mnasiadka> [2025-02-19] (r-krcek):
14:26:22 <mnasiadka> please review https://review.opendev.org/c/openstack/kolla-ansible/+/933073
14:26:22 <mnasiadka> (podman migration) please review the cahin starting at https://review.opendev.org/c/openstack/kolla-ansible/+/912460
14:26:34 <mnasiadka> 933073 is not dependent on this ubuntu python3-docker problem, right?
14:26:58 <r-krcek> Not, this one is not
14:27:06 <mnasiadka> frickler: can you re-review? I've seen r-krcek has updated the patch after your comments
14:27:23 <mnasiadka> jovial: Willing to have a look in podman migration patch?
14:27:34 <mnasiadka> (I know you did some Kayobe related work with Podman, so maybe this would be useful)
14:28:05 <frickler> ack, added to my list once again
14:28:10 <jovial> Yeah, it did look super cool. I can certainly take a look.
14:28:30 <mnasiadka> thank you
14:28:35 <mnasiadka> (both)
14:28:38 <mnasiadka> #topic Open discussion
14:28:40 <r-krcek> Thank you guys :)
14:28:48 <mnasiadka> Anything else anybody?
14:29:10 <mhiner> Can someone please close this: https://review.opendev.org/c/openstack/kolla-ansible/+/905837
14:29:23 <mnasiadka> As in abandon?
14:29:23 <mhiner> Original author is not available anymore to do it
14:29:26 <mhiner> Yes
14:29:41 <mnasiadka> done
14:29:45 <mhiner> Thanks
14:29:57 <mnasiadka> Ok then - I'm sorry but I need to run
14:30:02 <mnasiadka> Thank you all for coming :)
14:30:08 <yuval_> Thank you
14:30:13 <mnasiadka> If there's anything - please ask after the meeting and I'll reply later
14:30:15 <mnasiadka> #endmeeting