14:01:36 <mnasiadka> #startmeeting kolla
14:01:36 <opendevmeet> Meeting started Wed Mar 26 14:01:36 2025 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:36 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:36 <opendevmeet> The meeting name has been set to 'kolla'
14:01:41 <mnasiadka> #topic rollcall
14:01:42 <mnasiadka> o/
14:01:45 <frickler> \o
14:01:51 <koperg[m]> o/
14:01:51 <r-krcek> o/
14:02:06 <bbezak> o/
14:02:22 <MattCrees[m]> o/
14:04:42 <mnasiadka> #topic agenda
14:04:47 <mnasiadka> * Announcements
14:04:49 <mnasiadka> * Review action items from the last meeting
14:04:53 <mnasiadka> * CI status
14:04:59 <mnasiadka> * Release tasks
14:04:59 <opendevreview> Merged openstack/kolla-ansible master: Remove notifiers from uwsgi service role  https://review.opendev.org/c/openstack/kolla-ansible/+/945282
14:05:02 <opendevreview> Merged openstack/kolla master: Switch to 2025.1 sources  https://review.opendev.org/c/openstack/kolla/+/944672
14:05:05 <mnasiadka> * Regular stable releases (first meeting in a month)
14:05:11 <mnasiadka> * Current cycle planning
14:05:17 <mnasiadka> * Additional agenda (from whiteboard)
14:05:21 <mnasiadka> * Open discussion
14:05:23 <mnasiadka> #topic Announcements
14:05:39 <darmach> o)
14:05:45 <mnasiadka> I will be mainly off for the next three weeks - I'm going on a trip to New Zealand
14:06:06 <mnasiadka> So if I'm needed to review anything - just tag me here and I'll try to do that in a very async manner :)
14:06:35 <mnasiadka> bbezak: as always agreed to manage the meetings and also do everything that is required for a release - so please support him in that :)
14:06:42 <mnasiadka> #topic CI status
14:07:03 <mnasiadka> I think it's overall ok - but we see timeouts there and there
14:07:08 <bbezak> :)
14:07:19 <mnasiadka> #topic Release tasks
14:07:32 <mnasiadka> Next week is coordinated OpenStack release - so we have like 7 weeks to do the release
14:07:48 <mnasiadka> No pressure though :)
14:07:59 <MattCrees[m]> Plenty of time :)
14:08:10 <mnasiadka> All required patches are RP+2 or RP+1 (I hope) - let's try to not add a lot more
14:08:33 <mnasiadka> #topic Current cycle planning
14:08:55 <mnasiadka> Anybody has a patch that HAS to go in 2025.1 and doesn't have RP+1 or RP+2 - reach out to me or bbezak
14:09:02 <mnasiadka> that's the planning ;)
14:09:56 <mnasiadka> I'll skip Additional Agenda - we will only review the RP patches - nothing else - we'll come back to some additional things after branching 2025.1
14:10:04 <mnasiadka> #topic Open discussion
14:10:07 <mnasiadka> Anybody anything?
14:10:30 <mnasiadka> I have one thing
14:10:42 <mnasiadka> I'd like to deprecate Bifrost - although we don't have a solution to replace it yet.
14:11:15 <frickler> fine for me
14:11:21 <mnasiadka> And I think it should be quite easy to reproduce the same config with Kolla-Ansible Ironic-related roles and Ironic-related Kolla images - so we have everything, it just needs a dedicated playbook.
14:11:52 <mnasiadka> And we're deprecating in 2025.1, so that operators are aware that something new will come in (which we could backport to 2025.1 once it's in place for 2025.2)
14:12:02 <mnasiadka> And remove Bifrost in 2026.1 at latest
14:12:15 <mnasiadka> I never liked the way it was implemented, so it's time to drop off that weight.
14:12:23 <mnasiadka> Anybody opposes? :)
14:12:30 <mnasiadka> (I added also PTG topic around that)
14:12:51 <felipeafv> I have a proposal, could you guys review it pls. https://review.opendev.org/c/openstack/kolla-ansible/+/934696
14:13:38 <MattCrees[m]> Sounds sensible to me. I see johnthetubaguy has also added to discuss Bifrost replacements in the Kayobe PTG session.
14:14:48 <mnasiadka> Matt Crees: And I commented it doesn't really fit in there, we should rather have the replacement in K-A and make Kayobe to use it - unless we want to break the traditional cycle of Kayobe not owning OpenStack-y components :)
14:15:40 <MattCrees[m]> Makes sense, I agree KA should own it
14:15:44 <mnasiadka> #agreed to deprecate Bifrost in 2025.1 (with no planned removal date yet)
14:15:51 <mnasiadka> Ok then - anybody else anything?
14:16:17 <felipeafv> This proposal? https://review.opendev.org/c/openstack/kolla-ansible/+/934696
14:17:02 <mnasiadka> felipeafv: I'm sorry, it's not a priority for us - and most probably will be reviewed after 2025.1 is branched
14:17:31 <mnasiadka> Kolla core team is small and we need to focus on making our deliverables usable for 2025.1
14:17:36 <felipeafv> I understand, thanks
14:17:54 <mnasiadka> Ok then
14:18:11 <mnasiadka> bbezak, frickler - giving back 42 minutes of your lives back to review RP patches :-)
14:18:17 <mnasiadka> Thank you all for coming!
14:18:20 <frickler> yay ;)
14:18:21 <mnasiadka> #endmeeting