13:00:22 <mnasiadka> #startmeeting kolla
13:00:22 <opendevmeet> Meeting started Wed Sep 17 13:00:22 2025 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:22 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:22 <opendevmeet> The meeting name has been set to 'kolla'
13:00:26 <mnasiadka> #topic rollcall
13:00:27 <mnasiadka> o/
13:00:28 <mnasiadka> koperg[m]: now
13:00:45 <frickler> \m/
13:00:52 <amir58118> o/
13:01:08 <bbezak> o/
13:01:09 <marekbuch> o/
13:02:20 <koperg[m]> still here o/ :D
13:02:42 <AlexWelsh[m]> o/
13:02:52 <r-krcek> o/
13:03:36 <mnasiadka> #topic agenda
13:03:36 <mnasiadka> * CI status
13:03:36 <mnasiadka> * Release tasks
13:03:36 <mnasiadka> * Regular stable releases (first meeting in a month)
13:03:36 <mnasiadka> * Current cycle planning
13:03:38 <mnasiadka> * Additional agenda (from whiteboard)
13:03:38 <mnasiadka> * Open discussion
13:03:40 <mnasiadka> #topic CI status
13:03:46 <mnasiadka> CI is not bad overall
13:04:07 <mnasiadka> container-engine-migration needs fixing, because it tries to migrate ephemeral Neutron containers without a systemd unit
13:04:29 <mnasiadka> skyline mysqldb import got fixed with switch to pymysql
13:04:38 <mnasiadka> anything I missed?
13:05:41 <mnasiadka> guess not
13:05:42 <mnasiadka> #topic Release tasks
13:06:40 <mnasiadka> It's R-2, that on our schedule means Feature Freeze
13:06:49 <mnasiadka> #link https://docs.openstack.org/kolla/latest/contributor/release-management.html
13:07:15 <mnasiadka> I'll start tagging patches that HAVE to go in with RP+2
13:07:23 <mnasiadka> and probably group them in a topic
13:07:34 <mnasiadka> I'll post that later here and tag the usual core reviewers
13:07:43 <mnasiadka> Let's try to make things work before December ;-)
13:07:46 <bbezak> :)
13:08:22 <mnasiadka> I would assume we need Ansible bump and Rocky 10 support (so that includes Valkey)
13:08:26 <mnasiadka> as a minimum
13:09:07 <mnasiadka> So that means we need to get back to the Valkey discussion
13:09:24 <bbezak> We need to do some TODO cleaning
13:09:26 <mnasiadka> Do we want to leave redis around for Debian and Ubuntu - or should we rather switch everybody to Valkey?
13:09:38 <bbezak> I vote for valkey
13:10:16 <AlexWelsh[m]> Also vote valkey everywhere
13:10:21 <mnasiadka> I'd rather have one solution, if Debian/Ubuntu users prefer to leave Redis for G cycle and remove it in I - I can live with that
13:10:42 <mnasiadka> frickler: still opposing to switching completely to Valkey?
13:11:25 <frickler> I don't like it, but I'll likely also not be able to work on supporting both, so kind of ok-ish for me
13:12:17 <mnasiadka> Ok, koperg[m] make sure we have migration working in upgrade jobs - redis is currently only running in multimode jobs - so these need to be stable :)
13:12:47 <koperg[m]> rgr
13:12:48 <mnasiadka> #agreed to remove redis role and images, given we have a working migration from redis to valkey
13:13:24 <mnasiadka> bbezak: oh, TODO, FIXME and others are really all over the place - would be nice if somebody could make a list and start going through things that we need to remove/rework
13:14:05 <mnasiadka> Given reworking things - while working on adding Rocky Linux 10 support in Kolla-Ansible - I found myself in a big headache situation when trying to go through jobs.yaml in our Zuul configs
13:14:21 <mnasiadka> I started a patch to rework it to use project templates, which I think is a bit more readable solution
13:14:22 <mnasiadka> #link https://review.opendev.org/c/openstack/kolla-ansible/+/961226
13:15:01 <mnasiadka> I would love some comments and reviews, if we want to do it or not, but I would prefer to do that reorg
13:15:47 <mnasiadka> I understand backporting CI related things might be complicated, but I don't think we backport CI jobs often
13:16:03 <frickler> +1
13:16:43 <mnasiadka> Ok then, bbezak willing to volunteer for making a list of things we need to drop/rework before releasing 2025.2?
13:16:56 <bbezak> I shall
13:17:34 <mnasiadka> Fantastic
13:17:34 <mnasiadka> Let's move on
13:17:46 <mnasiadka> #topic Current cycle planning
13:18:12 <mnasiadka> We actually did that, I think we often cover everything in the Release tasks item - I think I'll post a patch to rework the usual meeting agenda.
13:18:32 <mnasiadka> #topic Additional agenda (from whiteboard)
13:18:52 <mnasiadka> r-krcek [2025-09-10]
13:18:52 <mnasiadka> please review https://review.opendev.org/c/openstack/kolla-ansible/+/928986, https://review.opendev.org/c/openstack/kolla-ansible/+/920714
13:18:55 <mnasiadka> this is from last week
13:19:25 <r-krcek> Yes, sorry, forgot it there
13:19:33 <mnasiadka> I'll add RP+1 to these
13:19:44 <mnasiadka> these are not really MUST HAVE for the release, but it's a good improvement
13:20:00 <mnasiadka> I'll have a look later this week
13:20:38 <mnasiadka> marekbuch [2025-09-17]
13:20:38 <mnasiadka> please review https://review.opendev.org/c/openstack/kolla-ansible/+/943799, https://review.opendev.org/c/openstack/kolla-ansible/+/947116, https://review.opendev.org/c/openstack/kolla-ansible/+/948409
13:20:49 <mnasiadka> Ensure neutron_bridge_name and neutron_external_interface have the same length
13:21:02 <mnasiadka> Well, that precheck makes sense - and probably would be useful to backport this
13:21:18 <mnasiadka> but I always had an idea to stop having this as two different variables - and merge them in one dict
13:21:38 <mnasiadka> marekbuch: is that something you'd like to pick up?
13:21:45 <marekbuch> yeah, sure
13:22:06 <mnasiadka> thanks
13:22:14 <mnasiadka> Add support for volume label filtering
13:22:21 <mnasiadka> #link https://review.opendev.org/c/openstack/kolla-ansible/+/947116
13:23:55 <mnasiadka> Is there a reason we're sticking to args: and then a sub-dict instead of exposing that directly?
13:24:16 <mnasiadka> I'll ask that in Gerrit and please reply there
13:24:31 <marekbuch> okay
13:24:43 <mnasiadka> Add documentation for Kolla Ansible CLI command completion
13:24:48 <mnasiadka> #link https://review.opendev.org/c/openstack/kolla-ansible/+/948409
13:25:12 <mnasiadka> Looks like a no brainer - added my +2
13:25:19 <mnasiadka> bbezak/frickler: want to have a look?
13:25:39 <frickler> ack
13:25:48 <mnasiadka> thanks
13:25:59 <mnasiadka> No more topics on the whiteboard
13:26:07 <mnasiadka> #topic Open discussion
13:26:16 <mnasiadka> Anybody anything?
13:26:53 <mnasiadka> Just a reminder from me - that we have Gazpacho/2026.1 planning ether pad - please add topics there so we know how many days to schedule
13:26:55 <mnasiadka> #link https://etherpad.opendev.org/p/kolla-gazpacho-ptg
13:30:06 <mnasiadka> I guess that's it
13:30:06 <mnasiadka> Thanks for coming!
13:30:06 <mnasiadka> See you next week
13:30:10 <mnasiadka> #endmeeting