16:02:50 <mugsie> #startmeeting Kosmos
16:02:51 <openstack> Meeting started Tue Sep  1 16:02:50 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:54 <openstack> The meeting name has been set to 'kosmos'
16:03:06 <mugsie> #topic Announcements
16:03:23 <mugsie> #link http://git.openstack.org/cgit/openstack/kosmos-specs
16:03:35 <mugsie> the kosmos-specs repo is now in gerrit
16:03:43 <johnsom> +1
16:03:56 <mugsie> so all future specs must be done there
16:04:10 <mugsie> KunalGandhi: that will include the arch stuff
16:04:26 <KunalGandhi> @mugsie .. ok i will add it there..
16:04:48 <mugsie> you will need to write an RST doc now - it will not pass gate currently
16:06:09 <mugsie> for the stuff we have -  the basic python code can't merge as is. we need to start defining what services we will have, and start building them up with oslo.messaging / oslo.db / and pecan
16:06:36 <mugsie> #topic Architechture Proposal
16:06:48 <mugsie> has anyone had a chance to look at the pull request?
16:06:56 <sballe> o/
16:07:04 <mugsie> I am just catching up after 2 weeks of travel around the US
16:07:13 <KunalGandhi> i have actually created a code review
16:07:22 <KunalGandhi> for the source files
16:07:31 <mugsie> KunalGandhi: yeah, thats what can't merge
16:08:13 <mugsie> we need to know what services exist, and define the RPC interfaces / wsgi api framework etc
16:08:47 <KunalGandhi> @mugsie ... i created it not for merge.. the code represents sort of the arch in soruce filess.. it is jsut to get a feedback on the overall modules
16:09:06 <mugsie> OK...
16:10:11 <mugsie> I can leave code reviews on that then
16:10:12 <KunalGandhi> @mugsie ... once we have feedback on that and an agreement on the arch, we start building it with existing libraries
16:10:39 <mugsie> it would be great to get a list of services as well, and what they are responsible for doing
16:11:11 <mugsie> anyone else had a chance to look?
16:11:33 <KunalGandhi> https://review.openstack.org/#/c/218709/
16:12:24 <mugsie> OK, can everyone please spend some time (30 mins or so) this week looking at this?
16:12:29 <mugsie> we need to get traction
16:12:34 <johnsom> Nope, but I will take a look
16:12:43 <mugsie> cool
16:12:59 <mugsie> dougwig: you too :)
16:13:09 <mugsie> #topic Open Discussion
16:13:15 <mugsie> any off agenda items?
16:13:29 <mugsie> as a note our talk for Tokyo got rejected :(
16:13:42 <KunalGandhi> @mugsie ... yeah saw that :(
16:13:52 <johnsom> I would like to poke dougwig on the openstackgerrit integration with the channel.
16:14:00 <johnsom> I think he was working on that
16:14:02 <KunalGandhi> @mugsie .. i had one question
16:14:31 <mugsie> johnsom: i think we have it ....
16:14:41 <johnsom> mugsie My load balancing talk got accepted, so maybe I can make a reference there.
16:14:45 <mugsie> just 0 patches :)
16:14:45 <KunalGandhi> when can we start getting to implement some of these GSLB features and what should our starting point be
16:14:51 <mugsie> johnsom: cool - that would be goos
16:14:54 <mugsie> good*
16:15:09 <mugsie> KunalGandhi: when we get a basic service arch I thinkl
16:15:17 <johnsom> Ah, we do.  Some how I missed kunalgandhi's check in
16:15:39 <mugsie> and starting point - using lbaas v2 + desingate to do fail over between 2 regions
16:15:55 <KunalGandhi> @mugsie .. ok..
16:16:18 <KunalGandhi> so it would be great if all of you could provide feedback on the code reivew
16:16:22 <mugsie> but if people have other ideas, please speak up
16:16:41 <KunalGandhi> the code review is just starter source files and modules..
16:17:05 <mugsie> OK, anything else to discuss?
16:17:20 <KunalGandhi> also, i am assuming that everyone in the meeting will have bandwidth to contribute code wise
16:17:53 <mugsie> +1
16:18:15 <mugsie> OK, unless there is anything else?
16:18:21 <KunalGandhi> ok cool.. so the action item is provide feedback on the code review
16:18:41 <mugsie> #action all - provide feedback on https://review.openstack.org/#/c/218709/
16:18:47 <mugsie> yup
16:19:05 <mugsie> going once
16:19:12 <mugsie> twice
16:19:18 <mugsie> gone!
16:19:20 <mugsie> #endmeeting