16:00:57 <mugsie> #startmeeting Kosmos
16:00:58 <degorenko> o/
16:00:58 <openstack> Meeting started Tue Sep 29 16:00:57 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:01 <openstack> The meeting name has been set to 'kosmos'
16:01:08 <mugsie> #topic rollcall
16:01:18 <mugsie> so, whos around?
16:01:33 <johnsom> o/
16:01:55 <elarson> o/
16:01:58 <mugsie> give people a few mins
16:02:34 <mugsie> this is now offically our time now btw, http://eavesdrop.openstack.org/#Kosmos_(Global_LBaaS)_Meeting
16:02:49 <mugsie> i submitted a patch to swap ownership
16:03:03 <xgerman> o/
16:03:42 <mugsie> OK - I think thats enough time for everyone to join
16:03:46 <timsim> o/
16:03:51 <mugsie> #topic Action Items from Last week
16:03:59 <mugsie> there is ....
16:04:07 <mugsie> eh, none as it turns out
16:04:22 <mugsie> #topic Architecture - https://review.openstack.org/#/c/223663/
16:04:30 <mugsie> #link https://review.openstack.org/#/c/223663/
16:04:36 <johnsom> I see you have put up an update
16:04:37 <mugsie> #link http://docs-draft.openstack.org/63/223663/2/check/gate-kosmos-specs-docs/8f73cfa/doc/build/html/specs/liberty/sysarch.html
16:04:47 <davidlenwell> o/
16:05:02 <mugsie> yeah, I think I got all the questions answered - I moved a lot of it around
16:05:15 <mugsie> (it got quite confusing wiht the single diagram)
16:05:46 <mugsie> I would like to get this merged soon, so we can start finding thre holes
16:06:28 <johnsom> I will give it another pass today/tomorrow
16:06:56 <mugsie> is there any questions so far?
16:07:00 <mugsie> am I crazy?
16:07:02 <mugsie> :P
16:07:24 <johnsom> Probably
16:07:32 <mugsie> :)
16:07:35 <johnsom> You signed up for two PTL positions
16:08:00 <mugsie> yeah
16:08:45 <mugsie> OK, so the action is all interested parties look at the reivew
16:08:58 <mugsie> #action ALL Review arch spec
16:09:10 <mugsie> #topic Open Discussion
16:09:17 <mugsie> any off agenda items?
16:10:02 <johnsom> Is the status tree API complete enough for your needs?
16:10:16 <mugsie> I think so.
16:10:40 <johnsom> Great
16:10:40 <mugsie> but any holes will show during the implementation phase I think
16:10:50 <mugsie> is there a library for the v2 API
16:11:14 <xgerman> neutron-client
16:11:30 <johnsom> Yep, but status tree isn't implemented there yet
16:11:42 <mugsie> OK, that will be a hole
16:12:03 <xgerman> well, I am sure that can be fixed, johnsom ;-)
16:12:23 <mugsie> xgerman loves signing people up for things :)
16:12:44 <xgerman> well, he wrote the CLI for v2 in the first place
16:12:53 <johnsom> This may be covered in the new arch docs, but is there the idea that we would roll up stats as well?
16:13:29 <johnsom> I got it cleaned up, working, and merged....
16:13:43 <mugsie> its not in the docs yet ... by roll up you mean a single status endpoint for a whole GLB?
16:13:59 <johnsom> I'm still a bit fuzzy on how deep the integration with LBaaSv2 will go
16:14:17 <johnsom> stats, i.e. bytes in and out
16:14:26 <mugsie> oh
16:14:33 <mugsie> I hadnt even considered that
16:14:39 <mugsie> that is a good question
16:14:51 <mugsie> should we have that in scope?
16:14:53 <johnsom> I guess I am full of them recently
16:14:56 <mugsie> :)
16:15:12 <johnsom> Let me read through the new spec, and I'll comment there
16:15:18 <mugsie> cool.
16:15:33 <mugsie> we have not defined a stats endpoint yet at all
16:15:43 <mugsie> so that might need to be added to the API spec as well
16:16:03 <johnsom> Yeah, just thinking about metering/billing type issues
16:16:23 <mugsie> yeah
16:16:52 <mugsie> damn deployers needing to charge people
16:16:54 <mugsie> :)
16:16:59 <dougwig> in theory, we should just be hitting the rest endpoints of designate and lbaas, right?  if not, i think we have a missing api.  :)
16:17:39 <mugsie> yeah, so maybe the stats may not be needed
16:17:44 <johnsom> One approach could be to just account for gslb hits/traffic.  Another could be a deeper integration.  I lean towards the first option myself.
16:18:08 <mugsie> yeah. which comes back to the designate stats endpoint
16:18:21 <dougwig> i'd think you'd want to track DNS hits, for billing gslb.
16:18:25 <mugsie> where we decided to explicitly *not* support number of queries
16:18:48 <mugsie> so we may have to revisit that
16:18:50 <johnsom> Hahahaha, fun had by all
16:20:02 <mugsie> OK, any other queries / comments / complaints?
16:20:07 <mugsie> or bikesheds?
16:20:20 * dougwig readies his paintbrushes.
16:20:24 <mugsie> we could talk about commit message lengths? :P
16:20:27 <johnsom> Did we pick a logo?
16:20:32 <mugsie> oh, yeah
16:20:43 <johnsom> Or we could talk about code width
16:20:54 <xgerman> tabs or spaces anyone?
16:21:18 <mugsie> https://a248.e.akamai.net/cdn.hpcloudsvc.com/g8f08eda56ca72a0a73bb6684f43aac18/prodae1//kosmos-logo.zip
16:21:28 <mugsie> will link that off the wiki
16:21:45 <mugsie> tabs converted to 3 spaces obviously xgerman
16:21:54 <davidlenwell> 2 spaces or go home ;)
16:22:09 * xgerman gets scissors for the yak
16:22:10 <mugsie> and windows line ending
16:22:40 <mugsie> there will be stickers in tokyo as well :)
16:22:53 <johnsom> Awesome!
16:23:24 <johnsom> Ok, that was the important business I had.
16:23:30 <mugsie> :D
16:23:35 <mugsie> OK, last chance ....
16:24:21 <mugsie> OK
16:24:24 <mugsie> #endmeeting